[Sammelthread] MacOS BigSur 11.0 DEV-Beta Erfahrungen

  • wenn sich das wer ansehen könnte

    Du hast keine SSDT-EC.aml im ACPI Ordner und auch keine in der config.plist eingetragen. Teste diese mal.

    Files

    • EFI.zip

      (3.71 MB, downloaded 51 times, last: )

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • So Leute, Clover ist auch am Start. Vielen Dank an kuckkuck für die Unterstützung!


    Edit: Dateien auf Wunsch von kuckkuck gelöscht

    LG Chris


    Meine Hardware:

    Edited 4 times, last by CMMChris ().

  • Erdenwind Inc. Bei mir hat es auf meinem MacBook Pro Retina 2012 mittels folgender Anleitung ohne Probleme geklappt: https://parrotgeek.com/bigsur/. Es hat nur recht lange gedauert (ca. 1h). :-)

    PowerHackG4





    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.5.9)
    Operation Systems: macOS "Mojave" 10.14.6, Windows 10 Professional


  • An die Fans der Crappy macOS Grafiktreiber: Keine Fixes in der Big Sur Beta.

    Die UI Glitches welche es zuletzt mit Vega10/20 und Navi10/14 im transparenten Bereich von Mission Control gab ziehen sich nun durch alle transparenten Bereiche der neuen UI. Gut sichtbar ist das im Dark Mode. Bewegt man die Maus über einen transparenten Bereich flackert es wie verrückt. YUCK!


    Edit: RadeonBoost funktioniert noch einwandfrei mit der VII.

    LG Chris


    Meine Hardware:

  • CMMChris läuft das System bei dir mit Clover oder nicht und hast du es neuinstalliert oder von Catalina raus geupdatet? Und wo genau muss ich die Befehle ändern also neu Einstagen will es gerne mal auch versuchen zu Installieren bitte.


    Bekomme immer wieder diese Fehlermeldung bei der Installation von Big Sur und kann mir bitte einer sagen, an was es liegt und was ich falsch mache?

  • CMMChris Das ist wenigstens eine konsequente Weiterentwicklung. 👍🏼

  • Du hast keine SSDT-EC.aml im ACPI Ordner und auch keine in der config.plist eingetragen. Teste diese mal.

    Vielen Dank karacho das Du Dir meinen EFI Ordner angesehen hast.


    Mit Deiner EFI bootet kein macOS bei mir, ABER ich bin gerade dabei mir deine Änderungen anzusehen, durchzuarbeiten und einzeln mit den diversen Änderungen zu booten.

    Angefangen habe ich mit dem Eintrag der SSDT-EC.aml und alcid=1 ohne agdpmod=pikera. Das bootete schon mit Catalina und Big Sur :)

    agdpmod=pikera musste ich aber wieder hinzufügen das mein macOS sonst denkt ich habe zwei Monitore mit 2580 x 1440 statt einem mit 5120 x 2880. (Es ist ein DIY 5K Monitor mit 2 DP Kabeln zur RX580)


    Es freut mich das ich jetzt schon über 100 Min. ohne Absturz Big Sur intensiv verwende und gehe davon aus das die SSDT-EC.aml schon den Unterschied macht !


    Bis jetzt brauchte ich so eine SSDT-EC weder bei Mojave noch bei Catalina. Darum kannst Du mir bitte etwas zu der SSDT-EC sagen die Du mir eingebaut hast.


    Musstest Du diese selber erstellen, was bewirkt diese ??


    Bei alcid=1 bin ich mir nicht sicher ob ich den Eintrag brauche bzw. ob es bei meinem Absturz Problem geholfen hat ?


    Jetzt schaue ich weiter denn irgendein Eintrag Deiner EFI hat bewirkt das ich nur den Apfel sehe ohne Ladebalken und er auch nicht hochfährt.

    Hackintosh: Z97X-UD3H Rev. 1.0 - OpenCore v0.6.0 nightly - macOS 10.15.5 (19F101) - I7 4790K - Corsair H100i Cooling - A-DATA 32GB 1600 MHz - Sapphire AMD Radeon RX 580 Pulse OC 8GB - Corsair MP510 M.2

    MachBook pro 13" 2018 macOS 10.15.5

  • Gut sichtbar ist das im Dark Mode. Bewegt man die Maus über einen transparenten Bereich flackert es wie verrückt.

    Kann ich nicht bestätigen. Ich habe es versucht nachzustellen, bei mir flackert nichts und Glitches habe ich auch nicht, weder in Catalina noch in Big Sur.

    Ich will damit aber nicht deine Erfahrungen in Frage stellen.

    MfG, docplag



  • Bekomme immer wieder diese Fehlermeldung bei der Installation von Big Sur und kann mir bitte einer sagen, an was es liegt und was ich falsch mache?

    Du kannst Big Sur nicht auf einem Hackintosh installieren. Du musst es am Mac installieren und danach kannst du die Installation am Hackintosh booten.

    LG Chris


    Meine Hardware:

  • SAUKE

    Man kann den Installer noch nicht verwenden. Man muss mit einer vm oder einem Mac installieren.

    Und für das fertig installierte brauchst du OCquirks als AptioFix :)

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS

    :hackintosh:

    !!Kein Support per PN!!

  • Da ich gesehen habe das CMMChris für seine Big Sur Installation ich denke unter Clover

    booter-fileset-basesystem <00> auch ins NVRAM schreibt, macht das auch bei der Verwendung von OpenCore sinn ?


    Ich habe "nur"

    booter-fileset-kernel <00> im NVRAM

    Hackintosh: Z97X-UD3H Rev. 1.0 - OpenCore v0.6.0 nightly - macOS 10.15.5 (19F101) - I7 4790K - Corsair H100i Cooling - A-DATA 32GB 1600 MHz - Sapphire AMD Radeon RX 580 Pulse OC 8GB - Corsair MP510 M.2

    MachBook pro 13" 2018 macOS 10.15.5

  • Ich habe es auch bei Opencore eingetragen. Wenns nur mit Booter-fileset-kernel auch läuft, dann ist das egal.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS

    :hackintosh:

    !!Kein Support per PN!!

  • An die Fans der Crappy macOS Grafiktreiber: Keine Fixes in der Big Sur Beta.

    ......

    Ich bereite schon mal die Mojave Installation vor ...................... 😤😤😢

    Edited once, last by LuckyOldMan: Vollzitat eingekürzt & Kommentar aus dem Zitat "befreit". ().

  • Tach @ alle ,


    hier auch erfolgreich via VM installiert und mit OC 0.60 gebootet

    Weiss zufällig schon jmnd wie man den Volume-Namen unter BS ändern kann ? Habe leider beim Install die SSD mit "ohne Titel" pre-fomartiert :( ?

    Sonst machen wir das eben nochmal …

  • Du kannst Big Sur nicht auf einem Hackintosh installieren. Du musst es am Mac installieren und danach kannst du die Installation am Hackintosh booten.

    sorry, dass muss ich übersehen haben. Dann erstmal Tschüss bis später und viel Spaß beim Testen.

    --
    Grüße


    Christian


    "Ein Hackintosh ist wie ein Garten, es gibt immer etwas zu tun."


    iMacPro1,1 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 2), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020), CT 10.15.6 (19G46c) Clover r5119 OC 0.60

    MacBookPro 13,1 Lenovo ThinkPad T460 i5 6300U 8Gb RAM, iGPU HD520 IPS 1920x1080, WIFI DW 1560, CT 10.15.4 (19E287), Clover r5108

    MacBookPro 9,2 Lenovo Thinkpad T430, Intel Core i5 3320M 2,6GHz, Intel HD4000 1366x768 DE, 8GB RAM, Mojave 10.14.6 (18G3020), Clover r5108

    iMacPro1,1, Asus B85M-E, Intel Core i5 4460, Sapphire RX 560 4 GB iGPU HD4600, Realtek ALC877 (ID 1),TP-LINK Archer T9E AC1900 PCIem 12 GB RAM, CT 10.15.4 (19E287), BootLoader OC 0.5.7

    • New
    • Helpful

    chmeseb man braucht dazu keinen echten Mac es geht genau so gut auch mit einer VM (VMWare oder ähnliche) wichtig ist nur das man für BigSur (im Moment) eine eigene Platte einplant und diese als Raw Disk in die VM einbindet. Folgende Dinge braucht es:


    • VMWare (ich habe VMWare Fusion verwendet es geht aber analog auch mit Parallels, vBox und co)
    • Einen macOS Big Sur Installer Stick (erstellt im Terminal mit dem CreateInstallMedia Command)
    • Eine im HFS+/GUID Format formatierte HDD oder SSD
    • Einen USB Stick. mit OpenCore/Clover um das installierte System anschließend zu booten

    Um zu starten erstellt man zunächst eine neue benutzerdefinierte virtuelle Maschine für macOS 10.15:


    Da ich mich hier auf VMWare Fusion beziehe geht es nun im Terminal weiter denn jetzt müssen wir VMWare sagen welche unserer Festplatten wir der virtuellen Maschine als Rawdisk zuordnen möchten (die VM darf noch nicht gestartet sein wenn sie gestartet sein sollte bitte herunterfahren). Im Terminal geben wir zunächst einmal folgenden Befehl ein diskutil list um uns einen Überblick über die vorhandenen Laufwerke zu verschaffen und um die Disk Nummer unseres gewünschten Laufwerks zu ermitteln.


    Für mein Beispiel muss Disk4 (meine Datenplatte) herhalten da ich BigSur schon laufen habe und den Spaß eigentlich nicht wieder von vorne durchspielen möchte ;) Einmal die Disk Nummer ermittelt geht es nun darum ein VDMK für die raw Disk zu erstellen und diese anschließend in die VM einzubinden. Unter VMWare Fusion gibt es dazu den Befehl vmware-rawdiskCreator der sich innerhalb der VMWare Fusion.app befindet. mit dem Befehl /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator print /dev/disk# lässt sich eine Übersicht der Partitionen auf der zuvor im Diskutil ermittelten Platte anzeigen (das # wird durch die Nummer ersetzt die ermittelt wurde in meinem Fall also Nummer 4):

    Um nun das VDMK File für die Disk tatsächlich zu erstellen geht es mit dem Befehl /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator create /dev/disk# <partNums> <virtDiskPath> sata weiter hierbei wird <partNums> und <virtDiskPath> jeweils an die eigenen Gegebenheiten angepasst.

    • <partNums> muss ersetzt werden durch eine Komma getrennte Liste der zu verwendenden Partitionen (1,2,3..) oder durch fullDevice wenn die gesamte Platte verwendet werden soll (wir benutzen fullDevice).
    • <virtDiskPath> wird ersetzt Durch den Pfad zu Deiner vorher erstellten virtuellen Maschine zum Beispiel so: ~/Virtual\ Machines.localized/BigSur.vmwarevm/rawDiskFile

    Der Komplette Befehl sähe dann zum Beispiel wie folgt aus:

    /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator create /dev/disk4 fullDevice ~/Virtual\ Machines.localized/BigSur.vmwarevm/rawDiskFile sata wenn alles geklappt hat gibt es nun innerhalb unserer erstellten VM eine Datei Namens rawDiskFile.vmdk welches wir zu guter Letzt jetzt noch in das *.vmx File unserer VM eintragen müssen. Um das alles zu sehen/zu prüfen navigieren wir im Finder auf unseren Benutzer Ordner (im Finder Gehe zu Ordner wählen und ~ eingeben als Ziel. Es öffnet sich der Benutzerordner:

    in dem sich ein Ordner Virtuelle Maschinen befindet den wir dann ebenfalls öffnen um uns im Anschluss den Inhalt unserer VM anzeigen zu lassen (Paketinhalt anzeigen im Kontext Menu):



    nun ist es schon fast geschafft denn was jetzt noch zu tun ist ist das *.vmx File mit dem Texteditor zu öffnen und die so eben erstellte Rawdisk dort einzufügen. Zum einfügen suchen wir im Texteditor den Teil indem es um die SATA Devices der VM geht

    und ergänzen direkt unter dem letzten Device folgende Zeilen:

    Code
    1. sata0:X.present = "TRUE"
    2. sata0:X.fileName = "rawDiskFile.vmdk"
    3. sata0:x.deviceType = "rawDisk"
    4. suspend.disabled = "TRUE"

    wobei das x durch eine Zahl zu ersetzten ist die eine Nummer höher ist als die des letzten Device in dem File (in meinem Fall die Nr. 2). Ist das erledigt wird das File gespeichert und wir sind bereit zur Installation. Der USB Stick mit dem Installer wird der VM zugewiesen und die VM gestartet sie bootet daraufhin automatisch in den macOS Installer von dem Punkt an kann dann die macOS Installation wie gewohnt durchgeführt werden. Am Ende habt Ihr dann eine SSD/HDD mit einer installierten BigSur Kopie die sich dann im Hack mit OpenCore oder Clover booten lässt.

  • Darum kannst Du mir bitte etwas zu der SSDT-EC sagen die Du mir eingebaut hast.

    Guckst du hier. https://dortania.github.io/OpenCore-Desktop-Guide


    Auf der linken Seite dein System aussuchen und dort im Inhaltsverzeichnis auf ACPI. Möglicherweise brauchst du noch eine SSDT für's Powermanagement. Diese musst du dir jedoch für dein System selber erstellen. Die SSDT-EC die du jetzt drinnen hast, ist bei OC schon mit dabei. Im Ordner

    Docs->AcpiSamples, jedoch nur Files mit der Endung *.dsl



    Bei alcid=1 bin ich mir nicht sicher ob ich den Eintrag brauche bzw. ob es bei meinem Absturz Problem geholfen hat ?

    Bei Big Sur hatte ich persönlich ohne die alcid (trotz DevicePropertie Eintrag) neben dem HDMI kein anderes

    Ton-Ausgabegerät. Das hat jedoch nix mit deinem Absturz zu tun. Du kannst ja testen, ob Audio bei dir ohne den alcid boot-arg trotzdem funktioniert.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • atl erstmal vielen Dank für die Zielgerichtete Anleitung. jedoch bei punkt 10 brauch ich nochmal Schützenhilfe. patch_installer.sh erneut ins Terminal (klappt nicht ohne was davor!) Dann nochmal auf den gerade erstellten USB Stick. Was aber tut das da dann? Das ist mir gerade zu schwammig formuliert. Dann Enter drücken. Tut sich nichts... Oder raff ich grad nichts? Ich tue mich echt schwer mit all den Inputs gerade hier im Forum. Sehr unübersichtlich. Jeder schwimmt woanders hin.