OpenCore Sammelthread (lauffähige Konfigurationen) Desktop

  • Hier eine selbstgezimmerte Config mit EFI-Folder für OC 0.5.3 für diese Hardware:


    Gigabyte Z390M Gaming

    i7-8700K

    MSI RX580 ARMOR 8G OC

    32 GB RAM

    M.2 SATA Samsung SSD 840 EVO 1TB

    macOS Catalina 10.15.1

    iMacPro1,1

    Audio geht über DisplayPort an meinen Monitor LG HDR 4K (dort hängt ein Lautsprecher-System dran)


    Soweit ich es beurteilen kann und es bisher getestet habe, scheint alles zu funktionieren. Vielleicht hilft es jemandem mit ähnlicher Hardware beim Start. Der war bei mir mit OpenCore sehr holprig...

  • Ich habe es auch endlich mal geschafft mich einigermaßen in OC einzuarbeiten.

    Daraus entstanden die EFIs für das Asus Prime Z390-A und für das Gigabyte H170n-Wifi.


    Die Eckdaten der Systeme stehen in der Signatur.


    Update 19.01.2020:

    OC 0.5.4 Version für beide Boards hinzugefügt.

    Das Z390-A nun auch mit aktivem NVRAM.


    Update 07.11.2019:

    Die OC 0.5.3 EFI mit den Settings für die 5700 XT hinzugefügt.


    Achtung:

    Die beiden EFIs sind in OC 0.5.4 entstanden.

    Zur weiteren Bearbeitung für euer System müssen mindestens folgende Angaben unter "PlatformInfo"->"Generic" auf eure Gegebenheiten hin geändert werden.

    Es macht keinen Sinn, dass ihr mit den MAC-Adressen meiner Netzwerkkarten (ROM-Eintrag) oder meiner Seriennummern euer System ausstattet und dabei in ungeahnte Fehler reinlauft.

    Files

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Edited 4 times, last by al6042 ().

  • Hallo Community,


    hier mal eine weitere Möhre...


    Quelle: ASRock

    • ASRock Z77 Pro4
    • i5 3550
    • Nvidia GTX 660 Ti
    • 16 GB RAM DDR3 1600 MHz
    • 2 x SATA SSD Samsung 120 GB
    • Realtek ALC 892
    • macOS High Sierra + Mojave + Catalina 10.15.3
    • SMBIOS iMac13,2
    • OpenCore Version v004 + v054

    Im Anhang der dazugehörige unbereinigte EFI Ordner, das heisst nach dem Download muss ein neues SMBIOS erstellt werden. :)


    :hackintosh:


    Gruß derHackfan

  • Gigabyte GA-Z170-HD3P mit i7-6700K und AMD R9-280 unter OpenCore 0.5.2. Die USB-Kext muss vermutlich angepasst werden, also ist besser gleich eine neue mit dem Hackintool zu erstellen. In den ACPI-Dateien sind (noch) keine _OSI-Abfragen enthalten, also sollte hier Windows besser nicht mit OpenCore gebootet werden.


    Wichtig: CFG-Lock ist deaktiviert. Für die momentan aktuelle Firmware-Version f22g geht das so: setup_var 0x4EF 0x0 (s. setup.txt). Bitte vorher prüfen, ob das bei euch der selbe Wert ist. Ansonsten kann man auch erfolgreich mit AppleXcpmCfgLock = true booten, aber davon wird abgeraten. PlatformInfo ist wie immer noch anzupassen.


    luxus13: Die Konfiguration findest du hier.


    Ich habe mal die Konfiguration für das GA-Z170-HD3P aktualisiert (OC 0.5.6), da luxus13 danach gefragt hat.

    Files

    Edited once, last by Harper Lewis ().

  • OC Sammelthread: Ok ich stelle mal den OC-Bootloader für ein /ASUS ROG STRIX Z390-F GAMING, AMD RX-VEGA64 8GB, Core i9 9900K/ zur Verfügung.

    USB-Ports müssen natürlich angepasst werden und auch ne eigene Seriennummer; ROM; MLB; SmUUID muss rein, sind nur im Clover Configurator wild gewürfelte Werte drin.


    Der Rechner läuft zuverlässig, auch Sleep funktioniert und WakeUp per Bluetooth, die eqMac2.kext für den gleichnamigen EQ ist mit drin... getestet wurde das Ganze unter High Sierra, Mojave und Catalina.


    Sollte mit einigen kleineren Anpassungen auch für ähnliche ASUS-Boards zu gebrauchen sein (Z390 Prime A, etc.).


    WICHTIG: Im Uefi muss unter Boot-Boot Konfiguration "Bei Fehler auf F1 warten" deaktiviert werden!!


    MfG Jens!

    Files

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

    Edited once, last by locojens ().

  • Hallo Freunde,


    anbei meine funktionierende OC 0.5.3 Version für folgendes System:


    • Motherboard: MSI Z170A-G45 Gaming (MS-7977)
    • CPU: 1151 QuadCore Intel Skylake Core i7-6700K @ 4.4 GHz (OC)
    • Chipset: Intel® Z170 Express - 32 GB (4x8 GB)
    • Intel Graphics oder Grafikkarte: Nvidia GeForce GTX 980 Ti (6 GB) & aktivierte intel HD 530
    • RAM: 32 GB
    • Festplatte: Samsung SSD 850 EVO 1TB
    • Audio Device: Realtek ALC 1150 & Audio über Nvidia HDMI
    • macOS Version: macOS High Sierra 10.13.6 (17G9016)
    • verwendetes SMBIOS: iMacPro1,1
    • OpenCore Version: OC 0.5.3


    Alles läuft sehr flüssig. OC wurde nur mit einem entsprechenden Program zur Bearbeitung der Config.Plist benutzt, in meinem Fall verwende ich: PlistEditPro-App. Es wurde (zumindest von meiner Seite) keine OC Configurator App verwendet. Alles wurde manuell in die Plist eingepflegt. Habe die IGPU als erste Wahl im Bios am laufen für mein System, da ich interne wie externe GPU benötige. Müsst ihr euch anpassen. Zudem ist noch unter ACPI eine DSDT.aml im Ordner, aber nicht aktiviert da ich diese wohl nicht länger benötige. Unter Kernel befindet sich auch eine USB Kext, die ich mit Hackintool generiert hatte. Ich schlage vor, ihr erstellt euch mit o.g. Tool zudem auch eure eigene USB Kext. In NVRAM unter BOOT-args benutze ich shikigva=100,.. Ergo,.. solltet ihr euch die BOOT-args auch für eure Bedürfnisse anpassen. Denkt bitte daran, stets ein NVRAM-Rest durchzuführen, besonders wenn ihr zwischenzeitlich bspw. via Clover euer System umstartet.


    Abschlussweise:

    Großes Dank gebührt allen Kumpels, Kollegen und Anwender, die sich täglich hier auf freiwilliger Basis, den Arxxx aufreissen und uns helfen..!!! In diesem Fall besonders:


    karacho & al6042 (Riesiges Dankeschön Freunde!)


    Viel Spaß euch allen und gutes gelingen!

    Gruß

    sv

    Files

    iMac Pro 1.1 macOS High Sierra 10.13.6 (17G11023) • MSI Z170A-G45 Gaming (MS-7977) 1151 QuadCore Intel Skylake Core i7-6700K @ 4.4 GHz (OC) Chipset Intel® Z170 Express - 32 GB (4x8 GB) Nvidia GeForce GTX 980 Ti (6 GB) OpenCore (0.5.6)


    • „Jeder Mensch hat seine eigene Geschichte: Meine befindet sich direkt hinter meiner ramponierten Visage“ •

    Mache aus deinem “Bald“ lieber ein “Jetzt“ bevor daraus ein “Nie“ wird ••

    Edited once, last by sv0911 ().

  • Edit by al6042 -> Bitte keine Vollzitate von Beiträgen, welche direkt über deiner Antwort stehen...


    Sollte das mit meinem MSI Krait Z170A Gaming R6 Auch laufen ?

    Hacki // MSI Krait Z170A Gaming R6 // Intel Core i5 7400 // GTX 1050

    Edited once, last by al6042 ().

  • Hallo Gemeinde, hier meine funktionierende OC 0.5.3 für. CoffeLake - GA-Z390 Aorus Elite 1.0


    Die Daten meines System findet ihr in der Signatur "System" iMacPro 1.1


    EFI CoffeeLake Z390.zip

  • siiNCeyyy

    Diese könnte für dein Board funktionieren, muss vorher aber an diversen Stellen angepasst werden.

    Die Details dazu besprechen wie aber eher in deinem eigenen Thread, da diese hier nichts zu suchen haben.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo,


    wäre es evtl. möglich deine EFI hier zu aktualisieren? Würde gerne mal mit OC versuchen und wollte diese EFI in aktueller Form als Basis nehmen. Danke!

    Cooltek Jonsbo UMX1 Plus (ITX) / BeQuiet PurePower 10 400W / SilentWings 3

    ASRock Z390 Phantom Gaming ITX Board

    Intel i5-9400f

    AMD RX580 Sapphire Pulse 8 GB

    Crucial Ballistix Sport 2x8 GB DDR4 3000 MHz

    Samsung EVO 970 Evo Plus 500 GB (macOS - 10.15) / WD S520 120 GB (Windows 10)

  • Bitteschön! :)

    Klick mich

    MfG, docplag



  • Mainboard: Asus Prime B360M-A | BIOS: 2806 (newest)

    Prozessor: i5 8600 - 3,1 GHz

    Grafikkarte: MSI Radeon RX 580 Armor 8GB OC

    RAM: 16GB G.Skill Aegis DDR4-3000Mhz

    WiFi + BT: BCM943602CS


    Betriebssystem: macOS 10.15.6 Dev

    Bootloader: OpenCore v0.5.6



    Update | 03.05.20:

    USBPorts.kext erneuert da nicht korrekt. Je nach Front USB solltet ihr den Kext neu erstellen!

    SSDT-PLUG.aml wurde mit CPUFriend auf das SMBIOS vom iMac19,1 gebracht um das Speed-Stepping der CPU zu verbessern. Die CPU taktet nun bis 800MHz runter. Wer also kein i5 hat, der im iMac19,1 verbaut wurde sollte die SSDT-PLUG.aml aus der OpenCore Repo nehmen!

    In dieser Anleitung gibt es mehr zu dem Thema, ihr solltet sie euch durchlesen.


    Update | 04.05.20:

    OpenCore auf 0.5.8 aktualisiert!

    USBPorts.kext korrigiert.

    Neu erstellte Config auf Basis von OC 0.5.8! ( Download )


    Update | 11.06.20:

    OpenCore auf 0.5.9 aktualisiert!

    Kexte auf den neusten Stand gebracht.

    Neu erstellte Config auf Basis von OC 0.5.9! ( Download )



    Es wurde eine zufällige SN generiert, diese bitte nach dem der installation umgehend ändern!




    Files

    Mit freundlichen Grüßen,

    alex


     hackint0sh [iMacPro1,1] - macOS 10.15.6 (19G46c)
    MB: Asus Prime B360M-A | CPU: i5 8600 | GPU: MSI Radeon RX 580 | RAM: 16GB G.Skill Aegis | WiFi + BT: BCM943602CS | OpenCore v0.5.9


     iDevice - iOS 14
    iPhone 11 | iPhone 8 Plus | iPad Pro 12,9" | iPad Pro 11"
                                               
     Real Mac - macOS 11.0
    MacBook Pro 15” Late 2015 | MacBook Pro 13” Late 2014



    Edited 21 times, last by Un!x: OC Updated ().

  • Un!x

    Deine "SSDT-EC-USBX.aml mit zwei Definitionsblöcken sieht etwas merkwürdig aus. Das würde ich mal zusammenfassen. Nehme an, dass der untere Teil so wie es ist, gar nicht geladen wird.

    "EC" hätte ich auch in den Scope "LPCB" gesetzt, wo es – wenn vorhanden – auch steht.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G • i9-10980XE • DDR4 64GB • SSD 970 EVO Plus 1TB • Thunderbolt3 Titan Ridge • DeckLink 4K Extreme 12G • 2x AMD Radeon VII

  • apfelnico Ich habe einfach nur die EC und USBX zusammengelegt. Funktioniert ja auch so wie ich es gemacht habe.

    Mit freundlichen Grüßen,

    alex


     hackint0sh [iMacPro1,1] - macOS 10.15.6 (19G46c)
    MB: Asus Prime B360M-A | CPU: i5 8600 | GPU: MSI Radeon RX 580 | RAM: 16GB G.Skill Aegis | WiFi + BT: BCM943602CS | OpenCore v0.5.9


     iDevice - iOS 14
    iPhone 11 | iPhone 8 Plus | iPad Pro 12,9" | iPad Pro 11"
                                               
     Real Mac - macOS 11.0
    MacBook Pro 15” Late 2015 | MacBook Pro 13” Late 2014



  • Un!x


    Habe ein solchen Konstrukt noch nicht gesehen, habe es auch nicht getestet. Dachte schon, dass es nur einen Definitionsblock geben dürfte, so hätte ich die beiden zusammengefasst:


    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G • i9-10980XE • DDR4 64GB • SSD 970 EVO Plus 1TB • Thunderbolt3 Titan Ridge • DeckLink 4K Extreme 12G • 2x AMD Radeon VII

  • apfelnico Okay, dann mach ich das mal und update die Config einfach.

    Mit freundlichen Grüßen,

    alex


     hackint0sh [iMacPro1,1] - macOS 10.15.6 (19G46c)
    MB: Asus Prime B360M-A | CPU: i5 8600 | GPU: MSI Radeon RX 580 | RAM: 16GB G.Skill Aegis | WiFi + BT: BCM943602CS | OpenCore v0.5.9


     iDevice - iOS 14
    iPhone 11 | iPhone 8 Plus | iPad Pro 12,9" | iPad Pro 11"
                                               
     Real Mac - macOS 11.0
    MacBook Pro 15” Late 2015 | MacBook Pro 13” Late 2014



  • Un!x Tipp: lade dir Mal 'SSDTTime' runter und erstelle dir damit deine ssdt.

    Gruß, karacho


    Bitte keine Supportanfragen via PN. Eure fragen gehören ins Forum!

    Ich hab noch drei Patronen, eine für dich und zwei für mich...

  • Vorab danke an all die Hilfe aus dem hackintosh-forum.com und amd-osx.com, deswegen möchte ich hier auch wieder alles zurückgeben!

    Ryzen Mac Pro

    Prozessor: AMD Ryzen 9 3900X

    Mainboard: AsRock X570 Phantom Gaming ITX/TB3 (BIOS 2.0)

    Memory: Corsair Vengeance RGB Pro (2x, 16GB) DDR4-3200

    Storage: Corsair MP600 (1000GB) M.2 NVMe

    Video Card: Sapphire Radeon RX 5500 XT Pulse 8G

    Power Supply: Corsair SF600 Platinum

    Case: Phanteks Enthoo Evolv Shift (Mini-ITX)

    Monitor: LG 38WK95C-W


    OS: macOS 10.15.2

    Bootloader: OpenCore v0.5.4


    Informationen:

    Der integrierte Intel Bluetooth Chip ist voll funktionsfähig. Display ist per USB-C (TB Port) angeschlossen inkl Video/Audio über USB-C Kabel (GPU -> DisplayPort IN). Alle USB Ports sind funktionsfähig und HPET ist geladen.

    GPU ist auf PCIe 3.0 limitiert da es sonst Probleme mit dem Riser Kabel gibt, die SSD läuft mit PCIe 4.0.


    BIOS:

    CSM disabled

    Above 4G decoding disabled

    SVM enabled


    Benchmarks

    EFI



    Update 10.02.2020

    OC 0.5.5 (ohne Standard Kexte/Drivers um Platz zu sparen).

    SSDT-XHC.aml aktualisiert mit allen USB Ports richtig konfiguriert und umbenannt. HS10 ist der interne USB Port an dem das Bluetooth Modul hängt. SS10 ist der USB-C Port. HS/SS 1-4 sind die Ports auf der Rückseite, HS/SS 5-6 sind die beiden Ports am Case vorne.

    Files

    AMD Ryzen 9 3900X | AsRock X570 Phantom Gaming-ITX/TB3 | Sapphire Radeon RX 5500 XT Pulse 8GB | Corsair MP600 NVMe | Corsair SF600 Platinum | MacOS 10.15.5 | OC 0.5.9

    Edited 2 times, last by Aluveitie ().

  • NVMeFix.kext (improve NVMe controller)

    Wie wirkt sich das aus? Werden damit die Drops behoben? Also das sie einfach so langsamer wird.

    Mit freundlichen Grüßen,

    alex


     hackint0sh [iMacPro1,1] - macOS 10.15.6 (19G46c)
    MB: Asus Prime B360M-A | CPU: i5 8600 | GPU: MSI Radeon RX 580 | RAM: 16GB G.Skill Aegis | WiFi + BT: BCM943602CS | OpenCore v0.5.9


     iDevice - iOS 14
    iPhone 11 | iPhone 8 Plus | iPad Pro 12,9" | iPad Pro 11"
                                               
     Real Mac - macOS 11.0
    MacBook Pro 15” Late 2015 | MacBook Pro 13” Late 2014



  • Wie wirkt sich das aus? Werden damit die Drops behoben? Also das sie einfach so langsamer wird.

    laut Beschreibung wird unter anderem der Stromverbrauch des NVMe Controllers optimiert: https://github.com/acidanthera/NVMeFix

    Bis jetzt hatte ich keine Probleme mit oder ohne diesem Fix.

    AMD Ryzen 9 3900X | AsRock X570 Phantom Gaming-ITX/TB3 | Sapphire Radeon RX 5500 XT Pulse 8GB | Corsair MP600 NVMe | Corsair SF600 Platinum | MacOS 10.15.5 | OC 0.5.9