Radeon RX Vega 64 crasht im beim Rendern aus Adobe Programmen

  • Moin!


    Ich habe ein Problem mit meiner Vega64:

    Wenn ich sie intensiv zum Video-Encoding im Adobe Media Encoder oder Premiere nutze schmiert sie mir regelmäßig komplett ab. Der Mauszeiger lässt sich zwar noch bewegen aber der Bildschirm freezt in seinem aktuellen Zustand und ich kann nirgends mehr klicken. Der Ton läuft im Hintergrund weiter und sofern ich via SSH eingeloggt bin kann ich das weiterhin nutzen, ich kann mich aber nicht mehr neu verbinden.

    Unter /Library/Logs/DiagnosticReports finde ich zu den meisten (nicht allen, seltsamerweise) Crashs eine Datei mit dem Namen "Kernel_#datum/uhrzeit_#rechnername.gpuRestart" mit beispielsweise folgendem Inhalt:


    Ich habe macOS Mojave 10.14.3 mit iMac 18,3 SMBIOS. Kein OC. Die Vega ist derzeit testweise die einzige Karte in einem PCIEX16 slot und auf PCIEX16_1 mit x16 Lanes.

    Im BIOS habe ich schon beides probiert, IGPU komplett abschalten als auch einschalten.


    Das Ganze passiert sowohl mit OpenCL sowie Metal-Unterstützung als auch "Software only". Die Preferences von Adobe CS hab ich auch schon komplett gelöscht.


    Unter DaVinci Resolve konnte ich den Crash allerdings nicht reproduzieren auch wenn ich die GPU und den Graka Speicher über 20 Minuten in Vollauslastung bringe.


    Hat jemand eine Idee woran das liegen könnte? Danke schon mal!


    Cheers,

    Lenny




    edit:


    geladene kexts:

    AirportBrcmFixup.kext

    AppleALC.kext

    BrcmFirmwareData.kext

    BrcmPatchRAM2.kext

    IntelMausiEthernet.kext

    Lilu.kext

    USBPorts_190203.kext (selbst erzeugt)

    VirtualSMC.kext

    WhateverGreen.kext


    bootflags:

    dart=0

    shikigva=1

    -v

    brcmfx-country=#a

    keepsyms=1

    debug=0x100

    darkwake=8

  • IGPU im BIOS komplett deaktivieren und iMacPro Smbios nutzen.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • IGPU im BIOS komplett deaktivieren und iMacPro Smbios nutzen.

    Wahrscheinlich trotzdem richtig das so zu machen, hat aber leider auch nichts gebracht... :(

  • Klingt mir stark nach Problemen mit den Settings. Hatte diese Symptome auch schon bei nicht optimalen PowerPlayTables. Nutzt du überhaupt eine?

    LG Chris


    Meine Hardware:

  • Nein. Um ehrlich zu sein hör ich davon zum ersten Mal... ?(

    Muss ich mich wohl mal einlesen. Aber vielleicht hast du ja nen Tipp wie ich zu optimalen PowerPlayTables komme. :saint:

  • Hm und deine Lüftersteuerung der Karte funktioniert? Dann wärst du ja der erste dem es so geht mit der Nitro+.

    LG Chris


    Meine Hardware:

  • Hi, ich glaube dass ich das selbe Problem habe und wollte wissen ob schon ein Lösungsansatz gefunden wurde? Bei mir ist es eine Radeon RX 580 und seit ein paar Tagen ist es in keinem Adobe Program möglich zu rendern weil ansonsten der Bildschirm einfriert im Moment indem man export klickt. Die Maus lässt sich dann nach wie vor bewegen und kann mit großer Verzögerung auch noch weitere Befehle ausführen, die alle aber nicht ausgeführt werden sondern auch einfrieren. Hilft da Neu installieren von Adobe weiter?

  • Hm und deine Lüftersteuerung der Karte funktioniert? Dann wärst du ja der erste dem es so geht mit der Nitro+.

    Hmm, wahrscheinlich eher nicht. Ich habe jetzt erst gemerkt, dass die Lüfter komplett ausgehen sobald macOS hochfährt und machen auch keine Anstalten unter Last zu starten.

    Wenn ich die per

    Code
    1. while sleep 1; do clear;ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f 2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan\|Clock'; done

    kontrolliere wird mir angezeigt, dass die Lüfter mit 36% und 0 rpm laufen. ?(

    Allerdings sind die Temperaturen wenn die Karte aussteigt nie höher als 55°C.


    Mit der VegaTAB Application von morgonaut habe ich die Lüfter mal auf 4900rpm aufgedreht, stehen aber immer noch still. Wie machen andere Leute das denn, wenn es so ein gewöhnliches Problem ist?


    Hi, ich glaube dass ich das selbe Problem habe und wollte wissen ob schon ein Lösungsansatz gefunden wurde? Bei mir ist es eine Radeon RX 580 und seit ein paar Tagen ist es in keinem Adobe Program möglich zu rendern weil ansonsten der Bildschirm einfriert im Moment indem man export klickt. Die Maus lässt sich dann nach wie vor bewegen und kann mit großer Verzögerung auch noch weitere Befehle ausführen, die alle aber nicht ausgeführt werden sondern auch einfrieren. Hilft da Neu installieren von Adobe weiter?

    Bei mir friert der Bildschirm wirklich ein. Auch kein verzögertes Klicken. Außerdem kommt der Fehler nicht sofort beim Drücken auf Export sondern eher random mal nach wenigen Sekunden, mal nach einigen Minuten Rendern. Was bei Adobe immer mal helfen kann ist mit dem Preference Manager mal die Einstellungen zurückzusetzen.

  • VGTab ist nicht von Morgonaut. Auch kannst du mit VGTab den Lüfter nicht einfach so aufdrehen. Das Tool generiert Steuerungsdaten für die Karte. Die Web Oberfläche ändert erstmal gar nichts.


    Beobachte doch mal den Lüfter während du den Valley Benchmark oder Luxmark laufen lässt.

    LG Chris


    Meine Hardware:

  • Nein, sorry, da hab ich mich natürlich missverständlich ausgedrückt. Mit dem Tool habe ich eine kext erzeugt und beim Reboot geladen. So sollte es eigentlich funktionieren, oder?

    Ich check mal die Lüfter bei Benchmark. Beim Adobe Rendering haben sie allerdings nichts getan.

  • Bitte den Test ohne die Kext machen.

    LG Chris


    Meine Hardware:

  • Ok, also in beiden Benchmark Test drehen mir die Lüfter laut Stats auf ca 1.300-1.600rpm auf. Fahren danach aber nicht wieder runter.

    Übrigens genauso wie in Adobe, da habe ich mich getäuscht.


    Ansonsten bei den Benchmarks keine Problem bezüglich Abstürzen o.ä. Was allerdings auch auffällt ist, dass bei Adobe der Speicher der Graka deutlich voller ist - aber jetzt auch nicht randvoll.

  • Dieses Symptom kommt mir sehr bekannt vor. Ich lese das jetzt schon mehrmals und es scheint eine Verbindung immer mit den I9 9900K und der Vega bzw. den neuen Boards 390 zusammen zu hängen. Bei Ctopher kann ich das nicht erklären, da seine Signatur fehlt. Ich hatte das auch sehr oft gehabt und CMMChris weist das auch. Was gut funktionierte war SMBIOS mit der Vega 18.3 mit IGPU und iMacPro natürlich ohne (für die RX580 - bleibt nur 1. Auswahl). Ich arbeite ohne Adobe Programme auf den Mac und kann Freeze mit den oben genannten Symptom nur mit FCPX provozieren. Kommt aber beim normalen Arbeiten damit kaum vor. An Bios-Einstellungen kann man wenig schrauben - höchstens mal mit V24-119 Entries und VAbove4G enable oder disable probieren.

    Valley Benchmark wird bestimmt ohne Freeze voll laufen.

    Ich würde folgenden probieren:

    - wenn Deine GPU die Lüfter richtig regelt (was ich auch nicht glaube) - wenn nicht PowerPlayTables verwenden.

    CMMChris die Nitro+ regelt manchmal das schon ganz gut ohne PowerTable beim nächsten Start dann einfach nicht mehr. Ist kurios (hatte ich mal im November gepostet) - also ist das bei mir implementiert.

    - wenn die Lüfterregelung gut funktioniert - starten ohne iStat oder HWMonitorSMC2 (da habe ich so ne Vermutung)

    - Bios CPU mal auf Standard lassen - keine Übertaktung oder so

    - alle USB-Geräte bis auf Maus und Tastatur abklemmen

    - in Clover PluginType auf 1 setzen

    - Hardwarebeschleunigung mit VideoProc testen

    dann schau mal ob Freeze zur gleichen Zeit oder sogar gar nicht mehr auftritt

    für wertere Hinweise mal Deine Config posten. CMMChris kann dann bestimmt auch mehr dazu sagen.

    1. Z390 Aorus Master - i9 9900K - Sapphire Vega 64 Nitro + - 64GB DDR4 3200

    2. GA Z77-DS3H v1.0 - Intel Core I7 - GeForce GTX 980 (Multi-Monitor-Betrieb) - 32 GB DDR3


  • Teste einfach mal das: [TOOL] Vega 64 PowerPlayTable Generator


    Nutze die Default Settings die schon in der Tabelle gesetzt sind. Minimum PWM Value eventuell mit dem Wert aus der PPT deiner Karte anpassen.

    LG Chris


    Meine Hardware:

  • Teste einfach mal das: [TOOL] Vega 64 PowerPlayTable Generator


    Nutze die Default Settings die schon in der Tabelle gesetzt sind. Minimum PWM Value eventuell mit dem Wert aus der PPT deiner Karte anpassen.

    Crasht mir mit den Standard-Settings immer noch (mindestens genauso schnell) in Adobe. Wie kann ich denn den PWM-Wert aus der Original-PPT auslesen?

    Habe eine Sapphire Radeon RX VEGA 64 Nitro+ - 8GB HBM2 - Grafikkarte

  • PowerPlayTable im VBIOS suchen und die entsprechende Stelle anschauen. Das entsprechende Markup ist ja in meiner Excel Tabelle. Mit der Taschenrechner App kannst du Hex in Dezimal umwandeln.

    LG Chris


    Meine Hardware:

  • Ich glaub mir müssen mit den Basics anfangen, wie kann ich mir denn das verwendete VBIOS anzeigen lassen?

  • Öffne IOJones, suche GFX0 oder display@0 (je nach System und Config), markiere den Eintrag und dann suche rechts nach ATY,bin_image. Das ist das gesamte VBIOS als Hex Code. Einfach kopieren und in einem Texteditor versuchen die PowerPlayTable zu finden. Die Muster nach denen du suchen musst kannst du meiner Excel Tabelle entnehmen.


    Sobald du die PowerPlayTable hast, löschst du den Rest, sodass nur diese der Übersicht halber übrig bleibt. Dann schau dir an wo in meiner Excel Tabelle der Wert für Minimum PWM Limit steht. Mit dieser Information kannst du den Wert auch in der PowerPlayTable deiner Karte lokalisieren.


    Anschließend öffnest du die Taschenrechner App und wechselst in den Hex Modus. Hier gibst du nun den Hex Wert umgedreht ein (in der PowerPlayTable wird das Little Endian Format genutzt). Aus 0A 0B wird beispielsweise 0B 0A. Danach wechselst du in den Dezimal Modus und du siehst den Dezimalwert von Minimum PWM Limit.

    LG Chris


    Meine Hardware:

  • Ich bin gerade nach der guten Anleitung von CMMChris vorgegangen und habe die PowerPlayTable und damit auch den Minimum-PWM-Wert für meine Sapphire Radeon RX Vega 64 Nitro+ herausgelesen. Er lautet "28" (1C 00).

    Ich habe dann zunächst den Rest der pptable_v64-2.0.xlsx-Tabelle unverändert gelassen und nur diesen Wert ersetzt. Mit dem Lüfter-Verhalten war ich noch nicht ganz zufrieden und bin nun auf die Werte im Bild (ebenfalls aus einer Empfehlung von CMMChris aus einem anderen Thread) umgestiegen und habe dort aber zusätzlich wegen meiner Karte eben noch den Minimum-PWM-Wert auf 28 statt 35 gesetzt. Außerdem habe ich PP_DisableFanControl hinzugefügt, mit "3" als Number. Das Lüfterverhalten finde ich jetzt recht angenehm, nur ein bisschen "Coil Whine" habe ich noch, wenn er hochdreht.


    Ob die Abstürze jetzt ausbleiben, muss ich noch beobachten. Bisher kamen sie aus heiterem Himmel, nur einmal wirklich unter Last, ansonsten bei Kleinigkeiten wie E-Mail-Schreiben, aber vielleicht liefen ja irgendwelche Prozesse von macOS im Hintergrund, die die GPU kurz mal zu heiß werden lassen?)
    Der Bildschirm wurde dann immer schwarz und die GPU-Lüfter haben im Moment des Absturzes voll hochgedreht, bis man den Ausschaltknopf gedrückt hat.


    Mein System ist:

    macOS Mojave 10.14.3

    Motherboard: Gigabyte Z390 Designare

    GPU: Sapphire RX Vega 64 Nitro+ 8GB

    CPU: Intel Core i9 9900K

    Kühler: BeQuiet Dark Rock 4 Pro

    RAM: 2x16GB HyperX Predator DDR4-3600 DIMM CL17

    PSU: 750W Corsair RM750x

    SSD: 1000GB Samsung 970 Evo M.2 2280 NVMe

    Bluetooth/WiFi: BCM943602CS Combo Karte


    Der Systemordner ist komplett sauber und ohne irgendwelche Änderungen, weil ich eine Vanilla-Installation gemacht habe. Sämtliche Anpassungen befinden sich also ausschließlich im EFI-Ordner.


    EDIT:

    Die richtigen Werte meiner Sapphire RX Vega 64 Nitro+ für

    Power Limit W: 240 (F0 00)

    Current Limit A: 300 (2C 01)

  • Der Bildschirm wurde dann immer schwarz und die GPU-Lüfter haben im Moment des Absturzes voll hochgedreht, bis man den Ausschaltknopf gedrückt hat.

    Das bedeutet, dass eine Komponente auf der Karte überhitzt ist. Die Karte führt dann eine Notabschaltung durch. Bzgl. Spannung und Takt solltest du die aktuell in der Tabelle standardmäßig gesetzten Werte nutzen. PP_DisableFanControl kannst du rauswerfen. Nimm noch PP_DisablePowerContainment = 1 und PP_DisableDIDT = 1 mit rein.


    Für die Lüftereinstellungen nimmst du 3500 als Maximum. Außerdem solltest du mal ausprobieren wie du mit der Lautstärke ohne Zero RPM zufrieden bist. Die Lüfter sprechen nämlich schneller auf Temperatur Änderungen an, wenn sie immer laufen. Setze dazu mal EnableZeroRPM auf 0 und sie Start und Stop Temperature ebenfalls auf 0. Als minimale Lüftergeschwindigkeit kannst du 800 - 900 RPM setzen, je nachdem ab welcher Drehzahl die Lüfter tatsächlich anfangen sich zu bewegen.


    Wenn dann alles stabil läuft kannst du noch versuchen die HBM Spannung auf 1000 zu setzen. Wenn das dein Coil Whine wieder verstärkt lass es auf 1075. Außerdem kannst du versuchen mit dem HBM Takt noch etwas raufzugehen (1000, 1025). Danach wieder auf Stabilität testen und Temperatur prüfen.

    LG Chris


    Meine Hardware: