Anleitung für Broadcom-WLAN-Patch unter macOS Sonoma

  • guck, kaum macht man es richtig, funktioniert es :) glückwunsch dazu :)


    lg :)

    --

    du kannst ja mal deine efi nun ersteinmal sichern,- wenn du das gemacht hast, vergleiche deine ursprungs mit der jetzigen efi,- dann ersiehst du die änderungen/unterschiede :)

  • Das mache ich auf alle Fälle. BVB Führt 3:1. alles klasse heute.

    ja nach dem Update auf 14.1.1 ist mein W-Lan wieder fort.S...Apple

    Was haben die den da wieder angestellt.

    GA-B460M-D3H, ATI Radeon RX570 ,OpenCore 9.5 Ventura
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win11

    Edited once, last by tidow ().

  • ja nach dem Update auf 14.1.1 ist mein W-Lan wieder fort.S...Apple

    Was haben die den da wieder angestellt.

    GA-B460M-D3H, ATI Radeon RX570 ,OpenCore 9.5 Ventura
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win11

  • Die haben Dir den Treiber wieder deinstalliert.

    Du musst nochmal das Terminal bemühen und dann den OCLP starten und die fehlenden Treiber wieder installieren.

    Das ist der Nachteil dieser Methode, aber es gibt da keinen anderen Weg.

  • die musst den Patch wiederholen tidow

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • der Patch hilft nicht. Der kennt 14.1.1 ja noch nicht.

    Der ist natürlich schon 3 Mal durchgelaufen.

    GA-B460M-D3H, ATI Radeon RX570 ,OpenCore 9.5 Ventura
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win11

  • wie soll der 14.1.1 nicht kennen, wenn er 14.2 Beta 4 kann.? tidow


    EDIT: Du kannst versuchen einenaktuellen OCLP zu bauen.

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

    Edited once, last by Arkturus ().

  • Den braucht es nichtmal...

    Das Problem wird sein das entweder die SIP wieder aktiv ist oder AMFI nicht richtig im Zaum gehalten wird...


    Wie sieht das mit AMFIPass.kext aus bei Dir? BootArg passend gesetzt? Zeig mal config.plist tidow

  • hier ist sie


    Unter

    Files

    • config.plist

      (63.05 kB, downloaded 18 times, last: )

    GA-B460M-D3H, ATI Radeon RX570 ,OpenCore 9.5 Ventura
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win11

  • Du hast Doch eine Fenvi gekauft richtig?


    Wenn ja dann brauchst Du weder den AirportBrcmFixup noch den BrcmPatchram3 und/oder BlueToolFixup und auch nichts was zu einem dieser Extensions gehört. Ansonsten musst Du wirklich na jedem Update den Patcher neu laufen lassen (wobei der sich aber auch meldet und Dir sagt das er erkannt hat das die Patches fehlen). Generell ist der Patcher in der Version 1.2.1 oder höher ist kompatibel mit allen aktuell verfügbaren Versionen von Sonoma (bis inkl. 14.2 Beta 4). Wenn der Patcher den Patch anbietet dann sollte er auch laufen. Ich hab mal die unnötigen Extensions deaktiviert (config.plist im Anhang)...

    Files

    • config.plist

      (62.97 kB, downloaded 16 times, last: )
  • Jo jetzt habe ich wieder W-Lan. Danke und Sogaar ohne den Patch. Danke gleich mal sichern. Danke warum gibt es keine Smileys mehr? naja Gute Nacht.

    GA-B460M-D3H, ATI Radeon RX570 ,OpenCore 9.5 Ventura
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win11

  • Die gibt es schon noch musst mal Deinen Scriptblocker so einstellen das er sich hier auf der Seite benimmt [hehee]


  • sorry, ich habe mich vertan

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Moin —-> Sonoma Freunde.

    Habe es nun euch endlich geschafft / mir die Zeit genommen Sonoma zu installieren.


    Alles lief zunächst Reibungslos, bis ….. es zum Wlan patchen mit OCLP 1.21 kam.


    Danach bootet Sonoma nicht mehr.


    Bleibt irgendwo stehen, wo dann öfters AMFI zu lesen ist.



    Installiere gerade das dritte mal neu.


    Nun ist es an der Zeit mal nachzufragen, bezüglich der Patcher einstellungen.


    Ich poste hier mal die Screenshots von den Einstellungen.


    Irgendwas läuft schief mit diesem AMFI.


    Obwohl wahrscheinlich schon hier mehrmals erklärt. aber wofür steht das nochmal?


    Also dieses AMFI.

    Kann vielleicht gütigerweise jemand was zu meinen Screenshots sagen?


    Gibt es sonst noch Sachen die man unbedingt an haben muss bzw. ausstellen muss?

    Braucht es noch die EFI?

    Also wie gesagt. Eigentlich wollte ich ja nur den W-lan Patch ausführen. aber er macht ja dann leider alles an einstellungen. Un da passt irgendwas nicht.

    Kann mir jemand bitte damit helfen.






    Eigentlich dachte ich, das er nur das WLan Patching macht und gut. aber nö.... da scheint es noch Irgendwas zu zerhauen im System dann.


    Files

    • S14.1 efi.zip

      (6.51 MB, downloaded 9 times, last: )

    Hardware:


    1. Original MacMini Late 2012


    2. Ipad Pro 12.9 2018


    3. HacMini Late 2018 ( Intel NUC 8I7HVK Hades Canyon )

    Edited 2 times, last by Maulwurf ().

  • es genügt i.d.R., den Installer über das korrumpierte macOS drüber zu bügeln, um den Fehler vom OCLP zu bereinigen. Maulwurf

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Echt. Hab jetzt leider nicht drauf geachtet, ob dann W-Lan da war oder nicht.


    Mist.


    Also du sagst, den Patch ausführen und dann nochmal drüberBügeln und dann wäre auch W-Lan da?


    NAch dem Patchen bleibt es immer an dieser Stelle hänge.


    Bootet weder mit der System Efi noch mit der Install Usb Stick Efi.


    mmmmh

  • Nein, ich meine wenn das System wegen fehlerhaftem OCLP Patch nicht mehr funktioniert, also kein Login mehr möglich ist, dann nicht alles Löschen sondern Sonoma drüber Installatieren.
    Falls das gelingt erstmal mit Revert die alten Patches entfernen und erst dann den Patch neu ausführen. Vorher einen Reboot dann bist du sicher.

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • hallo Maulwurf ,

    könntest du bitte mitteilen, um welche sonoma version es sich genau handelt und ob du das auf einem nativen mac, oder auf einem hacky installiert/gepatcht hast-welcher rechner?


    deine efi enhält auch kexte die mutmaßlich für bigsur/catalina sind, enthält weder amfipass.kext noch das "dreigespann" der ioskywalk-kexte,- dessen block schon, das ggf, restrictevents ist auch nicht enthalten- demzufolge auch weder noch deren bootargs hast du eine fenvi t919 verbaut?

    sprich deine efi-wenn du diese von anhang nutzt ist nicht ganz stimmig


    lg :)

  • die EFI ist von einem Hacki

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • ok, dann fehlen einträge


    lg :)

    ---

    edit

    bei uefi-apfs würde ich bei mindate/minversion jeweils "-1" eintragen, den haken bei hide verbose auch für den moment wegnehmen, bei kernel -add, folgende kexte hinzufügen: amfipass.kext (+bootarg -amfipassbeta) , ioskywalkfamily.kext (den appleeigenen blockst du ja bereits+ "minkernel:23.0.0") , io80211family-kext (+ "minkernel:23.0.0"), io80211familylegacy.kext (+ "minkernel:23.0.0"), restrictevents.kext (+bootarg revpatch=sbvmm) , bluetoolfixup.kext airportbcrmfixup.kext


    das fällt mir dazu ein, ggf. noch ein usb portmapping