Update von Mojave auf Big Sur oder höher

  • Guten Tag zusammen,


    nach langer Zeit bin ich gezwungen ein Update zu machen da meine Aktuellen Programme Mojave nicht mehr unterstützen.

    Meine Einstellung ist eher never touch a running system... weswegen ich mich nur wage an den Installationsvorgang erinnern kann.

    Geschweige denn auf dem laufenden bin :think:


    Nach einiger Recherchezeit musste ich feststellen das sich einiges geändert hat und ich eure Hilfe benötige.


    Ziel ist es von Mojave auf ein möglichst aktuelles Update zu kommen.

    Vorausgesetzt die vorhandene Hardware lässt dies zu.

    1. Frage: Welches wäre das aktuellste Update das ich aufspielen könnte ?


    So wie ich es verstanden habe muss ich vor einem Update mein Clover updaten, (aktuell 4920) bzw. auf Opencore umsteigen.

    2. Frage: Auf welche Cloverversion soll ich mit meiner Hardware gehen oder macht es mehr sinn auf Opencore umzusteigen ?


    Des Weiteren habe ich mit Carbon Copy Cloner ein Backup auf eine Externe Festplatte erstellt die Bootfähig ist.

    Auf dieser wollte ich das Update durchführen um mir durch einen Fehler nicht das ganze System zu zerschießen.

    3. Frage: Ich habe festgestellt, wenn ich das Backup von der externen Platte Boote und dort eine Datei lösche oder hinzufüge. Das diese Änderung nach dem booten der SSD mit dem "Original System" nach kurzer zeit die selbe Änderung vornimmt. Genau dies möchte ich ja in meinem Fall nicht haben wenn ich auf dem Backup das update durchführen möchte. SafetyNet ist auf Aus gesetzt und der Backupplan deaktiviert/gelöscht. habe ich was falsch gemacht oder einen Denkfehler ?


    Bin über jede Hilfe dankbar, und auch für andere Vorschläge um ans Ziel zu kommen.

    Vielen dank im voraus !


    Zum Schluss noch meine Setup:


    macOS Mojave 10.14.4


    Clover: 4920


    Prozessor:

    Intel Core i5-4690 4x3,5GHz


    Mainboard:

    Gigabyte GA-Z97M-D3H


    Grafikkarte:

    AMD Radeon HD 7870 2 GB


    Arbeitsspeicher:

    8 GB DDR3 1866 CL10 Kingston Fury


    Netzteil:

    be quiet! System Power B8 450W


    Kühler:

    Intel Boxed


    SSD 1 für MAC:

    Samsung SSD 850 EVO Series 250GB


    SSD 2 für Windows:

    WDC WDS120G1G0A-00SS50


    HDD:

    WD Blue 3,5-Zoll-PC-Festplatte mit 3 TB


    Laufwerk:

    DVD-RW SATA Samsung


    Files

    • EFI.zip

      (3.93 MB, downloaded 42 times, last: )
  • generell als tip, weißt du vermutlich,- baue dir einen extra bootteststick, mit welchem du die /oder neue efis erstmal testest und wenn das system damit läuft- kannst du diese ins system übertragen-kopieren


    lg :)


    --

    edit zu clover - > https://github.com/5T33Z0/Clover-Crate

    inwiefern deine d-gpu läuft kann ich dir nix sagen, deine igpu sollte bis big sur/ monterey laufen


    edit 2- falls es dich zu opencore zieht, wäre dies der weg- aufgrund der cpu - > https://dortania.github.io/Ope…config.plist/haswell.html


    edit3-

    das die daten später auch auf dem 2t laufwerk gelöscht werden liegt an dem synch feature- wenn du z.b. mit /dev/null synchst... wird alles gelöscht.., ;) - also fluch und segen zugleich


    edit 4-

    anscheinend läuft deine dgpu auch bis monterey - näheres in der info - https://dortania.github.io/GPU….html#hd-8000-series-8xxx

  • Danke schon mal für die schnelle Antwort :thumbup:


    Das hört sich ja schon mal gut an das meine Grafikkarte unterstützt wird.

    Kexst'e habe ich in dem fall schon mal runtergeladen.


    Nun wollte ich meine bestehende Clover Version 4920 mit dem Clover Configurator Klonen um von der geklonten Version dann auf die aktuelle 5148 Version zu Aktualisieren.


    Nach dem Klonvorgang muss ich ja noch das Clover-Installationsprogramm drüber laufen lassen um diese Bootfähig zu machen, aber unter den Werkzeugen -> Installiere/Aktualisiere Clover wird mir nur die Aktualisierung von 4920 auf 5148 angeboten.


    Die zweite Option, direkt einen neuen mit der Version 5148 zu erstellen scheitert auch an dem Punkt das mir nur eine Aktualisierung angezeigt wir.


    Hatte eigentlich von früher in Erinnerung das ich einfach eine Setup durchgeführt hatte und diese mir ohne Probleme die Cloverversion auf den USB Stick installiert hatte. Jetzt habe ich von hier nur eine Zip Datei bzw. beim Entpacken das direkte Clover-Verzeichnis mit Unterordnern.


    Wie stelle ich es richtig an ?


    Ich sehe schon wenn es hier scheitert... wird ein langer Weg für mich :lasche:

  • Hi,

    du musst das Install Programm nicht nutzen, aber du musst die config updaten um mit den neuen Versionen die OpenCore integriert haben booten zu können. Link hat glaube apfel-baum schon geschrieben, ich habe davon keine Ahnung was da richtig ist.

    Und dann die Dateien im Ordner auch aktualisieren mit denen der neuen Version, sollte eigentlich auch in dem Guide stehen.


    Würde ich noch empfehlen zu lesen: 3. OpenCore EFI Bootloader

  • Kann dein Rechner noch kein UEFI-Boot? Wenn der Rechner das kann ist der ganze Aufwand mit dem Setupprogramm umsonst. UEFI-Fähige BIOS-Versionen können direkt die BOOTX64.efi im EFI-Ordner starten.


    Die EFI auf einen im FAT32 Formatieren Stick kopiern und davon starten.


    An die Quirks denken. Sind neu in denn neueren Clover-Versionen. Ansonsten startet da gar nichts.

    [GUIDE] Clover updaten (ab v5123) inkl. OpenRuntime und Quirks (UEFI only)


    Das hier ist Müll, einfach ignorieren.

    3. OpenCore EFI Bootloader

  • Kann dein Rechner noch kein UEFI-Boot? Wenn der Rechner das kann ist der ganze Aufwand mit dem Setupprogramm umsonst. UEFI-Fähige BIOS-Versionen können direkt die BOOTX64.efi im EFI-Ordner starten.

    Das war mir nicht bekannt, ja UEFI-Boot ist möglich. aber der vollständigkeit halber noch zu meiner Frage:

    Hatte eigentlich von früher in Erinnerung das ich einfach eine Setup durchgeführt hatte und diese mir ohne Probleme die Cloverversion auf den USB Stick installiert hatte. Jetzt habe ich von hier nur eine Zip Datei bzw. beim Entpacken das direkte Clover-Verzeichnis mit Unterordnern.

    Wie stelle ich es richtig an ?

    Unter GitHub direkt kann man die Clover Versionen als Installationsdatei laden, mit der .pkg Endung. Sicherlich für die meisten hier selbsterklärend aber vielleicht ja doch noch für Irgendjemanden hilfreich.



    Danke für die Tollen Anleitungen, habe jetzt einen zweiten Bootstick mit Clover 5148 erstellt.
    Mit diesem konnte ich mein macOS Mojave 10.14.4 schon mal starten :thumbup:


    Habe mich an die Anleitungen gehalten, aber über die Datei "CloverConfigPlistValidator_5148"

    habe ich nichts gelesen, habe ich da etwas wichtiges ausgelassen ? Für was ist diese Datei ?

    edit3-

    das die daten später auch auf dem 2t laufwerk gelöscht werden liegt an dem synch feature- wenn du z.b. mit /dev/null synchst... wird alles gelöscht.., ;) - also fluch und segen zugleich

    Nun möchte ich probieren macOS Monterey zu installieren, macht es in meinem Fall mehr sinn zum test eine Neuinstallation auf einer Externen Platte zu machen ?


    Wäre denn ein Update von Mojave direkt auf Monterey überhaupt möglich ?


    Über tipps wie ich hier am besten vorgehe wäre ich dankbar, möchte mein Aktuelles System mit Mojave jedenfalls nicht direkt überschreiben/updaten falls was schief läuft.

  • "CloverConfigPlistValidator_5148" ist zum Prüfen deiner config.plist


    Zum Testen von Monterey kannst du dank APFS einfach ein neues Volumen neben deinem macOS Mojave Volumen erstellen und das als Installationsziel auswählen. Entweder läuft dann Monterey oder nicht mit der EFI. Das ganze hat auf die Mojave Installation keinen Einfluss.


    Die Installationsdatei mit der .pkg Endung ist bei UEFI unötig und aus meiner sicht viel zu kompliziert. Herunterladen der reinen EFI und Update der Inhalte in die vorhandene EFI ist viel einfacher.

  • Das mit dem APFS ist ja echt praktisch, habe jetzt unter Samsung SSD 850...-> Container disk1 -> Mac OS X (mit bestehendem Mojave System drauf) & neu erstellt Mac Monterey zum testen.


    Nun bin ich mit meiner Installation nicht gerade weit gekommen.. Bekomme gleich am Anfang die Meldung:

    Support.apple.com/mac/startup und Rechner wird automatisch heruntergefahren.


    Zum erstellen des Insatallstick's habe ich mich an folgende Anleitung gehalten.

    Die Installationsdatei konnte ich im App Store nicht direkt runterlasen, Meldung:

    Der erforderliche macOS-Version ist nicht verfügbar.


    Habe dann mit Hilfe des OpenCore Legacy Installer den Monterey Installer heruntergeladen und auch gleich den Installstick damit erstellt.


    Habe das gleich auch noch mit dem TINU Programm probiert, leider die Selbe Meldung.


    Was mache ich falsch ?

  • Kannst du denn aktuellen Stand von deinem EFI-Ordner hochladen?

  • Ja, selbstverständlich :thumbup:


    Die Einstellungen für BOOTER- und KERNEL-EINSTELLUNGEN (QUIRKS)


    CPU

    └── Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz

    ├── Cores: 4 cores

    ├── Threads: 4 threads

    ├── SSE: SSE4.2

    ├── SSSE3: Supported

    └── Codename: Devil's Canyon


    In dem Fall Haswell habe ich angenommen, habe ich aus dieser Quelle entnommen.

    Files

    • EFI.zip

      (7.53 MB, downloaded 35 times, last: )
  • Ist das Absicht das deine SMBios Einstellungen komplett leer sind?

  • Nein, eher Unwissenheit.


    Also im BIOS selber hatte ich nach Anleitung Einstellungen vorgenommen, allerdings schon länger her bei der Mojave Installation.


    Sind hier zusätzliche Einstellungen im Clover nötig ?

  • Ich habe im SMBios verschiedene Systeme ausgewählt, leider ohne Erfolg.


    Core i5-4...

    Mac mini 7,1 -> Apfelsymbol -> Ladebalken -> Fehlermeldung (Support.apple.com/mac/startup)


    Zwar nicht meine CPU Generation aber trotzdem probiert Core i5-5...

    iMac 16,2 -> Apfelsymbol -> Ladebalken -> Neustart

    iMac 17,1 -> Apfelsymbol -> Ladebalken -> Fehlermeldung (Support.apple.com/mac/startup)


    Systeme die mehr zu meiner CPU passen würden werden von Monterey nicht mehr unterstützt.


    Habe ich noch irgendwo einen Fehler drin, oder ist meine CPU zu alt für Monterey ?

  • Eben gesehen das du FakeSMC.kext und VirtualSMC.kext parallel benutzt. Das funktioniert nicht.


    Nur eine der beiden verwenden und da würde ich denn VirtualSMC.kext bevorzugen in der neusten Version.

    Auch die SMCHelper.efi löschen.

  • Eben gesehen das du FakeSMC.kext und VirtualSMC.kext parallel benutzt. Das funktioniert nicht.


    Nur eine der beiden verwenden und da würde ich denn VirtualSMC.kext bevorzugen in der neusten Version.

    Auch die SMCHelper.efi löschen.

    Habe dies befolgt, nur leider ohne Erfolg .


    Habe in der Zwischenzeit noch versucht in die Boot-Argumente -no_compat_check einzufügen.

    Habe daraufhin eine Mac Version gewählt die besser zu meiner CPU passt iMac 15,1

    aber selbes Resultat > Apfelsymbol -> Ladebalken -> Fehlermeldung (Support.apple.com/mac/startup)

    ohne die Boot-Argumente -no_compat_check bekomme ich gleich am Anfang die Meldung:

    This version is not supported.


    Des Weiteren habe ich noch versucht Big Sur zu installieren, auch hier das selbe Problem.

    Auch mit einem System 14,4 was Big Sur unterstützt und auch zu meiner CPU passt.


    Zuletzt hatte ich noch versucht meine Grafikkarte auszubauen und so die Installation durchzuführen,

    auch hier das selbe Problem.


    Habe mir die Quirks Einstellungen nochmals angeschaut, dabei ist mir aufgefallen das unter Kernel and Kext Patches der Punkt KernelPM bei mir hell grau ist bzw ich diesen nicht aktivieren kann. Laut Anleitung müsste diese aber Aktiviert werden, jemand eine Ahnung warum das so ist ?


    Und natürlich noch irgendwelche Ideen was ich sonst noch testen könnte ?


    Im Anhang nochmal die aktuelle EFI.

    Files

    • EFI.zip

      (7.49 MB, downloaded 33 times, last: )
  • Nochmal für mich bitte...die efi geht gar nicht oder eine bestimmte macOS Version geht beim installieren nicht? weil für Big Sur und Monterey brauchst du ja ein usbmapping.

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.9.4 - Win 11 macOS Ventura / macOS Sonoma

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Sonoma

    MacMini 6,1  Late 2012 - macOS Ventura Beta - OC Legacy Patcher 0.6.9

  • Mit angehängter veränderter EFI von dir konnte ich bei mir Monterey starten. Schaue da mal unter Kexte und was dir noch komplett fehlt ACPI > patched was ich verändert habe.

    Dein EFI-Ordner ist noch lange nicht fertig. Der Hinweiß mit dem USB-Mapping ist auch Gold richtig.

  • Nochmal für mich bitte...die efi geht gar nicht oder eine bestimmte macOS Version geht beim installieren nicht? weil für Big Sur und Monterey brauchst du ja ein usbmapping.

    Die EFI funktioniert für mein altes Mojave System aber nicht für die Monterey Installation.


    Mit angehängter veränderter EFI von dir konnte ich bei mir Monterey starten. Schaue da mal unter Kexte und was dir noch komplett fehlt ACPI > patched was ich verändert habe.

    Dein EFI-Ordner ist noch lange nicht fertig. Der Hinweiß mit dem USB-Mapping ist auch Gold richtig.

    Habe das USB-Mapping mit Hilfe dieser Anleitung durchgeführt, und mit der abgeänderten EFI von dir konnte ich die Installationsoberfläche von Monterey zum ersten mal sehen :verneigen:


    Musste dann aber nochmals im SMBios auf iMac16,2 umstellen was Monterey unterstützt damit die SSD auch für die Installation wählbar war. Davor war bei allen Platten die Meldung: Installation auf ... nicht möglich.


    Nach der Installation musste ich noch für den Sound nach folgender Anleitung vorgehen.


    Mich würde noch interessieren was für schritte du genau unternommen hast für die Änderung im ACPI > patched. Vielleicht in dieser Anleitung die Überschriften, die nötig waren.


    Ich danke allen vielmals für eure Zeit und Hilfe !:danke2:

  • In der config.plist von Clover habe ich dazu nichts verändert. Du must in den Ordner ACPI > patched schauen. Da fehlten zwei Dateien welche für deinen Rechner wichtig sind.


    SSDT-EC.aml

    SSDT-AWAC-DISABLE.aml


    Denn uralt Kext NullCPUPowerManagement.kext zu verwenden war sicher auch nicht zielführend. Daher habe ich denn gelöscht.