Clover r5125 ff. und die Quirks

  • Ich habe keine Probleme damit das Clover nicht gleich das richtige anbietet!

    Musst Du auch nicht haben, speziell wenn Du nur ein OS benutzt. Ich habe es unter den beschriebenen Umständen aber. ;)

    Und ich habe auch nicht behauptet, dass OC Alles richtig macht. Und ich als Anwender älterer Hardware - speziell Haswell und noch spezieller Gigabyte - weiß sehr wohl um die Meldungen sowohl hier im Forum als auch draußen in den OC-Foren. Ich war auch Betroffener, wenn Du Dich erinnerst.

    aber seit clover 5126 läuft Clover genauso gut

    Genau da gehen unsere Meinungen wohl auseinander.

    Ich erwarte nicht nur reines "Laufen", sondern die Optik muss auch stimmen.

    Wenn ich mit Metall oder Holz arbeite und muss ein Teil mit einer Erweiterung versehen, um einer neue Funktion herzustellen, dann muss das (für mich) so geschehen, dass das Endergebnis so ausschaut, als wäre es schon immer so gewesen und dass man an der Oberfläche keine Arbeits-/Änderungsspuren mehr erkennt: es ist dann perfekt eingearbeitet und hat vollumfängliche Funktionen.

    Aber das kann Jeder nach seinem Gusto auch anders sehen. ;)


    Genug der Philosophie: hast Du eine Idee, wie ich den BS-Preboot-Eintrag als einzigen sichtbaren aus den anderen herausfiltere?

    Gruß

    LOM



  • Du meinst so was wie das hier?


    Wenn man sich GUI Einträge erstellt und die automatischen Scanns abschaltet geht das.

    Ist nur das drin was ich auch sehen möchte.

    Grüße und Good Hack Michael


    :hackintosh:

  • Du meinst so was wie das hier?

    Wenn Du damit meinst, aus dem eigentlichen Eintrag Preboot ... BS den gewünschten BS .. zu machen und den nicht nutzbaren BS... raus zu werfen und ebenso die Preboots der anderen OS - dann ja. Das könnte die Sache zumindest übersichtlicher gestalten und anwenderfreundlicher machen.

    Das dürfte aber nicht über die Custom Entries gehen - da reihe ich ja nur auf. Wo muss ich mich da einlesen?

    Gruß

    LOM



  • Das mit dem Einlesen ist ein Problem bei Clover. Eventuell hier wenn man es versteht.

    Clover Online-Dokumentation


    Ich habe mich da mit Try-and-Error eingearbeitet. Das Bild oben zeigt nur Custom Entries. Alle Scans sind aus.

    Grüße und Good Hack Michael


    :hackintosh:

  • Ich habe mich da mit Try-and-Error eingearbeitet.

    Willkommen im Klub! ;)

    Ich schau mich mal um.

    Gruß

    LOM



  • Neuer Anlauf - neues Glück.


    Es hat mich nicht ruhen lassen. dass mein Catalina auf der SSD, das ich schon seit Anfang der Betas dort eingerichtet hatte, seit einiger Zeit Bootloader-spröde wurde, was sich besonders bei Clover nach 5096 und nach dem Übergang von 10.15.6 auf 10.15.7 bemerkbar machte.

    Man mag sich daran erinnern, dass plötzlich bei 10.15.7 eine neuere Clover-Version erforderlich war.

    Aber dennoch kam es mir seltsam vor, das 10.15.7 auch bei OC widerborstig war - zuweilen war ein zweiter Bootanlauf notwendig, weil Catalina unterwegs die Kehre machte.

    Weil das Theater hier bei meinen Clover5127-Bemühungen weiter ging und mir nicht in den Kopf wollte, wieso bei Catalina, obwohl BS mMn doch wohl das dickere Brett für Clover & OC ist, habe ich einem anderen Ansatz gewählt.


    Meinen Clover5120-Bootstick (war bis BS@OC mein BL) & den 10.15.6-Installstick her und auf einer HDD im Flexi-Container Platz für eine Testinstallation geschaffen. Das ging eine Zeit lang seinen Gang und dann war 10.15.6 installiert und bootete ohne Zucken mehrmals hintereinander. Dann habe ich auf den Clover5127-Bootstick gewechselt und auch Alles durchbooten lassen. Nach dem Update auf 10.15.7 und den folgenden Si-Updates gab es auch noch keine Beschwerden.


    Ich interpretiere das bis dato so, dass mit der 10.15.7 auf der SSD etwas krumm läuft, ich aber immer auf der BL-Seite gesucht habe.

    Ich werde jetzt auch nicht den Migrationsassistenten oder die Recovery + TM nutzen, sondern schön neu installieren, was so gebraucht wird. Läuft ein Programm quer, sollte es sich bemerkbar machen. Ich glaube aber als Ursache weniger daran.


    Somit habe ich zumindest alle macOS von HS bis BS mit 5127 startfähig und kann mich nach vollendeter Einrichtung von Catalina dem Thema BS-Preboot widmen (wenn ich denn Lust dazu habe ;) ).


    Ich hoffe, ich bleibe bis auf Weiteres von Cata-Zickereien verschont.

    Gruß

    LOM



  • Ich habe auch mehrere OS. Verbaut ist windows 8.1. auf eigener ssd und Big Sur auf ssd. dort ist auch Clover. Meine Alte Platte weil etwas klein hat Mojave und Catalina drauf. Die ist in ein USB C Gehäuse gewandert. Dort ebenfalls 5128 drauf.


    Catalina ist für mich aber unwichtig. Benötige Mojave weil Quarkexpress 2015 unter Big Sur abschmiert. Unter Catalina lief es richtig blöd.

    Ich finde auch Mojave besser gegen Catalina.

  • schön neu installieren,

    Ich habe in Erinnerung alter Vorgehensweisen bei zickigen/unwilligen OS X doch einen etwas anderen Weg eingeschlagen und - bevor ich die bestehende Catalina-SSD komplett löschte - so wie früher bei OS X einfach 10.15.6 über die bestehende 10.15.7 installiert. Das ist ja gegenüber WinOS ein entscheidender Vorteil, dass dabei alles bislang Eingerichtete so bestehen bleibt.

    Was soll ich sagen? Kein Start-Problem mehr - 10.15.7- & Si-Update nachgezogen und Alles bestens. :)

    Ganz zum Schluß noch alle OS-Starts einzeln geprüft und zu guter Letzt von den Verbose-Mode ausgeschaltet.


    Ich staunte nicht schlecht, als heute Morgen Cata mittendrin hängen blieb. Sollte etwa ...?

    BS gestartet, Verbose wieder ein, um die Stelle des Stockens zu finden und Cata gestartet. Und Cata lief locker durch. Offensichtlich verursacht der deaktivierte V-Mode nur bei Cata einen Hänger. Und da ich das bei OC auch erlebt (und dazu noch keine Antwort gefunden) habe, ist die Ursache wohl eher BL-unabhängig.

    Da wechsle ich doch mal den Thread.


    Aber ist ja schon mal schön, dass (inzwischen) 5128 als Bl seinen Dienst verrichtet und mich mit gewohntem Bootmenü-Anblick erfreut. :)

    Jetzt muss ich nur noch die überflüssigen Preboot-Menüeinträge von HS, Moj und den nicht nutzbaren BS-Eintrag löschen.

    Gruß

    LOM



  • Lieber anonymous writer


    Starte Dank deinen Tipps jetzt mit dem Preboot Volumen, und ich muss

    sagen, BigSur funktioniert jetzt auch perfekt.


    Es lag also wirklich daran, daß ich das Preboot Volumen auswählen muss.

    Hatte ja leider in der EFI die Darstellung der Preboot Volumen ausgeschalten.


    Danke und schönen Abend.....

  • LuckyOldMan : Wenn Du genug über Clover abgelästert hast, hab ich auch noch eine Lösung für die Reboot-Darstellung. Leider ist das, was anonymous writer oben schreibt ja nur die Hälfte: Du musst Dir auch noch die richtigen Volume-UUIDs raussuchen, mit denen Du in Zukunft starten möchtest.

    Das geht aber relativ einfach: im Configurator unter GUI fügst Du ein Volume unter "Custom Entries" hinzu. Da suchst Du dann die richtige UUID oder den richtigen Namen raus.

    Dann kannst Du Dein Volume für den Clover-Start auch noch beliebig umbenennen, also aus Deinem Preboot-Volume, das Du brauchst, einen BigSur-Starter machen oder so. Wenn Du den Haken bei Custom/Entries nicht setzt, werden ausschließlich genau diese Volumes nachher beim Start angezeigt. Das ist dann bei einem Update nicht unbedingt sinnvoll. Da brauchst Du ja zusätzlich immer das OSX-Install-Volume. Aber sonst..


    BTW: man kann bei Clover auch noch während des Starts die Config-Liste wechseln. Automatisch startet es ja immer mit der Liste mit dem klassischen Namen "Config.plist". Wenn man den Start bei der Volume-Auswahl unterbricht und bis auf Options/Configs geht, kann man die auswählen, die einem hier gefällt. (Ich mache vor größeren Veränderungen immer eine PList-Kopie über den Finder, Sicherheit geht vor..)

    Das Gleiche geht hier übrigens auch mit den Quirks-Einträgen. Mach das On-the-Fly mal mit OpenCore..


    :hackintosh:

    Edited once, last by MacGrummel ().

  • MacGrummel


    Das ist ein "Ablästern" im positiven Sinne bzw. eher ein Sich-Luft-machen, wenn man es nicht so hinbekommt, wie man es persönlich gerne hätte. Ich könnte es mir ja auch bequem machen, BS links liegen lassen, wie früher mein 5120 nutzen und mich nicht weiter damit befassen. Aber wie das schon mal so ist: es läßt Einen nicht ruhen. ;)


    Wie Du eventuell mitbekommen hast, habe ich die Clover-Fahne stets hochgehalten, auch wenn ich die ausgefeilten Möglichkeiten von OC mit dem Aufkommen von BS durchaus anerkenne und sie auch bis dato erfolgreich genutzt habe.


    Dennoch ist seit kurzem wieder mal Clover am Start (durch meine Methode, ausschließlich per Stick zu booten, ist ein BL-Wechsel von außen recht leicht zu bewerkstelligen) und ich bin froh, dass Du mit Deinem Leitfaden die Möglichkeit dazu aufgezeigt hast, weiterhin in langjährig gewohnter Umgebung zu agieren. :)



    Der Mensch ist zuweilen auch ein Gewohnheitstier. ;)


    Dass ein Umbenennen des Volumes im Falle eines Updates zur Verwirrung führen kann, ist mir auch schon in den Sinn gekommen - da muss man halt abwägen, ob es den Aufwand wert ist. Die beiden links nach WinOS verbliebenen Menü-Einträge "Boot Mac OS X Install for macOS Mojave via Preboot & "Boot ...... macOS High Sierra via Preboot", die ins Leere führen, muss ich allerdings entfernen - die nehmen Platz in der Breite weg.


    Spezifische Config-plists via Options nutze ich schon länger, denn die brauchte ich für meine OS X-Oldies: die Standard-Config.plist lief nur bis YOS runter - MAV braucht bereits schon leicht Modifiziertes, für ML & L habe ich die angepassten config.plists noch nicht richtig hinbekommen.

    Gruß

    LOM



  • MacGrummel ,ich habe auch nicht gegen Glover, aber bei Größeren Updates zersägt es mir immer den Grafigbeschleuniger. Meine HD 4000

    vom Lenovo G500. Kommentar: es wurde kein Treiber geladen. das hatte ich schon 2 mal, und immer wieder suche ich den Fehler. aus versehen selber zersägt. habe einen Stick für OC erstellt und in die falsche EFI gespeichert. Scheisse. Wollte einmal einen OC Stick für mein

    G 500 basteln. Glaube ich lasse das. Für BigSur ist des Teil sowieso zu schwach auf der Brust. i3 16 GB Speicher und sogar 2 Platten drin 1. Catalina 2. windof aber kann mich von nichts trennen. Bleibt Gesund.

    GA-B460M-D3H, ATI Radeon RX570 , Z77DS3H.OpenCore 6.6 Big Sur 11.2.1
    Lenovo G500, MacBookPro 9.2 W-Lan BCM94322HM8L. Glover 10.15.7 und win10

    MSI Z97-G43, Nvidia GT 640 4095, OpenCore 6.6 Big Sur 11.2.1 und win10

  • MacGrummel vielleicht hast Du einen Tipp für mich, ich habe über das GUI Menue im Clover Configurator die Anpassung meines Clover Boot Menüs versucht, um von den beiden Big Sur Options nur die Preboot Option anzuzeigen, die Option „Boot mac OS from Big Sur“ also auszublenden. Zusätzlich habe ich noch Win 10 und Catalina als Boot Volumes; diese beiden Boot Optionen konnte ich einfach ampassen, aber bei den Big Sur Optionen gestaltet sich die Konfiguration beschwerlich, zumindest für mich. Das Problem ist, dass die UUIDs für die beiden Big Sur Optionen im Clover Boot Menue identisch sind. Ich kann also bei den „Custom Entries“ nicht zwischen den beiden Big Sur Optionen differenzieren. Wie kann man das bewerkstelligen? 🤔


    Gruß


    Gerhard

  • Bei mir sieht das so aus


    Eintrag 2 sieht im ganzen so aus

    Code
    1. \1D2965A1-F89F-4A32-ABA8-B8309BF1944B\System\Library\CoreServices\boot.efi

    1D2965A1-F89F-4A32-ABA8-B8309BF1944B ist die UUID vom BigSur Daten Volumen.

    Grüße und Good Hack Michael


    :hackintosh:

  • anonymous writer Danke, ich habe es analog so bei mir umgesetzt und damit das Clover Bootmenue wie gewünscht anpassen können ;-)


    Ich habe noch eine zweite Variante erstellt, bei der die ursprünglichen Einträge im Clover Bootmenue erhalten bleiben, das nicht auszuwählende Big Sur Volume aber geeignet umbenannt wurde. Diese Variante habe ich jetzt auf meinem Notfallstick.


    Gruß


    Gerhard

  • Also ich muss sagen, wenn man darauf achtet, dass "Mann" beim Booten bei BigSur das Preboot Volumen erwischt

    und die anderen Volumen ausblendet funktioniert alles prächtig.


    Versteh nicht wieso alle so über Clover schimpfen..

  • Spezifische Config-plists via Options nutze ich schon länger, denn die brauchte ich für meine OS X-Oldies: die Standard-Config.plist lief nur bis YOS runter - MAV braucht bereits schon leicht Modifiziertes, für ML & L habe ich die angepassten config.plists noch nicht richtig hinbekommen.

    Da bin ich inzwischen einen Schritt weiter (wenn man den Wechsel auf 5129 nicht mitrechnet): Mountain Lion bootet jetzt auch mit einer angepassten config-plist, benötigt allerdings noch etwas Zuwendung bzgl. GraKa: 7MB ist doch etwas wenig.



    Lion dreht mit der config.plist leider direkt in einen Reboot ab.


    Dafür ist der Anblick von Snow Leopard (alle OS X von SL bis EC sind ja auf einer HDD) zumindest ein kleiner Ausgleich (wenn auch noch nicht mit 5129, sondern noch mit der iBoot Haswell-CD gebootet). Da benötige ich aber noch eine etwas höhere Auflösung.



    Ich meine mich an ein Projekt zu erinnern, wo Jemand kürzlich SL auf einem Haswell-System nicht zum Laufen brachte.

    Geht, wie man sieht. ;)


    Retro-Computing macht schon Laune. :)

    Gruß

    LOM



  • LuckyOldMan Ich finde Snow Leopard auch richtig schön.

    iMac19,1: Big Sur, Windows10, BL: OpenCore v063, Mainboard: Gigabyte Designare, CPU: i7-9700K, Ram: 32Gb Corsair Vengeance LPX; Grafik: Sapphire RX5700 XT Nitro+ 8Gb, SSD: Samsung 970 NVME 500GB, Samsung 850 Evo 500Gb, HDD: Seagate ST3000DM001 3TB Wifi/Bluetooth: BCM94360CD Combo (oob), PSU: be quiet! Dark Power Pro11, Case: Jonsbo UMX4

  • Snow Leopard auch richtig schön

    Stimmt ... und wenn ich mal auf Retro richtig Lust habe, ziehe ich einen der G5 nach vorne und nutze mal zur Abwechslung Leopard oder Tiger. ;)

    Gruß

    LOM



  • Ich denke die RX 560 ist auch ein wenig zu neu für ML, da werden noch keinen Treiber vorhanden sein, denke eher, daß das nichts wird...

    Hab auch heute 10.8.5 mit meiner HD 4000 (Laptop) gebootet, bis auf das Touchpad + Tastatur (vermutlich Kexte zu neu) lief es sogar :)