Beiträge von MacGrummel

    Im Grundsatz gehen Updates bei gut laufenden Rechnern eigentlich recht problemlos, besonders, wo Du von Allem ein Backup zu haben scheinst. Mojave wird mit deiner Grafik allerdings nicht wirklich laufen, die Nvidia-Techniker sind zur Zeit wohl mit dem Erstellen der neuen Windows-Sync-Treiber voll ausgelastet..

    Du solltest allerdings alle Hackintosh-Kexte aus den eigentlichen (Mac-)System-Ordnern in die Clover-EFI verschieben. Da findest Du sie leichter und kannst sie auch besser auf aktuellem Stand halten. BTW.: bitte die Hackintosh-Kexte UND Clover unbedingt vor dem System-Update auf den neusten Stand bringen. Wir hätten da auch ein passendes Tool..

    Mit der DVD von Deinem Freund wirst Du nichts anfangen können: die sind an den Rechnertyp und teilweise sogar an die Seriennummer gebunden. Bei Apple gibt es diese DVD aber immer noch zu kaufen. Für's Hackintosh-Schrank-Regal.

    Sonst lohnt sich die Vorbereitung an einem anderen Mac oder Hackintosh auf jeden Fall: Auch da kann der CloverConfigurator laufen, an dem Du viele Deiner Vor-Einstellungen erledigen kannst. Nur muss man sehr darauf achten, dass man dort nicht aus Versehen Clover auf die Mac-System-Platte installiert. Das gibt ernsthafte Start-Probleme..

    Rechner:

    Zotac Z-Box M553TB m.

    Kaby Lake i5 7300HQ, IntelHD 630 und Thunderbolt

    2x16GB DDR-4-Arbeitsspeicher

    Broadcom BCM94352Z M.2 statt Intel WLAN/BT

    NvME-SSD als Startplatte, normale SSD als Datenplatte


    Unterdessen bin ich wieder ein paar Schritte weiter gekommen: Ich kann zwar immer noch nicht nachvollziehen, warum der DP-Anschluss schon im BIOS partout nicht gehen will (und der zukünftige Schirm hätte den passenden Anschluss), ich habe aber keine Lust bei der Suche im BIOS wieder den Rechner abzuschießen. Auch den Clover-ACPI-Auszug für die DSDT bekomm ich trotz x Versuchen einfach nicht hin. Mag das System da keine Start-NVMe's?

    Die USB-Anschlüsse verwundern mich noch etwas: wenn ich meinen Ersatz-Booter in den Kartenschacht stecke, der gleichzeitig USB-Buchse ist, wird er nur erkannt, wenn er schon beim Start dort steckt. Das macht das Verändern der Config-Einstellungen etwas schwierig.

    Sonst läuft jetzt alles: Bt/WLAN mit allen Apple-Zusatz-Funktionen von Handoff über AirDrop bis zu iMessages dank der kleinen BCM94352Z M.2 und den jetzt komplett aktualisierten Kext-Sets aus AirportBrcmFixup, BrcmFirmwareData, BrcmPatchRAM2 und BT4LEContinuityFixup-Kexten.

    Der Sound geht jetzt komplett, also Kopfhörer, Mikro-Eingang und HDMI-Sound, wofür ich allerdings den AppleALC gegen Voodoo tauschen musste. Diese Blackbox ist mir stets unheimlich gewesen, auch wenn schon im Original-Ozmosis von meinem Quo eine speziell abgespeckte Version davon steckt(e).


    Was ich jetzt noch nicht wieder ausprobieren konnte ist die Grafik-Box über Thunderbolt, aber zumindest FireWire über die Kette TB3:TB2 und TB2:FW läuft tadellos.

    Jetzt kann sich der kleine Elch wieder anderen Projekten widmen, die Box steht an ihrem Bestimmungsort. Aber vielleicht kann apfelnico ja noch eine passende Thunderbolt-SSDT basteln, am Wochenende werde ich den Kleinen wieder besuchen..


    Eine "schon entwickelte Hackintosh-Version" ist keine gute Idee. Wir arbeiten hier im Forum ausschließlich mit dem von Apple direkt bezogenen unveränderten Original. Um diese Datei zu laden brauchst Du eine eigene Apple-ID (die sich jeder erstellen kann..), (und als juristische Lizens-Vorraussetzung eine DVD mit MacOS 10.6.3 von Apple) und Zugang zu einer im Mac-System GUID/HFS+-formatierten Festplatte, auch eine virtuelle in einer entsprechenden Virtuellen Maschine reicht hier. Aber mit irgendwo vorgefertigten Hackintosh-Platten können und dürfen wir Dir nicht weiter helfen.

    Leider ist Deine Mainboard-Bezeichnung (geht es genauer??) mehr so etwas wie ein Sammelbegriff, ich schließe aber aus Deiner CPU (die auch im MacPro von 2012 eingebaut war), dass es sich wohl um ein X58er Board handelt. Mit Deiner Nvidia-Grafik wirst Du unter macOS Mojave keinen Spaß haben, da fehlen schlicht passende Treiber und es ist nicht absehbar, ob und wenn wann Nvidia welche bereit stellt.

    Hast Du Dich schon etwas in unser Wiki eingelesen? Der Bootstick allein reicht nicht aus, Du wirst auch einiges zu Clover lesen müssen. Da brauchst Du nicht nur eine zu Deinem System passende Geräte-Definition, sondern auch den richtigen Ansatz: X58er und x67er Systeme bootet man über Clover schon in dessen Installation vorbereitet ohne den Haken "Installation für UEFI-Motherboards", mit ".. BiosBlockIO", damit auch ein USB-Stick hier funktionieren kann.


    Ich nehme mal an, dass es um den ASUS P7P55D geht? P55er Rechner sind eigentlich immer noch ganz brauchbar, besonders wenn sie auch noch mit FireWire-Anschluss ausgestattet sind und nicht mit den ersten USB-3-Versuchen.. Du hast doch eine DSDT in deinem Kistchen. Wo kommt die her, warum dann die tausend Haken im Configurator? Und ausgerechnet der Verbose-Haken im Configurator auf der "Boot"-Seite fehlt. Und jeglicher HFS-Treiber in EFI/Clover/Drivers64..

    Ich nehme auch mal an, dass Du normale SMBios-Daten über Enoch hast, in Deiner Clover-Liste steht ja nichtmal der Rechner-Typ. Woher kommt denn der ZEvOreboot.Kext? Ohne "Z" kenn ich da was..

    Wenn der Rechner aber mit Enoch klar kommt, würde ich den auch laufen lassen.

    Die PublicBeta ist auch schon da!




    Leider hat mein guter alter Haupt-Rechner, der MacPro5,1 - Ga-EX58-UD5 das Update zur Version 3 nicht überstanden: der hat sich irgendwo im Kabel-oder USB-Bereich beim Neustart kurz geschlossen und sagt keinen Ton mehr. Mit der Komplett-Demontage bin ich noch nicht durch, aber das Netzteil blinkt nichtmal. Schade nach so vielen Jahren.

    So schwierig kann das doch nicht sein, ich hab zwei derartige Gehäuse laufen und neben der leuchtenden LED sogar den kleinen Reset-Knopf als solchen wieder verwendet. Einfach mal durch probieren, so viele Möglichkeiten gibt es ja nicht. Wenn ich mich recht entsinne, gab es aber nur ein kleines Masse-Kabel. Ich sehe heute Abend mal nach, was ich Dir da Fotografieren kann, ist ja rückseitig wieder ne Box drauf und nicht die zugänglichste Stelle..

    Die Schalter-Sets gibt es eigentlich nur für die großen Rechner G5 und MacPro, da gehören dann auch USB, FireWire und/oder eSata dazu. Die haben die kleinen G3/G4-Gehäuse ja nicht im originalen Front-Panel.

    Das mit den zwei verschiedenen NICs bei der Box-Größe find ich lustig, ist aber in der PC-Welt eher normal und sorgt dann bei unseren Hackintosh-Versuchen das eine oder andere Mal für zusätzliche Probleme, eben weil wir dann zwei angepasste Treiber-Kexte brauchen.

    Mit der Beleuchtung war das nicht so ernst gemeint: die SMCBattery- und SMCLight- Kexte sind Erweiterungen für Notebooks, und die kleinen Z-Boxen haben weder einen Akku noch eine eingebaute Tastatur, weil sie eben Boxen sind..:kichern:

    BTW: Du brauchst weder den Voodoo-Kext für PS2, noch SMCBattery- und -Light-Sensor-Kexte für die kleine Box: Den Tastatur-Anschluss aus dem letzten Jahrhundert hat Intel bei den Mini-Boards endlich gestrichen. Und wenn Du eine beleuchtete Tastatur hast, muss die sich extern helfen.. Wahrscheinlich reicht auch allein der Intel-Mausi-Ethernet-Kext und Du kannst den für Realtek raus werfen.


    Läuft denn bei Dir der On-Board-Sound ? Bei meiner kleinen Kiste geht der leider nicht, über HDMI dagegen läuft der Sound prima, so lange ich bei Devices/Audio/Inject keine Zahl stehen habe..

    Ich gehe mal davon aus, dass Du mit einer kleinen WLAN/BT-Karte Broadcom BCM94352Z M.2 wie in der von mir aufgebauten Z-Box Mi553tb auch das WLAN-Problem endgültig lösen könntest, ich brauch bei diesem kleinen Kasten das WLAN jedenfalls dringender als das Lan-Kabel, der BT-Sender haut allerdings nicht so durch alle Zimmerdecken und -Wände wie beim iPhone...

    Auch Grummels kleine Kaffee-Maschine läuft seit langem mit so einem Teil und dem entsprechend abgestimmten Kext-Bausatz.

    Rechner:

    Zotac Z-Box M553TB m.

    Kaby Lake i5 7300HQ, IntelHD 630 und Thunderbolt

    2x16GB DDR-4-Arbeitsspeicher

    Broadcom BCM94352Z M.2 statt Intel WLAN/BT

    NvME-SSD als Startplatte, normale SSD als Datenplatte



    Mal ein paar Updates zu Grummel-Elchs Z-Box-Mini:

    - Der kleine Rechner arbeitet am saubersten als iMac18,1, auch wenn er nicht so aussieht..

    - Ich versuche seit einiger Zeit vergeblich einen Clover-ACPI/DSDT-Auszug per F4 beim Start hin zu bekommen. Weder auf der internen NvMe noch auf dem externen USB-Starter gibt es da ein Resultat, ich hab nur die DSDT oben von der ersten defekten Box..

    - Der Rechner arbeitet ohne DSDT und ähnliche Hilfen, nur mit al6042 's Standart-Hilfen für Kaby-Lake-Rechner aus seiner Aufbau-Box.

    - Sound über HDMI geht, über den "normalen" Aus- und Eingang und AppleALC leider nicht. Ich hab da noch immer nichts sinnvolles zum Codec im Netz gefunden und weiß nicht mehr, welche Nummer ich noch nicht probiert habe..

    - Der DP-Ausgang quittiert noch immer jeden Startversuch mit einem Hupkonzert, das hat sich auch mit der zweiten Kiste nicht geändert. Beim Anschluss eines Schirms mit analogem Eingangssignal über HDMI-Adapter übrigens das gleiche Hupen. Will er eben nicht..



    - Der BrcmPatchRam2.kext 2.2.7 (das ich direkt so von Grummels Kaffeemaschine übernommen habe) lässt sich nicht updaten, bzw. nach einem Update auf Version 2.2.10 gibt es kein Bluetooth mehr.

    Hab ich da bei den Punkten was vergessen?

    - Thunderbolt auf FW läuft von Anfang an prima, allerdings fehlt mir da noch apfelnico 's TB-Hotplug-Version. Und dazu eben auch siehe Punkt 1: ich hab ja weder DSDT- noch SSDT-Auszüge vom aktuellen Rechner..

    Die dicke Box mit der AMD-Grafik hab ich grad leider nicht hier, die BIOS-Einstellungen und die weiteren Auszüge sehen allerdings sonst wie oben aus.

    Auf der kleinen Kiste läuft die aktuelle Mojave-Beta-Variante. Mit dem Sound hatte ich aber von Anfang an keine Probleme über den Apple-ALC-Kext und einen entsprechenden Eintrag bei Devices/Audio/inject, ich glaub, es war die 1, komme aber zZt. nicht dran..

    Einfach geht es über den Clover Configurator: Da machst Du erst Deine eigene Config-pListe auf, dann gehst Du oben über File/New und machst eine neue auf, da suchst Du unter SmBios nach Deinem Rechnertypen und holst Dir da neue Nummern.