Mac Pro 5.1 macOS Ventura mit Asus Dual rx580 8gb geht nicht

  • Hello Forum Leute.


    hab heute mit Opecore Pachter 0.5.0 macOS Ventura auf dem Mac Pro 5.1 installiert. Doch leider läuft da die Grafikkarte (Asus Dual rx580 8gb) nicht. Die GTX Titan 6gb läuft problemlos. Desweiterens muss ich meine Maus und Tastatur auf ein PCIe USB Port belegen. (Sonnet) Im USB Port des Mac Pros wird es nicht erkannt. USB Sticks dennoch schon.


    Mit Freundlichen Grüßen

    EdgarsZimmer

    Classic Mac Pro 5.1 (2012) / AMD W5700

  • Kannst Du mit der eingebauten RX580 denn überhaupt in den Installer bzw. das Installierte System booten oder endet das Ganze einfach mit einem schwarzen Bildschirm? Das Problem mit der RX580 (Polaris und aufwärts im allgemeinen) ist die Tatsache das Ventura die offiziell unterstützt und somit auch versucht die offiziellen Treiber für die Karte zu laden was scheitert weil dem MacPro 5.1 die AVX-2 Befehlssatz Erweiterungen fehlen. Hier beißt sich die Maus irgendwie in den Schwanz denn den passenden Root Patch kannst Du mit OCLP nur anwenden wenn die Karte verbaut ist weil er sie ansonsten nicht erkennt und einbauen kannst Du sie auch nicht weil er mit eingebauter Karte nicht hochfährt.


    Mögliche Ansätze wären...


    • Boot in den save Mode (-x als Bootarg oder shift Taste im OC Bootmenu)
    • Das BootArg -amd_no_dgpu_accel verwenden (soll das laden der Treiber unterdrücken)


    Kannst ja mal testen. Wenn Du auf eine der beiden Weisen auf den Desktop kommst kannst Du den PostInstallRootpatch nochmal ausführen und im Anschluss sollte dann zumindest theoretisch die RX580 im MacPro werkeln können (natürlich die BootArgs dann wieder entfernen sofern eingefügt).

  • griven also in den Installer kann ich Booten und auch Installieren. Nach der Installation erkannt man ja das es nicht mehr Install macOS Ventura oder so ähnlich, sondern das der Name der Festplatte angezeigt wird. Dann kommt ein Bootscreen bis wahrscheinlich die Grafikkarte geladen wird. Dann passiert nichts. Bei der GTX Titan 6gb konnte ich so Prozent Zahlen lesen. Dann gibt es mit dem Einrichten. Bei der Rx 580 passiert dann Black screen mit dem Schriftzug auf dem Monitor kein Signal. Hab auch recht lange gewartet. Nichts Passiert.


    die Möglichen Ansätze werde ich dann Morgens Probieren.

    vielen dank schonmal


    griven im safe modus hat es leider nicht geklappt bleibt schon beim Apfel Logo hängen. Wie füge ich das BootArg hinzu?


    Update: opencore patcher 0.5.1 jetzt auf dem Stick und immer noch Probleme

  • würde also bedeuten, ein cMP könnte mit einer pre-polaris oder nvidia kepler karte ventura installieren und starten?

    °MacPro6,1 - Xserve2,1 - MacBook Pro11,4°



  • Bin auch dabei … melde mich mit Erfahrungen spätestens Donnerstag

  • Es ist nach wie vor Bewegung in der Polaris Kiste inzwischen gibt es den OCLP in der Version 0.5.2 (Selbst bauen) der das Thema nochmal adressiert in wie weit erfolgreich kann ich nicht sagen mangels Testmöglichkeiten...

  • bezüglich gcn-polaris der commit - bzw. kann man das auch im code nachlesen - https://github.com/dortania/Op…5a73a68d68a11051f13a0f81d

    ich habe es beim ivy nachwievor, noch nicht zum laufen gebracht


    lg :)

  • Hi Jungs,


    Ich kann machen was ich will, ich bekomme einfach die Rechte nicht den

    Patch auszuführen..........

    Am MBP2012 habe ich die Rechte.......... Komisch.... verwende die selben args

  • DerTschnig ,

    hast du das via eines seperaten usb-sticks schon ausprobiert, also ggf. mit der selbstgebauten version, und oder mit der release-version, oder mit der version für welche du einen gitacc benötigst? - oder hast du den schon als root via terminal gestartet?- das wäre noch eine möglichkeit

    ala "sudo su ->passworteingabe, dann bist du root,- im anschluß dort wo sich die app befindet, bzw. wanderst du dorthin und danach "./name der app.app"

    edit- geht natürlich nicht, da es ja via terminalebene ein verzeichnis ist.. ok..


    edit2- zu library validation - https://github.com/mologie/macos-disable-library-validation


    lg :)

  • Danke für den Tipp.........


    Kann ich die KEXT unter den Kernel in open core auch setzen ?

  • ich habe einfach mal nach der fehlermeldung geguckt, -siehe dein screenshot und dies war eines der ergebnisse- ggf. ist das vielleicht auch ein quirk oder eine einstellung bezüglich des securebootmodels "misc-security" oder ähnlich. das du den kext eintragen kannst, sollte auch möglich sein- ist bei anderen sachen ala netzwerktreibern ja nicht anders- es gilt da ja wie immer, das zuerst via eines seperaten efi usb-sticks auszuprobieren


    lg :)

  • ich habe einfach mal nach der fehlermeldung geguckt, -siehe dein screenshot und dies war eines der ergebnisse- ggf. ist das vielleicht auch ein quirk oder eine einstellung bezüglich des securebootmodels "misc-security" oder ähnlich. das du den kext eintragen kannst, sollte auch möglich sein- ist bei anderen sachen ala netzwerktreibern ja nicht anders- es gilt da ja wie immer, das zuerst via eines seperaten efi usb-sticks auszuprobieren


    lg :)

    Danke lieber apfel-baum für die Tipps.......

    Habe die Kext in Open Core eingebaut ....

    Startet durch........ hab aber leider auch keine Rechte......

    Ich glaub die OCLP Typen beissen Sich da gerade auch die Zähne aus.


    Kann ich im Recovery Modus noch was abschalten?



    Danke für Alles

  • im recoverymodus kannst du ggf. via des terminals sachen wie sip oder den gatekeeper ausschalten, vielleicht auch noch mehr


    lg :)

  • Bin gerade über diesen Patch in der neuesten Nightly von OCLP gestoßen.


    Kann ich aber leider erst Donnerstag testen......

  • bisschen spät aber besser als nie-
    OpenCore Patcher 0.5.3 geht auch nur mit GTX Titan 6gb mit EFI Bios. Vielleicht liegt es einfach am EFI Bios. Man weiß ja nie was Apple sich so einfallen gelassen hat.

    Classic Mac Pro 5.1 (2012) / AMD W5700

  • EdgarsZimmer hast Du mal die aktuell in der Entwicklung befindliche OCLP Version 0.5.4 getestet?

    Es heißt im ChangeLog zur 0.5.4 wie folgt:

    Quote

    Disable native AMD Graphics on pre-Haswell Macs in Ventura

    • Allows for easy root patching, dropping reliance on Safe Mode to boot
    • Primarily applicable for Mac Pros with AMD Polaris and Vega GPUs

    Ich könnte mir vorstellen das hierin der Schlüssel zum Erfolg liegt :)

  • Sinn an der Stelle machen wohl die Nightly Builds vom OCLP also quasi dem Link von DerTschnig folgen (Github Account muss vorhanden sein zum Download). Wenn ich das richtig verstanden hab entfaltet der KDKlessWorkaround.kext wohl an der Stelle seine Magie indem er das laden der nativen AMD Extensions von Ventura auf Pre Haswell Maschinen unterbindet :) Ich habe, in dem Fall leider, keinen Ivy Desktop mehr zur Hand in den ich mal eine RX580 packen könnte um das zu testen.


    Den Changelog findest Du hier: https://github.com/dortania/Op…er/blob/main/CHANGELOG.md

    Die Nightly Builds hier: https://github.com/dortania/Op…ws/build-app-wxpython.yml


    Wie gesagt zum Download der nigthly Builds muss man bei Github eingelogged sein. Alternativ kannst Du natürlich auch einfach das Git Repo klonen und die App selbst bauen ;)