Posts by bluebyte

    pannemann Habe heute erfolgreich von Legacy auf UEFI umgestellt. Kannst es ja mal mit meiner EFI versuchen.

    Eigentlich brauchst Du nur mit gparted eine FAT32-Partition erstellen mit dem Namen "EFI" und dem Flag "Boot".

    Da packst Du dann den EFI-Ordner drauf. gparted gibt es als live-iso im Netz. Ist sogar mit Klickibunti. An Bord

    ist auch ein Dateimanager. Da kannst Du dann per Drag&Drop arbeiten. Glaube ich zumindest das das funktioniert.

    Habe es noch nie gemacht.

    karacho ...and the winner is ... karacho. Habe eben mal den AptioMemoryFix mit rein getan. Und schwupps

    ist er über UEFI gestartet. Das ging richtig fix bis ich auf dem Desktop war. Ich habe mich in der letzten halben

    Stunde noch einmal schlau gemacht wegen den MemoryFixes. Da der MemoryFix ist für UEFI zuständig. Bei InsanelyMac

    steht: "First driver OsxAptioFixDrv by Dmasar made possible UEFI boot macOS on PC. Other ways to make Hackintosh were legacy boot". Da wurde ich hellhörig. karacho, bitte sei mir nicht böse. Ich habe deinen Tip nicht ignoriert. Ich wollte nur verstehen,

    warum ich diesen Fix brauche. Hier wird immer von den Fixes diskutiert. Aber warum man ihn braucht, wußte ich bis heute

    nicht. Na ja, hatte mich bis heute nicht interessiert, weil ich es die ganzen Jahre nicht gebraucht habe.


    https://www.insanelymac.com/fo…urpose-of-aptiomemoryfix/



    :danke: an alle Leute, die mir bei meinem Problem geholfen haben.:danke:


    Jetzt kann ich den EFI-Ordner auf der Platte durch den EFI-Ordner vom Stick ersetzen


    Ich habe den Eindruck, dass der Rechner jetzt flüssiger läuft. Kann das sein?


    :party::feuerwerk::party:

    13:00 Vor der Arbeit: Die config.plist ist nicht hundertprozentig zu meinem laufenden System identisch.

    Die Patches und auch einige Haken kommen von Clover.


    19:32 Früher Ich habe mit der EFI vom Stick gebootet. War auch auf dem Desktop. Aber das war so ein

    kleines Mikrobild, das manchmal geflackert hat. Jetzt habe ich die config.plist von meinem Legacy-System

    auf den Stick gepackt. Habe ihn nochmal im Clover-Configurator geprüft. Ich bin mir nicht hundertprozentig

    sicher, ob die Einstellungen für Legacy und UEFI gleich sind oder ob es da Abweichungen gibt. Ich habe das

    Board schon seit November 2013 und habe mich vor UEFI immer gedrückt.

    Ich habe hier im Forum gelesen, dass hier jemand einen Extra-Bootstick hat, von dem er seine Systeme startet.

    Jetzt mal eine Frage, da ich mir nicht hundertprozentig sicher bin. Wenn ich jetzt UEFI-mässig vom Stick boote,

    wird doch auf die EFI auf der Platte nicht zugegriffen,oder? Ich möchte nämlich auf dem Stick etwas herumtesten.

    Aber eigentlich ist das ja die empfohlene Vorgehensweise. Ich lade hier nochmal die EFI vom Bootstick mit der

    config.plist vom laufenden System hoch. Nicht erschrecken karacho , in der config.plist steht noch weniger drin.

    Ich boote dann mal.

    g-force Danke, danke, danke, bin ich blöd!!!:wallbash:


    karacho Das meinte ich ja, dass es kein Problem sein wird.


    Ich lade hier mal meine EFI hoch vom Installationsstick. Mein erstes Mal. Ich hoffe die 2,6 MB sind nicht zu groß für Euch?

    Die müsste dann ja auch für mein System funktionieren. Es fehlt da drin noch der erwähnte HFS-Treiber für die Installation.

    griven Erst mal möchte ich mich bei Dir und den anderen Usern entschuldigen. Ich habe hier wohl ein paar Begriffe durcheinander geworfen. Nämlich Legacy und MBR. :oops:Wahrscheinlich war ich durch den Eintrag "Installiert boot0af in der MBR" irritiert und dachte somit, dass man diese Installation als MBR-Installation bezeichnet.

    Gut, ich habe eine Installation im Legacy-Mode auf GPT. Im Moment stehe ich voll auf dem Schlauch.


    Meine Platten mit MacOS sind definitiv GPT und mit der GUID-Partitionstabelle. Clover liegt auf der Partition EFI. Im Modus MBR würde der EFI-Ordner mit aller Wahrscheinlichkeit im ROOT-Verzeichnis der Apple-System-Partition liegen, oder irre ich mich da? Ich habe da mal ein paar Screenshots gemacht. Bilder sagen mehr als tausend Worte. Aber es ist definitiv so eingerichtet wie dein altes Board.


    Habe im Moment ein Dejavu. Habe ich das nicht schon einmal geschrieben?:think:


    Leute tut mir leid. Im Moment brummt mir der Kopf. Zum Glück habe ich heute, für dieses Jahr, meinen letzten

    Arbeitstag.


    Aufgrund der Voraussetzungen wäre es doch jetzt ziemlich einfach das System auf reines UEFI umzustellen, oder?


    Ich habe mir schon einen Bootstick gebastelt. Er wird im Bootmenü des BIOS (F12) als UEFI USB Harddrive angezeigt.

    Wenn ich davon starte, werden alle Platten angezeigt. Jedoch kein MacOS Install für Catalina. Bin gerade an der EFI

    und werde sie mal hochladen.


    Das mit den Bugs konnte ich mir schon denken. Irgendwie haut der bei mir jetzt Sachen rein, die ich noch nicht drin hatte.

    Auch die config.plist sieht merkwürdig aus. Stehen Einträge drin, die ich nie gesetzt habe. Warum legt Clover den Ordner /drivers/BIOS an, auch wenn ich bei der Installation nur UEFI angebe?:think:


    Windows liegt auf einer Platte mit MBR.

    @Alle Vielen Dank erst einmal für Eure Rückmeldungen. Die Umstellung des WinOS von MBR auf UEFI stellt für mich das geringste Problem dar.

    Habe das schon einmal auf meinem T520 mit der Kommandozeile durchgezogen. Brauche dafür kein spezielles Werkzeug. Ich habe damals den

    EFI-Ordner von griven und bluebyte verglichen. Bis auf ein paar Abweichungen wegen seinem Xenon war es fast identisch. Auch griven

    sein System war auf MBR mit Clover in der ESP aufgesetzt.

    Habe das ganze gestern mit Mojave versucht. Das Resultat war ein Black-Screen. Ebenso liess sich Catalina nicht mehr starten. Da hatte ich

    noch mehr Panik. Ich hatte bei Catalina ein Update auf Clover 5099 gemacht. Als ich gestern nach Hause ka, da lief Catalina wieder. Das

    was mich beiu UEFI verwirrt, dass sind die vielen Option im BIOS. Mit OPRom, PXE, etc. griven wird verstehen, was ich damit meine.

    Fortsetzung folgt ...

    karacho Ich weiss doch das ich UEFI kann, aber ich habe damals kegacy installiert, weil Windows auch legacy installiert war.

    Ich versuche so langsam auf UEFI umzustellen. Aber nur mit dem Umpacken wird es wohl nicht erledigt sein. Habe ja noch

    den Boot-Loader in der bootoaf-Schlagmichtot installiert. Muss ich da nicht erst Clover mit dem Installer neu installieren

    mit "Clover for UEFI booting only", damit er den Boot-Code aus dem Bootsektor löscht? Macht er das überhaupt?


    yoyo268 Das ist schön zu hören, dass Du auch ein Z77-Board besitzt. Bis vor kurzem war ja griven der perfekte Ansprechpartner.

    Leider hat er sein Board in Rente geschickt.


    Ich probiere das jetzt mal mit meinem alten Mojave. UEFI only, Treiber und kexte drauf, und sehen was passiert.

    Habe ja noch mindestens 5 Updates von jedem System.


    Ich habe gerade, bis auf Mojave, alle Platten im Bios abgemeldet habe.

    Was mich stutzig macht ist, dass bis auf Catalina und Windows, alle Platten sichtbar sind.

    Hallo Leute, ich bin das erste Mal so richtig ratlos. Ich hatte vor langer Zeit mein MacOS mit El Capitan mit MBR installiert.

    Danach folgten über die Jahre die Updates und Upgrades bis Catalina. Wenn ich so in meinen Clover-Ordner schaue

    und mit den alten Ordnern von El Capitan vergleiche, so sieht der Ordner ziemlich jungfräulich aus. Was nicht heißen

    soll, das ich Probleme habe.


    Mir ist aufgefallen, das ich im Ordner ~/driver/BIOS/ zwei Dateien habe: apfs.efi und FSInject.efi

    Im Ordner ~/driver/UEFI eine Datei: ApfsDriverLoader.efi


    Wie wir wissen existiert im Clover-Configurator unter Drivers Bios 64 Bit auch ein Eintrag mit ApfsDriverLoader.efi.


    Meine Frage ist, kann ich den unter Drivers UEFI 64 Bit abwählen und unter Drivers Bios 64 Bit anwählen, oder landet

    dieser Treiber standardmäßig im Ordner ~/driver/UEFI?


    Ich habe heute hier im Forum gelesen, dass FSInject nicht mehr benötigt wird. Das würde bedeuten, dass ich nur noch

    zwei Treiber laden muß. Es ist nicht so, dass ich damit nicht glücklich wäre. Es ist mir eher etwas unheimlich, wenn ich

    bedenke, dass die Ordner unter El Capitan bis High Sierra noch gut gefüllt waren.


    Ist apfs.efi noch nötig? Wenn ich das hier so mit Euren EFI's vergleiche, so kome ich zu dem Schluß

    apfs.efi löschen - ApfsDriverLoader.efi unter Drivers Bios 64 Bit aktivieren - ApfsDriverLoader.efi unter Drivers UEFI 64 Bit deaktivieren.

    Ach ja, ist mir noch aufgefallen. Der SMCHelper.efi für FakeSMC.kext ist hat sich auch irgendwie davon geschlichen.


    Viele Grüße von bluebyte

    Formatieren löscht keine Daten, sondern initialisiert den Datenträger nur zur Aufnahme von Daten.

    Wozu gibt es wohl Programme um Formatierungen rückgängig zu machen. Das ging früher sogar schon

    unter DOS mit mit dem Befehl 'unformat'. Eine Festplatte gilt dann als sicher und vollständig gelöscht,

    wenn sämtliche Sektoren mit zufälligen Bytefolgen mehrmals überschrieben werden. Daher würde ich

    auch die Security Options empfehlen. Gerade bei Hardware aus dem geschäflichen Bereich.

    g-force NTlite kenne ich schon seit dem Erscheinungsdatum.

    Ich habe früher immer die Freeware Nlite benutzt. Das war immer sehr praktisch um sich eine personalisierte Installations-CD mit den benötigten Treibern, den Patches und Servicepacks zusammenzustellen. Dazu gesellte sich dann ct'-Offline-Update, das jetzt untern dem Namen

    WSUS-Offline-Update bekannt ist.

    In meinem Fall ging es um die Optimierung innerhalb der schon laufenden virtuellen Maschine unter VMware.


    Viele Grüße von bluebyte

    chmeseb Ist doch eigentlich egal. Sorry, war vorhin etwas gefrustet. Hatte mein

    Windows 10 in der VM mit VMware OS Optimization Tool so sehr optimiert, dass ich

    keinen Netzwerkzugriff mehr hatte. Danach neu installiert und Updates aufgespielt

    und dann festgestellt, dass ich erst kürzlich von sämtlichen VM's Backups gemacht habe.:wallbash:

    Bei 9 Platten im System verliert man schon mal den Überblick.:think:

    chmeseb Wenn ich zuvor geschrieben habe, dass ich für Platten mit unterschiedlichen

    Dateisystemen 'dd' im Expertenmodus benutze und ich als Antwort bekomme, dass man

    im Expertenmodus 'dd' benutzen kann, dann verstehe ich nicht deine Aüßerung mit dem

    Leseverständnis.

    Karamaru Herzlich willkommen. Mach bitte keinen neuen Thread auf. Sollte das erforderlich sein, so kümmern sich die Mod's .

    Habe zwar ein Gigabyte mit Z77-Chipsatz und einen Intel I5-3550. Als SMBIOS mit der GPU würde ich Dir SMBIOS vom IMac 13,2

    empfehlen.

    kaha Sag ich doch. Expertenmodus und 'dd'. Probleme mit dem Leseverständnis?


    Ich zitiere:"Wenn ich es jetzt mal nutze mit unterschiedlichen Dateisystemen, dann im Expertenmodus und mit 'dd'."


    Sorry, das musste sein!

    ron Ich benutze Superduper! seit 2007. Bin damit mehr als zufrieden. Einmal bezahlen und dann Updates auf Lebenszeit. Seit der Umstellung auf Catalina steckt Superduper! noch in der Beta-Phase, die aber schon lauffähig ist. Es kommen regelmässige Beta-Updates. Habe damit schon zweimal erfolgreich Catalina

    geklont.


    https://www.shirt-pocket.com/blog/


    Weder CCC noch Superduper! klonen die EFI. Ob nun 1:1 auf eine Platte

    oder gepackt in einem Sparse-Image. Es wird nur die System-Partition kopiert.


    Doctor Plagiat Dus sagst es ....

    Man kann natürlich auch Clonezilla benutzen. Da Clonezilla noch kein APFS

    oder HFS+ unterstützt, kann nur eine sektorweise Kopie erstellt hat. Dazu

    benutzt Clonezilla das bekannte 'dd'. Bei einem Dualboot-System mit MacOS

    und Windows auf einer Platte würde ich mich aber nicht darauf verlassen. Das

    kann in die Hose gehen. Selbst erlebt. Windows auf Partition sda2 wurde

    geklont. MacOS auf sda3 wurde zwar geklont, aber das Image war am Ende

    nur einige Bytes groß. Ich hatte den Fehler gemacht und die automatische

    Funktion gewählt. Ich nehme an, das Clonezilla ntfsclone genutzt hat und

    am Ende bei MacOS durcheinander kam. Man hätte für die EFI und Windows

    ntfsclone nutzen können und für MacOS dd, aber dann hätte man die Platte

    partitionsweise konen müssen und nicht als ganzes Laufwerk. Klingt jetzt

    etwas verwirrend, ist aber logisch. Wenn ich es jetzt mal nutze mit unterschiedlichen Dateisystemen, dann im Expertenmodus und mit 'dd'.