OpenCore Sammelthread (Hilfe und Diskussion)

  • Lädt nicht!

    Das vermeldet zumindest das iPad am USB Port und verhält sich wie ein echter Mac.

    Wenn der Bildschirm vom Pad aus ist, lädt es ganz langsam.


    Ich habe im ACPI Ordner eine SSDT USBX.aml, was wohl nicht hilft.


    Gibt es noch weitere Schalter?


    Gruß

    IMacPro 1.1 - Catalina 10.15.6
    Gigabyte Z170 XP SLI
    Intel CPU i7 6700k @4,6 GHz
    48 GB DDR 4 Ram @3200 MHz
    RX 580 8GB
    512 GB . M2 EVO SSD
    Broadcom BT / Wlan Combo (OOB Device)

  • Was meinst du mit "Lädt nicht!"

    wie soll man dir helfen bei so unklarer formulierung?


    Edit: Anscheinend gibt es Leute die da mehr rauslesen koennen als ich

    :bahnhof:


    MfG Claus

    ich lebe und arbeite in Changchun, China


    Meine Systeme:

    Edited once, last by Claus59 ().

  • Tommisan Setze mal die Power Properties in die USBKext. Die USBX kannst du dann entfernen. SSDT-EC wird außerdem in Mojave benötigt damit der Power Controller lädt.

    VORERST BETEILIGE ICH MICH HIER NICHT MEHR. PER PN KÖNNT IHR MICH WEITERHIN ERREICHEN.


    LG Chris


    Meine Hardware:

  • Tommisan

    Deine SSDT muss auch via config.plist eingebunden werden.

    ASUS PRIME X299-DELUXE i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

    ASUS WS X299 SAGE/10G  i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • DeckLink 4K Extreme 12G

  • Danke erstmal


    apfelnico : das ist sie

    CMMChris : schau ich mir an. Guckst Du Anhang? Is doch richtig so?!

    Claus59 : alles gut, passt scho'



    EDIT: Nu aber! Habe die Ports via Hackintool nochmal gepacht.

    Gruß

  • Alles soweit in OpenCore 0.6.0 eingerichtet. Nun brauche ich aber Hilfe bei der Kosmetik.


    Im BootPicker werden mir EFI angezeigt. In 0.5.0 gab es noch HideSelf?

    Ich habe auch die Partitionen mit HideAuxiliary in der config.plist eingetragen bzw. auf Auxiliary gesetzt. Bekomme die nicht ausgeblendet. Gibt es einen einfachen Weg die beim normalen Start nicht angezeigt zu bekommen?


    Anderer Punkt ist, wenn ich Extern als Bootpicker mit den Ressourcen nutze, werden die Icons verdammt groß und es passen nicht mehr alle auf den Bildschirm. HiRes (02) ist gesetzt. BuildIn Grafik wird genutzt und Resolution gesetzt. Muss ich das Set ändern um die kleiner zu bekommen?


    Hoffe, bin da in diesem Thread richtig.

  • Laurin Wenn du gar keine EFI-Partitionen im Picker sehen willst, musst du sie bei der ScanPolicy ausschließen. Wie du die entsprechende Nummer für den ScanPolicy-Eintrag ausrechnest, ist in der Configuration.pdf von OpenCore beschrieben.

    Zusätzliche Custom-Einträge werden in der normalen OpenCore-Version glaube ich nicht einfach statt den automatisch erkannten angezeigt (anders soweit ich mich erinnere im N-D-K-Fork). Du kannst z. B. Custom-Einträge anlegen, die Dateisysteme etc. betreffen, die du aus der ScanPolicy ausgeschlossen hast. Wie hast du die Partitionen denn genau eingetragen?

    Hast du die Resolution auf Max? Immer noch zu groß?

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Resolution hatte ich Max eingetragen, aber wieder entfernt, da es keine Änderung gab. ScanPolicy hatte ich mir angeschaut. Wollte aber da die EFI nicht ausschliessen, da die ja fürs booten gebraucht werden (dachte ich). Wenn das aber mit Custom-Einträgen geht ...

    sieht etwa so bei mir aus:


    Win10 ist doppelt und deswegen ausgeblendet. Linux passt. EFI Catalina ist ein externes Testsystem. Da wird zum Beispiel EFI trotz Eintrag angezeigt. Ich denke mal, der 2. bei mir angezeigte EFI beim Boot ist der von Windows. Im Bootmenu selbst kann man sich ja die Eigenschaften /UUID wohl nicht anzeigen lassen? Versuche wäre noch, die einzelnen EFI mal temporär umzubenennen.

  • Laurin Die EFI-/ESP-Volumes brauchst du dir nur dann im Boot-Picker mit anzeigen lassen, wenn du Windows ohne Custom-Eintrag booten willst. Für macOS-Systeme werden die EFI-Partitionen im Picker nicht benötigt (die enthalten ja nicht die boot.efi von macOS, sondern nur OpenCore selbst). Warum hast du eine "EFI-Catalina" als Custom-Eintrag drin? Vom OpenCore-Picker aus kannst du eh keine anderen OpenCore-Instanzen starten. Du brauchst übrigens für weitere macOS-Systeme auf deinem Rechner keine eigenen EFI-Partitionen mit OpenCore, egal, auf welcher Platte die Systeme drauf sind. Eine einzige EFI-Partition mit OpenCore reicht, die kann alle installierten Systeme booten.

    Dein Screenshot sieht nach einem OpenCore Configurator aus. Wir raten hier generell davon ab, einen solchen zu verwenden und stattdessen einen Plist-Editor (zum Beispiel PLIST Editor aus dem AppStore oder auch Xcode) zu verwenden. Dann bist du unabhängig von den Voreinstellungen des Configurators (der immer an eine bestimmte OpenCore-Version gebunden ist und daher auch nicht immer aktuell, was gerne Fehlermeldungen und Bootprobleme verursacht). Außerdem ist der auch nicht schwerer zu bedienen, ganz im Gegenteil.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • 5T33Z0 Hab ich doch oben schon beantwortet. Den ScanPolicy-Wert so berechnen, dass ESP-/EFI-Volumes nicht berücksichtigt werden.

    HideAuxilary hat mit EFI-Partitionen nichts zu tun. Es ist in der OpenCore-Dokumentation doch genau erklärt, was es betrifft:

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Gibt es ein eMöglichkeit die HUAWEI auf dem MacBookPro13,1 zum laufen zu bekommen?


    Die aus der MobilePartner.app extrahierten Kexte funktionieren nicht, wenn ich die in die EFI packe. Triber installieren nützte auch nichts.


    Grüße

    Arkturus


    iMacPro1,1 Asus Prime B250M Plus, Intel QuadCore i5 7500 Kaby Lake 3,41 Ghz, PowerColor RX580 8192 MB VRAM, Realtek ALC888B (ID 1 (2)), Fenvi T919 , 16GB Ballistic Sport DDR4 2400, Mojave 10.14.6 ((18G3020) Clover r5119 , CT 10.15.6 (19G46c), BS 11.0 Beta3 ((20A5323l) OC 0.61

    Edited once, last by Arkturus ().

  • JimSalabim Danke für den Link. Ich habe die ScanPolicy nun berechnet für SATA und NVME Laufwerke für APFS, HFS und NTFS (ergibt 592643). Die EFI Partition wird jetzt ausgeblendet, aber das Windows Laufwerk leider auch. Kein Plan. Ich bleib Scan Policy 0 glaub ich.

  • Probier mal Scanpolicy 3085059


    LG

    iMac Pro (2017) | iMacPro1,1
    GA-Z170X-Ultra Gaming | i5-7400 | 16GB | Sapphire RX580 8GB Pulse
    Toshiba m.2 512GB | AirPort BCM943602CS (OOB) | be Quiet 11
    macOS Big Sur public beta / OC 0.6.2


    iMac Pro (2017) | iMacPro1,1
    GA-Z170-Gaming K3 | i5-6400 | 16GB | Sapphire RX560 4GB Pulse
    Samsung m.2 MZVLW256HEHP | AirPort BCM943602CS (OOB) | Enermax Modu 82+ 425W
    macOS Big Sur public beta / OC 0.6.2


    iMac Pro (2017) | iMacPro1,1
    GA-Z170-HD3P | i5-7400 | 8GB | Sapphire RX560 4GB Pulse
    Sabrent m.2 256GB | AirPort BCM9460CD (OOB) | be Quiet 530W
    macOS Big Sur public beta / OC 0.6.2


    iMac (Late 2015) | iMac17,1
    Lenovo ThinkCentre M710q | i5-7400T | 8GB | Intel HD Graphics 630 1536MB

    Samsung 960 m.2 256GB | Intel DualBand Wireless-AC 8265 | Bluetooth 4.2

    macOS Big Sur public beta / OC 0.6.2

  • 5T33Z0 Damit Windows angezeigt wird, müssen die EFI-/ESP-Volumes gescannt werden. NTFS braucht dafür übrigens nicht gescannt zu werden. Die bootmgfw.efi von Windows befindet sich auf der Windows-EFI-Partition, nicht auf dem NTFS-Volume. Wenn man die EFI-Volumes nicht scannen lässt und Windows trotzdem im Picker haben will, legt man einen Custom-Eintrag für Windows an. Anleitung hierfür ist im Anhang.

    Files

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Computer name: macOS Big Sur beta

    version Motherboard: ASUS ROG MAXIMUS IX HERO

    Processor: Intel Core i5-6600K @ 3.50GHz

    Graphics card: REZ-STRIX-RX580-O8G-GAMING

    Memory: USCORSAIR DDR4 3200 32GB

    Files

    • EFI.zip

      (6.7 MB, downloaded 8 times, last: )

    Edited once, last by diy2018 ().

  • Gibt's eigentlich ne Möglichkeit in iStat den "FauxMac" zu forcieren?

    Vor einiger Zeit habe ich bzgl. der Unterstützung zusätzlicher Sensoren via VirtualSMC mal eine Anfrage an den Bjango-Support gestellt und folgende Antwort bekommen:

    Quote

    iStat Menus only supports FakeSMC. If you are using VirtualSMC or any other SMC emulator then it is currently not supported. We may add support for other SMC emulators in the future.

    D.h. du mußt FakeSMC nutzen.

    Seit dem nutze ich die FakeSMC-Extension und bekomme alle Werte außer Lüfterdrehzahlen angezeigt, auch unter Big Sur.

    PowerHackG4
    (PowerMac G4 Quicksilver)



    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.6.0)
    Operation Systems: macOS "Catalina" 10.15.6, Windows 10 Professional


  • The boot theme is stored in the OC Configurator in EFIResources / Image.

    I don't know where in which Menu is another boot theme configured in OC, where are boot icons removed?

    In the old Clover there was a Theme folder in which I inserted a theme and confirmed it in the Clover menu.


    Thanks for help :)