Planung meines ersten Hackintoshs gestartet

  • Die Ports raussuchen ist nur der erste Schritt.

    Das Ziel ist, in Hackintool eine USBPorts.kext erstellen lassen, die nur die benötigten Ports enthält. Dazu musst du Hackintool mitteilen welche Ports du behalten willst und welcher Art diese Ports sind (die verschiedenen Port-Typen sind auch bei Dortania beschrieben). Zum Portmapping mit Hackintool gibts hier im Forum auch ein paar Threads.

    Es lohnt sich übrigens auch, mal die Anleitung zum manuellen Erstellen der Kext zu lesen, auch wenn Hackintool das übernimmt. Da lernt man ganz gut was diese Kext eigentlich macht.


    Als Benchmark und kleiner "Stresstest" (jaaa ich weiß, Cinebench ist kein echter Stresstest) ist Cinebench 20 ganz gut, weil es AVX nutzt und dementsprechend belastend ist.

    Um die CPU zu beobachten, bietet sich das Intel Power Gadget an. Da sieht man Takt, Temperatur und elektrische Leistung der Cores ganz gut.

    Richtig übertakten würde ich nicht unbedingt, wenn du dir nicht ein weiteres Hobby ans Bein schrauben willst, was dich viele Stunden und nerven kostet. Teste doch erstmal, ob die CPU ohne Powerlimits deinen Ansprüchen genügt.

    3.7 ist der Basistakt. Der wird genutzt wenn du nichts allzu anspruchsvolles machst. Bis 5.3GHz geht der Boost-Takt vom Turbo, den Intel bei Bedarf zuschaltet. Das siehst du auch gut im Power Gadget.

    Standardmäßig geht der Turbo Boost nur eine bestimmte Zeit, bevor die Stromaufnahme gedrosselt wird. Das sind die beiden Powerlimits im BIOS. Wenn du beide auf 300W oder so stellst, ziehst die CPU immer so viel wie sie will, unendlich lange. Das sollte mit deiner Kühlung auch dauerhaft klargehen (wenn nicht drosselt die CPU sowieso automatisch, sieht man aber alles wunderbar im Power Gadget).

    Am Basistakt und am Turbotakt schrauben solltest du nur, wenn du einen groben Überblick hast, was du dann mit der Spannung machen musst und was bei LLC evtl. zu beachten ist. Da steht viel experimentieren dahinter, bis man die Einstellung gefunden hat, bei der die CPU stabil läuft und trotzdem so kühl wie möglich bleibt. Wenn du bei Intels vorgegebenen Taktraten bleibst, kannst du dir sicher sein, dass die CPU damit schon getestet wurde und stabil laufen wird.


    Zur Auflösung der iGPU: Da bin ich leider voll raus, habe noch nie einen Monitor am Hacki mit Intel GPU betrieben. Wenn 4k unter Windows geht, kann es nicht am Kabel oder am Monitor liegen, dann bliebe nur noch die iGPU(-Config) als Fehlerquelle...

  • Richtig übertakten würde ich nicht unbedingt, wenn du dir nicht ein weiteres Hobby ans Bein schrauben willst, was dich viele Stunden und nerven kostet.

    Auf keinen Fall. ^^ Sitze mit dem Hackintosh schon viel zu lange am Rechner, aber es macht Spass, so dass die Zeit wie im Flug vergeht.
    Deshalb sage ich auch erst einmal wieder gute Nacht und wieder ein großes Dankeschön für Deinen genialen Support traeu und auch Dir Corv für Deine Tipps.


    EDIT:

    Zur Auflösung der iGPU: Da bin ich leider voll raus, habe noch nie einen Monitor am Hacki mit Intel GPU betrieben. Wenn 4k unter Windows geht, kann es nicht am Kabel oder am Monitor liegen, dann bliebe nur noch die iGPU(-Config) als Fehlerquelle...

    Unter Windows funktioniert sie einwandfrei. Dann muss ich mal weitersuchen. Eventuell hat hier noch einer eine Idee.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

    Edited once, last by Spike-Muc ().

  • Hallo zusammen,

    ich wollte auch einmal wieder ein Update geben, da es ja die letzten Tage etwas still um mich geworden ist.

    Ich warte weiterhin auf die Fenvi Karte aus China. Inzwischen wurden ja die neuen AMD Karten Released und ich denke es wird die RX 6800 XT werden.


    Mit meiner Auflösung bin ich nicht weiter gekommen. Keine Ahnung ob die onboard Karte unter Mac OS nur diese niedrigere Auflösung unterstützt.


    Die USB Einstellung habe ich auch noch nicht finalsiert, da die Ports soweit ich diese brauchte, funktioniert haben. Das Standby Management muss ich noch angehen. Der REchner wacht nicht wieder auf , wenn er in den StandBy Modus gegangen ist. Aber das scheitn ja ein bekanntes Problem zu sein.


    Allen einen schönen Sonn- und teilw. Feiertag heute!


    Gruß Sebastian

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Klingt doch nicht schlecht!

    USB ist ein bisschen fies: Durch den Portlimit-Quirk funktioniert es zwar, aber die Entwickler sagen selbst, dass es ein Hack ist für dessen Stabilität niemand garantieren kann. Darauf, dass es grundsätzlich funktioniert, sollte man sich also nicht ewig ausruhen.

    Zum Standby hat auch das Hackintool eine Sektion die dabei hilft zu prüfen, ob die relevanten MacOS-Einstellungen korrekt eingestellt sind. Ansonsten gibt es dazu auch eine riesige "Fixing Sleep" Rubrik bei Dortania. Und, falls du auf das Problem stoßen solltest, dass du zwei Mal auf die Tastatur hauen musst damit auch der Monitor aufwacht, hilft USBWakeFixup, das habe ich bei meinem Vision D auch benötigt.

  • Das Standby Management muss ich noch angehen. Der REchner wacht nicht wieder auf , wenn er in den StandBy Modus gegangen ist. Aber das scheitn ja ein bekanntes Problem zu sein.

    Hast Du das XMP-Profil aktiviert? Wenn ja, dann deaktiviere es mal, so dass das RAM mit Standard-Timing betrieben wird prüfe anschließend, ob das Aufwachen funktioniert.

  • Mieze Danke Dir, klappt aber mit Standard Timing auch nicht. Werd mich mal einlesen.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Hallo zusammen,

    ich habe wieder einmal ein paar Fragen. Ich habe gerade mal den Cinebench laufen lassen und kommen auf 6.258 Punkte. Laut der Cinebenchseite und einigen Vergleichscores liegt der Pprozessor bei 6.399. Von daher denke ich ist das in Ordnung.

    Was mich jetzt wundert, ich habe parallel den HWMonitor laufen lassen.
    Da steigt dann nur bei TMPIN2 die Temparatur. Ist das die CPU Temperatur?

    Was mich auch wundert. Im Inneren meines Towers be quiet! Pure Base 500DX laufen zwei der drei Gehäuselüfter weiterhin langsam einer erhöht die Drehlzahl. Habe ich die drei Lüfter falsch angeschlossen? Habe mich aber gefragt beim Zusammenbau wie die eh gesteruert würden, da sie nur zwei Pole haben und scheinbar nicht PWM unterstüzen.


    Die Pure Loop 360 Lüfter beschleunigen auch auf über 2.000 RPM und machen ordentlich Krach. Bringt es was diese gegen Noctua auszutauschen?


    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Cinebench klingt auch für mich plausibel, meine Werte sind nahezu identisch.

    Welche Temperatur dir da angezeigt wird, kann ich leider nicht sagen. Wenn HWMonitor die nicht beschriftet bzw. zuordnet, bleibt nur experimentieren. Du könntest zB im BIOS die maximale Temperatur auf eine krumme leicht niedrigere Zahl stellen (87 oder so) und dann schauen, ob diese angezeigte Temperatur unter Volllast genau bei dem Wert stehen bleibt. Dann würde es wohl die CPU-Temperatur sein. Grundsätzlich sollten aber mehrere Sensoren steigende Temperaturen melden wenn die CPU belastet wird, die CPU ist ja nicht das einzige Bauteil, dass unter Last warm wird. Das kommt aber sicher auch darauf an, wie lange du Cinebench oä laufen lässt, wenn du bisher noch keine anderen Temperaturen hast steigen sehen...soweit ich weiß steigt die Temperatur der CPU schneller (und sinkt auch wieder schneller im Leerlauf) als die der anderen Beuteile, weil dort auch die meiste elektrische Energie umgewandelt wird. Wenn beim kurzen Cinebench-Durchlauf nur eine Temperatur schnell steigt, ist es schon wahrscheinlich, dass das die CPU-Temperatur ist.


    Die Frage nach den Lüftern kannst nur du dir selbst beantworten, da das eine Konfigurationssache ist. Das Board hat verschiedene Lüfter-Anschlüsse und verschiedene Temperatursensoren. Im BIOS kannst du einstellen, welcher Lüfter bei welcher Temperatur wie schnell laufen soll, und auch welcher Temperatursensor dafür verwendet werden soll.

    Edit: Lohnt sich übrigens sehr, damit ein paar Stunden rumzuspielen, wenn du die Lautstärke minimieren willst. Meiner Erfahrung nach sind die Standard-Lüfterkurven zu aggressiv eingestellt und man erreicht mit niedrigeren Drehzahlen ebenfalls akzeptable Temperaturen. Allerdings kenne ich mich nicht mit AIO-Kühlern aus, ich weiß nicht einmal, wie dort die Lüfter angesteuert werden.


    Sicher, dass deine Lüfter nur 2 Pins haben? Standard sind eigentlich 3 Pin (5V, GND, Tachosignal) oder 4 Pin (5V, GND, Tachosignal, PWM-Signal zur Lüftersteuerung).

    In der Geschwindigkeit regelbar sind grundsätzlich beide Varianten, bei 3 Pin über die Spannung (da stellt man dann im BIOS den Fancontrol-Mode auf Voltage) und bei 4 Pin eben über die extra dafür vorgesehene Leitung (da dann im BIOS Fancontrol Mode auf PWM stellen)

  • Hallo Spike-Muc :)


    Freut mich das es bei dir so gut vorran geht :top:

    Bezüglich HWMonitor kann ich dir leider nicht. Ich verwende hier bisher https://www.heise.de/download/product/core-temp-49834 , da dieses Programm nur für Windows verfügbar ist, kannst du bei folgendem Link mal Schauen und eine der anderen Alternativen für macOS wählen https://formac.informer.com/core-temp


    Bezüglich der Lüfter tippe ich auf falsche Bios Einstellungen, solltest du die PWM nicht aktiviert haben, machen die BeQuiet! schon ziemlich hässliche Geräusche :P Weiterhin solltest du hier auch ein Lastprofil erstellen können, mit verschieden Steuerpunkt, welche Temperaturabhängig die Lüfterdrehzahl regulieren. Hast du deine Lüfter direkt mit dem Mainboard verbunden, oder besitzt das PureBase 500 dx wie das Dark Base 700 auch eine seperate Steuerungsplatine? Bei mir war diese im hinteren Bereich in dem Kabelführungsschacht enthalten.

    Bevor du diese Einstellungen nicht angepasst hast, bringt der Austausch gegen Noctuan wohl keinen Vorteil.


    Bei deiner Pure Loop AIO vermute ich selbiges Problem, was hier zusätzliche Geräusche verursachen kann ist die Verwendung im Push oder Pull betrieb. Bei Letzterem ziehen die Lüfter die Luft durch den Radiator (Anstelle des Push betriebs, bei welchem sie "drauf pusten" und dadurch Störgeräusche verursachen können), hier wird meist eine minimal schlechtere Kühlleistung erzielt, du solltest jedoch auch einen Vorteil im hinblick auf die Lautstärke verzeichnen können. Hier sind die Philosophien aber weitläufig, sodass hier schon fast religiöse Ausmaße erreicht werden [hehee]


    Ps: Deine Cinebench Resulatate sind doch schon mal recht passend, wenn macOS soweit läuft kannst du dich ja ans OC machen, oder warst du hier bereits Tätig?


    Grüße Corv

    Hackintosh 2020: In Planung =)


    StreamPC 2018: MSI X470 | Ryzen 7 2700X | MSI GTX 1070 | Ram G.Skill 16GB | NVMe Samsung 970 EVO

  • Hallo Ihr beiden traeu und Corv

    Danke wieder mal für Euren schnelle Hilfe. Ihr habt mir damit wieder die richtige Richtung gegeben.

    Core Temp habe ich gerade ausprobiert. Das zeigt mir pro Kern die Temp. an. Der Max. war 83 C. Das dürfte sich ja im Rahmen bewegen.

    Mit dem Bios und meinen Anschlüssel auf dem Board werde ich mich noch einmal auseindersetzen. Das mit den Einstellungen der Fan Pins wusste ich nicht. Ich prüfe auch mal auf was die stehen und vermutlich habe ich 3 Pins an den Lüftern und dachte für die Steuerung braucht es 4 (Danke traeu)
    Die drei Gehäuselüfter habe ich direkt mit dem Board verbunden. Ich habe eben im BIOS gefunden, dass man jeden Lüfterport ansteuern kann :-). Wahnsinn wie sich das BIOS geändert hat in den letzten 10 Jahren.

    Die Lüfter der aio Loop sind so eingestellt, dass sie in Aufruckrichtung (Pfeil) arbeiten und die Luft von draußen durch den Kühler nach innen blasen und die drei Towerlüfter die Luft nach draußen blasen, damit ein Luftstrom entsteht. Ich hatte schon gelesen, dass es auch hier verschiedene Philosphien gibt, die Luft durch die AIO von innen nach außen oder umgekehrt zu befördern.

    Mit dem OC habe ich mich noch nicht weiter beschäftigt, weil mir das Textmenü gereicht hat. Da ich aber die Woche Urlaub habe, werde ich mich mal dran machen und weiter testen.
    Im Moment nutze ich das Mac OS noch gar nicht so, weil ich einfach unter Windows meinen Office Kram mache immer noch auf die neue Grafikkarte warte. Bin echt am überlegen, ob ich nicht übergangsweise doch noch ne 5700 XT nehme. Denn ob die RX 6800 XT direkt zum 18.11. für mich verfügbar ist, steht ja auch noch in den Sternen. Mal sehen vielleicht verkauft ja hier jemand im Marktplatz gerade etwas.

    Will endlich mit dem neuen FlugSim abheben :-)

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

    Edited once, last by Spike-Muc ().

  • Ich bin es wieder. Ich habe mal etwas herumprobiert mit der decive-id der iGPU, aber ich habe es bisher nicht geschafft eine UHD Auflösung auswählbar zu bekommen.


    Bin ziemlich ratlos. Hat das einer schon mal mit der iGPU des i10 10900K geschafft?
    Sollte die Intel UHD Graphics 630 sein.


    Danke Euch für jeden weiteren Ansatz. Ich habe auch nochmal meine config.plist angehängt.




    Noch als Ergänzung, beim Booten des OpenCore und bei der Auswahl des Systems ist UHD also eine 4k Auflösung aktiv. Das muss dann ja schon irgendwie richtig in der EFI config sein, oder?

    Files

    • config.plist

      (27.13 kB, downloaded 3 times, last: )

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Hallo Spike-Muc :top:


    Ein Fehler welcher das von dir beschriebene Verhalten erläutern könnte, wäre das das von dir verwendete Kabel nicht die richtige Spezifikation unterstützt.

    Diesbezüglich hier ein Auszug aus Wikipedia.

    Selbiges gilt für DisplayPort.


    Solltest du also maximal nur ein 1.3er HDMI Kabel (als Beispiel) zum Verbinden mit deinem Monitor gewählt haben, wirst du unabhängig deiner Einstellungen am Computer wohl keine höhere Auflösung erzielen können. :)


    Edit: Die in deiner CPU integrierte Intel® UHD Graphics 630 Einheit, ermöglicht laut Intel folgende Auflösungen.

    siehe https://ark.intel.com/content/…cache-up-to-5-30-ghz.html


    Grüße Corv

    Hackintosh 2020: In Planung =)


    StreamPC 2018: MSI X470 | Ryzen 7 2700X | MSI GTX 1070 | Ram G.Skill 16GB | NVMe Samsung 970 EVO

  • Hi Corv

    danke für Deine Ideen.

    Am Kabel kann es eigentlich nicht liegen, da das System unter Windows mit UHD läuft. Das HDMI Kabel ist auch nagelneu und bei meinem Samsung U28R554UQU dabei gewesen.


    Am Samstag ist meine Fenvi aus China angekommen. Die werde ich die Tage mal installieren.


    Zudem grübele ich immer noch über die Grafikkarte. Man liesst ja einiges, dass die neuen Radeon Karten zum 18.11. schnell vergriffen sein werden. Eventuell greife ich doch noch zu einem Übergangsmodell.
    Was könnt Ihr empfehlen, vor allem auch vor dem Hintergrund des Wiederverkaufpreises in ein paar Monaten?


    Gruß Sebastian

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x