Planung meines ersten Hackintoshs gestartet

  • Spike-Muc

    Ich hab aktuell zwar keine Möglichkeit das Vision D zu testen, aber mit dem AsRock Phantom TB3/ITX funktionieren die device Properties, die ich in die beiden iMac20,2 gepackt habe.


    Du musst natürlich immer den ganzen Knotenpunkt von der iGPU in den Device Properties übernehmen, nicht einfach nur eine ID ändern.


    Geht auch, aber dann...


    wenn die iGPU als computing only fungieren soll (kein Signal am onboard HDMI) mindestens mit:


    Und wenn die iGPU als display-out fungieren soll (Videosignal am HDM), dann mindestens mal mit:



    framebuffer-stolen-mem nur, wenn du in deinem BIOS das mit den 64M nicht einstellen kannst.


    Wenn du so keine Bildausgabe bekommst, dann mit den Framebuffern:



    So ist mein Verständnis von der ganzen Sache. Und ich bekomme mit den Settings eine Bildausgabe via HDMI vom onboard HDMI, allerdings auf dem AsRock Phantom.

  • Hey SchmockLord vielen Dank. Das probiere ich gleich mal aus. Ja ich nutze den Onboard HDMI für Grafikausgabe. Dann starte ich mit der zweiten Variante.


    EDIT: Mit der Variante drei --> Framebuffern bin ich endlich in die Ausgabe gekommen. Danach konnte ich mit der Installation beginnen, nachdem ich die 2. Platte über das Festplattendienstprogramm als APFS formatiert hatte.


    Leider hängt er jetzt beim Booten an der nächsten Stelle:

    Nach dem Coredump of kernel


    Please go to ... to report this panic

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

    Edited once, last by Spike-Muc ().

  • Schonmal sehr gut, dass du ein Bild bekommst!

    Damit klar ist, wo du genau stehst: Das Installationsprogramm lief komplett durch und anschließend wurde in Opencore die neu installierten "mymac" Platte angezeigt? Wurde die Installation dort dann noch fortgesetzt oder kommt es immer wenn du versuchst von "mymac" zu Booten zu dieser Kernel Panic? Nach dem ersten Teil, der vom gebooteten Stick erfolgt, kommt eine weitere Installationsphase wenn man dann von der frischen Platte startet. Ist da schon irgendwas passiert oder direkt Kernel Panic?

    Oder passiert die Panic schon während der Installer auf dem Stick noch läuft?


    Der Installations-Stick bootet aber weiterhin problemlos?


    Auf der Kiste lief schonmal Windows oder? Vielleicht bringt dann ein NVRAM-Reset etwas. Wenn du AllowNVRAMReset in der Config aktiviert hast (in deinem letzten EFI-Upload ists aktiv), zeigt Opencore direkt einen Eintrag zum resetten an.

  • Hallo traeu

    - Das Installationsprogramm lief komplett durch

    - Im openCore Menü wird die neue Platte mymac angezeigt

    - Wähle ich diese aus, laufe ich immer in die Kernel panic

    - Der Stick bootet weiterhin problemlos, der Fehler kommt immer erst nach Auswahl der mymac Platte aus dem openCore Menü

    - Windows 10 läuft problemlos und kann gebootet werden

    - NVRAM-Reset aus dem openCore Menü brachte keine Abhilfe

    - AppleCpuPmCfgLock und AppleXcpmCfgLock auf enable, wie in diesem Beitrag klappt auch nicht

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Kannst du bitte nochmal deine EFI hochladen?
    Ich will mal versuchen, auf die Schnelle alles nicht zwingend zum booten notwendige zu entfernen, nur damit wir Fehlerquellen ausschließen, die zum jetzigen Zeitpunkt unnötig sind.

    Falls das zum Erfolg führen sollte, können wir suchen woran es genau lag, falls nicht können wir immerhin auf einen Schlag ein paar Sachen als Ursache ausschließen.


    Wenn im BIOS CFG-Lock deaktiviert ist, sollte auch AppleCpuPmCfgLock und AppleXcpmCfgLock nicht benötigt werden.

  • Ich bin gerade weiter gekommen. In dem erwähnten Beitrag hatte ich gelesen

    --> Der Eintrag unter "PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)" triggert die Nutzung des AppleIntelI210Ethernet.kext und führt zu dem Kernel Panic


    Deshalb habe ich bei mir den Passus:

    mal entfernt.


    Damit bin ich jetzt im zweiten Bootschritt wo ich Land und Netzwerverbindung auswählen kann.



    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Megagut!!

    Jetzt wo du es sagst, ist es logisch: Wir brauchen später noch ein zwei Kexte, um deinen zweiten LAN-Port zusammen mit diesem Device-ID-Eintrag zum laufen zu kriegen. Dass dieser Eintrag ohne Kexte eine Kernel Panic erzeugt ist mir auch neu, wieder was gelernt.


    Wenn du das Land und so weiter wählen kannst, bist du mit der Installation eigentlich durch. Dann solltest du bald zum ersten Mal den Schreibtisch deines neuen Hackis sehen können!

    Der nächste Schritt wäre dann, die Kiste ohne USB-Stick zum booten zu bringen, indem du den EFI-Ordner vom Stick auf die EFI-Partition des Hackis kopierst. EFI kannst du per Terminal finden und mounten oder wie ich den Opencore Configurator dafür nutzen (der hat ein Menübar-Icon extra dafür), oder du nutzt eins der zahlreichen anderen Tools die hier so kursieren, die EFI mounten können viele.

    Edit: Sogar das Forum verlinkt automatisch eine Anleitung dazu :D

    Hebe dir auf jeden Fall den aktuellen EFI-Ordner gut auf, am besten auf dem Stick (und bei zukünftigen funktionierenden Versionsständen auch mal die Version auf dem Stick aktualisieren). Dieser EFI-Ordner ist das Herz deines Hackintoshs, der Rest der Festplatte ist 1:1 wie beim echten Mac. Damit kannst du also zur Not immer booten, wenn die Experimente mal zu wild wurden.

    Eine andere Variante wäre, Änderungen am EFI immer erst vom Stick zu testen bevor du sie auf die Festplatte überspielst, aber ich finde das ein bisschen übertrieben. Wenn man Änderungen nur einzeln und mit Verstand vornimmt, kommt man eigentlich selten in die Situation, den Rettungs-Stick zu brauchen.

  • traeu Du schreibst es, ich sehe das erste mal den Schreibtisch :gänsefuss::danke2:

    Danke Dir für diese Hilfsbereitschaft. Bin schwer beeindruckt!


    Du hast mir auch gleich schon meine nächsten Fragen beantwortet. Wie gehts weiter. Dann mach ich mich gleich mal ran den EFI Ordner in die EFI auf der Platte zu schieben.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Hallo Spike-Muc ich Gratuliere! :hurra:


    Ich verfolge euren Austausch mit Spannung und bin froh für dich das du nun das erste mal deinen Desktop erblickst :)


    Viel Erfolg bei der weiteren Konfiguration *weiter still Mitlesen*


    Ps: Super Arbeit traeu


    Grüße Corv

    Hackintosh 2020: In Planung =)


    StreamPC 2018: MSI X470 | Ryzen 7 2700X | MSI GTX 1070 | Ram G.Skill 16GB | NVMe Samsung 970 EVO

  • Corv Danke für die Glückwünsche. Es war ein Stück Arbeit, aber durch die stetige Unterstützung hier aus der Community, besonders die tolle Hilfe von traeu hat es geklappt.


    Ganz besonders traeu s Tipp die EFI noch einmal mit seiner und der Dortania Hilfe komplett aufzubauen war sehr viel wert. Dadurch habe ich viel mehr verstanden, als wenn es von Anfang an mit der fertigen EFI funktioniert hätte. Natürlich gibt es immer noch viele Fragezeichen, aber ich bin zuversichtlich.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Was du auf jeden Fall auch mal machen kannst, ist das Tool Hackintool zu installieren. Das kann bei vielen Sachen sehr nützlich sein!
    Jetzt geht der wie ich finde eigentlich spaßigste Teil los: Du kannst grundsätzlich booten und diese Stufe nimmt dir keiner mehr. Jetzt kannst du dich solange den Feinheiten widmen, bis alles passt und funktioniert!

    Bei Dortania gibt es sehr viele Anleitungen in der Rubrik Post-Install, die sehr nützlich sein werden.


    Wenn die EFI kopiert ist, und du einmal ohne Stick gebootet hast, solltest du im BIOS (wieder) die Bootoption "Opencore" sehen. Das ist eine kleine Hilfe von Opencore (Bootstrap) um zu verhindern, dass sich Windows zukünftig vordrängeln kann (auch wenn ich erstmal die Windows Platte abgesteckt lassen würde). Wenn du dann im BIOS als erste Bootoption dieses Opencore auswählst und alle anderen Einträge deaktivierst (auch den Eintrag der SSD selbst) sollte sichergestellt sein dass dein Rechner immer in Opencore bootet.


    Als nächstes könntest du die beiden LAN-Ports testen und einrichten und anschließend alles für die saubere Nutzung der iServices vorbereiten. Einer der LAN-Ports sollte jetzt schon gehen (der 1GBit-Port), denn den Treiber dafür, IntelMausi, hast du bereits. Für den 2.5GBit-Port wird ein Treiber, der schon in MacOS vorhanden aber eigentlich für ein leicht anderes Modell ist, zurechtgebogen (bzw die Karte wird so umbenannt, dass der MacOS-eigene Treiber sie als kompatibel erkennt). Dazu brauchst du einmal den Eintrag, den du vorher wegen der Kernel Panic gelöscht hast (Zur Sicherheit auch nochmal mit Schmocklords Config vergleichen ob der PCI Pfad korrekt ist), und einmal die beiden FakePCIID Kext aus Schmocklords Github (NICHT intel-hdmi-audio, den braucht man für die neuesten Opencore-Versionen gar nicht mehr, sondern die beiden anderen). Wenn du diese Kexts hinzufügst und aktivierst, und gleichzeitig den Device-ID Eintrag einfügst, solltest du ohne Kernel Panic booten und beide LAN Ports nutzen können.

    Wenn die LAN Ports gehen, kannst du diese Anleitung durcharbeiten und iServices einrichten:
    https://dortania.github.io/Ope…/universal/iservices.html

    -Serial generieren bzw. prüfen ob deine aktuelle gut so ist

    -Deine ROM zur MAC-Adresse von En0 ändern (ist bei dir aktuell noch 11 22 33 44 55 66)

    -Prüfen ob du En0 als Netzwerkkarte hast (die beiden Terminalbefehle um die Netzwerkeinstellungen einmal zu resetten würde ich generell ausführen, schadet nix und danach sollte auf jeden Fall eine deiner LAN-Karten En0 heißen)

    -Prüfen, ob NVRAM funktioniert. Sollte es eigentlich, du kannst zum testen einfach in Hackintool eine neue beliebige NVRAM-Variable mit beliebigem Namen und beliebigem Inhalt anlegen. Wenn die nach einem Reboot noch da ist (nicht wundern, wenn du einen String eingibst wird der nach dem Reboot nicht mehr lesbar sondern in HEX angezeigt), funktioniert NVRAM.


    Dann hast du schonmal LAN, NVRAM, SMBIOS-Kontrolle und iServices erledigt. Falls du nen Apple-Account hast, solltest du dich ab dann ohne Probleme einloggen können. Wichtig: Das SMBIOS darfst du dann nicht mehr ändern (nicht einfach mal auf neu generieren klicken und vor allem nicht versehentlich verlieren) und muss auch immer übernommen werden, wenn du mal eine andere Config testen solltest. Sonst kann es Probleme mit dem Apple-Account geben.


    Corv & Spike-Muc danke für das Lob, aber ich bin wirklich auch nur Anwender und aufmerksamer Leser von Anleitungen. Mein Glück ist bloß, dieses Board schon einmal verwendet zu haben. Die wirkliche harte Arbeit haben längst andere vor mir für uns erledigt und ich kann gar nicht sagen, wie unendlich dankbar ich dafür bin. An der Stelle mal ein fettes Dankeschön an alle Entwickler*innen und Vordenker*innen die das möglich machen! Abartig cool was ihr möglich macht und immer wieder cool zu sehen, dass ihr sogar noch Zeit und Lust habt, nebenher in Anfängerthreads wie diesen mitzuhelfen :)

  • traeu

    - Das Hackintool habe ich gleich wieder installiert, das hat mir auf meinem Quell-Macbook schon sehr zum Erstellen des Bootsticks geholfen


    - Bootoptionen sind im Bios auch so eingestellt, dass er immer im openCore Menü startet. Das würde ich später angehen, hier soll es ja auch noch ein grafisches Menü geben.


    - Lan Port geht aktuell nur der 1GBit, der 2,5GBit funktioniert nicht, genauso nicht der Audioport im Frontpanel. Alle USB-Ports habe ich auch noch nicht überprüft.


    - WLAN weiß ich gar nicht, ob ich das onboard System nutzen kann. Die Fenvi Karte aus China ist unterwegs.

    - Meine apple-id hatte ich eben schon eingegeben. Das scheint zu funktionieren. Ich hatte aber in die config.plist vorher schon neu generierte Serial eingetragen


    - NVRAM scheint auch zu funktionieren. Die Testvariabel ist nach dem Reboot immer noch vorhanden.


    Morgen werde ich mich auch mal durch die POST Install Doku von Dortania wühlen.


    Eine gute Nacht und noch mal ganz herzlichen Dank!

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Wenn du die Apple ID schon verwendest, würde ich erst Recht damit anfangen, zu überprüfen ob da alles korrekt ist. Ich glaube auch, dass iMessage und Facetime nochmal empfindlicher sind als andere Apple-ID-gebundenen Apps, also am besten erst mal nichts weiter nutzen was mit der Apple ID zusammenhängt. Höchstwahrscheinlich muss nur noch die ROM Nummer geändert werden, wenn die generierte Serial die bei Dortania beschriebene Prüfung besteht, NVRAM funktioniert und dein 1GBit-LAN schon En0 ist.


    Wie du den 2.5GBit Port nutzen kannst, habe ich ja oben geschrieben. Kannst danach zur Sicherheit nochmal prüfen, ob weiterhin einer der beiden Ports En0 ist (im Terminal ifconfig), das ist wichtig für iServices.


    Fürs Audio musst du mal bei Schmocklord vergleichen, ob dein PCI-Pfad bei den Device Properties korrekt ist, der ist beim Vision D nicht wie bei Dortania beschrieben. Falls Schmocklord in seiner Config noch eine andere Device-ID bei der Soundkarte drin hat: Das braucht man seit einem AppleALC Update nicht mehr. Für Audio muss also nur die Layout-ID eingetragen werden. Da Bootargumente Vorrang haben, darfst du dann kein alcid=X Bootargument mehr verwenden, weil das sonst den Layout-ID-Eintrag bei DeviceProperties überschreibt. Als Layout-ID funktionieren 7 & 11 (beide gleich) und 16. Musst mal testen was dir besser passt, bei einem von beiden ist das Front-Mikro etwas leise und wird als Line-In erkannt. Audioausgabe sollte aber bei keinem ein Problem sein. Auch die anderen Ports hinten sollten funktionieren.


    Zur Opencore GUI gibts auch eine Anleitung bei Dortania, ist nicht schwierig und läuft bei mir bisher absolut stabil. Die Audio-Files im Ressources-Ordner kannst du dabei wieder löschen wenn du nur GUI und keine Audioausgabe im Bootmenü willst, das bläht den EFI-Ordner sonst ziemlich auf.


    Für das aktuell eingebaute WLAN gibt es meines Wissens erste erfolgsvesprechende Experimente, aber ich denke das ist nichts, was du jetzt ausprobieren müsstest, wenn die Fenvi unterwegs ist.


    Für das USB: Als erste Vorüberlegung kannst du mal in Schmocklords Github schauen, da ist eine PDF, in dem die USB-Anschlüsse (HS, SS und SSP) mit ihrem Namen bzw. ihrer Nummer abgebildet sind. MacOS erlaubt per USB-Controller nur 15 Ports. Das Vision D Board hat 2 USB Controller: An einem hängen nur die SSP-Ports (USBC-Buchse), deshalb muss man sich da keine Sorgen um das Limit machen. Am anderen Controller hängen alle HS (HighSpeed, USB2) und SS (SuperSpeed, USB3) Ports, also alle anderen. Auch wenn du sehen wirst, dass nicht jede Buchse ein eigener Port ist, weil manche Buchsen über Hubs zusammengefasst sind: Dadurch, dass USB3-Ports von MacOS als zwei Ports gezählt werden (HS und SS, weil man an USB3-Buchsen ja auch USB2-Geräte anschließen kann, das sind eigentlich zwei getrennte Anschlüsse in einer Buchse) überschreitet das Vision D Board das Portlimit, ich glaube 20 Ports sind es. Du musst also 5 Ports raussuchen, die du nicht brauchst, die dann deaktiviert werden. Den USB-Port für die onboard-Bluetooth-Karte brauchst du schonmal nicht, den Port für den RGB-Licht-Controller vermutlich auch nicht. Dann schaust du am besten, welche internen USB-Ports du nicht brauchst: Wenn dein Case keinen USB-C-Anschluss hat, kannst du da nochmal 3 Ports sparen und bist schon bei 15. Den internen USB2.0-Port brauchst du für das Bluetooth der Fenvi. Falls dein Case USBC und USB3 hat und du die internen Header dafür deshalb nicht deaktivieren willst, musst du die andere Ports raussuchen, die du (teilweise) deaktivierst. Du kannst zB auch von einer USB3 Buchse das USB2 deaktivieren um Ports einzusparen, dann gehen halt keine USB2-Geräte mehr an dieser USB3-Buchse.

  • Guten Abend,

    ich wollte Euch noch einmal ein kleines Update geben.


    Habe heute Audio zum laufen gebracht. Dazu habe ich wie von SchmockLord beschrieben die beiden zusätzlichen kexts

    FakePCIID_Intel_HDMI_Audio.kext und FakePCIID.kext eingebunden und in den Device Properties den Eintrag hinterlegt.

    Ich dachte zwar der Ton wäre auch vorher schon über die Audio Ausgänge am Frontpanel rausgekommen ohne die Kexts aber da war ich nicht sicher. Die Audio Ausgänge hinten laufen noch nicht. Das ist aber aktuell unwichtig.


    Dann habe ich mit der FakePCIID_Intel_I225-V.kext den 2,5GBit Ethernet Port zum laufen bekommen.


    USB Ausgänge funktionieren schon einige. Da habe ich aber noch nicht geprüft ob alle.

    Was ich mich frage, ob ich aus der iGPU auch eine UHD also 4k Auflösung herausbekomme. Das habe ich noch nicht gefunden.

    traeu Was Du mit dem ROM Eintrag gemeint hast, das habe ich noch nicht ganz verstanden. Da finde ich auch nichts bei SchmockLord und im Dortania was da im Post Install noch gemacht werden muss. Mit der apple-id läuft aber bisher alles. Auch facetime sehe ich schon meine Historie von meinem iPad im Hackintosh.


    Jetzt ist es wirklich nur noch finetuning. Ich bin auch sehr gespannt auf die neuen AMD-Karten, die ja bald zu erwarten sind.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • NICHT intel-hdmi-audio, den braucht man für die neuesten Opencore-Versionen gar nicht mehr

    layout-id sollte und korrekter PCI-Pfad sollte für Audio ausreichen. Bin mir natürlich nicht 100% sicher weil ich es nur in Kombination mit AMD-GPU testen konnte, aber bei meinem Hacki war der fakepciid kext für intel hdmi audio nur eine Zeit lang für die Audioausgabe der GPU notwendig und nach einem Kext-Update hat die Audioausgabe auch so funktioniert. Also kannst du mal testen, wenn du Monitor und die analogen Audioports auch ohne diese Kext als Ausgabegeräte siehst, geht es auch so.

    Zu den hinteren Ports: Der hintere grüne Port sollte immer dann aktiv sein, wenn vorne nichts eingesteckt ist. Das sollte automatisch umschalten. Die anderen Ein- und Ausgänge sollten als weitere Ein- und Ausgabegeräte in den Systemeinstellungen erscheinen. Wäre irgendwie komisch, wenn du trotz AppleALC kext und der richtigen Layout-ID nur den grünen Port ansteuern könntest und nicht die anderen...und auch wenn du sie gerade nicht brauchst, empfehle ich, sowas immer gleich komplett fertig zu testen, dann kannst du es gedanklich abhaken und weißt, dass in Zukunft Audio uneingeschränkt nutzbar sein wird.


    Zum ROM: Der Guide zu den iServices hat einen eigenen Abschnitt "Fixing ROM". Das findest du bestimmt! Bei Schmocklord findest du da nix, weil das für jedes Board anders ist, da es von einer deiner MAC-Adressen abhängt.


    Die Auflösung ist wie bei MacOS einzustellen, da gibts nichts Hackintosh-spezifisches. Wenn du ALT gedrückt hältst und in den Systemeinstellungen bei Monitore bei der Auflösung auf skaliert klickst, solltest du auch andere Auflösungen sehen. Ansonsten mal danach googeln. Bei HDMI 1.4 ist bei 4k leider schon bei 30Hz Schluss...


    Hast du dir zu den USB Ports Gedanken gemacht? Welche der internen Ports nutzt du denn?

  • Ah danke. Das hatte ich nicht gesehen mit dem "fixing ROM"
    Dann werde ich da noch meine Mac-Adresse eintragen.


    Auflösung wird gleich getestet.


    Zu den USB-Port habe ich mich noch gar keine Gedanken gemacht. Der Port am Frontpanel funktioniert mit dem Boot Stick.


    Was mir noch beim Audio aufgefallen ist, in einigen Videos z.B. bei Youtube klingt Sprache manchmal etwas "knackend". Ich habe das mal unter Windows geprüft, ob es an dem Video liegt, aber scheinbar ist es das Mac-Audio. Soll ich da mal eine andere layout-id probieren? Dafür gibt es ja ganz viele für meinen Audio-Chip. Vielleicht funktioniert dann auch der grüne Port hinten. Der geht im Moment nicht, auch nicht wenn ich vorn nichts drin habe. Die Ausgänge sind aber unter Sounds als Line-Out vorhanden.

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Zu den USB-Port habe ich mich noch gar keinen Gedanken gemacht. Der Port am Frontpanel funktioniert mit dem Boot Stick.

    Wenn du dir mal in der PDF, die Schmocklord wirklich mega übersichtlich erstellt hat, alle Ports mit ihrem Namen raussuchst, die du später verwenden willst (aber maximal 15 ausser SSP, SSP-Ports zählen beim Vision D nicht zum Limit), wird das Portmapping relativ einfach.


    Layout IDs kannst du theoretisch alle für deinen Codec unterstützten durchtesten. Du findest sie hier: https://github.com/acidanthera…alc/wiki/supported-codecs

    Das Vision D hat den ALC1220 Codec. Allerdings wird nicht jedes Layout funktionieren, weil das von der Verdrahtung des Soundchips mit den Buchsen abhängt, das kann bei jedem Board trotz gleichem Codec anders sein. Wenn du in der verlinkten Tabelle auf den Link "ALC1220" klickst und in dem verlinkten Github-Ordner auf die Info.plist, kannst du auch nachschauen wofür die verschiedenen Layout-IDs ursprünglich gemacht wurden und wie die Ein- und Ausgänge verschaltet sind (moderne Boards sind da ja sehr flexibel und manche Ports lassen sich als EIn- und auch als Ausgang umkonfigurieren). Speziell für das Vision D-Board wurde (noch) kein eigenes Layout erstellt, sonst wäre die Wahl ja einfach. Deshalb testen wir durch und schauen was am ehesten an die Verdrahtung vom Vision-D-Board rankommt.

  • Das PDF von SchmockLord ist ja mega übersichtlich und eindeutig.

    Habe ich das richtig verstanden, dass ich die Zuordnung einfach im Hackintool unter USB durchgehen und zuordnen kann?


    Das mit der Layout-id für Audio hatte ich gesehen. Da teste ich einfach mal ein paar durch.

    iMessage funktioniert bei mir auch.


    Langsam wird es :klatschen:


    Sag mal traeu ich habe eben mal ein wenig gegoogelt zum Thema Takt meiner CPU erhöhen. Die läuft ja im Moment auf 3,7Ghz kann aber wenn ich es richtig verstanden habe 5,2 pro Kern.
    Gibt es da auch gute Anleitungen und dann Tools, um das ganze anzugehen. Gehts das übers BIOS. Ich gestehe ich habe nur Punktuell was ich gerade brauchte in meinem Gigabyte-Handuch nachgeschlagen. Die BIOS Sektion so gut wie noch gar nicht. Hättest Du einen Tipp für ein gutes Tool um sämtliche Systemparameter im Blick zu behalten, also auch CPU Temp. usw. Ich hatte mal sowas gelesen, finde es aber nicht mehr.
    Und für Benchmarks welche Tools sind da am gebräuchlichsten? Cinebench?

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x

  • Hallo ihr beiden, freut mich das ihr Vortschritte macht :)


    Bezüglich Benchmarks, sind Cinebench 20, Prime95 (beide CPU) sowie FurMark für die GPU recht gebräuchlich. Um deinen Gesamten PC zu Verorten gibt es noch Pc Mark 10 :top:


    Was das Übertakten deiner CPU und das Anpassen des RAMs angeht, so wird dies (zumindest was meine Erfahrung bei Window PCs betrifft) im BIOS umgesetzt, sodass ich vermute dies ist Betriebssystem unabhängig und sollte so auch Funktionieren. Ob für macOS noch spezifische Anpassungen notwendig sind (was ich nicht glaube) sollte jemand anderes Beantworten :P


    -> CPU: Takt und Spannung

    -> Arbeitsspeicher: Timing, Takt sowie Spannung (Meist relativ einfach durch XMP Profile und Memory Try It! einzustellen)


    Was du meinst mit den 5,2 GHz CPU Takt sollte der Turbo-Takt sein, welcher die performantesten Kerne kurzzeitig (laut Intel) bei dem 10900k auf 5.3GHZ erhöhen soll. In diesem Zustand wird dann auch das zweite Leistungslevel (250W) verwendet und läuft nach meiner Kenntnis für 56 Sekunden. Einfach mal nachlesen :)


    Edit: Hier mal ein Video, welches dir die Grundlagen in den Gigabyte Settings aufzeigt =)

    Ich habe mir das Video nicht ganz angeschaut, wenn du den Eindruck hast das manche Schritte zu Groß sind, mach lieber kleiner. Im Jahre 2020 solltest du durch BIOS Einstellungen deine Hardware zwar nicht mehr töten können, aber sicher ist sicher :)


    Grüße Corv

    Hackintosh 2020: In Planung =)


    StreamPC 2018: MSI X470 | Ryzen 7 2700X | MSI GTX 1070 | Ram G.Skill 16GB | NVMe Samsung 970 EVO

  • Die Auflösung ist wie bei MacOS einzustellen, da gibts nichts Hackintosh-spezifisches. Wenn du ALT gedrückt hältst und in den Systemeinstellungen bei Monitore bei der Auflösung auf skaliert klickst, solltest du auch andere Auflösungen sehen. Ansonsten mal danach googeln. Bei HDMI 1.4 ist bei 4k leider schon bei 30Hz Schluss...

    Das Höchste was er mir auch mit gedrückter ALT Taste anzeigt ist 2560x1440. UNterstützt die iGPU evntuell nicht mehr?

    Desktop:

    Intel Core i9 10900K 10x 3.70GHz | Gigabyte Z490 Vision-D | bis jetzt nur die iGPU | 64GB G.Skill Tridentz Z Neo DDR4-3600 DIMM CL18 Dual-Kit (2x32GB)| 2x Sabrent 1 TB Rocket NVMe PCIe M.2 2280 SSD für Windows 10 PRO & macOS 10.15.7 | be quiet! Pure Base 500DX | be quiet! Pure Loop 360mm | Corsair RM750x