Kein Bluetooth mit BCM943602CS

  • Hallo zusammen,

    seit ein paar Betaversionen in Catalina funktioniert mein Bluetooth trotz aktuellen kexts nicht, wlan dafür komplett ohne Treiber. Meine EFI hat sich eigentlich nicht wirklich verändert, weshalb es etwas seltsam ist. Hat jemand eine Idee?

  • Soweit ich weiß, läuft der Bluetooth Teil dieser Karte über USB, vielleicht ist der USB Port deaktiviert?

    Hast du denn deine USB Ports gepatched? mit dem Hackintool z.B.

  • Beim Switch von Mojave auf Catalina hatte ich das gleiche Thema - auf einmal war zusätzlich noch folgende Kext notwendig: BrcmBluetoothInjector.kext


    Natürlich neben den bereits im Einsatz befindlichen Kexten (zumindest bei mir):

    - AirportBrcmFixup.kext

    - BrcmFirmwareData.kext

    - BrcmPatchRAM2.kext


    cheers

    _______________________________________________________________________________

  • Soweit ich weiß, läuft der Bluetooth Teil dieser Karte über USB, vielleicht ist der USB Port deaktiviert?

    Hast du denn deine USB Ports gepatched? mit dem Hackintool z.B.

    Ich habe einen Usb-patch mit dem Hackintool gemacht, aber die Karte sollte da mit drin sein, zumindest wird mir der bluetooth part unter usb als Broadcom Bluetooth Download Device angezeigt. Ic habe folgende kexts in L/E:

    - BrcmBluetoothInjector.kext

    - AirportBrcmFixup.kext

    - BrcmFirmwareRepo.kext

    - BrcmPatchRAM3.kext

  • Da es sich hier um eine Apple Karte handelt benötigt diese auch keine zusätzlichen Kexte. Ich habe die auch verbaut. Läuft problemlos in Catalina. Die Anzeige unter USB stimmt nicht. Sieht aus als hätten die Kexte da was verpfuscht. Nimm den Kram bitte raus und schau ob sich was verändert.

    LG Chris


    Meine Hardware:

  • CMMChris gibt es irgendeine Möglichkeit die Firmware neu zu flashen? Ich hatte die Karte vor schon mal draußen und es hat absolut nichts gebracht.

  • Was willst du da Flashen? Raus mit den Kexten wie Chris bereits gesagt hat und gut ist.

    MacBookPro15,1 - HP Envy X360 - Intel i5 10210U - 16GB RAM - 512 GB SSD - Intel UHD 630 - 10.15.2 (19C57)

    MacPro7,1 - Intel Xeon 3175X - Gigabyte C621 Aorus Xtreme - 192 GB RAM - 2x 960GB Corsair Force MP510 - 2x MSI Radeon VII - 10.15.2 (19C57)




    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Sehe ich genauso. Wenn es eine original Apple Karte ist benötigt die keine dieser Patch-Dinger. Habe 3 Stück in 3 verschiedenen Rechnern laufen und ALLE 3 funktionieren OOB ohne Patches... (sind 2 PCs und ein Laptop).


    PS: es handelt sich um 2 -CS2 Karten und eine 2CS Karte.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Leider ist es nicht so einfach, auch ohne kexte funktioniert bluetooth nicht und wird unter usb nur als Broadcom Bluetooth Download Device angezeigt

  • Wie hast du sie denn angeschlossen??

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • An einem internen usb2 header

  • hast du mal das Kabel vom Adapter zum Mainboard und den Sitz der Karte im Adapter überprüft? Die Kabel sind so Sche.... da löst sich gerne mal eine der dünnen 4 Adern aus den Steckkontakten. Hatte ich bei meiner Ersten Adapterplatine auch... Da war es die rote 5V+ Ader, unter Bluetooth wurde zwar irgendwas angezeigt, aber es funktionierte eben nichts.


    PS: und es muß was mit dem USB zu tun haben, da dein WLan ja funktioniert, dieses ist per PCIe angebunden. der Bluetoothpart nur über USB. Also erst ale mechanischen / elektrischen Fehlerquellen ausschließen und dann bei der Softwareseite, USB-Port Einbindung in mac OS weitermachen, dann findest du den Fehler schon und es sollte dann ohne die besagten Patch-Kexte funktionieren.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Ic habe folgende kexts in L/E:

    - BrcmBluetoothInjector.kext

    - AirportBrcmFixup.kext

    - BrcmFirmwareRepo.kext

    - BrcmPatchRAM3.kext

    GGf die Kexte mal in den Others Ordner vom Clover reinpacken.

    Also aus L/E löschen, Kext-Cache bereinigen. Dann die Kexte in den EFI/Clover/Kexte/other packen. Wobei du dann den Repo gegen den Data Kext austauschen mußt...


    • BrcmFirmwareRepo.kext: Install to /System/Library/Extensions (/Library/Extensions on 10.11 and later). This kext is much more memory efficient than BrcmFirmwareData.kext and is the preferred configuration.
    • BrcmFirmwareData.kext: Most appropriate for EFI/Clover/kexts. BrcmFirmwareRepo.kext, while much more memory efficient, cannot be injected as can BrcmFirmwareData.kext

    iMacPro1,1: Fractal Define R6 - ASUS Prime Z390-A 1302 - i9 9900k 3,6Ghz - 64 GB - PowerColor Radeon RX 580 8GB - NVMe SanDisk Extreme Pro 500 GB - BCM943602CS Combo Karte - Thunderbolt 3 Titan Ridge - macOS 10.14.6 - Clover 5070

    iMac18,3: G5-Casemod - GA Z270-HD3P - i7 7700k 4,2Ghz - 16 GB - ASUS DUAL Radeon RX 580 4GB - NVMe SSD 960 EVO 250 GB - BCM943602CS Combo Karte - macOS 10.14.6 - Clover 4945
    MacBook Pro: Dell Inspiron 5370 - i5-8250U 1.6GHz - 8 GB (1x8 GB) RAM - Intel UHD 620 - 250 GB NVMe (macOS 10.14.6) - Clover 5058

  • Wenn es ne Originale BCM943602CS ist braucht man keine diese Kext-Dateien .

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Ja, ich weiß! Löppt bei mir auch ohne, aber Versuch mach Kluch...

    iMacPro1,1: Fractal Define R6 - ASUS Prime Z390-A 1302 - i9 9900k 3,6Ghz - 64 GB - PowerColor Radeon RX 580 8GB - NVMe SanDisk Extreme Pro 500 GB - BCM943602CS Combo Karte - Thunderbolt 3 Titan Ridge - macOS 10.14.6 - Clover 5070

    iMac18,3: G5-Casemod - GA Z270-HD3P - i7 7700k 4,2Ghz - 16 GB - ASUS DUAL Radeon RX 580 4GB - NVMe SSD 960 EVO 250 GB - BCM943602CS Combo Karte - macOS 10.14.6 - Clover 4945
    MacBook Pro: Dell Inspiron 5370 - i5-8250U 1.6GHz - 8 GB (1x8 GB) RAM - Intel UHD 620 - 250 GB NVMe (macOS 10.14.6) - Clover 5058

  • Dann hast du nicht den Richtigen Port limit patch drin !!


    Und für die originale BCM benötigst du auch keine Texte wie bereits erwähnt..

    Next Hacki im Aufbau



    (Original) MacBook Pro 2018 Touch Bar mit vier Thunderbolt Anschlüssen, Core i5 - 8259U, 16GB DDR4, 512GB m.2 SSD Catalina 10.15


    Bitte keine Supportanfragen per PM bzw. auf meiner Pinnwand. Dafür ist das Forum da!

  • Leute, ein USB Problem liegt nicht vor. Die Karte wird ja erkannt. Nur eben falsch. Das deutet darauf hin, dass die Firmware der Karte durch diese Patch Kexte beschädigt wurde. "Download Device" deutet darauf hin, dass sich die Karte in einer Art Flash Modus befindet.

    Edit: Versuche mal ein Ubuntu Live System zu starten und Teste dort das Bluetooth.

    Edit 2: Hast du eigentlich nach dem Entfernen der Kexte auch den Kext Cache neu aufgebaut?

    LG Chris


    Meine Hardware:

  • Edit: Versuche mal ein Ubuntu Live System zu starten und Teste dort das Bluetooth.

    Edit 2: Hast du eigentlich nach dem Entfernen der Kexte auch den Kext Cache neu aufgebaut?

    Ok ich schaue mal was Ubuntu sagt. Ich habe gerade meinen usbpatch mit Hackintool neu gemacht, also der kext cache wurde mehrmals neu aufgebaut

  • CMMChris ,stimmt irgendwie, garnicht drauf geachtet, wenn USB Geräte im Flashmodus sind, nennen die sich ja des öfteren "Downloaddevice" oder zumindest sowas in der Art. [wech]

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • Also leider wird Bluetooth auch unter linux nicht erkannt, wlan schon

    CMMChris Hast du einen Vorschlag, was ich jetzt machen soll?

    Edited once, last by The_Dave ().