Miserable GPU Performance in CAD Software, fehlende Hardwarebeschleunigung RX580

  • Moin zusammen,

    ich hatte ja auf OS 13 upgedatet.

    Lief so weit auch alles ganz gut.

    Der Grund fürs Update war der Zwang von Fusion360 dazu.

    Leider läuft die Software seid dem Update echt schlecht, regelmäßiges Ruckeln und Hängen, vor allem bei mittelgroßen Dateien.

    Nun hatte ich mit VideoProc mal geschaut ob, denn Hardwarebeschleunigung verfügbar ist.

    Leider ist dies nicht gegeben.

    Ich vermute nun mal, dass hierdurch die schwache Performance kommt.

    Mein Monitor ist jedoch an der GPU angeschlossen, funktioniert auf voller Auflösung (3440*1440) und auch im About this Mac wird die RX580 angezeigt.

    Gibts da einen Fix?



    Vielen Dank für euren Rat:groesten:

    Mit freundlichen Grüßen




  • Die Hardware Beschleunigung für Videos hat nichts mit der 3D Beschleunigung zu tun. Das ist also nicht die Ursache. Wechsel auf das iMacPro oder Mac Pro SMBIOS wenn du grünes Licht in VideoProc willst.

    LG Chris


    Meine Hardware:

  • Die eigentliche Arbeit findet ja nicht auf dem Schirm, sondern in den entsprechenden Chips statt. Wenn Deine RX580 nicht erkannt wird, darf die CPU mit ihrer iGPU die Arbeit eben allein machen. In meinen Grafik-Programmen kann ich mir meinen Rechenknecht meist selbst aussuchen..

    Als was für einen Rechner-Typ hast Du Deinen Z490 denn definiert? Wenn es noch der iMac 20,1 Deiner Abbildung ist, versuch es doch mal mit dem 19,1er, der hat im Original ja ne 580er.

    Aber in der OC-Liste NUR GENAU DIESE ZAHL ändern. Wahrscheinlich wäre dann aber aber auch ein neuer USB-Kext fällig. Da kannst Du testweise in Deinem alten auch in der internen P-Liste genau diese Zahl ändern, aber das funktioniert nicht immer..


    Ich gehe mal davon aus, dass Du Lilu & Whatevergreen benutzt, da sollte die RX eigentlich richtig erkannt werden.


    :hackintosh:

  • Moin, danke für euer schnelles Feedback.

    Ah okay, dachte hängt evtl damit zusammen, dass dann auch die GPU Umschaltung nich richtig rennt....

    Also auswählen kann ich es nicht, finde zumindest nicht.
    Falls hier jemand ist der mehr Plan davon hat als ich möge er mir gern n Tipp geben wo es geht.

    Ne Anleitung finde ich auch nur für Windoof


    Die Software hat aber ne Diagnose, diese sagt, dass die richtige GPU verwendet wird siehe hier:


    Rechnertyp is 2020er iMac, ja. Wurde mir seiner Zeit so empfohlen.

    Was meinst du mit in meinem USB Kext die P-Liste ändern?

    Ist in der USB Kext etwa auch die PC Variante hinterlegt?


    Anbei mal meine EFI.


    Ändern auf 19.1 sollte ich noch hinbekommen, das ging doch mit ProperTree oder?

    Files

    • EFI.zip

      (11.64 MB, downloaded 47 times, last: )

    Mit freundlichen Grüßen




  • Ich glaube das Problem ist hier, dass die Software OpenGL nutzt wie im letzten Screenshot sichtbar ist. Apple hat mittlerweile keine nativen OpenGL Treiber mehr, sondern lässt das über einen Translation Layer auf Metal laufen. Die Übersetzung ist katastrophal langsam.

    LG Chris


    Meine Hardware:

  • Hm okay, also hab ich mit keiner GPU der Welt ne Chance, dass das unter macOS besser läuft?

    Musste leider von 10.15 updaten, weil die Software es so wollte.

    Merkwürdig dass Sie dann dennoch OpenGL nutzt.

    Muss zugeben hatte dieses Fenster heute zum ersten Mal geöffnet....

    Mit freundlichen Grüßen




  • OpenGL ist für mich zumindest die plausibelste Erklärung für dein Problem. Kannst ja mal beim Hersteller der Software fragen, ob es Pläne gibt daran was zu ändern.

    LG Chris


    Meine Hardware:

  • @FighterSchrauber warum bist du nicht erst mal auf macOS 11 umgestiegen, langsam steigern, Autodesk sind nicht die schnellst und auch nicht unproblematisch in Sachen Unterstützung von neuer OS Versionen.

    WSR:

    GR:

    Mac:

  • Das kommt mir aber seltsam vor: ein Update einzufordern, dann aber nicht passend liefern zu können. Zumal es ja auch ne Version für iPad und iPhone gibt, die sicher auch mit Metal laufen muss. Das müsste doch umzuschalten sein.


    :hackintosh:

  • Bob-Schmu Weil Fusion mir gesagt hat, dass es schon minimum 12 wollte...


    Ja ich habe mal angefragt, wie es da aussieht.


    Also meint ihr an sich sollte die gpu richtig laufen?


    Gibts n guten Mac benchmark mit dem ich das prüfen könnte?

    Mit freundlichen Grüßen




  • Das kommt mir aber seltsam vor: ein Update einzufordern, dann aber nicht passend liefern zu können. Zumal es ja auch ne Version für iPad und iPhone gibt, die sicher auch mit Metal laufen muss. Das müsste doch umzuschalten sein.

    Ich habe mal etwas recherchiert, finde nichts zu einer Metal Unterstützung der macOS Version. Nur OpenGL wie es scheint.

    FighterSchrauber Lass halt nen Benchmark laufen. Basemark GPU zum Beispiel.

    LG Chris


    Meine Hardware:

  • Also, ich sag mal die GPU rennt richtig.

    Cs. 50t Punkte

    https://browser.geekbench.com/v6/compute/838914


    Metal ca 60t

    https://browser.geekbench.com/v6/compute/838937


    Aber krass wie gut die Apple M1/2 so abliefern

    Mit freundlichen Grüßen




  • Hatte auf meinem Hackintosh auch Fusion 360 laufen. Eigentlich gab es da nie Probleme.

    Für mich sieht das nach zu wenig RAM aus. Wieviel Speicher hast du installiert?

    Die empfohlenen Mindestanforderungen sind absoluter Quatsch.

  • Er hat 32 GB... mag sein mehr bringt etwas?

    Jedoch glaube ich eher das - inzwischen - seine CPU ne 10400er das bottleneck ist. OPenGL zieht mehr CPU Last nach sich - daher bei OpenGL schnellere CPU sinnvoll. An der RX 580 wirds net liegen.

    Inzwischen gibts bei ebay Kleinanzeigen schon recht preiswert 10600K+ - das wird auf jeden Fall ein gewisser Unterschied werden. In allen Apps.

    Da du ein Z Mainbord hast und falls gute Kühkung kannst du ruhig ne ..K CPU nehmen und bei nur etwas OC wird die auch net zu viel Watt ziehen.

    Die 10400er halt inzwischen echt ne Einsteiger CPU für neues OS, neue Apps.


    PS: Denke ein SSD Sata Laufwerk irste schon haben (neben normaler HD) - mag sein ein NVME , gerade günstig GEN3 bringt auch noch einen gewissen Schub in der Verarbeitung großer Dateien..

  • Ich hatte Fusion 360 mal auf meinem i9-9900K mit RX580 ausprobiert. Ich hab's nicht weiter verfolgt, weils zu stark geruckelt hat. Wenn ich das hier so lese, glaube ich, dass es tatsächlich an der geänderten Grafikarchitektur von macOS liegt. :/

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Grafik: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.9.8)
    Operation Systems: macOS "Ventura" 13.6, macOS "Sonoma" 14.3,
    macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i3-10103F (Comet Lake)
    Mainboard: ASROCK H470M-HDV/M.2
    Grafik: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.8.7)
    Operation Systems: macOS "Ventura" 13.1, Windows 10 Professional

    Stopinprogress...

    Lenovo Thinkpad X1 Tablet Gen3 Intel Core i7-8550U, Intel® UHD Graphics 620, 16 GB LPDDR3, Thunderbolt 3, Intel Dual-Band Wireless-AC 8265, 802.11ac Dual-Band 2x2 Wi-Fi® + Bluetooth 4.2, Touchscreen & Stift