Boot Performance Boost NVMe WD SN750 vs NVMe Samsung EVO 970 PLUS

  • SchmockLord Also ist es besser die iGPU zu deaktivieren, wenn man schnelle Boot Times haben will?

    !!!KEIN SUPPORT PER PN!!!

  • Kann ich leider so nicht stehen lassen. Denke eher das der Rest deines Systems da mehr Schuld bei trägt. 90 Sek. sehr utopisch. Kann ich nicht bestätigen.

    Deshalb schrieb ich ja auch „kann man…“. Bei mir und einigen anderen Besitzern dieser SSD war das halt so, getestet mit einem sehr hohen Wert unter SetApfsTrimTimeout. Wenn man da -1 eingetragen hat, bekommt man davon nix mit. Bevor es SetApfsTrimTimeout gab, hat macOS trim nach 10 Sekunden mit einem Timeout abgebrochen. Mit der neuen WD Black bootet macOS jetzt übrigens sauflott.

  • Bei mir gibt der Befehl von anonymous writer auch nichts aus.

    !!!KEIN SUPPORT PER PN!!!

  • SchmockLord Also ist es besser die iGPU zu deaktivieren, wenn man schnelle Boot Times haben will?

    Ist wie immer. Kommt drauf an. Wenn du die iGPU Features brauchst und ein SMBIOS (z.B. iMac20,x) nutzt, was normal (in einem echten Mac) eine iGPU hat, dann solltest du sie aktivieren. Beispiele: Quicksync. SideCar.


    Wenn du aber ein SMBIOS nutzt wie iMacPro1,1, welches keine iGPU hat, dann lieber disablen.

    My Youtube Channel: https://www.youtube.com/channel/UCnohQxGguJlqTeOsZUl3E4A


    Desktop: MiniITX Build Asrock Z490 Phantom Gaming ITX/TB3 | Intel i9-10900k| Trinity 3090 für Windows, Sapphire Pulse 5700XT per TB3 im eGPU Case Razer Core X für MacOS | 32GBRAM TridentZ 36000Mhz | 1TB Samsung 960 EVO für macOS | 1TB Samsung 970 EVO für Windows 10 | 2TB Intel 660p als ExFat für Windows/Mac


    Laptop: MacBook Pro 16 Base Model

  • und damit dann ein paar Millisekunden einsparst. Was eure Parameter aber wirklich bewirken auf der M2 scheint ihr wohl aber nicht zu wissen oder? Schonmal den Eintrag im DortaniaGuide dazu gelesen? Zwar bootet ihr für euch schneller aber damit kastriert ihr den TRIM ganz ordentlich. Ob das mal nützlich für eure Daten auf Dauer sein kann?

  • Das wurde schon zwei mal erwähnt!


    Es stellt sich nun die Frage, ob bei der WD der Trim nicht ausgeführt wird, oder eben schon, aber dafür sauber.


    pebbly hat seinen Verdacht gut beschrieben.


    Daher noch mal die Frage, kann man in irgendwelchen Logs sehen, ob der Trim während des Bootvorgangs zum tragen kommt, oder während des laufenden Betriebs?

  • ich glaube bei dem Log sollte das drinstehen. hast du denn Trimforce enable gesetzt? Ohne SetApfsTrim Parameter gesetzt zu haben? Dann sollte man das aus den Werten dort sehen können. Was ich aber jetzt nicht verstehe warum deine WD nicht im Log auftaucht?

    War doch so oder irre ich mich jetzt?

  • Ja im Log taucht sie nicht auf.



    SetApfsTrim ist per default auf -1 gesetzt.


    Wenn ich mich nicht irre, irgendwo gelesen zu haben, dass Trim automatisch aktiviert wird bei APFS formatierten Platten.


    Das ist ja ein weiteres Indiz das sich diese zwei Platten so unterschiedlich verhalten. Mir ist die Boot-Zeit im Prinzip auch ganz gleich, wenn ich weiss das alles sauber ausgeführt wird.

  • bluebyte


    Referenz


    Yep - als ich meinen Server neu aufsetzt (i5-6600) mit m2-SSD war ich anfangs zu langsam, um dem Boot-Vorging zuvorzukommen, nachdem weitere 6 Platten installiert waren, wurde es "gemächlicher" - ist also normal.

    Bei FreeBSD und auch linux Bootvorgängen kann man das schön am Bootlog verfolgen :p

    Bye

    Stefan


    Edited once, last by guckux ().

  • jo bezog sich ja auf meine Aussage...genau dieser Abschnitt.aber ich glaube das sich das noch auf die EVO beziehen nicht auf die EVO Plus. Auch der ursprüngliche Phoenix Controller wurde bei der 970 EVO Plus überarbeitet. Ist also nicht das gleiche Pendant zu EVO.

    Im Praxiseinsatz kann ich jetzt nichts schlechtes sagen oder das bestätigen. Bootzeit richtet sich eindeutig danach was aktiv ist und geladen wird. Und die Bootzeit ist eigentlich in Ordnung. Ausfälle sind auch nicht zu verzeichnen. Trim aktiv.Warum aber die WD jetzt nicht im Log auftaucht? Liegt wahrscheinlich am Controller?

  • So jetzt.... man seit ihr ungeduldig... alle warten auf das Video :totlachen:


    also Leute ich hab mich etwas zu weit aus dem Fenster gelehnt :oops:


    sind doch nicht 6-7 Sekunden wenn man eine Stoppuhr benutzt [hehee]

    da sind es dann doch 2-3 Sekunden mehr.

    hab immer so in etwa mit gezählt naja bin ja keine Stoppuhr :)

    aber es waren gefühlte 6-7 Sekunden [wech]


    nicht desto trotz kann sich die Geschwindigkeit sehen lassen. wenn man bedenkt das es eine SSD ist.

    Hast du filevault aktiv?

    Nein hab ich nicht, brauch ich auch nicht! meine wichtigen Daten sind in der Cloud :)


    Welche EVO? Die 850 und die 860 hab ich hier auch, die haben ne echt schnelle Bootgeschwindigkeit, aber im OS ist der Unterschied zu anderen Platten (SATA, NVMe hab ich keine) wirklich sehr gering.

    hatte erst die 850 EVO bin jetzt auf 870 EVO V-NAND die noch bissle schneller ist.

    aber beim booten war die 850 EVO vielleicht minimal langsamer aber auch eine gute SSD.

  • Ich hatte nach dem Einbau der WD Black SetApfsTrimTimeout auf einem sehr hohen Wert belassen und trotzdem eine sehr kurze Bootzeit. Der Controller dieser SSD kann mit Trim unter macOS besser umgehen, als der meiner 970 EVO. Firmware war aktuell. Das Problem hat wie gesagt nicht jeder, ich hatte es aber massiv. Es waren übrigens insgesamt > 120 Sekunden:


    2021-02-07 10:27:25.127770+0100 0x1fc Default 0x0 0 0 kernel: (apfs) spaceman_trim_free_blocks:3327: scan took 67.082337 s, trims took 61.671375 s


    Die 970 EVO habe ich in ein externes Gehäuse verpflanzt und nutze diese nun für Backups.

  • Amante81 Ja doch, das ist schon sehr schnell. Also mein Z590i mit eGPU via TB booted nicht so schnell, trotz 980 Pro als OEM Version.


    Aber: Du hast auch nur die iGPU, oder? Weil als ich in meinem Vision D Build neulich erst nur die iGPU genutzt habe, gings auch schneller als danach dann mit der W5500 im PC.


    Und das ist jetzt mit oder ohne Trim?

    My Youtube Channel: https://www.youtube.com/channel/UCnohQxGguJlqTeOsZUl3E4A


    Desktop: MiniITX Build Asrock Z490 Phantom Gaming ITX/TB3 | Intel i9-10900k| Trinity 3090 für Windows, Sapphire Pulse 5700XT per TB3 im eGPU Case Razer Core X für MacOS | 32GBRAM TridentZ 36000Mhz | 1TB Samsung 960 EVO für macOS | 1TB Samsung 970 EVO für Windows 10 | 2TB Intel 660p als ExFat für Windows/Mac


    Laptop: MacBook Pro 16 Base Model

  • SchmockLord

    Hi,

    Ja nur mit iGPU da ich Optimismus habe kann ich die GeForce 640m nicht benutzen! Naja gibts schlimmeres 😁 die Hd4000 hat ja originalen 1536 mb bin am überlegen ob ich ihr mit einem Patch 2048 mb verpasse ! Bringt das was? Weiß das jemand?


    Und die SSD läuft ohne Trim!


    Siehe Foto!


    meinst das ist schneller mit Trim? Glaub eher nicht.... oder
    hab auch irgend wo gelesen das Trim bei APFS nicht notwendig wäre 🤷🏻‍♂️ kein Plan hab mich nicht damit befasst, außerdem ist auf der gleichen Platte meine Windows Partition drauf nicht das ich mir nachher noch was zerstöre.

  • Ne. Trim machts eher langsamer. Ist ja ein extra Prozess wo die SSD quasi Selbstpflege betreibt um länger zu halten.

    My Youtube Channel: https://www.youtube.com/channel/UCnohQxGguJlqTeOsZUl3E4A


    Desktop: MiniITX Build Asrock Z490 Phantom Gaming ITX/TB3 | Intel i9-10900k| Trinity 3090 für Windows, Sapphire Pulse 5700XT per TB3 im eGPU Case Razer Core X für MacOS | 32GBRAM TridentZ 36000Mhz | 1TB Samsung 960 EVO für macOS | 1TB Samsung 970 EVO für Windows 10 | 2TB Intel 660p als ExFat für Windows/Mac


    Laptop: MacBook Pro 16 Base Model

  • Das ist so nicht richtig.


    Wenn kein TRIM läuft und alle Zellen mal beschrieben waren, DANN wird es grottenlangsam, weil erst die nicht mehr belegten "freien" Zellen freigeräumt werden müssen, bevor neue Daten geschrieben werden können.

    TRIM beugt diesem Vorgang vor und macht dies "Häppchenweise" im aktiven Betrieb.

    Nähere Infos hier.

    Bye

    Stefan


  • So, gebe mal mein Gyros auch dazu [hehee]

    Ab OC booting bis Bildschirmaufbau ca. 21 sec.


    Habe dafür die iGPU deaktiviert. Passt alles. Verwende OC 0.6.9 und Nightly Kexts.

    Hab keine HDD sonst reißt es mir bis auf 30 sec rauf.

    WEG hatt ich mal unterschiedliche Versionen ausprobiert, da hatt´s mal auch etwas länger gedauert.

    Hab mal meine config.plsit dazu gegeben.

    Files

    Bootloader: Open Core

    MoBo: Gigabyte Z490 Vision G

    WiFi : BCM94360CD

    CPU : Intel Core i9 10850K 10x 3.60GHz
    GPU : Radeon RX 5700 8GB
    Mem : 32 GB DDR4 3600 4x 8GB
    SSD M2: OSX 11
    SSD M2: WIN10 / Linux
    Case: Corsair Carbide Series 275R

    Edited 3 times, last by greecedrummer ().