Kann ich diese Teile kaufen um einen Hackintosh daraus zu bauen?

  • Dr. Peterchen 11


    Offensichtlich hast Du meinen Beitrag nicht verstanden und was dahinter steckt, wenn Du das als Angriff siehst.


    Ich mache kein Drama daraus, sondern ich schildere die Dinge so, wie sie sind. Und gerade, wenn man sich als TE in ein neues Thema hineinbegibt, sollte es eine Selbstverständlichkeit sein, sich vorher mal richtig einzulesen. Jeder hier hat mal neu angefangen und war Frischling.

    Es geht auch nicht um das Fragen an sich, sondern darum, was man fragt. Wer einen Hackitosh aufbauen will, sollte zumindest wissen, was ein Verbose-Modus ist - das gilt auch für einige andere Sachen. So aber offenbart es, wie sehr sich vorher mit der Sache beschäftigt wurde.

    Ein Forum ist nicht nur nach meinem Verständnis nicht dazu da, sich Alles anreichen zu lassen, sondern dazu gedacht, wenn sich ein TE eigeninitiativ, aber vergeblich um die Behebung eines Problems bemüht, ihn zur Lösung hinzuführen und zwar so, dass auch was bei ihm hängen bleibt - eben Nachhaltigkeit.

    Ein Hochladen einer EFI ist vollkommen OK, sie dann seitens Helfer aber ohne große Erklärung wieder runter zu reichen "Hier - probier mal", ist ziemlich sinnbefreit.

    Gruß

    LOM



    Edited 2 times, last by LuckyOldMan ().

  • Und hier wieder ein Beispiel wie man es schafft einen ganzen Thread lahmzulegen, weil einem die Arbeitsweise der anderen nicht gefällt.


    Einen Link reinklatschen LuckyOldMan ist mit Sicherheit genauso wenig zielführend. Wenn es dir so ein Anliegen ist, die Threads wieder qualitativ hochwertiger zu gestalten, dann geh doch mit bestem Beispiel voran. Rummaulen von außen, ohne konstruktive Beteiligung, dass machst du auch nicht zum Ersten Mal. Und bitte sieh dieses Mal davon ab mir eine private Nachricht zu schreiben, mich interessieren deine Beweggründe nicht.


    Ändere was, dann wird man dir auch respektvoll folgen.

  • Ich hab ein Fenvi Modul (das FV-T919) die funktionieren eigentlich ganz gut und deshalb hatte ich mich dafür entschieden. Das WLAN funktioniert super nur das Bluetooth eben nicht. Ich glaube einer meiner Kexte blockiert das ganze.

    Files

    • EFI.zip

      (3.22 MB, downloaded 6 times, last: )
  • Das ist ja etwas blöd gelaufen hier. Der Thread scheint wirklich zum Stillstand gekommen zu sein, das war sicher nicht die Absicht der Kritik.

    Wie kriegen wir das wieder hin?


    EDIT: Dr. Peterchen 11 Ich habe deinen letzten Beitrag aus dem neuen Thread in diesen Thread verschoben, da es ja weiterhin um dasselbe Projekt und Hardware geht.

    Außerdem möchte ich gerne diesen Thread wieder zum Leben erwecken, nachdem es ja zu einem vorübergehenden Stillstand gekommen war.

  • Dr. Peterchen 11 Ich gebe Dir mal ein Beispiel, wie ich mich vor einer Frage informiere: KLICK MICH


    Wenn ich damit nicht schlauer geworden bin, kann ich hier im Forum detailliert mitteilen, was ich bisher versucht habe und was nicht funktioniert.

    So ist die Chance auf eine brauchbare Antwort wesentlich größer, da die Helfer so deine Eigeninitiativer (an)erkennen. :klatsch:

  • Ich hab jetzt die Kexte angepasst die im anderen Beitrag erwähnt worden sind, aber es tut sich leider nichts. Es hat sich nichts zum possitiven und zum negativen geändert. Warum kann mir keiner helfen wenn er es weiß...

    Files

    • EFI.zip

      (5.78 MB, downloaded 2 times, last: )
  • Dr. Peterchen 11 Das erinnert mich gerade sehr an meine ersten Gehversuche mit der Fenvi T919! Die Fenvi Karte benötigt normalerweise überhaupt keine Konfiguration, sie sollte einfach so komplett von MacOS erkannt werden. Ein paar Voraussetzungen müssen allerdings stimmen:
    Für WLAN: Das WLAN der Karte ist per PCIe angebunden, also dem breiten Slot, in den man die Karte einsteckt und festschraubt.
    -->Also muss PCIe funktionieren. Das tut es meistens ohne Weiteres, deshalb funktioniert WLAN bei dir wohl schon.

    Für Bluetooth: Das Bluetooth der Karte ist per USB2.0 angebunden, das ist ein kleiner (oft weißer) vierpoliger Zusatzstecker auf der Fenvi-Platine. Mit dem beigelegten Adapterkabel muss die Karte für Bluetooth-Funktionalität dann in einen internen USB2.0-Port am Motherboard gesteckt werden (in Handbuch steht, wo die sind). Die PCIe-Verbindung wird nicht für Bluetooth genutzt!
    -->Also muss für Bluetooth USB korrekt funktionieren, zumindest muss der interne USB2.0-Port, an dem die Karte hängt, in MacOS auch als ein solcher interner Port bekannt sein. Das macht man, indem man die Ports mappt, also MacOS mitteilt, welche USB-Anschlüsse es an dem Motherboard gibt und ob das interne Ports, externe USB2-Buchsen, externe USB3-Buchsen, USBC-Buchsen usw. sind. Das kann man entweder von Hand machen oder wieder das "Hackintool" dafür nutzen, das kann das auch. Wenn man "(Hackintool) USB Port Mapping" googelt, wird man mit entsprechenden Anleitungen überschüttet, das ist ein unumgängliches Verfahren, durch das jeder Hackintoshnutzer durch muss.
    Wenn die Karte also per USB-Kabel angeschlossen ist und der interne USB-Port korrekt "gemappt" ist, sollte MacOS das Bluetooth-Modul ohne weitere Konfiguration erkennen und nutzen.


    Was außerdem immer super ist: Schreibe hier so viele Infos wie möglich rein! Wenn du zB die Vermutung hast, dass ein Kext dein Bluetooth blockiert, dann schreib auch, wieso du das vermutest. Hast du Tests gemacht und mit bestimmten deaktivierten Kexts funktioniert es plötzlich? Das würde jedenfalls auf ein außergewöhnliches Problem hinweisen, das mir so noch nie begegnet ist.
    Und schreibe auch, was du bisher probiert hast, auch wenn es zu keinem Ergebnis geführt hat, oftmals sind das Infos, die man selbst für gar nicht wichtig hält, aber andere können daran zB typische Muster wiedererkennen.

    Edit:
    siehe auch dein letzter Post: Du stimmst mir hoffentlich zu, dass es noch viel informativer wäre, wenn du den Post verlinken würdest, wenn du von einem "anderen Beitrag" schreibst, und wenn du mitteilst, welche Anpassungen du da an welchen Kexten vorgenommen hast, was du eigentlich erwartet hast, was dadurch passieren sollte und was stattdessen passiert ist (auch wenn es "nichts" ist). Mir zumindest würden solche Infos sehr helfen!

  • traeu danke für deine Hilfe, ich werde mich morgen an diesem versuchen und berichten ob es geklappt hat. Btw. ich hab an meinem Mainboard keinen DVI sondern nur ein HDMI Anschluss möchte aber demnächst ein Apple Cinema Display anschließen, was du was ich da für Möglichkeiten habe? brauche ich dafür eine Grafikkarte oder kann man das auch anders lösen?


    Edit: Ja werde ich machen traeu

  • Warum kann mir keiner helfen wenn er es weiß...

    Das sind leider genau die Sätze, die LuckyOldMan auf die Palme gebracht haben. Auch ich lese aus so einer Formulierung einen versteckten Vorwurf und finde das nicht gut.

    Außerdem stolperst Du nun von einem Problem in das nächste, ohne das erste Problem bearbeitet oder gelöst zu haben - so wirst Du den Faden verlieren und die Helfer auch.

  • Was das Cinema Display angeht kannst Du einen Adapter nutzen (HDMI auf DVI-D) um von Deinem vorhandenen HDMI Onboard Port auf DVI zu adaptieren und im Bezug auf die Bluetooth Funktionalität Deiner Fenvy Kart führt leider wirklich kein Weg an den USBPort Mappings vorbei. Bei den USBPorts kann Dir von extern auch niemand wirklich zur Hand gehen oder eine fertige Lösung präsentieren denn um die zu erstellen muss man vor dem Rechner sitzen und die Ports ermitteln die genutzt werden sollen/dürfen (geht Durch einstecken von USB Medien). Das Hackintool selbst bringt eine gute Anleitung zum Vorgehen mit:

    Dann einfach so vorgehen wie es in der Hilfe vom Tool beschrieben ist (genau so vorgehen wie dort beschrieben ist wichtig und führt sicher zum Erfolg).

  • Das sind leider genau die Sätze, die LuckyOldMan auf die Palme gebracht haben. Auch ich lese aus so einer Formulierung einen versteckten Vorwurf und finde das nicht gut.

    Du triffst es auf den Punkt und zudem zeigt sich da eine Auffassung seitens des TE, die ihn auf lange Frist nicht weiter bringt. Nachhaltigkeit sei hier erwähnt.


    Und um auch mit einer anderen irrigen Sichtweise aufzuräumen: meine Kritik am bisherigen Gesamtablauf des Threads speist sich nicht daraus, "weil einem die Arbeitsweise der anderen nicht gefällt", sondern das ist im Team nach den chaotischen Threadentwicklungen der letzten Monate bzgl. Hilfestellung genau so besprochen worden.

    "Hilfe zur Selbsthilfe" ist der grundsätzliche Kern dieses Mottos und dieses teile ich in vollem Umfang - es handelt sich also nicht um eine Einzelmeinung.


    Nebenbei: ein hereingereichter Link kann sehr wohl zielführend sein, besonders wenn er beim TE etwas anstoßen kann und dieser bereit ist, im Vorfeld reichlich infos zu sammeln und auch seine Helfer - wie schon von einem Vorredner angesprochen - mit Berichten über in Eigeninitiative angefangenen Lösungsversuchen zu versorgen.


    Dieser Thread kann durchaus zu einem Beispiel werden, wie es besser gehen kann, besonders wenn Hilfesuchende auch bereit sind, Eigeninitiative zu zeigen (die sich auch in erfolglosen Versuchen ausdrücken darf) und die Helfer davon absehen, wie ein Büffetier dem Gast die fertigen Speisen auf dessen hereingereichten Teller zu servieren.


    In diesem Sinne ... genug der Manöverkritik. Ich wünsche gutes Gelingen!

    Gruß

    LOM



    Edited 3 times, last by LuckyOldMan ().

  • brauche ich dafür eine Grafikkarte oder kann man das auch anders lösen?

    Ja - man könnte das anders lösen. Schon mal über einen HDMI-DVI-Adapter nachgedacht?

    Gruß

    LOM



  • Die Info die dir hier fehlt ist, dass es nicht reicht den USBInjectAll.kext einfach im Ordner Kext abzulegen. Bei OC musst du jede Kext die geladen werden soll in die config eintragen. In dem Fall würde das in der config so aussehen.



    Den vorhandenen USBport.kext (der übrigens verhindert, dass dein BT läuft, weil dein interner Port damit ausgeschlossen ist) kannst du löschen. Den neu erstellten USBport.kext trägst du in die config so ein wie er momentan drin steht. Vorrübergehend kann du diesen Eintrag bei Enabled auf No stellen, bis du deinen eigenen erstellt hast und solange du USBInjectAll verwendest.


    Da du mit einer vorgefertigten EFI gestartet bist, kann ich dir nur empfehlen dich mit dieser Seite zu beschäftigen, wo du mehr und mehr über die Zusammenhänge deines Booloaders erfahren kannst.

    https://dortania.github.io/OpenCore-Install-Guide/

  • LuckyOldMan dass tut mir leid, dass von diesem „neuen“ Motto leider noch nichts angekommen ist. Denn entsprechend nach außen publiziert wurde es ja auch nicht.


    Aber gut, wir können dieses leidige Thema dann jetzt auch abhaken, ich bin auf die Umerziehungsmaßnahmen mehr als positiv gespannt ☺️

  • was mir hier auffällt ist, dass hier nur EFI-Ordner herumgereicht werden. Dabei hat der TE gefragt, wie er die config.plist konfigurieren kann.
    Dr. Peterchen 11 besorge dir für 4,49€ den PLIST Editor aus dem App Store. Der ist vollkommen ausreichend. Damit kannst Du die Konfigurationsdateien bearbeiten.

  • Danke für eure zahlreiche Hilfe zu dem Bluetooth Problem, ich hab mittlerweile das Problem gefunden und behoben. Einer der USB Ports auf dem Mainboard war gesperrt, da drin steckte der Fenvi drinnen. Hab ihn jetzt in den anderen reingesteckt und jetzt funktioniert er. hackmac004  bluebyte  griven


    Ich hab bereits nach dem HDMI und DVI Adapter gesucht, aber dort findet man nichts brauchbares was zu dem Cinema Display passt welches ich benutzen wollen würde. Ich dachte an diesen Adapter von Amazon, aber da fehlt mir halt der DVI am Mainboard LuckyOldMan

  • DVI ist in dem Fall auch verkehrt ;)


    Du hast am Mainboard einen normalen HDMI Anschluss (Buchse) und am Cinema Display ist ein Mini DisplayPort Stecker vorhanden. Was Du jetzt brauchst ist ein Adapter von HDMI (Stecker) auf Mini DisplayPort (Buchse) um das Display am HDMI Port Deines Mainboards betreiben zu können.

  • aber dort findet man nichts brauchbares was zu dem Cinema Display passt

    Mit Deiner Übersichtsseite stehst Du bereits fast davor: 1SZ4/erste Spalte-vierte Zeile. Das ist der Adapter, den ich im Sinn hatte. Vollständige Kabel 1.8m in der Variante gibt es sicher auch.

    Da bei Adaptern auch die Richtung wichtig ist, in der sie arbeiten (bei Display bzw. mini-Display gibt es da unterschiedliche Versionen), habe ich meinen Adapter mit einem Kabel kombiniert, d.h. Adapter HDMI->DVI->DVI-Kabel zum Monitor und ich habe ein Bild.


    griven

    Meine älteren 24"-Cinema Displays haben DVI-Kabel - es kommt auf das Modell an, was der TE hat. Da wissen wir bislang nichts Genaues. ;)

    Gruß

    LOM



  • Wenn Dein Cinema Display ein 27 Zoll mit Mini DP Kabel ist wird es mit dem klappen, ja.