OpenCore Sammelthread (Hilfe und Diskussion)

  • OC-Gen-X für OC0.6.3 ist da.


    Gruß

    LOM



  • Hallo liebe Leute, ich habe schon lange Probleme mit der UEFI-Shell.

    Beim Drücken von Shift, Alt und Strg flitzt mir der Cursor davon und zieht eine Linie.


    Beispiele hierzu


    FS_________________________:___________________________________0

    map_______________________>____________________________________


    Ist natürlich blöd nach dem Drücken der entsprechenden Tasten immer Delete oder Backspace zu drücken.


    Beim Durchlesen der Doku bin ich auf die Parameter "KeyForgetThreshold" und "KeyMergeThreshold" gestossen.

    Nun meine Frage:

    Sind "KeyForgetThreshold" und "KeyMergeThreshold" gleichbedeutend mit "Repeat Delay" und "Repeat Rate"?


    Vielen Dank für das Lesen und viele Grüße von bluebyte

  • bluebyte

    Ich würde mal sagen ja genau das ist es, laut Dokumentation:

    1. KeyForgetThreshold
      Type: plist integer
      Failsafe: 0
      Description: Remove key unless it was submitted during this timeout in milliseconds.

      AppleKeyMapAggregator protocol is supposed to contain a fixed length buffer of currently pressed keys. However, the majority of the drivers only report key presses as interrupts and pressing and holding the key on the keyboard results in subsequent submissions of this key with some defined time interval. As a result we use a timeout to remove once pressed keys from the buffer once the timeout expires and no new submission of this key happened.

      This option allows to set this timeout based on the platform. The recommended value that works on the majority of the platforms is 5 milliseconds. For reference, holding one key on VMware will repeat it roughly every 2 milliseconds and the same value for APTIO V is 3-4 milliseconds. Thus it is possible to set a slightly lower value on faster platforms and slightly higher value on slower platforms for more responsive input.

      Note: Some platforms may require different values, higher or lower. For example, when detecting key misses in OpenCanopy try increasing this value (e.g. to 10), and when detecting key stall, try decreasing this value. Since every platform is different it may be reasonable to check every value from 1 to 25.

    2. KeyMergeThreshold
      Type: plist integer
      Failsafe: 0
      Description: Assume simultaneous combination for keys submitted within this timeout in milliseconds.

      Similarly to KeyForgetThreshold, this option works around the sequential nature of key submission. To be able to recognise simultaneously pressed keys in the situation when all keys arrive sequentially, we are required to set a timeout within which we assume the keys were pressed together.

      Holding multiple keys results in reports every 2 and 1 milliseconds for VMware and APTIO V respectively. Pressing keys one after the other results in delays of at least 6 and 10 milliseconds for the same platforms. The recommended value for this option is 2 milliseconds, but it may be decreased for faster platforms and increased

    Probier mal die werte:


    KeyForgetThreshold --> 5

    KeyMergeThreshold --> 2

  • ozw00d vielen Dank für deine Rückmeldung. Genau diese Werte stehen bei mir drin.

    Die Bezeichnung Threshold (Schwelle) kenne ich eher von meinen virtuellen Gitarren-Amps bei Noise-Reduction.;)

    Bei meinem Lenovo T520 funktioniert die Shell einwandfrei. Habe die config eben mal verglichen.

    Einziger Unterschied ist, dass beim Lenovo bei "PointerSupportMode" ein leerer Eintrag ist.

    Ist aber unerheblich, da "PointerSupport" auf "False".

    Probiere das trotzdem einmal. Wer weiß, ob da nicht mehr dahinter steckt.

    Keine Änderung. Ein Wechsel auf Tastatur mit Kabel bewirkt auch nichts.

    Werde mal die Openshell.efi vom T520 kopieren.

    Keine Änderung.


    Ich habe mich gestern im Forum umgeschaut und dabei erfahren, dass Maddeen ein ähnliches Problem hatte.

    Er hatte es im "N-D-Fork" beschrieben. Bei ihm war es anscheinend umgekehrt.


    OpenCore Sammelthread (N-D-K Fork)

  • Seit OpenCore 0.6.3, Commit 1b7525c


    Neue Funktion:


    Kernel > Quirks > ForceSecureBootScheme


    "Note: This option is required on virtual machines when using SecureBootModel different from x86legacy."


    Neu seit heute; 0.6.4 (commit 3998399):


    Misc > Security > BlacklistAppleUpdate


    "Ignore boot options trying to update Apple peripheral firmware. This option exists due to some operating systems, namely macOS Big Sur, being incapable of disabling firmware updates with the NVRAM variable"


    Jetzt weiß ich glaub ich auch, warum mein upgrade nicht fehlschlug – weil BS versucht hat ,die firmware meiner wlan karte upzudaten!

  • Ich habe es geschafft. Endlich funktioniert die Shell wie sie soll.

    Endlich ohne "_______________________________________________" :hurra:


    Es war nur ein Eintrag "KeySupportMode" von "Auto" auf "AMI" :wallbash:


    Tastaturbelegung mit den Sonderzeichen stimmt zwar nicht, aber immerhin ein enormer Fortschritt.

  • die UEFI-Shell kennt halt nur die US-Belegung (QWERTY) bei der Tastatur. Am Besten druckt man sich die mal aus um im Bedarfsfall die Sonderzeichen zu finden.

  • Bei mir ist neuerdings die größer/kleiner Taste (><) vertauscht mit der Grad/Accent Circumflex Taste (^°) auf meinem Notebook Keyboard (Lenovo T530).


    Habe kürzlich PSController.Kext upgedatet. Sind da eventuell Mappings für die Tastatur-Tasten drin in dem Keyboard-Kext? Weil unter Tastatur > Eingabequellen habe ich schon Deutsch und Deutsch – Standar ausprobiert, aber da ändert sich nüscht.


    EDIT: Hab's gefunden. Es lag tatsächlich an einet Einstellung in der plist von VoodooPS2Keyboard.kext:


    IOKitPersonalities > ApplePS2Keyboard > Platform Profile > Default > Use ISO layout keyboard: YES (stand auf NO)

  • Versuche OpenCore 0.63

    Bootstick erstellt für OpenCore 0.63, der boot gelingt teilweise mit install MacOS Catalina (external), kommt aber nicht bis zur DiskUtility.

    Wäre über Kommentare erfreut.

  • Hallo zusammen, ich habe hier ein kleines Problem mit OpenCore und dem Asus Z490M- Board.

    Einen „Fahrrad-Kumpel“ habe ich überredet mal sein neues System, zum Hackintosh zu machen, alles kein Problem dachte ich, das schaffst du schon.

    Seine Hardware besteht aus:


    ASUS Prime Z490M-Plus

    I3-10100

    Corsair DDR4-3000

    Samsung SSD 250GB

    iGPU UHD630


    Mit dem erstellten OpenCore-USB-Stick eine vorhandene BIGSUR-SSD 11.0.1 gebootet….. läuft prima…. Alle zufrieden.

    Aber nach einem restart , kommt erst eine Meldung vom BIOS …. Failed…usw, siehe Bild.

    Dann F! Drücken im BIOS die Bootreihefolge ändern…. Dann geht der 2. OC-Boot


    Nach einigem recherchieren, habe ich das ganze mit dem neuesten Clover(5126) probiert…

    Und siehe da, das ganze bootet so wie es sein soll, ohne Fehlermeldung vom BIOS.


    Ich würde gerne OpenCore installieren, aber so ist das nicht praktikabel…..

    Hat einer eine gute Idee ?




    LG

    Gigabyte Z390 Aorus Master
    i9-9900KF-WA-Kü
    16GB DDR4
    SSD-NVMe-Samsung EVO970 500GB
    ATI Sapphire Nitro RX 580 4GB
    OSX HighSierra/Mojave/BigSur
    Boot: OpenCore

    Edited once, last by bananaskin ().

  • RizziCR

    du hast doch so was aufm z390 gehabt , was warn das RTC ?


    KEIN SUPPORT PER PN!

    julian.png

  • Auf meinem Z390 Board hat folgendes geholfen:

    - ProtectUefiServices = true

    - DisableRTCChecksum

    - BootProtect = none (deaktiviert, dass OC ständig einen EFI Boot eintrag ganz oben erstellt - führt bei mir zusätzlich dazu, dass Bluetooth mit meiner Karte auch nach Reboots fehlerfrei funktioniert.


    Laut OpenCore Guide (hier der gut durchsuchbare github Link) braucht man noch die AWAC SSDT für RTC.


    Ich weiß nicht in wie weit sich das in Z490 geändert hat, aber ich würde es mal mit den Quirks probieren.

  • Ja Leute , das war es ..DisableRTCChecksum=yes...:klatschen:

    und somit wieder einen "Hackintosh-Jüngling" gewonnen

    Er testet zwar jetzt in aller Ruhe zu Hause, aber sehr angetan von der ganzen Sache....:thumbup:


    Vielen Dank

    Gigabyte Z390 Aorus Master
    i9-9900KF-WA-Kü
    16GB DDR4
    SSD-NVMe-Samsung EVO970 500GB
    ATI Sapphire Nitro RX 580 4GB
    OSX HighSierra/Mojave/BigSur
    Boot: OpenCore

  • Bei mir hat auf dem Asus Prime Z390 ein RTC Patch geholfen (Screenshot).


    Ansonsten was auf jeden Fall funktioniert, im Bios unter "Boot" die Funktion "Wait for F1 if Error" deaktivieren. Hatte ich zuerst für Monate so und hat einwandfrei funktioniert.


    Grüße

    Leggalucci


    Asus Prime Z390-A 1502 | i5 9600k | 48GB | AMD RX580 4GB | NVMe 500 GB | BCM94360CS2 | macOS 11.1 | OpenCore

  • Seit ein paar Tagen habe ich unmittelbar nach dem Start noch vor dem OC-Picker diese Mitteilung, die ich nicht wirklich zuordnen kann.



    Das trat nach häufigem und ausschließlichem Verwenden von Win10 auf, ohne dass zwischendurch irgendein macOS eingestreut wurde.

    Fehlt da ein Eintrag in OC (dann hätte es aber schon früher auftauchen müssen) oder hat sich an anderer Stelle etwas "eingenistet"?

    Gruß

    LOM



  • Vll hast Du es aber auch bloß vergessen, weil es mit 063 erst dazu kam


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB |250GB SSD |macOS 11.2 .1| *
    iMac20,1 NVISEN Y-MU01 |i7-10510U |16GB |256GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacBookPro14,1 XiaoMi-Pro-15,6" |i5-8250U UHD620 |8GB |250 & 250GB SSD |macOS 10.15.7 (19H524) | *
    MacBookPro16,1 RedMi 14" |i7-10510U | 8GB | 512GB SSD |macOS 11.2.1 & 11.3 b1 | *
    MacMini8,1 HYSTOU P05B |I7-8550U UHD620|16GB |500GB SSD |macOS 10.15.7 (19H524) & 11.2.1 | *
    MacMini8,1HYSTOU S210H |I9-9880H UHD630|32GB |250GB SSD |macOS 11.2.1 & 11.3 b1| *

    | * BootLoader OpenCore REL-067-2021-02-20

  • Vll hast Du es aber auch bloß vergessen

    Worauf beziehst Du das jetzt? Ich habe 063 schon länger im Einsatz, aber dieser Hinweis (was bedeutet das überhaupt?) kommt erst seit ein paar Tagen - davor war nichts zu sehen.

    Gruß

    LOM



  • Dieser Eintrag steht in deiner plist. Einfach rauslöschen da er nun obsolete zu sein scheint.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<