Posts by Sascha_77

    Wie einige schon mitbekommen haben dürften ist seit spät. 14.09. schluss mit dem iTan verfahren bei allen Banken. Per EU verboten.

    Ich gehöre "leider" zu denen die bei der ING-DiBa sind, auf die derzeit ein ziemlicher Shitstorm hereinprasselt. Da ich zu denen gehöre die Transaktionen über eine Finanzsoftware tätigen (in meinem Fall BankX) kann ich jetzt lediglich nur noch Umsätze abrufen aber keine Überweisungen mehr tätigen. Das kann ich jetzt nur noch über eine App machen bzw. im Browser. Und da habe ich keinen Nerv drauf. Ich lasse mir keine App aufzwingen (die einen dann auch noch mit Kreditangeboten zuspamt).


    Einzige Alternative ... Bankwechsel. Ich habe jetzt schon bei allen namhaften Direktbanken auf den Seiten nachgeschaut. Bis auf die ING bieten die wohl alle noch eine angepasste HBCI Schnittstelle auf PSD2. Aber heisst das jetzt autom., dass eine Finanzsoftware auf jeden Fall in beide Richtungen funktioniert? Wirklich anpreisen tut das nämlich keine Bank direkt. Klar, die wollen ja auch ihre Apps unters Volk bringen.


    Wie geht ihr mit der Umstellung um? Seid ihr schon gewechselt? Welches Erfahrungen macht ihr mit Finanzsoftware seit PSD2?

    Habe den Text oben editiert. Die Meldung weist auf Kext Updates hin .... nicht auf Updates des KU selber. Ich werde den Hinweistext aber auch abändern.


    "Neue Kexte sind verfügbar."


    Das sollte Mißverständnissen vorbeugen.

    Wenn Updates verfügbar sind kommt diese Meldung in entsprechend eingestellten Intervallen immer wieder bis die Updates erfolgt sind (nach einem Neustart sowieso). Es geht sich hier im Kext Updates ... nicht der Kext Updater selber! Am besten ich werde eine Funktion einbauen die die Meldung für 24 Stunden ausser gefecht setzt wenn man auf "Schließen" geklickt hat. Praktisch wie bei den Apple Updates wo man auf "Morgen erinnern" klicken kann.


    Man kann die

    Also Unibeast ist keine gute Idee. Gründe dafür, warum das so ist, finden sich im Forum zu hauf. Damit wirst Du hier auch nicht wirklich Support erhalten, da es die Fehlersuche nur unnötig erschwert bzw. auch erst gar nicht möglich macht, da Unibeast im System "rumschmiert" und keiner weiss wo. Daher starte lieber mit einem taufrischen Clover.


    Zu deinem Laptop. Ich hab hier selber ein Thinkpad L412 mit dieser CPU, was als NAS unter Debian dient. Für macOS ist das nichts weil die Grafik nicht unterstützt wird. Ein Bild magst Du vllt. bekommen. Aber keine Beschleunigung. Arbeiten damit quasi nicht möglich.

    An alle OpenCore User ... könnt ihr bitte mal das Ergebnis von diesem Befehl hier posten?

    Code
    1. nvram 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:boot-path

    Aber bitte nur solche Ergebnisse wo das

    Code
    1. nvram: Error getting variable

    nicht drin vorkommt.

    Wer einen Monitor via mDP betreibt und den Audioausgang normal auf Lineout stehen hat wird öfters schon festgestellt haben, dass nach dem Sleep oder Neustart anstatt des Lineouts der mDP als Audiogerät aktiv ist. Das kann man mittels DSDT umgehen indem man das Device totlegt .... oder aber man nutzt einen einfach Terminalcommand.


    Es gibt ein Tool namens "audiodevice". Bsp:

    Code
    1. audiodevice output Internal\ Speakers

    Und schon ist der Ausgang wieder umgestellt. Da das Tool schon alt ist und es nur eine 32 Bit Variante davon gibt (also ab Catalina nicht mehr zu gebrauchen) habe ich hier mal eine 64 Bit Variante compiled.


    Gepaart mit z.b. Sleepwatcher bzw. einem LoginItem kann man jetzt ganz einfach immer den festgelegten Audioausgang schalten ohne in die Prefs gehen oder sonstwo klicken zu müssen.


    Falls gewünscht kann ich einen Wrapper beilegen den man Einfach nur in die LoginItems legen muss.

    Muss mal gucken. Hab irgendwo noch im Keller so ein Experimentierkasten rumliegen. "GAU, aber richtig" oder so ähnlich. Da kann man ein Kernkraftszenario mit nachstellen. Vor etlichen Jahren mal auf ebay.ru geschossen. Habe mich bis heute aber nicht getraut mal reinzuschauen. Der Karton schimmert so komisch und alle Glühbirnen im Umkreis von 20 Metern leuchten von alleine. :/

    Naja .. jeden config sieht anders aus. Du hattest z.b. nvram.plist mit drin die ich nicht habe. Und da ich die config.plist anhand von Ausschlußkriterien definiere kann jedes Wort was unerwartet neu mit drin steht (und schon in anderer Form im Suchstring enthalten ist) den Suchmechanismus "wuschig" machen. Daher ist es auch gut und wichtig, dass ich Feedback von Euch erhalte um genau diese Sachen die ich selber nicht habe im Script zu berücksichtigen. Somit wird der Suchalgorhythmus vereinfacht gesagt von mal zu mal "intelligenter".


    Du kannst ja mal ein bisschen mit den sed/grep-Sachen rumspielen. Dann wird schnell deutlich was ich meine.


    Aus dem:

    Code
    1. ../bin/./BDMESG | grep .plist | grep loaded | sed -e "s/\ loaded.*//g" -e "s/.*\\\//g" |sed 's/.plist.*/.plist/g' |grep -v "nvram" | xargs

    habe ich jetzt

    Code
    1. ../bin/./BDMESG | grep .plist | grep -v "not" | grep loaded | sed -e "s/\ loaded.*//g" -e "s/.*\\\//g" |sed 's/.plist.*/.plist/g' |grep -v "nvram" | xargs

    gemacht. Wie du siehst habe ich das Wort "not" nun exkludiert weil es in deinem Output vorkommt aber nichts mit dem gewünschten Ergebnis zu tun hat.


    Und wenn mir ein Andere User nun einen Output schickt wo bei ihm z.b. "allowed" gepaart mit .plist i einer Zeile vorkommt sähe das dann so aus:


    Code
    1. ../bin/./BDMESG | grep .plist | grep -v "not" | grep -v "allowed" | grep loaded | sed -e "s/\ loaded.*//g" -e "s/.*\\\//g" |sed 's/.plist.*/.plist/g' |grep -v "nvram" | xargs

    Weil letztlich will ich nur diese Zeile hier haben:

    Code
    1. 0:107 0:002 EFI\CLOVER\config.plist loaded: Success

    die ich dann (mit sed) weiter zerlegen und umformen kann. Das xargs am Ende jeder Zeil ist nur dafür da, evtl. vorkommende unnötige Leerzeichen am Anfang so wie am Ende zu eliminieren.

    So sieht das aus, ja. Das dürfte bei einigen anderen Usern dann auch diesen Fehler beheben. Schätze du bist nicht der Einzige mit so einer Konstellation.


    dramesis

    Hm in der Plist ist aber der korrekte Pfad hinterlegt.

    Sorry, da habe ich leider keine Erklärung für. Ich nutze hier ja auch OC und habe den selben Pfad. Bei mir legt er keinen Ordner namens "?" an.

    Danke, Problem gefunden. Das war jetzt echt fies (also nicht von Dir :P ).

    Das:

    config.plist 6:206 0:109 Loading nvram.plist from Vol EFI -


    Sieht im Terminal so aus:

    config.plist

    6:206 0:109 Loading nvram.plist from Vol EFI -


    2 Zeilen. Mein Script ging jetzt von 1 Zeile aus. Daher konnte das nicht klappen. Manchmal steckt die Tücke echt im Detail. :)

    sunraid

    Hää?


    Wenn ich zum Test so mache:

    Code
    1. echo "config.plist 6:206 0:109 Loading nvram.plist from Vol EFI -" |sed 's/.plist\ [0-9].*/.plist/g'

    kommt config.plist raus. Jetzt verstehe ich nur noch Bahnhof.


    Gib mir bitte mal die ganze Ausgabe von BDMESG:


    Code
    1. ../bin/./BDMESG > ~/Desktop/bdmesg.txt