Lenovo x260 benötigt Hilfe im Feinschliff

  • Hallo Hackintoshler,


    seit einigen Wochen können globoxnoob, arigata9 und ich uns glückliche Besitzer von Lenovo ThinkPads x260 nennen.


    Nach anfänglichen Problemen und Dank der EFI von paloema123 im Thread Lenovo ThinkPad X260 so wie den EFI´s von Github von den Usern SuhailSherief und x90skysn3k sind wir nun an dem Punkt das die Notebooks zu 98% Perfekt laufen.

    Jedoch harkt es an Kleinigkeiten.


    Zusätzlich dokumentiere ich alles auch auf Github >>>Klick-Mich<<<


    Die aktuelle EFI Version ist jetzt auch fähig, Monterey und älter zu booten.


    Anbei habe ich euch die aktuelle EFI so wie eine PDF mit allen BIOS Einstellungen und einem Origin ACPI und Video Bios Dump mit hochgeladen.


    Wir würden uns über Mithilfe und Lösungen freuen,


    Mit freundlichen Grüßen

    Globoxnoob, arigata9 und KayKun

    Files

    Mit freundlichen grüssen KayKun

    Edited 10 times, last by KayKun: Update zu einer der Problemen und EFI Update ().

  • Wie am Stammtisch besprochen, hier der ACPI dump vom T570, an dem die Brightness control ohne Probleme funktioniert.

    Files

    • T570 ACPI.zip

      (72.66 kB, downloaded 80 times, last: )

    Supportanfragen gehören ins Forum und nicht in meine Pinnwand/PNs

  • Versuchs mal mit dieser SSDT... Wegen der Helligkeit

    Files

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.9.4 - Win 11 macOS Ventura / macOS Sonoma

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Sonoma

    MacMini 6,1  Late 2012 - macOS Ventura Beta - OC Legacy Patcher 0.6.9

  • Ich hab davon nicht so ganz viel Ahnung, aber hab mal Deine DeviceProperties mit meinen verglichen, wobei es sich bei mir um ein Vorgängermodell handelt (Lenovo Thinkpad T450s).



    Mehr Properties habe ich nicht drin, aber Helligkeitssteuerung geht hier ohne Probleme via Tasten und auch im System, auch ohne Sleep, was ich auf der Kiste ohnehin kaum nutze, obwohl auch dies geht. Der externe MiniDP geht mittels Adapter auf HDMI auch ohne Probleme für externes Display.

    Eigentlich geht hier alles perfekt bis Ventura.

    Mein con0-Framebuffer sieht aber irgendwie bigger aus, welchen Du gar nicht so in der Art hast, sondern nur con1. Du schreibst, internes Display wird als extern erkannt, vielleicht liegt's ja an dem con1, statt con0, wobei es bei mir natürlich ein anderes Gerät ist.


    Naja, wie gesagt, hab davon nicht die größte Ahnung, kann alles Quatsch sein, was ich schrieb, aber vielleicht hilft es ja doch irgendwie.

    Medion P9614: C2D 2,8GHz 8GB DDR3 GT330M 512GB FullHD intern BCM WLAN/BT SSD 512GB + 512GB + 1TB macOS Catalina / Win10pro 8)

    Real: MacMini M1: 8GB 32" LG 4k SSD 250GB + 1TB nvme USB-C + 1TB thunderbolt nvme macOS 14.5

    MacBook Air M2 15": 8GB SSD 512GB macOS 14.5

    MacMini2014: i5 2,8GHz 16GB DDR3 Intel Iris 5100 23" Apple-Cinema 1TB NVMe / 1TB HDD macOS 13.6.6

    iPhoneSE 3.Gen 128GB: iOS 17.4.1 iPad Pro 9,7" WiFi 32GB: iPadOS 16.7.7 MacPro3,1 macOS 13.6.4 / 14.4

  • Cool danke jungs ich werde es Heute abend mal gegen testen =)

    Mit freundlichen grüssen KayKun

  • Hier wird beschrieben, worauf es ankommt:


    https://dortania.github.io/Ope…l-patching/connector.html

    HP Elite X2 G2, 12'', Intel Core i5-7300U, 16 GB RAM, Intel HD Graphics 620, 4 TB SSD, macOS Ventura

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Big Sur

  • So ich abe das ganze mal durchgespielt leider aber keine beserung ich habe euch mal die aktuelle EFI so wie einen IOReg vor und nach den Sleep hochgeladen

    Files

    Mit freundlichen grüssen KayKun

  • Probier mal, mit der angefügten config.plist zu starten (habe die Werte für die Intel HD Graphics 520 aus einem funktionierenden OC-Laptop mit der gleichen Graphik übernommen).

    Files

    • config.plist

      (44.37 kB, downloaded 66 times, last: )

    HP Elite X2 G2, 12'', Intel Core i5-7300U, 16 GB RAM, Intel HD Graphics 620, 4 TB SSD, macOS Ventura

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Big Sur

  • In Deinen ioreg's sind nach Sleep doch einige Änderungen zu sehen bei den Framebuffer@0 bis @2, teils ändert sich die Connector-Type und Anschluss-ID's, etc. pp..


    Ich hab auf GitHub mal eine EFI für Deinen x260 gefunden, wo der Framebuffer-Eintrag eher komplett aussieht, wie bei meinem Beispiel oben von dem Vorgängermodell.

    Kannst ja mal folgenden DeviceProperties versuchen, wenn die config von iPhoneTruth nicht geht:


    Medion P9614: C2D 2,8GHz 8GB DDR3 GT330M 512GB FullHD intern BCM WLAN/BT SSD 512GB + 512GB + 1TB macOS Catalina / Win10pro 8)

    Real: MacMini M1: 8GB 32" LG 4k SSD 250GB + 1TB nvme USB-C + 1TB thunderbolt nvme macOS 14.5

    MacBook Air M2 15": 8GB SSD 512GB macOS 14.5

    MacMini2014: i5 2,8GHz 16GB DDR3 Intel Iris 5100 23" Apple-Cinema 1TB NVMe / 1TB HDD macOS 13.6.6

    iPhoneSE 3.Gen 128GB: iOS 17.4.1 iPad Pro 9,7" WiFi 32GB: iPadOS 16.7.7 MacPro3,1 macOS 13.6.4 / 14.4

  • Hey danke für die Tips ich wahr die letzten Tage nur unterwegs und werd heute mal auf der Langen rückfahrt im ICE das mal wieder alles durch gehen und mal gucken.


    Danke an euch =)

    Mit freundlichen grüssen KayKun

  • Hey Sorry für das verspätete Update aber die letzten tage wahr Desaster Recovery am Server angesagt.


    iPhoneTruth, mit deiner config kommt nichts mehr am Ende


    MacPeet auch hier keine besserung

    Mit freundlichen grüssen KayKun

  • sehr schade


    Hast Du auch mal versucht im Bios CSM auf ein? Bei mir muss es an sein, ansonsten zickt er, aber meiner ist auch eine Generation älter.

    Medion P9614: C2D 2,8GHz 8GB DDR3 GT330M 512GB FullHD intern BCM WLAN/BT SSD 512GB + 512GB + 1TB macOS Catalina / Win10pro 8)

    Real: MacMini M1: 8GB 32" LG 4k SSD 250GB + 1TB nvme USB-C + 1TB thunderbolt nvme macOS 14.5

    MacBook Air M2 15": 8GB SSD 512GB macOS 14.5

    MacMini2014: i5 2,8GHz 16GB DDR3 Intel Iris 5100 23" Apple-Cinema 1TB NVMe / 1TB HDD macOS 13.6.6

    iPhoneSE 3.Gen 128GB: iOS 17.4.1 iPad Pro 9,7" WiFi 32GB: iPadOS 16.7.7 MacPro3,1 macOS 13.6.4 / 14.4

  • Hast Du auch schon mal die verschieden AAPL,ig-platform-ids ausprobiert, die hier angegeben werden:


    https://dortania.github.io/Ope…ake.html#deviceproperties

    HP Elite X2 G2, 12'', Intel Core i5-7300U, 16 GB RAM, Intel HD Graphics 620, 4 TB SSD, macOS Ventura

    ---

    HP Compaq 8300 Elite, Intel Core i5-3470, 4 x 3,20 GHz, 8 GB RAM, Ivy Bridge, Nvidia Geforce GT 710 (Intel HD Graphics 2500), macOS Big Sur

  • MacPeet die CSM Thematik sollte unter Skylake eigentlich nicht mehr exestieren werde es aber nochmal gegen testen


    iPhoneTruth Jup

    Mit freundlichen grüssen KayKun