Lenovo T470s EFI oder bzw. an der Config scheitert es

  • Hallo zusammen,


    ich hoffe hier kann man mir nochmal Input geben, um vielleicht doch noch erfolgreich MacOS auf das T470s zubekommen.


    Ich hab alles irgendwie probiert, hatte sogar aus dem Netz einen EFI Order mit Config die genau auf meine Hardware Konfiguration (T470s, Intel i7 7600U) passen sollte und nur noch das SMBIOS hinzugefügt werden musste.


    Hab es in verschiedenen Varianten probiert, EFI Ordner für T470s aus dem Netz oder EFI Ordner und Config komplett selber bauen.


    Bin nie bis zum Installationsbildschirm gekommen.


    Versuche scheiterten mit "kernel panic applesmc", "in memory panic stackshot succeeded" oder es wurde bis zum Apple Logo gebootet aber die Progress Bar blieb stehen.


    Hier wäre einer meiner leisten Versuche, wo auch beim Sanity Checker die Config einwandfrei aussah.


    Vielleicht hat ja jemand noch eine Idee, wo vielleicht mein Fehler liegt.

    Im Bios ist an sich auch alles so eingestellt wie es sein sollte.


    Danke euch schonmal :)

    Files

    • EFI.7z

      (22.71 MB, downloaded 11 times, last: )

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • :welcome2: im :hackintosh:


    Welches MacOS versuchst du zu installieren ?


    Sollte das wieder nicht klappen auf dem USB Stick sollte eine Text Datei sein log die posten :)

  • :welcome2: im :hackintosh:


    Welches MacOS versuchst du zu installieren ?


    Sollte das wieder nicht klappen auf dem USB Stick sollte eine Text Datei sein log die posten :)

    Danke dir :)

    Hatte es an sich immer mit Big Sur probiert, aber um hier eine Fehlerquelle auszuschießen auch mal Catalina probiert.


    Danke dir für deine Mühe, ich werde es mal damit probieren und dann, wenn es nicht funktioniert, das Logfile mal hochladen :)

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • Mir fällt ein dein Notebook sollte noch kein CFG_Lock haben


    Inder config.plist war es aktiviert Kernel/Quirks/AppleCpuPmCfgLock true/yes sollte aber auf false/no stehen .

    Files

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • Mir fällt ein dein Notebook sollte noch kein CFG_Lock haben


    Inder config.plist war es aktiviert Kernel/Quirks/AppleCpuPmCfgLock true/yes sollte aber auf false/no stehen .

    Danke dir :)


    Hab die Config noch ausgetauscht, aber es kommt am Ende wieder die Fehlermeldung "in memory panic stackshot succeeded".


    Das Logfile hab ich mal unten angefügt.


    Vielleicht noch irgendwie eine Fehlerquelle die möglich ist, ein Problem mit dem Ram? oder das die Festplatte am besten schon im Apple Format formatiert sein sollte?

  • Mal ein neuer Versuch :)

    Files

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • kentallica ,

    hallo und :welcome2:,

    ja da können bioseinstellungen durchaus dazwischenfunken. hast du beispielsweise csm disabled, uefi only, gestellt, desweiteren wirst du vermutlich die prozessoreigene igpu nutzen, dort wirst du ggf, sehen, das dein grafikram z.b. nur 5 mb beträgt- so sieht es aus, wenn das vram in der config.plist noch nicht richtig gesetzt ist, stichwort framebuffer.., aber da ist es das ziel erstmal bis dort hinzukommen.


    lg :)

  • Such mal nach Legacy Boot deaktivieren für UEFI

    Und Fast Boot deaktivieren

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

    Edited once, last by OSX-Einsteiger ().

  • kentallica ,

    hallo und :welcome2:,

    ja da können bioseinstellungen durchaus dazwischenfunken. hast du beispielsweise csm disabled, uefi only, gestellt, desweiteren wirst du vermutlich die prozessoreigene igpu nutzen, dort wirst du ggf, sehen, das dein grafikram z.b. nur 5 mb beträgt- so sieht es aus, wenn das vram in der config.plist noch nicht richtig gesetzt ist, stichwort framebuffer.., aber da ist es das ziel erstmal bis dort hinzukommen.


    lg :)

    Danke dir fürs Feedback :)


    Hab nochmal im Bios Sachen angepasst, hatte das einmal komplett wieder auf Standard zurück gestellt.


    Also es steht jetzt auf Uefi only, CSM Disabled (oder soll CSM auf Enable stehen?)


    Ist auch die interne GPU, wo trage ich das denn in der Config ein mit dem Framebuffer?


    Hab was gelesen von auf 64 MB stellen im Bios, ich kann aber nur 256 MB oder 512 MB auswählen.

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • kentallica

    das mit dem framebuffer bzw. das dann noch nicht das volle vram dasteht wäre noch nicht so wichtig, das kann später kommen, . zu sehen ist das im abschnitt dp in der config/im guide https://dortania.github.io/Ope…ptop.plist/kaby-lake.html


    deine config.plist kannst du hiermit bearbeiten -

    - https://github.com/ic005k/OCAuxiliaryTools/releases


    eigentlich csm-disabled, damit der goptreiber/efitreiber deines systems sowie uefi genutzt wird, daher auch das festplatten-system gpt und nicht mbr


    lg :)


    edit- infos zu deinem tragmich-

    https://thinkwiki.de/T470s

  • Danke dir :)


    Die Config, hab ich auch schon mit dem OCAuxiliaryTool bearbeitet.


    Ich frage mich halt nur, ich hab soweit alles gemacht , bei OC Validate kommt auch "No issues found" raus.


    Wo kann denn da nun der Fehler liegen?


    Sprich für den "in memory panic stackshot succeeded" Fehler muss es doch einen Lösungsansatz geben bzw. der Fehler muss doch irgendwie eingrenzbar sein.


    Hast du irgendwie noch einen Lösungsansatz, wenn jetzt die Config bearbeitet wurde wie in den Open Core Guide und der Fehler kommt dennoch beim Booten vom Stick?


    Ich hab mal den EFI Ordner sowie das letzte Logfile mal angehängt

  • hast du dir die quirks genauer angeguckt und verglichen? - die können auch mal dazwischenfunken


    edit- sowie einen anderen usb-port oder gar usbstick selbst, genommen?


    lg :)

  • hast du dir die quirks genauer angeguckt und verglichen? - die können auch mal dazwischenfunken


    edit- sowie einen anderen usb-port oder gar usbstick selbst, genommen?


    lg :)

    Danke dir :)


    Einen anderen USB Stick sowie andere Ports hab ich schon alles versucht kommt auch aufs Gleiche raus.


    Die Quirks hab ich auch verglichen, da sieht auch soweit alles in Ordnung aus, im Vergleich mit dem Open Core Guide.


    Hast du sonst noch Ideen?


    Sagt der "in memory panic stackshot succeeded" Fehler nix konkretes aus, woran es liegen kann, warum der Stick nicht korrekt bootet?

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • das kann ich dir so nicht beantworten - dazu ist es grade zu warm. ich würde die suchmaschiene deines vertrauens mit den schlagworten + osx86 +hackingtosh füttern und gucken was erscheint


    lg :)

  • kentallica


    Hattest du schon mal ein NvRamRest gemacht findest du im openCore Menü.


    Könntest du ein Foto machen von der Kernel Panik :)

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • Ist im BIOS VT-d an oder aus :?:

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • kentallica

    ich habe mal ausnahmsweise einen netzfund bearbeitet-

    evtl. passt der,- muß aber nicht


    lg :)

    vt-d aus ist richtig- ansonsten wird ein entsprechender quirk gesetzt


    edit-

    ich habe noch dell switches gesetzt, die muß man dann ggf. noch ändern-

    Dell Users:

    For Skylake and newer:

    • Kernel -> Quirk -> CustomSMBIOSGuid -> True
    • PlatformInfo -> UpdateSMBIOSMode -> Custom