macOS 13 VENTURA beta

  • schmalen


    Bei mir war es damals dieser Prozess:

    [01 wake at 04/12/62 01:47:16 by 'com.apple.alarm.user-visible-com.apple.email.SendLaterDelivery' User visible: true


    Der kommt zwar nach einem Sleep/Wake wieder, jedoch dreht dann powerd nicht mehr am Rad, wie zuvor. Kann man mit pmset -g sched checken.

  • Danke

    msart


    Hängt bei dir eventuell auch ein Prozess? Mir mir war es wie bei anderen powerd, den ich mit sudo pmset schedule cancelall gefixt bekommen habe. Lag aber meiner Meinung eher am Ventura Update.

    Hat bei mir auch geholfen ... Allerdings nur wenn ich das iPhone XR was zum laden am Rechner hing, vorher abziehe

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • LetsGo


    danke [dafuer]der war es auch, aber das ich den so schön ins Nirvana schicken kann, wusste ich noch nicht.

    Hatte auch schon mal das der Prozess einfach nach einer weile ruhe gab, und keinen ärger mehr gemacht hat.


    War aber bei Monterey nicht das Problem, da bleibe ich mal beim 082.


    Den unterschied zwischen dem älterem und neuerem 083 bei Ventura muss ich noch mal prüfen....

    Der mds mds_stores mdworker_shared braucht aber unter Ventura immer noch mehr Leistung als unter 12.5 ungefähr doppelt so viel.


    Wenn Monterey Idle ist, geht die CPU auf 2,5W ( mit 082 ) unter Ventura 7Watt. Temps und Lüfter Drehzahl bestätigen das exakt.


    Aber erst seit Beta 5 vorher hatte ich keine Probleme.


    P.S.: ich muss nach jeder Nutzung von Ventura ( selbe Hardware und SN etc. ) in Monterey das Passwort für die Apple ID erneut eingeben. Parallel Nutzung von Beta nicht vorgesehen ?


    Und eben mds mds_stores mdworker mdworker_shared rödelt jetzt nach jedem Wechsel Start.....


    Beta Test wegen zu hohem Energie Bedarf wird jetzt eingestellt ;-)


    Geringfügig würde ich das jetzt nicht nennen bei Doppeltem Leistung Bedarf bei jedem Prozess !! nicht nur im Idle !!!!, natürlich wenn die GraKa schon 150Watt zieht ......


    Evtl. hat Apple ja einen Trick für die 64Core M2 drin weil der im Vergleich zum 48 Core so wenig Leistung Plus liefert ( ca 3% mit Glück wenn ich das korrekt im Gedächtnis habe )


    Allerdings soll das an einem Hardware Design Fehler liegen und der Grund für das einstampfen der ersten Pro Generation gewesen sein......

  • Bei mir trat es auch erst seit Beta 5 auf. Hoffentlich wirds noch gefixt. Aber zumindest wissen wir, wie mans derweil repariert bekommt.


    Den geringfügig höheren Leistungsbedarf habe ich im Idle mit der neuesten OC Version jedoch nicht. Fahre zurzeit aber nur mehr Ventura.


    EDIT:

    Der hängende powerd Prozess ist aber hartnäckig. Gestern ist mein Rechner ein paar mal im Sleep/Wake Cycle gewesen. Der powerd Prozess drehte zwar nicht gleich nach dem Wake durch, aber nach ein paar Stunden kam er wieder. Heute beim Starten wieder das Gleiche. Aber anscheinend haben Mac User ebenfalls das selbe Problem, was man so auf Reddit liest. Könnte mir vorstellen, dass das mit der neuen Send Later Funktion vom Mail Programm zusammenhängt.

    Edited once, last by LetsGo ().

  • Ich musste das gleiche feststellen ... der kleine Workaround hilft nicht lange :(

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Aber zumindest tritt der Fehler nicht nur bei Hackintosh Geräte auf. Somit wird der Bug hoffentlich bald gefixt. Heute war der Rechner wieder oft im Sleep/Wake Cycle und bis aufs Einschalten hatte ich keine Probleme mehr. Wenn der Fehler weiterhin nur alle paar Stunden oder Tage auftritt, kann ich derweil mit dem Workaround leben.

  • Ich hab jetzt mit der Public Beta 3 neben den sleep Problemen auch noch sporadische Resets. Manchmal direkt beim einloggen. Manchmal 1h keinen. Vielleicht installiere ich nochmal neu ohne Migration meines Accounts und der Programme und schaue ob die dann immer noch auftreten.

  • Ich hab's bestimmt überlesen, aber hat es einen Grund warum du die 3er Beta nimmst und nicht die aktuelle?


    Zwecks den Abstürzen/Resets ... Das ist bei mir gar nicht, in noch keiner der Betas gewesen. Nur seit der vorletzten der kaputte Sleep.

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Ich bin im, ich glaube es heisst, Public Beta Seed. Da entspricht die Public Beta 3 wohl der Developer Beta 5.


    Gruss,

    Joerg


    PS: Bis zum letzten Update (PB3/DB5) bei mir auch null Probleme.

  • Trotz 02, klappt es nur beim zweiten mal, wenn er den Fullinstaller 11,5Gb lädt


    Code
    1. # nvram 94b73556-2197-4702-82a8-3e1337dafbfb:AppleSecureBootPolicy
    2. #94b73556-2197-4702-82a8-3e1337dafbfb:AppleSecureBootPolicy %02

    bei mir ist es genauso trotz secure boot 02, klappt es nur beim zweiten mall mit dem fullinstaller.


    was meinst du woran es liegt?

  • Beta 5 hier auch ohne Probleme, diesmal ist auch der erste kleinere Installer durchgelaufen.

    ( SIP on und 02% securebootmodel konfiguriert )

    Hallo, bei mir funktioniert das kleine Update nicht. Nur das große Update beim zweiten Anlauf.


    Ich habe secure Boot auf 02, hast du vielleicht eine Info woran es liegt? SIP ist auch aktiv

  • recep.67


    Keinen Schimmer, es wurde ja vermutet das es am Secure Boot Model liegt, deshalb hatte ich mal explizit erwähnt das das bei mir 02% ist und mein SIP auch an ist.


    Allerdings hatte ich vorher jedes Beta installiert und beim Beta 5 lief dann auch das kleine Update.


    Hattest du vorher auch Beta 1-4 drauf ?


    P.S.: bei mir funktioniert auch Sleep und bis auf den erhöhten Energie Bedarf hatte ich keine Probleme mit Beta 5.

  • Beim installieren der Public Beta 2 hatte ich das gleiche verhalten.

    Bei der Installation der Public Beta 3 = Developer Beta 5 hatte ich nur einen 1,1GB Download.


    Und ich hab secure boot 01


    Gruss,

    Joerg

  • wie genau hast Du diese 02% eingetragen beim ApEICD? msart

    Grüße

    Arkturus

  • Arkturus


    wenn SecureBootModel konfiguriert ist, kann es durch eingabe im Terminal geprüft werden mit:


    nvram 94b73556-2197-4702-82a8-3e1337dafbfb:AppleSecureBootPolicy

    If the variable is found, it can be one of the following:

    • %02 - Full Security Mode
    • %01 - Medium Security Mode
    • %00 - No Security Mode

    Unter SecureBootModel in der OC Plist den dem SmBios entsprechenden Wert eintragen:

    https://dortania.github.io/Ope…what-is-apple-secure-boot


    Den wert zum eintragen in ApEcid ermittelt man mit:

    Code
    1. python3 -c 'import secrets; print(secrets.randbits(64))'


    Beim Neustart wird dann oder du wählst es aus in das Recovery gebootet, dort dann im Terminal ausführen ( HD mit dem Namen deiner HD ersetzen ) :

    • bless --folder "/Volumes/HD/System/Library/CoreServices" --bootefi --personalize


    Dann ist SecureBootModel konfiguriert.


    SecureBootModel is used set the Apple Secure Boot hardware model and policy, allowing us to enable Apple's Secure Boot with any SMBIOS even if the original SMBIOS did not support it(ie. no T2 present on pre-2017 SMBIOS). Enabling SecureBootModel is the equivalent of "Medium Security"

     (opens new window), for Full Security please see ApECID

    Currently the following options for Misc -> Security -> SecureBootModel are supported:

    ValueSMBIOSMinimum macOS Version
    DisabledNo model, Secure Boot will be disabled.N/A
    DefaultCurrently set to x86legacy11.0.1 (20B29)
    j137iMacPro1,1 (December 2017)10.13.2 (17C2111)
    j680MacBookPro15,1 (July 2018)10.13.6 (17G2112)
    j132MacBookPro15,2 (July 2018)10.13.6 (17G2112)
    j174Macmini8,1 (October 2018)10.14 (18A2063)
    j140kMacBookAir8,1 (October 2018)10.14.1 (18B2084)
    j780MacBookPro15,3 (May 2019)10.14.5 (18F132)
    j213MacBookPro15,4 (July 2019)10.14.5 (18F2058)
    j140aMacBookAir8,2 (July 2019)10.14.5 (18F2058)
    j152fMacBookPro16,1 (November 2019)10.15.1 (19B2093)
    j160MacPro7,1 (December 2019)10.15.1 (19B88)
    j230kMacBookAir9,1 (March 2020)10.15.3 (19D2064)
    j214kMacBookPro16,2 (May 2020)10.15.4 (19E2269)
    j223MacBookPro16,3 (May 2020)10.15.4 (19E2265)
    j215MacBookPro16,4 (June 2020)10.15.5 (19F96)
    j185iMac20,1 (August 2020)10.15.6 (19G2005)
    j185fiMac20,2 (August 2020)10.15.6 (19G2005)
    x86legacyNon-T2 Macs in 11.0(Recommended for VMs)11.0.1 (20B29)


    #Special Notes with SecureBootModel

    • The Default value is not recommended as if you plan to use this with ApECID for full security, we recommend setting a proper value (i.e. closest to your SMBIOS or versions of macOS you plan to boot) since the Default value is likely to be updated in the future.
      • In addition, Default is set to x86legacy which will breaking booting High Sierra through Catalina.
      • x86legacy is not required for normal Mac models without T2's, any of the above values are supported.
    • The list of cached drivers may be different, resulting in the need to change the list of Added or Forced kernel drivers.
      • ie. IO80211Family cannot be injected in this case, as it is already present in the kernelcache
    • Unsigned and several signed kernel drivers cannot be used
      • This includes Nvidia's Web Drivers in 10.13
    • System volume alterations on operating systems with sealing, like macOS 11, may result in the operating system being unbootable.
      • If you plan to disable macOS's APFS snapshots, please remember to disable SecureBootModel as well
    • Certain boot errors are more likely to be triggered with Secure Boot enabled that were previously not required
      • Commonly seen with certain APTIO IV systems where they may not require IgnoreInvalidFlexRatio and HashServices initially however Secure Boot does.
    • On older CPUs (ie. before Sandy Bridge) enabling Apple Secure Boot might cause slightly slower loading by up to 1 second
    • Operating systems released before Apple Secure Boot landed (ie. macOS 10.12 or earlier) will still boot until UEFI Secure Boot is enabled. This is so,
      • This is due to Apple Secure Boot assuming they are incompatible and will be handled by the firmware just like Microsoft Windows is
    • Virtual Machines will want to use x86legacy for Secure Boot support
      • Note using any other model will require ForceSecureBootScheme enabled


  • den Abschnitt der Configuration.pdf kenne ich. Securebootmodel kann mit KU oder OCAT bestimmt werden, aber braucht noch eine 64bit Zufallszahl unter ApEICD. Was hast Du dort eingetragen? msart Diesen Wert meinte ich.


    EDIT: Sorry, ich habs gefunden. Erledigt

    Grüße

    Arkturus

  • To generate your own ApECID value, you'll want some form of cryptographically secure random number generator that will output a 64-bit integer. Below we provide an example that can be run if Python 3

     (opens new window)is installed on your machine:

    Code
    1. python3 -c 'import secrets; print(secrets.randbits(64))'

    With this unique 64-bit int, you can now enter it under Misc -> ApECID in your config.plist

    However before setting ApECID, there's a few things we need to note:

    • Fresh installs with ApECID set to a non-zero value will require a network connection at install time for verification
    • SecureBootModel should have a defined value instead of Default to avoid issues if the value were to change in later OpenCore versions.
    • Pre-existing installs will need to personalize the volume, for this you'll need to first reboot into recovery and run the following command(Replace Macintosh HD with your system's volume name):
    Code
    1. # Run this command after setting your ApECID value
    2. # You'll also need an active network connection in recovery to run this command
    3. bless --folder "/Volumes/Macintosh HD/System/Library/CoreServices" --bootefi --personalize

    And something to note when reinstalling macOS 10.15 or older is that you may receive "Unable to

  • Ja, den Python3 Befehl, der hats gemacht. Danke :thumbup:


    EDIT: Die Ermittlung mittels

    Code
    1. python3 -c 'import secrets; print(secrets.randbits(64))'

    hats jetzt gebracht



    Vielen Dank msart

    Grüße

    Arkturus

    Edited 3 times, last by Arkturus ().

  • Sagt einmal, würdet Ihr Euch mit einem Ryzen schon an Ventura Beta3 wagen? Laufen die Pactehs noch/schon? Hab im Thread noch nicht so richtig etwas von der AMD Fraktion gelesen... Mein NUC läuft soweit stabil... aber beim AMD traue ich mich nach dem letzten Debakel vor Monterey nicht so recht. OC und Kexte hab ich auf Stand alle....


    Danke Euch!

  • Ich hatte auch bis jetzt alle dev Betas 1-4 drauf, jedesmal ging das kleine Update nicht.

    In Beta 4 habe ich jetzt den Secure Boot auf 02 eingestellt und dachte das kleine Update auf Beta 5 wird funktionieren, leider nicht. Werde jetzt den Fullinstaller nehmen müssen.


    Was ich allerdings festgestellt habe, bei Beta 1-3 hatte ich eine sehr langsame USB Datenübertragung. Jedesmal wenn ich die EFI auf eine USB Stick kopiert habe, brauchte ich dafür mindestens 15 Minuten. Bei Monterey brauche ich nur 30 Sekunden und ab Ventura Beta 4 geht es auch schneller. Sleep ging bis jetzt bei allen Betas Problemlos.


    Ich mache jetzt das große Update auf Beta 5 und prüfe ob sleep funktioniert.

    Bin mittlerweile auf oc 084, beim Stromverbrauch hatte ich keine Änderung


    Was mich allerdings wundert ist die anzahl der CPU Kerne.

    Habe eine 12600k mit 6 P Cores und 4 E Cores. Im Bios sind alle auf on.

    iStat zeigt mir nur 8 Kerne an, HWMonitor zeigt mir 13 Kerne an