Eigenes Audio Layout erstellen (AppleALC)

  • Hallo Leute,


    Ich suche eine Möglichkeit meine Soundkarte (Onboard Z370M D3H ALC892) mal richtig komplett ans laufen zu bringen.

    Mit AppleALC funktioniert der ALC892 zwar aber die Ausgänge/eingänge sind bei keiner Layout ID so wie ich sie mir vorstelle.


    Da ich hier nen aufwendiges Audio Setup (mehrere einzel angesteuerte Subs) habe benutze ich Audio Hijack um mir meine Raummoden Korrektur zu berechnen.

    Alle anderen Audio Player (TV / Radio usw) gehen dann durch den Hackintosh und werden zusammengemischt.


    Die ALC892 hat laut Datenblatt 5 Stereo DACs + 2 digital SPDIF out und 2 stereo ADCs + 1 SPIDF in die chip intern an die 8 verschiedenen Ausgänge geschalten werden können.

    Mein Mainboard hat insgesamt mit front audio 8 Stereo Anschlüsse klinken Buchsen und einen SPIDF header onboard.

    SPIDF interessiert mich vorerst nicht.

    Die Konstellation sollte also ermöglichen das ich alle DACs und alle ADCs verwenden könnte.

    Bei allen vorhandenen LayoutIDs sind aber nur maximal 3 Ausgänge und 2 Eingänge vorhanden.


    Ich hab schon gegoogelt aber nicht gefunden wie die Layout.xml Dateien erstellt werden.

    Ich würde mir gerne ne eigene Layout.xml erstellen die mir ermöglicht alle 5 Dacs und die 2 ADCs zu benutzen.


    Hat da jemand ne Idee wie ich die Datei generiere?

    Ich hab kein problem damit das Mainboard auszumessen um rauszufinden an welchem ALC892 Port welche Buchse vom Mainboard angeschlossen ist.

    Das sollte aber eigentlich nichtmal nötig sein. Welche Buchse dann am ende wie im OS heißt ist mir egal.


    Die Datei würde ich dann natürlich irgendwo zur verfügung stellen damit andere mit de Board die Arbeit nicht mehr machen müssen.

    Vielen dank, liebe grüße.

  • Hallo Leute


    es gibt fortschritt:

    Ich habe mit der aktuellen version vom PinConfigurator rumgespielt und rausgefunden das keine von den mit Clover gedumpten Codec Dateien funktioniert.


    Verfahren war folgendes:

    Im Clover Bootloader F8 drücken um Codec zu Dumpen.

    Produzierte Datei in PinConfigurator einlesen.

    Verbs sanitize anklicken.

    AppleALC.kext patchen.

    mit gepatchter AppleALC.kext booten.


    Beim rumspielen ist mir aber aufgefallen das Layout ID 15 fast perfekt funktioniert. Alle Ausgänge sind da, nur leider ist Speaker intern im switchmode mit dem Kopfhöhrerausgang konfiguriert (selbiges bei Mic intern hinten + Frontpanel Buchse Mic)

    Also hab ich probiert den Switchmode aus den Daten von der 15er Layout ID zu entfernen, bin aber kläglich gescheitert.


    ALC1220 hat z.b. ID28 für manualmode und ID29 für switchmode, scheinbar ist diese Modeeinstellung aber nicht in den verbs gespeichert, denn beide layout IDs sind laut PinConfigurator exakt gleich?!?


    Kann mir jemand ne kleine Hilfe geben wie ich das mache?

    MacPeet vielleicht? Er scheint super viel Ahnung auf dem gebiet zu haben.


    Ich hab mal meinen Dump angehängt.


    Vielen Dank!

  • Soweit ich weiss unterstützt AppleHDA nur 8 Geräte, da bei Layout 15 schon 8 integriert sind müssen (falls benötigt) zusätzliche Geräte ersetzt werden.

    Da der Codec nur 2 ADCs hat müssen 2 Eingänge im Switchmode arbeiten. Den Kopfhörer kannst du aber im manuellen Modus betreiben. Bin selber kein Fan von diesem AutoSwitchmode, benutze eine App dafür.

    Die Pinconfig kannst du belassen wie sie ist. Ändere nur die Platforms15.xml, Pin 20 und 27 sollten wie 21-23 aussehen.

  • Hallo,


    Da ich 5 DACs und 2 ADCs haben sind das 7 Geräte total, das passt super mit den 8 Anschlüssen und Mic auf switchmode.



    Danke für die info.

    In der Plattform Datei ists also drin AHA!

    Nur leider gibts die in der AppleALC nicht?!?

    Da die Datei im Github liegt heißt das also ich muss das mit Xcode neu kompilieren?


    So richtig unterschiedlich sieht das bei 20/27 und 21/23 aber nicht aus?
    Die Struktur ist gleich, nur die NodeIDs unterscheiden sich, 12 u. 13 fürs eine 38 u. 37 fürs andere.

    Müssten die gleich sein?

    Meinem beschränktem Verständnis nach sind doch die Nodes quasi die Mixer im chip damit der passende DAC am gewünschtem Anschluss rauskommt oder?

    Das würde aber heißen ich kann die IDs nicht gleich setzen, dann müsste das signal ja durch die gleichen Mixer durchgehen?

    Überseh ich da was?


    Was Laut Block Diagramm vom codec auch gehen müsste:

    z.b. Mic Port 18 und Port 19 in hardware summieren und dann auf ADC 09h zu geben gleichzeitig aber Port 1B auf ADC 08h zu geben.

    Das konfiguriert man über die nodes?


    Was ich auch nicht verstehe:

    In den Platform.xml ist immer "CommonPeripheralDSP" erwähnt.

    Beutetet das da sind irgendwelche Hardware DSPs aktiv und machen irgendwelche Klangveränderungen?

    Unter Windows gibts ja z.b. Equi und Komische "Badezimmer" / "Höhle" Filter, ich dachte immer diese leben im Windows Treiber bzw der Software.

    Im Blockdiagramm sind auch nur "Digital Filter" erwähnt, das ist aber so wie es aussieht nur Signalrekonstruktion / LP für out und HP für in.


    Die Macbooks verwenden mit Sicherheit DSPs um den klang der internen Lautsprecher zu verbiegen, wie ist das geregelt?

    Wenn ich mir z.b. den Schaltplan vom A1297 anschaue (5 Lautsprecher)

    Da sind direkt Verstärker hinter den Codec Ausgängen, wo wird da das Processing gemacht?

    Übernimmt das OSX mit AU plugins oder ist da was im codec?

    Das Datenblatt vom Codec hab ich natürlich nicht gefunden.

    Edited 3 times, last by e4535030 ().

    • Helpful

    8 Gerate insgesamt, also jeden Pin auch wenn im switch modus konfiguriert.

    Die NodeIDs musst du nicht ändern, können aber geändert werden. Anbei die kompilierte ALC und xml mit getrenntem Kopfhöreranschluss.

    CommonPeripheralDSP ist für Micro und Apple Earbuds, funktionieren aber nur mir dem MikeyDriver. DSP ist auch möglich, da kann mann mit den Gleitkommazahlen experimentieren.

    Bei den MacBooks wird alles über DSP gesteuert.

  • Hallo,


    Danke für die Arbeit!

    Ich bin aber grad ein wenig verwirrt.

    Ich hab die Platform15.xml und die Platform15.xml von GitHub (AppleALC) durch nen text checker geschickt und der findet keine unterschiede außer 2 Leerzeilen Zeile 223?

    AppleALC teste ich jetzt mal.

    Öh Also die AppleALC funktioniert perfekt!

    Kann das sein das du die falsche Platform Datei hochgeladen hast?


    Schön wäre noch wenn du kurz erklären könntest wie du es gemacht hast, damit ich bei neuem AppleALC release nicht um Hilfe bitten muss und auch andere aus diesem thread lernen können.


    Perfekt vielen dank!

    Edited once, last by e4535030 ().

  • e4535030


    Deine Dump-Datei lässt sich nicht komplett wandeln und zeigt Fehler. Damit kann ich nix anfangen.

    Womit und wie ist die gemacht? Unter Linux?

    Ist aber im Prinzip auch egal, denn wern hat Dir wohl schon einen ManualMode-Kext gebastelt.


    Ich frage mich allerdings, was gegen den SwitchMode spricht. Hierbei muss man nichts mehr tun, wenn man von hinten grün (die Boxen) auf vorn grün (Kopfhörer) wechselt.

    Im ManualMode muss man dafür jedesmal ins Menü.

    Dem hinteren grünen LineOut-Anschluss ist es dabei völlig egal, ob er als LineOut oder interne Speaker konfiguriert ist, er funktioniert so oder so.

    Ich denke, Dich stört, dass der externe Anschluss als intern angezeigt wird und Du denkst, dass es falsch ist, oder? Sei ehrlich!

    Es ist aber nicht falsch, es macht genau so Sinn.


    In beiden Konfigurationen (SwitchMode/ManualMode) lassen sich alle LineOut's hinten mittels MidiSetup mit einem "gemeinsamen Gerät" zu einer 5.1 Konfiguration verbinden, falls man 5.1 Boxen betreiben möchte.


    Bei den Inputs ist es oft etwas schwieriger. Es gibt drei Ausgänge (hinten pink Mic, vorn pink Mic und hinten LineIn blau), allerdings oft nur zwei Ausgangs-Knoten.

    Somit müssen sich die beiden Mic's einen Knoten teilen.

    Einige Rechner haben sogar drei Ausgangsknoten, was ich an Hand Deines defekten Dump's so nicht sehen kann.


    Treiber, wie unter Windows ("Badezimmer" / "Höhle / Konzertsaal, etc.") gibt´s hier nicht. Du kannst zufrieden sein, dass Dein Audio unter macOS so gut läuft mit einem Hackintosh.


    Ferner kannst Du keine fertige kompilierte AppleALC.kext ändern. Hier kannst Du zwar die PinConfigs einsehen, aber ändern kannst Du hier nix.


    Du musst schon auf GitHub den aktuellen SourceCode laden (entpackt ist dat dann der Ordner "AppleALC-master").

    In diesen Ordner kopierst Du noch die neuste Lilu.kext, ansonsten kannst Du mit xcode nicht neu kompilieren, da AppleALC ein Plugin von Lilu ist.


    So, der einzige Unterordner, der Dich für Änderungen interessiert, ist der Ordner "Resources".


    Die dortigen Dateien (.plist/.xml) kannst Du nicht mit einem normalen Text-Editor bearbeiten.

    Ich empfehle die PlistEditPro.app dafür.


    In AppleALC-master⁩/Resources⁩/ liegt PinConfigs.kext dort rechte Maustaste "Paketinhalt zeigen" und zur info.plist navigieren.

    In dieser Datei liegen alle PinConfigs aller Codecs der AppleALC. Hier kannst Du einen bearbeiten, ggf. einen neuen Codec durch weiteren Eintrag erweitern.


    In Deinem Fall ist der nächste Ordner der "Resources/ALC892".

    Dort liegt die jeweilige layout??.xml und die dazugehörige Platforms??.xml, die Du ändern kannst.


    Wenn Du einen ganz neuen Codec hinzufügen willst, mit einer freien ID, dann musst Du die auch in der info.plist im Ordner "ALC892" erweitern.



    Hier z.B. siehst Du, die ID's 15, 16, 17, 18 sind alle von mir, allerdings alle nicht ursprünglich für einen Z370.

    Willst Du nun einen neuen Codec im ManualMode hinzufügen, z.B. ID 14 wäre noch frei, dann musst Du die neuen Dateien auch hier eintragen/hinzufügen in der info.plist unter Files/Layouts und Files/Platforms.

    Die entsprechenden z.B. layout14.xml und Platforms14.xml natürlich auch in dem Ordner "ALC892" ablegen. Nur mal so als Beispiel.


    Dann mit Xcode neu kompilieren und hoffen, dass alles läuft, wie gewünscht.

    Alle Änderungen die Du für Dich am SourceCode machst, werden im nächsten Release nicht auftauchen.

    Du musst den neuen Codec also verbreiten, mittels PullRequest oder jedes Mal den dann aktuellen SourceCode patchen.

    Wenn Du es einmal drauf hast, dann ist die letztere Option kein großer Akt mehr.

    Medion P9614: C2D T9600  2,80GHz  8GB DDR3  GT330M 512MB  23,6" intern  SSD 2x250GB: 10.14.6 / 10.15.7

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.0 DP10

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  GT710 2GB/ HD5770 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.14.6 / 10.15.7 / 11.0 DP10

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7  iPhone6s Plus 32GB: iOS 14.1  iPad Pro 9,7" WiFi 32GB: iPadOS 14.1

  • TLDR: Ich brauche die 5 Output Channel wie die Ports heißen ist vollkommen egal, Aber ich bin immer noch nicht viel schlauer :(

    Quote

    Ich frage mich allerdings, was gegen den SwitchMode spricht. Hierbei muss man nichts mehr tun, wenn man von hinten grün (die Boxen) auf vorn grün (Kopfhörer) wechselt.

    Im ManualMode muss man dafür jedesmal ins Menü.

    Dem hinteren grünen LineOut-Anschluss ist es dabei völlig egal, ob er als LineOut oder interne Speaker konfiguriert ist, er funktioniert so oder so.

    Ich denke, Dich stört, dass der externe Anschluss als intern angezeigt wird und Du denkst, dass es falsch ist, oder? Sei ehrlich!

    Es ist aber nicht falsch, es macht genau so Sinn

    Nein, Das ergibt schon sinn.

    Das "Problem" ist das ich kein herkömmliches 5.1 Setup benutze.

    Ich hab hier 4 Stereo Verstärker und betreibe damit im Prinzip nen 4.4 Setup.

    4 Subwoofer zur Raummoden Kompensation + Beamforming, dafür muss jeder Sub extra angesteuert werden.

    Jeder übernimmt einen anderen Frequenzbereich mit anderen delays. Das ergibt dann sozusagen Beamforming wie man es von Wlan kennt.

    Sinn und zweck davon ist es entweder die Nachbarn nicht zu stänkern = Bass mit gradem Frequenzgang fast nur am Sitzplatz, restlicher Raum weit weniger Pegel.

    Alternativ könnte man das Setup auch so einrichten das der Bass im Raum gleichmäßiger verteilt ist.

    Ich glaub das kennt ja jeder, in einer Ecke dröhnt es und an anderen Stellen vom Raum passiert nix.


    Um die Phasen / Frequenzgangs / Pegel Kompensation zu erreichen muss man allerlei Audio filter benutzen.

    Die Audiofilter laufen bei mir in Audio Hijack.

    OSX sieht ein normales Stereo Lautsprecher Pärchen, gibt das Signal über z.b. Soundflower oder Loopback an Audio Hijack.

    Selbiges berechnet dann die nötigen Änderungen und gibt das Signal auf die Ausgänge.

    Dafür brauch ich mindestens 8 einzelne Channel.

    Andere Geräte z.b. TV laufen dann an den Line in und werden so über Audio Hijack auch mit den filtern berechnet und anschließend ausgegeben.


    Man kann das natürlich auch für Surround machen, dann brauch man noch mehr Ausgänge dafür habe ich in späterer Heimkino Ausbaustufe USB Soundkarten vorgesehen.


    Das Problem:

    Ab und zu höre ich mit Kopfhörern und benutze dafür den Front output. Wenn der jetzt im Switchmode läuft fehlt mir hinten plötzlich nen Ausgang.

    Das bedeutet das die anderen Geräte die grade über den Line In rein kommen, unter anderem über den grünen Rear Ausgänge ausgegeben werden sollten, auf den Kopfhörern landen. Zusätzlich schaltet der Codec dabei den Amp vom grünen Rear Port ab. Der Anschluss ist dann Tristate und produziert brummen.

    Quote

    Treiber, wie unter Windows ("Badezimmer" / "Höhle / Konzertsaal, etc.") gibt´s hier nicht. Du kannst zufrieden sein, dass Dein Audio unter macOS so gut läuft mit einem Hackintosh.

    Die Sound Optionen möchte ich auch garnicht benutzen. Die Frage ist gewesen ob diese in Software oder im Codec berechnet werden. Wenn diese im Codec berechnet werden würde das ermöglichen manche Filter nicht mehr auf der CPU zu berechnen und damit Ressourcen zu sparen.

    Das würde z.b. ermöglichen das ich 2 Line in Eingänge im Codec Summiere, das sollte der Codec laut Blockdiagram können und würde die CPU entlasten.

    Naja zu <10.6.x Zeiten lief das auch immer wunderbar, das Setup gibts bei mir schon ne weile. Irgendwann wurde der MacMini aber zu klein und ich bin bei erscheinen auf Hackintosh mit Sandy Bridge Intel umgestiegen. Damit Lief das auch schon hervorragend (Gigabyte Board)

    Seit 10.15.x hab ich Probleme mit Audio Crashes die vorher nie da waren. (Siehe anderer Thread)


    Quote

    Erklärung zum Kompilieren der AppleALC

    Danke, soweit ist das jetzt klar, ich werde dann mal nen Pull Request machen wenn ich selber Kompiliert habe.

    Die Frage die mir bleibt:

    Wie extrahiere ich die Knoten? Wieso sind beide Platform15.xml Gleich aber haben unterschiedliche "Wirkung".

    Wie ich vom Dump zur PlatformXX.xml komme ist quasi das was mir fehlt.


    Quote

    Deine Dump-Datei lässt sich nicht komplett wandeln und zeigt Fehler. Damit kann ich nix anfangen.

    Womit und wie ist die gemacht? Unter Linux?

    Ich habe da einen Fehler gemacht, die Datei war nicht der Dump sondern das File vom Pin Configurator.

    Ich hab hier nochmal den richtigen Dump Angehängt.

    Erstellt wurde der mit Clover (F8 Taste im Bootloader)

    Files

    • Dump.zip

      (14.75 kB, downloaded 32 times, last: )

    Edited once, last by e4535030 ().

  • Hier mal optisch der Unterschied.


    alt: nach PathMap

    0 = 2x Line-In, switch Mode

    1 = 1x Line-In

    2 = 2x Line-Out + HP switch Mode


    neu:

    0 = 2x Line-In, switch Mode

    1 = 1x Line-In

    2 = 1x Line-Out

    3 = 1x HP

    Vielleicht hilft dies weiter. Benutze ein Plist Editor.


    Zum Auto Switch Mode.

    Ich benutze meistens Kopfhörer, da hat mich der Stecker vorne am Gehäuse immer gestört. Mein Mainboard hat hinten auch einen Kopfhöreranschluss da steckt auch immer der Kopfhörer drin. Immer aufstehen um die Lautsprecher zu benutzen ist nicht gerade komfortabel, deswegen kein AutoSwitchMode.

  • Vielen dank wern

    Die Datei in .plist geändert und mit xCode geöffnet zeigt es eindeutig.

    Keine Ahnung wieso mein Text Compare keine unterschiede gefunden hat. Da sind sie auf jeden fall!


    Bleibt nur noch, Wie kommt man vom Dump zur platformXX.xml?

  • Ich benutze dafür keine Tools vielleicht mal den Apple Taschenrechner um die hex. Werte nach decimal umzurechnen.


    Kleines Beispiel:

    Erster Pin (Suchfunktion)


    Node 0x14 [Pin Complex] wcaps 0x0040058D: Stereo Amp-Out

    Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=00, mute=1

    Amp-Out vals: [0x80 0x80]

    Pincap 0x0001003E: IN OUT HP EAPD Trigger Detect

    EAPD 0x2: EAPD

    Pin Default 0x01014010: [Jack] Line Out at Ext Rear

    Conn = 1/8, Color = Green

    DefAssociation = 0x1, Sequence = 0x0

    Pin-ctls: 0x20: IN

    Connection: 1

    0x0C



    Node 0x0C [Audio Mixer] wcaps 0x0020010B: Stereo Amp-In

    Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=00, mute=1

    Amp-In vals: [0x00 0x00] [0x80 0x80]

    Connection: 2

    0x02 0x0B


    Node 0x02 [Audio Output] wcaps 0x0000041D: Stereo Amp-Out

    Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=03, mute=0

    Amp-Out vals: [0x40 0x40]


    Pin: 0x14 (20)

    Mixer: 0xc (12)

    DAC 0x2 (2)


    Natürlich gibt es noch Feintuning, zB. AMPs usw.

    Die Codec Werte stimmen oft nicht. Der Treiber korrigiert das aber in der Regel. Hier zB. Pin Control "0x20 IN" ist falsch. Sollte "0x40 OUT" sein.

  • Die Unterschiede zwischen den beiden Platform-Dateien hat wern Dir ja schon aufgezeigt.

    Sofern der Kext von ihm für ManaualMode funktioniert, brauchst Du an der Platforms eigentlich gar nicht mehr fummeln.

    Für Deine Multi-Channel-Config musst Du ja nur noch die Outputs verbinden, mittels macOS/Dienstprogramme/Audio-Midi-Setup mittels unten + Zeichen (Gerät mit mehreren Ausgängen erstellen).

    Hier kannst Du auch die Pegel für jeden Anschluss einstellen.


    hier als Beispiel die ID 15, welche Du ja aktuell verwendest. Hier 20, 21, 22 und 23 verbinden, z.B..



    Fraglich nur, ob Du damit auf 5 Outputs kommst, die auch dat entsprechende machen. Jeder Anschluss hat ja eigentlich eine Funktion (Front, Center, etc.).


    Eines muss Dir dabei klar sein, die verwendete LayoutID 15 habe ich ursprünglich für einen MSI-Rechner entwickelt.

    Bis jetzt ist noch immer unklar, wie viele farbliche Ausgänge Dein Rechner tatsächlich hat für Multi-Channel.


    Weder der erste Dump vom PinConfigurator2, noch der letzte Dump von Clover F8 sind für mich zu gebrauchen.

    Diese Dumps zeigen ohnehin nur, was aktuell konfiguriert ist und nicht, was der Rechner tatsächlich kann.


    Ein echter Codec_Dump wird gemacht, in dem man mit einer Linux-Live-Version (z.B. Ubuntu) bootet, welcher einen ALSA-Audio-Treiber hat.

    Dort gibt man im Terminal folgenden Befehl ein und erhält den codec_dump:

    Code
    1. cd ~/Desktop && mkdir CodecDump && for c in /proc/asound/card*/codec#*; do f="${c/\/*card/card}"; cat "$c" > CodecDump/${f//\//-}.txt; done && zip -r CodecDump.zip CodecDump


    Anders als wern nutze ich sehr gern ein paar Tools dafür, z.B. jage ich jeden Linux-Dump erst einmal durch das Tool codecgraph und erhalte einige weitere nützliche Dateien mit Infos.


    Ich habe zufällig noch den codec_dump vom MSI B150M MORTAR hier, für den ich ebenfalls alc892 ID17 SwitchMode und ID18 ManualMode konfiguriert habe.

    nur als Beispiel:



    Mit einem echten Dump bekommst Du auch diese Infos. Vergleiche es mal selbst mit Deinen geposteten Dump's!


    Ferner hat man dann auch eine .svg - Datei, welche stark verkleinert dann so aussieht:



    Mit all diesen Dateien bekommt man auch ziemlich gut die entsprechenden Knotenketten für alle Anschlüsse.


    Natürlich braucht ein erfahrener User wie wern kein Tool für die Hex-Umrechnung, ich auch nicht, allerdings ist dies eine ganz andere Geschichte.

    Fakt ist aber, dass wir ohne echten Dump und entsprechende Hardwareangaben der tatsächlichen Ausgänge für Multi-Channel Deines Rechners eigentlich rein gar nichts sagen können.


    Es gibt Rechner, die haben hinten 3 Anschlüsse für Multi, einige haben 4, neuere sogar 5.

    Einige nutzen (zumindest unter Windows mittels echtem Treiber) teilweise die Frontanschlüsse oder sogar die Input-Anschlüsse für eine Multi-Channel-Config.

    Letzteres mit den Inputs könnte unter OSX schwierig werden.


    Was ich eigentlich damit sagen will, wenn Du eine LayoutID verwendest, die nicht explizit für Deinen Rechner gepatcht wurde, dann mag es für Stereo sicher reichen und vielleicht auch im gewissen Rahmen für Mehrfachanschlüsse, jedoch es muss und kann nicht immer perfekt sein.


    Ich habe oben echt nicht alles verstanden. Dein 4.4 Setup hebt die Sache evtl. unter macOS auf ein schweren Level.

    Ich kann leider nicht sagen, ob dat alles so möglich ist mit macOS, wie Du es oben beschrieben hast.

    Medion P9614: C2D T9600  2,80GHz  8GB DDR3  GT330M 512MB  23,6" intern  SSD 2x250GB: 10.14.6 / 10.15.7

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB: 10.15.7 / 11.0 DP10

    Real: MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  GT710 2GB/ HD5770 1GB  30" Apple-Cinema  SSD 2x250GB + 480GB: 10.14.6 / 10.15.7 / 11.0 DP10

    MacMini3,1: C2D P7550  2,26GHz  8GB DDR3  GF9400M 256MB  23" Apple-Cinema  SSD 500GB: 10.15.7  iPhone6s Plus 32GB: iOS 14.1  iPad Pro 9,7" WiFi 32GB: iPadOS 14.1

  • Danke für die Erklärung.

    Jetzt versteht es auch ein DAU wie ich!


    Soweit Funktioniert auch alles.

    Der Codec hat 5 Dacs und ich kann alle 5 unabhängig voneinander benutzen. Perfekt!

  • e4535030

    Added the Label Erledigt
  • Community Bot

    Set the Label from Erledigt to In Arbeit
  • Hallo.


    Ich hänge mich hier mal dran, denn ich habe ein, zwei Fragen:


    Wenn ich den Thread richtig verstanden habe, kann ich Kopplung des Front-Audio-Ausgang bei mit dem Line-Out am Mainboard ausschalten und dadurch den Line-Out auch benutzen, wenn am Frontausgang ein Gerät angeschlossen ist? Hintergrund: Ich habe einen kleinen Lautsprecher am Frontausgang dran, möchte ggf. (manuell) auf den Line-Out mit angeschlossener Anlage umschalten können.


    Kann man den "Kopfhörer"-Ausgang (bei eingestecktem Lautsprecher am Front-Ausgang heißt der so) umbenennen (in "integrierter Lautsprecher", oder so)?


    Danke.

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Video: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.6.1)
    Operation Systems: macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.6.0)
    Operation Systems: macOS "Mojave" 10.14.6, Windows 10 Professional


  • Hey,


    Soweit ich das gesehen habe ist die Namensgebung nur von der Pin Config abhängig.

    Die kannst du auswechseln ohne die AppleALC neu zu kompilieren.

    Dazu einfach mit dem PinConfigurator die AppleALC öffnen, deinen Codec+Layout ID wählen.

    Dann kannst du im Fenster die Anschlüsse sehen und umbenennen.


    Wenn du beide Ausgänge händisch umschalten willst dann musst du die PlatformXX.xml modifizieren und die ALC neu Kompilieren.

  • e4535030 , danke. Okay, dann versuche ich erst einmal das Umbenennen. Ich habe jetzt mal die Einstellungen für den Front-Ausgang angepasst:


    Ich hoffe, das paßt so. Dann habe ich die PinConfigs.kext aus dem AppleALC-Repo von Github geladen und die Änderungen da drin gespeichert. Die Kernelextension habe ich im OpenCore eingetragen, aber es wird immer noch Kopfhörer als Bezeichnung angezeigt. :/

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Video: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.6.1)
    Operation Systems: macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.6.0)
    Operation Systems: macOS "Mojave" 10.14.6, Windows 10 Professional


  • Ich hab das folgendermaßen gemacht:


    AppleALC aus GitHub geladen Link

    PinConfigurator aus GitHub geladen Link

    AppleALC auf desktop entpackt.

    PinConfigurator gestartet.

    File -> Import -> PinConfigs.kext -> Fenster zur Datei Auswahl öffnet sich -> AppleALC vom Dektop angeklickt.

    Jetzt Zeigt dir der PinConfigurator die PinConfigs der AppleALC an.

    Dort suchst du deinen Codec und wählst dann die Layout ID die du aktuell verwendest.

    Dann kannst du das genauso wie dein Screenshot ist ändern.

    Fertig.

    Nur noch den PinConfigurator schließen und die AppleALC vom desktop mit der die du verwendest ersetzen.

    Bei OpenCore weiß Ichs nicht, bei Clover kommt sie ins EFI.


    Die PinConfigs.kext brauchst du dafür nicht.


    Welchen Codec verwendest du den? Dann würde ich für dich die Manual AppleALC kext Kompilieren, so als Übung.

  • e4535030,
    das ist der Realtek ALC892 und Layout-Id 1.

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Video: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.6.1)
    Operation Systems: macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.6.0)
    Operation Systems: macOS "Mojave" 10.14.6, Windows 10 Professional


  • Hallo,


    Also Ich hab jetzt den HP out in Speaker Internal geändert und manuelles umschalten Hinzugefügt.

    Wenn ich alles richtig gemacht habe sollte das hier funktionieren:



    EDIT:

    Mir ist grad aufgefallen das das Eventuell verwirrend sein könnte. Mit der ersten Kext hast du 2x Speaker, Ich hab das aktualisiert, der Hintere Anschluss ist nun nen "Line Out" und der Front Audio Anschluss ist nun "Speaker intern", Manuell umschaltbar.

  • e4535030

    Set the Label from In Arbeit to Erledigt
  • e4535030 funktioniert fast. :-) das Umbenennen hat geklappt, aber Ton höre ich nur, wenn ich auf "Line Out" schalte, dafür aber auf beiden Anschlüssen (vorn und hinten) gleichzeitig. Wähle ich "interne Lautsprecher", bleiben beide stumm. :-(

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Video: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.6.1)
    Operation Systems: macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i7-3770 (Ivy-Bridge)
    Mainboard: ASUS P8H77-M PRO
    Video: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.6.0)
    Operation Systems: macOS "Mojave" 10.14.6, Windows 10 Professional