Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

  • JimSalabim hast du eigentlich absichtlich csr-active-config auf 77000000 (also SIP disabled) configuriert?

    Ich hab jetzt bei mir 00000000 eingetragen (SIP enabled) und bisher keine negativen Folgen bemerkt!

  • ... Ich hab auch SIP 0x0, und sogar KALSR aktiv, also kein slide Argument. Heisst alle Sicherheitsmaßnahmen die Apple verwendet. Funktioniert bis jetzt super.

    Ist aber möglich, dass es nicht auf jedem mobo gelingt, das und das zu verwenden.


    MSR Lock -> Früher hat man behauptet, dass mit dem MSR Lock NVRAM nicht nativ funktionieren kann, irgendwie stimmt das nicht, weil in meinem Fall MSR Lock aktiv ist und ich trotzdem NVRAM nativ habe. Oder Probleme mit irgendeinem PowerManagement-patch verursacht. Oder sogar Installation verhindert, so erinnere ich mich.

    Ich denke langsam, dem macOS ist das Wurst, und dem Windows auch. He he

  • SabineT Ich hab csr-active-config nur deshalb auf 77000000 (also SIP disabled), weil es vorkommen kann, dass andernfalls eine direkte Bearbeitung der config.plist auf der EFI-Partition aus Schreibschutzgründen nicht möglich ist. Kann man ja ausprobieren. Wenn das bei einem zutrifft und man die SIP trotzdem aktiv lassen will, kann man sich die Datei auch einfach auf den Schreibtisch ziehen, dort bearbeiten und dann wieder auf die EFI-Partition schieben, das ist auch kein Problem.


    Altemirabelle Ich hatte es auch ohne slide-Argument probiert, kann ohne allerdings nicht immer zuverlässig booten, deshalb ich es hier drin gelassen.


    Ja, genau, wie man sieht, ist es nicht notwendig, den MSR Unlock zu machen. Das mit dem nativen NVRAM funktioniert auch so. Wenn man den Unlock macht, spart man sich halt wie gesagt die Aktivierung von „AppleCpuPmCfgLock“ und „AppleXcpmCfgLock“ in der config.plist. Mehr weiß ich zu dem Thema leider nicht :-)

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • @JimSalabim

    mach es einfach, wenn das Vorteile in OC hat. Ich hab im Netz Berichte gelesen von Leuten die das gemacht haben, und keine Probleme festgestellt haben.

    Interessant ist was passiert, wenn du die „AppleCpuPmCfgLock“ und „AppleXcpmCfgLock“ deaktivierst mit aktivem MSR Lock. ^^

  • Altemirabelle Ja, hab ich gerade probiert. Da ist große Freude vorprogrammiert. :-) Besonders wenn man den Rechner unterm Schreibtisch stehen hat und man immer erst runter krabbeln muss, um den Ein-/Aus-Schalter zu bemühen :-D

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • JimSalabim

    Installiert und funktioniert wie Wein. Du bist wirklich ein Genie.

    Danke

  • Hi,


    erstmal, JimSalabim, danke. Eine Community lebt von Leuten wie Dir die voll reinbuttern, und davon gibt es hier außerordentlich viele. Also neben einem speziellen Danke an Dich ein generelles Danke an das Forum :-D


    Jetzt wünschte ich mir nur noch ZEIT um mich in OpenCore einzulesen und das auch für mein System umsetzen zu können.


    Leider weiß ich nicht genug über OC Bescheid um zu wissen was ich anpassen müsste (außer der USB Map) für das Gigabyte z390 Gaming X.


    Trotzdem: Top Job, und VG

    system1: iMacPro1,1; Gigabyte z390 Gaming X rev1, Intel Core i7-9700K, GSkill Ripjaws V, Sapphire RX 5700 XT Nitro+


    mein immer aktuelles EFI

  • PS.: Ich denke nur "0" nach der Adresse kann zu wenig sein.

    Nee, es reicht schon mit nur "0", das funktioniert.


    maybeageek Hast du nen einwandfrei funktionierenden Clover-Ordner mit ner korrekten USB-Map usw.? Wenn ja, kannst du mir den auch schicken, dann kann ich dir die nötigen Sachen bei Gelegenheit auch schnell in nen OpenCore-Ordner auf Basis von meinem reinbauen. Dann kannst du mal schauen, ob es geht. Dürfte aber nicht viel dagegen sprechen. Den Rest (wobei das dann eigentlich nur noch die Boot-Einträge im Menü bzw. Dual-Boot-mit Windows betreffen sollte) kannst du dann auch nach der Anleitung im ersten Post machen.

    Ich bräuchte dafür allerdings auch noch deine DSDT.aml, damit ich die SSDT-PLUG, die SSDT-EC und die SSDT-HPET erstellen kann. Da weiß ich nämlich nicht genau, ob meine bei deinem System genauso gehen. Dafür drückst du im Clover-Boot-Menü die Taste F4, dann liegen nach dem Start die ganzen ACPI-Tables im Ordner EFI/CLOVER/ACPI/origin/.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • JimSalabim Ich habe einen soweit einwandfrei funktionierenden Clover Ordner. USB Map habe ich noch keine gemacht, steht schon länger auf meiner Liste, aber ich kam bisher nicht dazu... Sobald ich das gemacht habe, melde ich mich hier bei Dir.


    Vielen Dank auf jeden Fall für das Angebot!

    system1: iMacPro1,1; Gigabyte z390 Gaming X rev1, Intel Core i7-9700K, GSkill Ripjaws V, Sapphire RX 5700 XT Nitro+


    mein immer aktuelles EFI

  • Altemirabelle Ich merke ehrlich gesagt null Unterschied zwischen deaktiviertem MSR-Lock und aktiviertem MSR-Lock (mit den zwei oben genannten Optionen in OpenCore dann natürlich). ;-)

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Melde mich in diesem Thread hier auch noch mal.

    JimSalabim Ich bin Dir unendlich dankbar für diese beiden Threads und das daraus resultierende Ergebnis. So ist es für Anfänger wirklich einfach mit diesem Board ein gutes System ans Laufen zu bekommen.

    Hatte mit Clover einige Zeit rumgespielt. Bei Nichtgebrauch des Rechners für eine gewisse Zeit ist dieser regelmäßig eingefroren. Woran das jetzt genau lag, keine Ahnung. Ggf. ja auch an der RX5700XT?!


    Da ich eh nochmal einen Clean Install machen wollte, habe ich es jetzt hier mal mit Open Core versucht und hat auch ziemlich gut funktioniert. Habe auch alles nochmal von Beginn an gemacht.

    2 Dinge funktionierten aber leider nicht:

    Wenn ich den Eintrag ShowPicker auf disabled setze komme ich weder mit "W" zu Windows noch mit "Alt" zum OC Menü. Beide Tasten beim BIOS Bild verwendet, mehrfach gedrückt und auch mal gehalten.

    Habe das jetzt entsprechend wieder enabled.


    Anderes Problem: Bin leider Spielkind und habe noch die anderen Dinge aus dem Thread umgesetzt. Sprich diesen MSR Unlock gemäß Post #17 und AppleCpuPmCfgLock sowie AppleXcpmCfgLock deaktiviert.

    Weiterhin csr-active-config mal auf 00000000 gesetzt.

    Hätte ich mir besser geschenkt. Jetzt habe ich dasa Problem, dass das OC Menü garnicht mehr erscheint und mich direkt zu MacOS bringt. Windows lässt sich nur noch zum Booten bewegen, wenn ich es im BIOS umstelle.


    Vielleicht irgendeine Idee, was ich da angerichtet habe und wie ich es beseitigen kann?


    :wallbash:Das mit dem OC Bootmenü konnte ich selbst beheben. Irgendwie hatte er in der config.plist doch Dinge nicht gespeichert. Also bitte ignorieren.



    Grüße

    Ich weiß, dass ich nichts weiß ...

    Edited once, last by scubamojo ().

  • JimSalabim für was sind die den da?


    SSDT-PLUG, die SSDT-EC und die SSDT-HPET


    das müsste ich dann auch noch machen bzw. überprüfen.

  • JimSalabim

    Größten Respekt und danke für dein Engagement!

    Kaum bin ich für paar Tage nicht im Forum und du haust hier noch den passenden OC-Bootloader für das Designare-Board raus. :thumbup:

    Jetzt muss ich wohl beide Themen im Auge behalten (Clover und OC), damit ich den Anschluß nicht verliere.

  • Das mit dem OC Bootmenü konnte ich selbst beheben. Irgendwie hatte er in der config.plist doch Dinge nicht gespeichert. Also bitte ignorieren.

    Aber das mit der Alt-Taste und der W-Taste funktioniert bei dir nach wie vor nicht? Ich bilde mir ein, in einem von den allgemeinen OpenCore-Threads schon mal was von dem Problem gelesen zu haben. Das mit der W-Taste für Windows oder der X-Taste für macOS funktioniert auf jeden Fall nur mit dem N-D-K-Fork, nicht mit der normalen OpenCore-Version.


    Ich lade in Kürze jedenfalls eh nochmal nen aktualisierten Ordner hoch. Ich versuche unter anderem gerade noch hinzukriegen, dass sich Windows auch unter macOS erfolgreich als Startvolume auswählen lässt. Außerdem haben die Entwickler im N-D-K-Fork zwischendurch ebenfalls noch ein paar Sachen optimiert (die HideAuxiliary-Option geht jetzt beispielsweise wie sie soll, so dass man jetzt wahrscheinlich auch mit ScanPolicy auf 0 arbeiten kann, ohne dass es unübersichtlich wird, aber das muss ich noch ausprobieren).


    Squallsnext Die SSDT-PLUG entspricht der Option PluginType=1 in Clover und sorgt für korrektes CPU-Power-Management.

    Zur SSDT-EC hab ich folgende Info (besser kann ichs auch nicht erklären):

    "Hides the Embedded controller and creates a fake one for macOS, needed for all Catalina users and recommeneded for other versions of macOS"

    SSDT-HPET:

    "Patches out IRQ Conflicts"

    (ob man die wirklich braucht, weiß ich ehrlich gesagt gar nicht, aber ich hab sie mir halt mal generieren lassen und eingesetzt).

    Alle drei Dateien kann man sich mit SSDTTime erstellen lassen. Dafür braucht man die DSDT.aml. Wie man die bekommt, steht weiter oben.

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Danke für die Info JimSalabim,


    ich habe mir diese gerade generieren lassen und die sind identisch mit deiner.

    Das mit dem Startvolume funktioniert bei mir auch nicht.

    Im bios boot screen alt zu drücken funktioniert auch nicht mehr. Es hat mal funktioniert vielleicht hat es auch ein ganz beschissenes Timing. Da muss ich mal weiter testen.

  • scubamojo und Squallsnext Ist bei euch auch ganz sicher im Bios in den Boot Option Priorities die Platte, die die OpenCore-EFI-Partition enthält, an erster Stelle? Hat sich da nichts verschoben?

    HACKINTOSH für Musik- und Videoproduktion

    EFI-Ordner für mein System:

    Gigabyte Z390 DESIGNARE: OpenCore-EFI-Ordner und Anleitung

    Gigabyte Z390 DESIGNARE: fertiger Clover-EFI-Ordner zum Download

  • Jopp ist an erster Stelle.

    Ist nur ein kleines Fenster in dem ich alt drücken kann. Muss drauf rumhämmern dann funktioniert es ab und an.