OpenCore Bootloader


  • ... ... ...

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Da kann das Testen ja weiter gehen, ohne das ich die vielen USB-Sticks durcheinander bringe ;)


    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Hat jemand bereits die default boot-options Funktionalität getestet?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Die ist aktuell noch sehr eingeschränkt und wird bei den meisten Setups nicht funktionieren. Vielleicht fix' ich morgen den Bug, der verhindert, dass der OC-Shim in der Bootreihenfolge übersprungen wird, dann sollte es funktionieren, insofern die FW nicht die entsprechende Bootoption löscht. Nutzt man den Shim nicht oder ist er nicht der Standard, sollte es schon funktionieren, zumindest für macOS

  • Zumindest im Log sollte sich jedoch bereits die Funktionsweise erkennen lassen, oder? Sprich, die richtige default Boot Option/bootnext wird bereits erkannt...

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Sagt jemanden die angehängte Fehlermeldung was? Die kommt bei mir beim Herunterfahren des Laptops.

    Das kommt eindeutig von I2C ohne diese Kexte kommt die KP samt Verhalten nicht und es ist wie am Desktop. Habe gerade mal ohne probiert.

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Danke an Ukr55 von applelife sind nun mehr SMBios Daten enthalten. Habe es mal damit neu gebaut.

    Zum Testen config.plist, Driver etc von Github Acidanthera nehmen, da ist viel neu oder geändert.


    Dateien aktuell hier OpenCore UEFI Bootloader

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

    Edited once, last by NoirOSX: Dateien aktualisiert ().

  • Danke NoirOSX , werde ich Morgenabend testen.

    Grüße und Good Hack Michael


    :hackintosh:

  • Zum Testen config.plist, Driver etc von Github Acidanthera nehmen, da ist viel neu oder geändert.

    Funktioniert bei mir so nicht.
    Habe mal eben das macbuild.tool machen lassen und komme auf ein anderes Ergebnis.
    In meinem Fall habe ich BOOTx64.efi und OpenCore.efi (203 KB statt 221 KB) einfach ersetzt, in der congig.plist unter Plattforminfo musste ich nichts ändern, danach erfolgt der Start wie gewohnt auf den Schreibtisch.



    Hier sollte m.M.n jeder OC Anwender sehr behutsam vorgehen, viel Dokumentation bedeutet nicht gleich Garant auf Erfolg, es mangelt derzeit an Anleitung und oder Unterstützung wann welcher Eintrag in der config angepasst werden muss.


    Edit: Generic Daten wurden entfernt, bitte mit Clover Configurator auffüllen.


    Gruß

    Files

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • + Generic Auto auf iMac18,3

    Danke Vit!

  • Anbei mein EFI für mein Asus Prime X299-Deluxe. Habe nur im "Generic" die MLB/ROM/SystemSerialNumber/SystemUUID entfernt, läuft als iMac Pro. Ansonsten alles wie mit Clover. Derzeit noch im Verbose-Mode, aber mit nativer Monitorauflösung von meinem alten "Apple Cinema HD Display" (16:10), 1920x1200. Also kein grober Text mehr wie in der ersten Variante.

    Files

    • EFI.zip

      (1.53 MB, downloaded 64 times, last: )

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Hallo NoirOSX ,

    du hast wie immer Recht, ohne den I2C Kext fährt das Zenbook sauber runter.

    Somit kann ich berichten, das Zenbook lüuft mit OC ohne irgendein Problem wenn man den I2C Kext nicht nutzt.


    :):thumbup:8)

    Grüße und Good Hack Michael


    :hackintosh:

  • Nun müssen wir den irgendwie biegen, will mein Touchpad wieder anonymous writer  :D

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Moin! Ich habe es noch immer nicht geschafft meine Vega zur mitarbeit zu bewegen. Bin das Brett vorm Kopf noch nicht los geworden.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.

  • Bei mir läuft nun OpenCore v0.2 , im Anhang mal die benötigten bzw die aktuellen Daten zum testen


    Dazu noch der OpenCore Changelog vom Release https://github.com/acidanthera/OpenCorePkg/releases der Version


    v0.0.1


    Initial developer preview release


    WARNING: This release is a developer preview, i.e. it targets experienced engineers and developers. Configuration and feature set are under works, i.e. refinements are expected to happen with 1.0.0 release.




    Files

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Für die schnelle zum bearbeiten der Plist, einfach aus dem Terminal gestartet.


    Cross platform GUI plist editor written in python https://github.com/corpnewt/ProperTree von CorpNewt



    iMac17,1 GA-Z170N WiFi F22f |i5-6600 IntelHD530 |RX 560 |16GB |250GB SSD |macOS 10.14.5 |Clover r4925 & OpenCore v0.2

    MacBook9,1 XiaoMi 12" |m3-6Y30 IntelHD515 |4GB |128 & 250 GB SSD |macOS 10.14.5 |10.14.6 DB |Clover r4934 & OpenCore v0.2

    MacBookPro14,2 XiaoMi Pro 15,6"(mod Bios)|i5-8250U IntelUHD620 |8GB |250 & 250GB SSD |macOS 10.14.5 |Clover r4934 & OpenCore v0.2
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U IntelHD520 |8GB |128 SSD 1TB HDD |Win10 - macOS 10.14.5 |Clover r49234 & OpenCore v0.2

    MacMini8,1 HYSTOU P05B|I7 8550U IntelUHD620|16GB |500GB SSD |macOS 10.14.6 PB | OpenCore v0.2


    IN ARBEIT

    I7-8709G & OpenCore Release OpenCorePkg.svg?style=flat-square&label=OpenCorePkg.svg?style=flat-square&color=informational&label=

  • Hier läuft jetzt auch OpenCore v0.2 wobei ich nur OpenCore.efi ersetzt habe, der Unterschied betrug bei mir nur 2 KB, der Rest (ist) von der ESP/EFI ist damit gleich geblieben.

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Wobei auch immer interessant ist, wie sich die config.plist ändert, also welche Funktionen dazu kommen.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Wie steht es denn um die NVRam-Geschichte bei Clover gab es ja den EMUVariable.....64.efi glaube der wird es bei OC wohl eher nicht bringen nehme ich mal ganz stark an. Siehe Neustarten Herunterfahren ohne Reset-Taste.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.