Mac Pro 2018 - Oder meine ersten Gehversuche mit einem Hackintosh

  • Hallo Zusammen,


    nachdem ich hier unglaublich viel Hilfe bekommen habe, und vermutlich auch noch brauchen werde, ist mein System an einem Standpunkt angekommen an dem ich fast zufrieden bin. Vielen Dank!!
    Daher möchte ich die Kiste euch einmal in aller Förmlichkeit vorstellen.


    Den aktuellen EFI Ordner habe ich angehängt. Er ist sehr groß inzwischen, ich weiß nicht was ich tun kann dass er kleiner wird? Den Microsoft Ordner habe ich rausgeschmissen damit es hochlandbar ist.


    So das ist er:



    Aus Dieser Ansammlung von Teilen...


    ...wurde diese Kiste


    Was ist verbaut:


    In einem Fractal Design Define R6 Gehäuse werkeln:

    • ASRock Fatal1ty Z370 Extreme Gaming i7
    • Intel Core i7 8700K 6x 3.70GHz So.1151
    • 32GB (2X16GB) G.Skill Riplaws V DDR4-3200 DIMM CL-16-18-18-38
    • 8GB Sapphire Radeon RX Vega 64 Nitro+ Aktiv PCIe 3.0 x16 (Full Retail)
    • ASROCK Thunderbolt 3 AIC Schnittstelle Karte Retail
    • 500GB Samsung 970 Evo M.2 2280 PCIe 3.0
    • 1000GB Samsung 860 Evo 2.5"
    • 250GB SSD die ich noch rumfliegen hatte
    • Custom Wasserkühlung mit

      • Pumpe: Enermax Pumpe NEOChanger 300ml,
      • CPU Kühler EK Water Blocks Supremacy EVO Acetal / Nickel CPU Kühler
      • 2x Alphacool NexXxoS ST30 Full Copper 240mm Radiator
      • Kleinkram wie Schläuche und Winkel
    • 750 Watt Corsair RMx Series RM750x weiß Modular 80+ Gold
    • ABWB 802,11 AC WI-FI + Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS Combo Karte für Hackintosh (Mac OS X) Flughafen Computer
    • 32" LG 32UD99 4K Monitor (Kompromiss aus Fotobearbeitung und Zocken)
    • Logitech C920 Webcam



    Was Funktioniert:

    • Mac OS 10.13.6 (Hoffentlich morgen 10.14)
    • Er ist sauschnell!
    • Windows 10 auf der 250 GB SSD
    • Soundkarte intern.
    • Thunderbolt
    • Dual Display (32" 4K und 27" WQHD), beide über Displayport
    • Hardware Encoding
    • Alle USB Ports inkl. der USB C.
    • 1 GBit Netzwerkkarte
    • 10 GBit Netzwerkkarte wird erkannt (nicht getestet mangels Netzwerk)
    • FaceTime audio und Video
    • iMessage
    • iCloud / iTunes
    • Hand Off
    • AirDrop
    • Entsperren mit Apple Watch
    • Ändern der Bildschirmhelligkeit mit Tastatur


    Was funktioniert noch nicht (so gut)

    • Größtes Problem ist ein nicht zu ortendes Spannungs-Geräusch, vermutlich verursacht vom Mainboard. Das Geräusch ist abhängig von Grafiklast. Je mehr FPS (Vermutung) desto lauter. Es ist am Mainboard zu hören und leider auch auf in meinen Aktivlautsprechern.


      Störende Geräusche in Lautsprechern, dauerhaft.


      Momentan Workaround: Eine Kabeltrommel für die Lautsprecher. Es ist viel leiser, aber weiterhin hörbar.

    • Final Cut bricht H264 Exporte mit dem Fehler-12912 ab. Pro Res und H265 funktionieren.


      FinalCut Pro X Experten – warum entsteht der Fehler -12912 bei iMac 18.3

    • Ruhezustand. Sobald der Rechner in den Ruhezustand gebracht wird, schläft er ein und wacht sofort wieder auf. Bin ratlos, hab aber noch kein Thread dazu aufgemacht. Workaround: In den Systemeinstellungen habe ich "Wenn Display aus Ruhezustand nicht aktivieren eingeschaltet. So schläft er nicht ganz ein (um wieder aufzuwachen), das Display wird aber trotzdem dunkel.
    • Grafikkarten Lüfter. Die drei Lüfter der Vega 64 sind zwar seit dem VegaTab_64.kext sehr viel leiser, sind aber immer noch hörbar und damit nicht abgeschaltet ohne Last. Unter Windows geht das, daher weiss ich dass die Karte es kann.


      Gigabyte Vega 64 Lüfterproblem

    • Time Machine Backup auf NAS. Es schlägt immer fehl. Nicht so schlimm, ich nutze CCC. S.U.
    • Die RAM Module, die, laut Kauf, 3200er sein sollen, bekomme ich im BIOS nur auf Max 3000 eingestellt. Sonst startet er nicht. Da bin ich aber glaube ich einfach noch zu unerfahren was da der wirkliche Unterschied ist.

    Overclocking


    Auch wenn es neu für mich ist, habe ich mich ans Übertackten gewagt. Mit solch einer Kühlung geht das ja, dachte ich. Und ja richtig! Es geht, und wie! Ohne den Prozessor zu enthaupten läuft er seit einigen Tagen stabil auf 5 GHz! Ich bin begeistert!





    Benchmarks

    Zu jedem dieser Geräte gehören ja harte Zahlen. Das sind die die ich gemessen habe:


    Geekbench:


    Cinebench:


    Bruce FCPX Test


    Diskspeed M2 und SATA SSD


    Meine Lösung zu Backup


    Dadurch dass ich die Volumen getrennt habe, sichere ich über zwei getrennte CCC Sicherungen:


    Eine Routine führe ich immer aus, bevor ich etwas ändere. Hierbei Monte ich beide EFI Partitionen und übertrage den aktuellen EFI Ordner auf die EFI Partition der externen Festplatte. Anschließend lasse ich CCC Die Macintosh HD (mein M2 Startvolumen) klonen. Nach dem Klonen mache ich bisher einen Teststart der externen Platte.


    Die Zweite Routine ist eine automatisierte. Jede Nacht wird einmal meine Daten SSD (SATA) auf mein NAS gesichert.


    Bilder vom Aufbau









    Bios Einstellungen








    Planung für die Zukunft

    • Der Monitor kommt noch an den Tisch mit einem VESA Mount. Dann gibts auch ein Bild vom Schreibtisch.
    • Wenn die neue Prozessorgeneration draussen ist, spiele ich mit dem Gedanken.. Naja mal sehen.
    • Da mir möglichst leise richtig ist, überlege ich, die Grafikkarte auch noch unter Wasser zu setzen.

    Files

    • EFI.zip

      (21.46 MB, downloaded 34 times, last: )

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor

    Edited 2 times, last by zw3ist3in ().

  • Vielen dank für deinen großartigen Beitrag. :hurra:
    :feuerwerk::hackintosh:

  • Jupp... ist wirklich hübsch geworden... :thumbsup:

    Gruß
    Al6042


    Asus Prime Z390-A 0903 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.4 | Clover 4920

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 | NVMe 250 GB | BCM94352Z | macOS 10.14.4 | Clover 4920

    NUC7i5BNK 0076 | i5 7260U | 16GB | HD540 | NVMe 500 GB | macOS 10.14.4 | Clover 4920

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.4


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!


    al6042.png

  • Echt ein tolles System :D

    Mein System :
    Mainboard : Gigabyte Z390 M (Bios Version aktuell)
    CPU : Intel Core i3 8100 Coffeelake
    RAM : Crucial 8GB DDR4
    Grafik : MSI Radeon RX580 8GB
    Betriebsystem : Windows 10 und Mac OS Mojave 10.14.1 im Dualboot
  • Schicke Kiste!
    Zu deinem Sleep Problem: Auch hier ist wieder die WLAN / Bluetooth Karte schuld. Du musst den USB Port an dem sie hängt als intern markieren und schon läuft der Sleep. USBInjectAll

    LG Chris


    Meine Hardware:

  • Hammer System, aber ich Persönlich präferiere ja hardtubes

    MFG

  • Ganz schön nett! :D

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • USBInjectAll[/url]

    Da muss ich mich mal reindenken. Dank dir!


    EDIT: Irgendwie verstehe ich das Teilzitat nicht.. es bezog sich auf @CMMChris s Beitrag.

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor

    Edited once, last by zw3ist3in ().

  • Quote

    Was funktioniert noch nicht (so gut)Größtes Problem ist ein nicht zu ortendes Spannungs-Geräusch, vermutlich verursacht vom Mainboard. Das Geräusch ist abhängig von Grafiklast. Je mehr FPS (Vermutung) desto lauter. Es ist am Mainboard zu hören und leider auch auf in meinen Aktivlautsprechern.


    Genau das habe ich auch. Ist halt Spulenfiepen. Denke mal die Graka/Mainboard. Ist ja normal, umso mehr FPS/Speed durch schießt, umso lauter wird es.


    Lg

  • Ergänzung:


    Ich habe gerade zu Mojave upgegradet. Funktioniert bisher gut!


    Außerdem habe ich es mithilfe von NativeDisplayBrightness hinbekommen, mein LG 4K Monitor mit der Tastatur heller und dunkler zu machen.


    EDIT:
    Working on heavy duty :)

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor

    Edited once, last by zw3ist3in ().

  • Kleines Update:


    Inzwischen hängt der Monitor.



    • Als Tastatur habe ich für Mac und Windows mich für Logitech Craft entschieden. Teuer aber gut.
    • Die lauten Lüfter der Vega sind Vergangenheit. Ich habe mit viel Hilfe und dem kleinen Tool "Vega Control Table Generator" eine Kext erzeugt. Ich hänge sie an.
    • Das Finalcut Pro X Problem habe ich mit sehr viel Hilfe lösen können. Es hing zusammen mit dem Problem seit Mojave, dass Vorschau keine Bilder mehr zeigte. Lösung war der Wechsel auf iMac 18.3 und die Aktivierung der iGPU, dass QuickSync funktioniert. Hier der lange Lösungsweg :) Danke an alle Helfer!
    • Im Zuge des Lösungsprozesses habe ich das Kext Setup umgestellt. Jetzt Werkelt virtualVNC und Whatevergreen konnte ich verbannen. Ich hänge den neuen Clover Ordner noch mal dran.
    • 10.14.1 : Das Update lief ohne Probleme. Ich musste nur feststellen, dass USB 3 Geräte erst nach Änderung des Patches funktionierten.

    Files

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor

    Edited 2 times, last by zw3ist3in: Neuer Clover Ordner mit neuem USB Patch für 10.14.1 ().

  • Yamaha HS8? Schöne Lautsprecher..

    Gruß CrusadeGT


    iMac 14.2

    GigaByte GA-B85M-D3H|Intel i7 4790K|16GB DDR3 1333Mhz|Sapphire RX580 Pulse 8GB|120 GB Sandisk SSD Plus

    MacBook Pro 7.1

    Lenovo Thinkpad T61 |T9500 2,6Ghz|2GB Ram|nVidia Quadro NVS140m|120 GB Sandisk SSD Plus



  • Du schreibst, daß Thunderbolt geht - was hast du denn dran angeschlossen? Monitor oder Datenträger?

  • CrusadeGT fast, es sind die älteren HS 80. Ich liebe sie aber immer noch. Auch wenn sie viel zu nah an der Wand stehen. Geht leider nicht anders.

    wuestling mometan ist nichts angeschlossen. Hatte es unter 10.6.5 mit Display und über Adapter mit einem FireWire Interface probiert. lief.

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor
  • Ein paar Worte zu der Entwicklung meines Projekts:


    Mainboard:

    Ich hatte zwischenzeitlich ein anderes Mainboard verbaut. Dieses ASUS Prime Z390 A habe ich jedoch inzwischen wieder gegen das ursprüngliche ASROCK Z370 Fatal1ty Professional Gaming i7 getauscht und damit die Erkenntnis gewonnen, dass mein nicht zu ergründender "Fehler" der in den Aktivlautsprechern hörbaren Grafiklast, mit dem anderen Board genauso auftrat. Also bin ich ratloser als zuvor, über die Ursache.


    Grafikkarte:

    Nachdem ich nach langer Wartezeit den für meine Vega passenden Kühlblock aus China bekam und, trotz chinesischer Anleitung, diesen erfolgreich verbaut habe, ist meine Vega Ungetüm etwas schlanker, und komplett still.







    Kühlkreislauf:

    Im Zuge der Wasserkühlung der Grafikkarte und der defekten Pumpe (Lagerschaden) musste ich den Loop ja eh entleeren und habe es neu Zusammengesteckt / organisiert. Inkl. leichterem Wasserablass mit Hahn zur Unterbrechung des Kreislaufes.



    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor
  • Coole Kiste, schade das Du am Samstag zum Stammtisch nicht kommen kannst. Würde gerne ein ähnliches Projekt in Angriff nehmen wollen.

    ASUS Z97-Pro Gamer / i7-4770 / AMD Radeon RX580 /2x8GB RAM Kingston KHX1866 /Wifi / NVMe 256GB


    iMac27 / iMac12,2 / i7 3,4 GHz / 16GB RAM / AMD Radeon HD6970M 2GB / 265GB SSD / 2GB HDD

  • Danke, Berlin ist etwas weit, außerdem muss ich arbeiten Samstag. ich helfe gerne hier, so gut ich kann.

    Hardware:

    • Mac Pro 2018: (iMac Pro 1.1 | ASRock Fatal1ty Z370 | i7 8700K OC: 5GHz | 32GB RAM | Sapphire Vega 64 | TB | Wasserkühlung | leise)
    • Apple MacBook Pro 13" 2015: (i5 2,7 GHz, 8GB RAM | 500GB M2 | Ichweissnichtobmandasgrafikkartenennt)
    • LG 32UD99 UHD Monitor
  • Toller Beitrag und sehr schöner Hacki. Sowas lese ich gerne bei einem Kaffee :)