Für RX 580 auf High Sierra upgraden?

  • Hi Community,


    ich bin günstig an eine Sapphire Nitro 580+ Special Edition gekommen und bin aktuell mit Sierra 10.12.6 unterwegs. Ich würde gerne High Sierra überspringen.


    Die Frage ist: Läuft die 580 einwandfrei mit dieser Systemversion? Muss ich irgendwas bestimmtes beachten? Whatevergreen Pflicht oder geht auch ohne? Systemdefinition spielt eine Rolle?


    Laut Informationen im Netz soll ja die 580 in 10.12.6 Untersützung finden. Bin mir da aber nicht so sicher...


    System ist das in der Signatur.


    Danke im voraus!

    iMac 14,2
    Intel Core i3 8100
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+ SE
    32GB RAM
    aktuell kein macOS installiert

  • Die RX laufen ohne WEG erst ab 10.13.5 wirklich gut alles davor ist Flickschusterei...
    mit 12.6 sollte die aber auch mit WEG gehen...

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • Die Frage ist: Läuft die 580 einwandfrei mit dieser Systemversion


    Mit 10.12.6 macht das echt wenig Sinn.
    Wie @griven schon sagte... benötigst du echt ein Upgrade. ;)

  • @griven @Dr.Stein


    Danke für die raschen Antworten. Die Sache ist die, ich schreibe aktuell meine Abschlussarbeit auf dem System. Soll nur übergangsweise sein. Solange sie mir ein Bild mit Grafikbeschleunigung für Office gibt und ich 60 Hz bei einer Auflösung von 3440x1440 hinbekomme ist mir der Rest egal. Ich mache keine Videobearbeitung oder spiele irgendwelche Spiele auf macOS. Sie sollte aber auch schon ohne die interne HD 4600 als Starthilfe laufen.

    iMac 14,2
    Intel Core i3 8100
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+ SE
    32GB RAM
    aktuell kein macOS installiert

  • Meine Rx580 läuft unter 10.13.3 mit WEG ganz prima. Eine famose Karte ist das, auch bei 3840x2160, obwohl die Generation Gleitsicht dann keine Buchstaben mehr erkennt.

    iMac 14,2: Mojave, High Sierra, Windows10, BL: Clover 4644, Mainboard: Ga-z97mx Gaming5, CPU: i7-4790K, Ram: 16Gb Crucial Ballistix
    Grafik: Sapphire RX580 Nitro+ 8Gb, SSD: Samsung 970 NVME 500GB, Samsung 850 Evo 500Gb, 2x Samsung 840 Evo 250Gb, HDD: Seagate ST3000DM001 3TB Wifi:
    BCM94360CD Combo (oob), Bluetooth: Gmyle Bt v4.0 (oob), PSU: Corsair CX600M, Case: Jonsbo UMX4
    Geekbench 3 (32bit): 3903/14731 (Mavericks) - 3916/14856 (El Capitan)

  • Daher ja WhatEverGreen :D

    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

  • @Wolfe


    Ich weiß dass die Karte unter High Sierra läuft :) . Ich wollte wissen ob sie mit Sierra 10.12.6 auch läuft damit ich das System nicht upgraden muss.

    iMac 14,2
    Intel Core i3 8100
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+ SE
    32GB RAM
    aktuell kein macOS installiert

  • genau, dann solltest du es mit WhatEverGreen und Lilu probieren.
    Sichere dir aber vorher deine Arbeit auf einem Stick und schließe sie in deinem Tresor auf deiner Bank ein. :D

  • Wo muss Lilu und Whatevergreen nochmal unter Ozmosis rein? Man man man, viel zu lange her alles :D. Man wird halt vergesslich wenn man ein zu gut laufendes System hat.


    Ich gehe mal davon aus, da wo die DSDT ist? Oder war das irgendein Extensions Ordner?


    Hab mal meine Struktur der EFI hochgeladen.

  • /EFI/Efi/Oz/Darwin/Extensions/Common/
    eins zwei drei

  • Darf ich mal eben schnell fragen wieso du solch eine Graka überhaupt brauchst? Wenn du doch sowieso keine Bildbearbeitung machst geschweige denn Zockst, dann sollte doch die HD4600 locker reichen oder?

    Acer Aspire 5


    Lenovo G510


    Asus Flip TP500L



  • Ich kann die Euphorie für High Sierra 10.13.5 im Zusammenhang mit AMD-Grafikkarten leider überhaupt nicht teilen: nach der zweiten Beta-Version war bei meinem X99er mit zwei RX580 der HDMI-Sound weg. Den hab ich mir gerade mühsam mit dem aktuellen WEG (EFI-Treiberversion: WEAR-117-2018-03-30) zurück geholt, die alternativ eingesetzte Vega FE 16 will auch damit nichtmal mehr ein sauberes Bild raus geben und hat keine Grafik-Unterstützung mehr.

    Das mag mit meiner eingesetzten Konfiguration als MacPro6.1 zusammen hängen (bei meinen anderen Rechnern, die als iMac13 und 14 laufen, rennt alles normal..), aber bis 10.13.4 gab es diese Probleme nicht. Und als Intel-Chip-freier Rechner mit zwei AMD-Karten war der kleine MacPro hier bisher eindeutig die beste Wahl.
    Unter High Sierra:


    und vorher unter Sierra:


    Für Deinen Rechner bietet sich allerdings auch eher eine iMac-Konfig an.


    Eine Kleinigkeit am Rande zur RX580: Die ist wie fast alle modernen Grafikkarten meist semi-passiv ausgelegt. D.h. die schön großen Lüfter springen erst bei einer recht ordentlichen Temperatur an. Durch die recht großflächigen Verbindungen zu Board und Gehäuse werden diese nach einiger Zeit auch bei geringer Gesamt-Belastung zumindest in meinen PowermacG3- und -G4-Gehäusen nah an diese Anspring-Temperatur gebracht. Das finden das die anderen Lüfter aber garnicht lustig und versuchen vergeblich, die Temperatur des Systems wieder zu senken und drehen sich nen Wolf. Und die beiden großen leisen Grafik-Lüfter sagen schlicht: "Nö, keine Lust! Wir arbeiten erst ab 60, 65 Grad." Und die recht kompakte metallische Innentür dieser Gehäuse, an der das Board angeschraubt ist, überträgt die Wärme eben ganz ordentlich, habt aber keine große Außenfläche..
    Deshalb sind die RX580er bei mir nicht in den kleineren Rechnern eingebaut, sondern im großen grauen MacPro-Gehäuse. Viel Alu, viel Fläche, viel Raum. Und schön niedrige Temperaturen, auch semi-passiv.


    Ach ja: ein passendes Ozmosis-ROM brauchst Du für High Sierra natürlich auch noch. Obwohl ich selbst inzwischen sogar den Quo mit Clover betreibe..


    :hackintosh:

    2 Mal editiert, zuletzt von MacGrummel ()

  • @hackintoshhood
    Ich spiele unter macOS nicht, unter Windows schon. War so gemeint, dass mir die Grafikleistung (auch in Benchmarks) unter macOS egal sind. Hauptsache Grafikbeschleunigung mit Auflösung und Bildwiederholrate stimmen. Auch wenn ich gar nicht zocken würde, müsste ich mir eine Grafikkarte zulegen. Meine Intel HD 4600 schafft mit dem HDMI Port an meinem Board keine 3440x1440 bei 60Hz. Die Auflösung kriegt die Karte noch hin, aber wer möchte schon nur ca. 40 bis 50Hz haben?


    @MacGrummel
    Ich kann verstehen warum du etwas verärgert bist. Würde mir persönlich genauso gehen. Ich hoffe, dass bei mir mit der iMac-Sysdef. alles läuft.

    iMac 14,2
    Intel Core i3 8100
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+ SE
    32GB RAM
    aktuell kein macOS installiert

  • Also ab 10.12.6 sind die Treiber für Polaris 10, also RX570/RX580 an Bord, der iMac mit diesen Karten wurde mit 10.12.6 ausgeliefert. Klar wurden die mit der Zeit verbessert, aber wenn du den Rechner gerade wirklich brauchst sehe ich es als ein größeres Risiko an jetzt auf High Sierra upzugraden. Die Gefahr, dass die Grafik nach der Einrichtung auf einmal nicht mehr funktioniert, sehe ich als verschwindend gering an. Mit Lilu und WhateverGreen sollte sie ohne Probleme auch unter 10.12.6 laufen.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 16GB DDR4-3000, 250GB NVMe SSD + 512GB SSD + 1TB HDD, Clover, macOS 10.13.6, Kubuntu 18.10, Win 8.1


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, Clover 4421, macOS 10.14, Kubuntu 18.10, Win 8.1


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 10.14), iPhone X 64GB (iOS 12.0.1)


    Ehemalige: Dell Optiplex 790 (weitergegeben), iPhone 6 64GB (verkauft)

  • Was ich nicht verstehen kann, ist die Aussage das die 580er nicht gut laufen unter Sierra.
    Kann ich so nicht bestätigen, meine XFX läuft genauso gut unter Sierra wie unter High Sierra, bei High Sierra ist der einzige unterschied nur noch, das ich den WEG+Lilu für denn HDMI Sound brauche, ansonsten läuft die Karte OOB, genau wie in Mojave.


    Anscheint ist es doch immer noch so wie zu alten OSX Zeiten, das Sapphire und ihre Bios Versionen nicht immer kompatible sind.
    Wer sich schon länger mit dem Thema Hacki beschäftigt, kennt die Probleme da gut.
    Bei Lion, Mavericks oder auch El Capitan, wurde sogar geraten die Finger von ASUS, MSI und Sapphire zu lassen, da ihre Bios Versionen meist nicht denn Erfolg gebracht haben.

  • Ich hab LiLu (version 1.2.3) und WEG (1.1.7) nun in den Ordner kopiert den mir @Dr.Stein genannt hat. Mein System fährt nicht mehr hoch.


    Ich hab mal ein Foto mit meinem Smartphone gemacht.


    Neben den kexten gab es noch "Whatevername" und irgendwelche DSYM-Files die ich nicht mit rein kopiert habe. Habe ich irgendwas falsch gemacht?


    iGPU ist deaktiviert!


    EDIT: Hab jetzt beschlossen auf HS upzugraden. Hier gehts weiter: Hilfe bei High Sierra Installation?