Angepinnt Anleitung: USB 3.0 unter El Capitan / Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

    Forum Unterstützen

    Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

    Team

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

      Ach Quatsch... ;)

      Es gibt manche Dinge, die bleiben einfach hängen... ob man will oder nicht... ;)
      @WeWin
      Coole Sache... dann sollt das Gerät doch soweit erledigt sein, oder?
      Gruß
      Al6042

      GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
      GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4077
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.5
      Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD SanDisk Ultra II 240GB & HDD Samsung 2TB | BCM943602BAED | macOS 10.12.5 | Clover 4077

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
      Ja mein großer Mac läuft jetzt :)
      Ich mach gerade noch genau das selbe einmal bei dem mac von einem bekannten, dann sollte das Sleep Problem auch gelöst sein :)
      Danke! :danke:


      EDIT:
      @kuckkuck Was ist denn wenn bei dem 6ten Schritt mit dem USB3.0 Stick nur HSXX aufleuchten? Soll ich dann trotzdem SSP1-6 exluden? Bei meinem anderen Hacki haben mit dem USB3 Stick auch nur SSPX grün geleuchtet.
      **Wenn ich die SSP1-6 exclude kommt nix mehr =O
      Spoiler anzeigen
      Desktop Ga Z97MX-Gaming5 | i5 4690K 3,9Ghz | 24GB RAM | HD4600 1,5GB | GTX 1050 Ti OC 4G | 1,88TB Mac (FD) | 500GB WIN | 128GB SSD | 5TB TM | OSXwifi | Ozmosis | Mac Pro G5 | macOS 10.12.X
      Desktop Ga Z97MX-Gaming5 | i5 4460 3,40Ghz | 16GB RAM | HD4600 1,5GB | 1,5TB Mac (FD) | 1TB WIN | OSXwifi | Ozmosis | Mac OS 10.12.X
      Desktop GA Z97M-D3H | i7 4790K 3,6Ghz | 16GB RAM | HD4600 1,5GB | 1TB Mac (FD) | OSXwifi | Ozmosis | macOS 10.12.X
      Notebook Dell E7450 | i5 5300U 2,3Ghz | 16GB RAM | HD5500 1,5GB | Nvidia 840M 4GB | 250GB SSD | Win 10
      Notebook Toshiba L750 1xp | i7 2670QM 3,1Ghz | 12 GB RAM | GT 525M | 320GB HDD | 10.11.6
      Netbook EEE 1005HA | N270 1,6GHz | 1 GB RAM | GMA 950 | Wifi | 320GB | Mac OSX 10.6.2

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „WeWin“ ()

      Wenn nur HSXX aufleuchtet dann Schaust du welche ports noch unbenutzt sind und excludest diese bis USB 3.0 funktioniert ;)
      Hm okay, das habe ich gemacht. Habe dann nachdem mit dem USB3 Stick nur wieder HSXX geleuchten haben mal alle SSPX excludet, aber danach kamen keine neuen Ports.. :(
      Ich hatte dann quasi nur noch die paar HSXX vom USB2.0 und sonst keine mehr.
      Spoiler anzeigen
      Desktop Ga Z97MX-Gaming5 | i5 4690K 3,9Ghz | 24GB RAM | HD4600 1,5GB | GTX 1050 Ti OC 4G | 1,88TB Mac (FD) | 500GB WIN | 128GB SSD | 5TB TM | OSXwifi | Ozmosis | Mac Pro G5 | macOS 10.12.X
      Desktop Ga Z97MX-Gaming5 | i5 4460 3,40Ghz | 16GB RAM | HD4600 1,5GB | 1,5TB Mac (FD) | 1TB WIN | OSXwifi | Ozmosis | Mac OS 10.12.X
      Desktop GA Z97M-D3H | i7 4790K 3,6Ghz | 16GB RAM | HD4600 1,5GB | 1TB Mac (FD) | OSXwifi | Ozmosis | macOS 10.12.X
      Notebook Dell E7450 | i5 5300U 2,3Ghz | 16GB RAM | HD5500 1,5GB | Nvidia 840M 4GB | 250GB SSD | Win 10
      Notebook Toshiba L750 1xp | i7 2670QM 3,1Ghz | 12 GB RAM | GT 525M | 320GB HDD | 10.11.6
      Netbook EEE 1005HA | N270 1,6GHz | 1 GB RAM | GMA 950 | Wifi | 320GB | Mac OSX 10.6.2
      Pack mal USR aus der excludest list... Wie sind denn deine BIOS settings?
      Okay werde ich machen. Auto, Enabled, Enabled, wie in deiner Anleitung geschrieben :)
      Spoiler anzeigen
      Desktop Ga Z97MX-Gaming5 | i5 4690K 3,9Ghz | 24GB RAM | HD4600 1,5GB | GTX 1050 Ti OC 4G | 1,88TB Mac (FD) | 500GB WIN | 128GB SSD | 5TB TM | OSXwifi | Ozmosis | Mac Pro G5 | macOS 10.12.X
      Desktop Ga Z97MX-Gaming5 | i5 4460 3,40Ghz | 16GB RAM | HD4600 1,5GB | 1,5TB Mac (FD) | 1TB WIN | OSXwifi | Ozmosis | Mac OS 10.12.X
      Desktop GA Z97M-D3H | i7 4790K 3,6Ghz | 16GB RAM | HD4600 1,5GB | 1TB Mac (FD) | OSXwifi | Ozmosis | macOS 10.12.X
      Notebook Dell E7450 | i5 5300U 2,3Ghz | 16GB RAM | HD5500 1,5GB | Nvidia 840M 4GB | 250GB SSD | Win 10
      Notebook Toshiba L750 1xp | i7 2670QM 3,1Ghz | 12 GB RAM | GT 525M | 320GB HDD | 10.11.6
      Netbook EEE 1005HA | N270 1,6GHz | 1 GB RAM | GMA 950 | Wifi | 320GB | Mac OSX 10.6.2
      Wie ich in der Anleitung geschrieben habe, kann es passieren das IOReg rumspinnt. Pack nochmal alle SSP Ports aus der excludest und teste dann nochmal die USB 3.0 Ports. Immerwenn du einen stick reinsteckst und es leuchtet nichts auf, restartest du das Programm und schaust nochmal. Außerdem steck den Stick dann nochmal raus und wieder rein ;)
      Okay ich werds nochmal testen, er bootet gerade neu.
      Aber es hat ja an jedem USB3 Port mit einem USB3 Stick was aufgeleuchtet, aber nur HSXX Einträge.

      HS10 ist zum Beispiel ein USB3 Port direkt am Mainboard, wird aber nicht als PSS erkannt.

      Mittlerweile geht es, keine Ahnung wieso.
      Vll war ich gestern einfach zu müde :wallbash:
      Danke :)
      Spoiler anzeigen
      Desktop Ga Z97MX-Gaming5 | i5 4690K 3,9Ghz | 24GB RAM | HD4600 1,5GB | GTX 1050 Ti OC 4G | 1,88TB Mac (FD) | 500GB WIN | 128GB SSD | 5TB TM | OSXwifi | Ozmosis | Mac Pro G5 | macOS 10.12.X
      Desktop Ga Z97MX-Gaming5 | i5 4460 3,40Ghz | 16GB RAM | HD4600 1,5GB | 1,5TB Mac (FD) | 1TB WIN | OSXwifi | Ozmosis | Mac OS 10.12.X
      Desktop GA Z97M-D3H | i7 4790K 3,6Ghz | 16GB RAM | HD4600 1,5GB | 1TB Mac (FD) | OSXwifi | Ozmosis | macOS 10.12.X
      Notebook Dell E7450 | i5 5300U 2,3Ghz | 16GB RAM | HD5500 1,5GB | Nvidia 840M 4GB | 250GB SSD | Win 10
      Notebook Toshiba L750 1xp | i7 2670QM 3,1Ghz | 12 GB RAM | GT 525M | 320GB HDD | 10.11.6
      Netbook EEE 1005HA | N270 1,6GHz | 1 GB RAM | GMA 950 | Wifi | 320GB | Mac OSX 10.6.2
      Vielen Dank für deine Anleitung? Gibt es auch eine Möglichkeit extra-current darüber zu steuern? Ich würde gerne mein iPad laden können... ;)
      Hackintosh: ASUS Z170M Plus, Core i5 6600K, 16 GB DDR4-2300 RAM, ALC 887 Audio, Gainward Phantom GTX680, BCM943602CS Wifi/BT Combo Card, OS: macOS 10.12, Clover 3773 (AppleALC, IntelE1000e, USBInject, audioCloverHDMI)
      Original: Macbook Pro Mid 2014, Core i5, 8 GB RAM, 256 GB SSD, iPad Air 2, iPhone 5s
      Vintage: Power Mac G5, Power Mac 6100/66 DOS Compatible
      Persönlich würde ich den 10watt ipad ladeadapter benutzen! Der usb port schafft das nicht...
      Gruß
      Jan
      Doch, es geht unter Windows problemlos. Mein Hack stellt unter Sierra über USB leider nur 500mA bereit, sollte aber eigentlich 2000 extra draufpacken, wenn ein Apple-Gerät dranhängt. Viele haben das Problem und ich wollte nur wissen, ob es sich über USBInject patchen lässt oder ob ein komplizierter DSDT-Hack dafür nötig ist.
      Hackintosh: ASUS Z170M Plus, Core i5 6600K, 16 GB DDR4-2300 RAM, ALC 887 Audio, Gainward Phantom GTX680, BCM943602CS Wifi/BT Combo Card, OS: macOS 10.12, Clover 3773 (AppleALC, IntelE1000e, USBInject, audioCloverHDMI)
      Original: Macbook Pro Mid 2014, Core i5, 8 GB RAM, 256 GB SSD, iPad Air 2, iPhone 5s
      Vintage: Power Mac G5, Power Mac 6100/66 DOS Compatible
      Dafür muss die DSDT gepatched werden, damit diese Angaben der USB-Port-Definition an OSX übergeben werden.
      Gruß
      Al6042

      GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
      GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4077
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.5
      Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD SanDisk Ultra II 240GB & HDD Samsung 2TB | BCM943602BAED | macOS 10.12.5 | Clover 4077

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
      Hätte da jemand noch einen Tipp? Bisher haben meine Dsdt's leider nie eine Veränderung gebracht. Könnte man auch über Clover patchen? Vielen Dank!
      Habe auch an anderer Stelle gelesen, dass es mit den 10.11.6 USB-Kexten funktionieren soll, deutet das nicht auch auf ein anderes Problem hin?
      Hackintosh: ASUS Z170M Plus, Core i5 6600K, 16 GB DDR4-2300 RAM, ALC 887 Audio, Gainward Phantom GTX680, BCM943602CS Wifi/BT Combo Card, OS: macOS 10.12, Clover 3773 (AppleALC, IntelE1000e, USBInject, audioCloverHDMI)
      Original: Macbook Pro Mid 2014, Core i5, 8 GB RAM, 256 GB SSD, iPad Air 2, iPhone 5s
      Vintage: Power Mac G5, Power Mac 6100/66 DOS Compatible

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „macinsane“ ()

      Ohne deine DSDTs wenigstens mal in Augenschein genommen zu haben, werde ich mich hier zu keiner Aussage hinreissen lassen.
      Kexte alleine tun es nicht, die helfen dir vielleicht in der erfolgreichen Nutzung von USB3.0 und USB2.0 Anschlüssen, aber den Eintrag für die Stromzufuhr bekommst du aus der DSDT.
      Hier zum Beispiel mal ein Patch aus dem Maciasl:
      Spoiler anzeigen

      Quellcode

      1. ​# Patches the Intel USB3 on Intel 9 Series chipsets to allow more power output
      2. #Fix EHC1
      3. into method label _DSM parent_label EHC1 remove_entry;
      4. into device label EHC1 insert begin
      5. Method (_DSM, 4, NotSerialized)\n
      6. {\n
      7. Store (Package (0x17) {\n
      8. "AAPL,clock-id", Buffer (One) { 0x02 },\n
      9. "AAPL,slot-name", "Built In",\n
      10. "name", "Intel EHCI Controller",\n
      11. "model", Buffer(0x3E) {"Intel 9 Series Chipset Family USB Enhanced Host Controller #1"},\n
      12. "device_type", Buffer (0x0E) {"USB Controller"},\n
      13. "AAPL,current-available", 0x0834,\n
      14. "AAPL,current-extra", 0x0A8C,\n
      15. "AAPL,current-in-sleep", 0x03E8,\n
      16. "AAPL,current-extra-in-sleep", 0x0834,\n
      17. "AAPL,max-port-current-in-sleep", 0x0A8C,\n
      18. "AAPL,device-internal", 0x02,\n
      19. Buffer (One) {0x00}\n
      20. }, Local0)\n
      21. DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
      22. Return (Local0)\n
      23. }
      24. end;
      Gruß
      Al6042

      GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
      GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4077
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.5
      Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD SanDisk Ultra II 240GB & HDD Samsung 2TB | BCM943602BAED | macOS 10.12.5 | Clover 4077

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
      Vielen Dank, hatte ich schon eingebaut, leider ohne Erfolg. Allerdings für 100er Boards(habe ja ein Z170) der Patch unterscheidet sich leicht. Vielleicht probiere ich es nochmals mit dem 9-Series Patch und schaue, was passiert. Es wäre so großartig, wenn ich so einen Patch über Clover injecten könnte, ohne dutzende Errors und Warnings aus ner Dsdt bügeln zu müssen :)
      Aber wie gesagt, drüben bei insanelymac behaupten Leute, sie hätten schlicht die alte Kext aus El Capitan genommen.
      Hackintosh: ASUS Z170M Plus, Core i5 6600K, 16 GB DDR4-2300 RAM, ALC 887 Audio, Gainward Phantom GTX680, BCM943602CS Wifi/BT Combo Card, OS: macOS 10.12, Clover 3773 (AppleALC, IntelE1000e, USBInject, audioCloverHDMI)
      Original: Macbook Pro Mid 2014, Core i5, 8 GB RAM, 256 GB SSD, iPad Air 2, iPhone 5s
      Vintage: Power Mac G5, Power Mac 6100/66 DOS Compatible
      Dann mach das mal und sage uns ob es funktioniert hat...
      Gruß
      Al6042

      GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
      GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4077
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.5
      Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD SanDisk Ultra II 240GB & HDD Samsung 2TB | BCM943602BAED | macOS 10.12.5 | Clover 4077

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
      Ja ist es denn...?

      Auf meinem Dienstrechner hatte ich den Tipp mit dem USB-Port-Limit noch gelesen, aber jetzt finde ich ihn nicht mehr. Könnte mir jemand sagen, wo ich den Finde oder machen muss, damit ich das Limit erhöhen kann?

      Das habe ich doch richtig verstanden, dass ein USB3-Port automatisch zwei Ports belegt, ja? Einmal für USB2 und einmal für USB3, oder?

      Danke.