Installation von macOS Big Sur auf Gigabyte Z490 Gaming X

  • Hallo zusammen,

    ich habe mir meinen ersten Hackintosh zusammengebaut und wollte nun macOS Big Sur darauf installieren. Ich kann zwar im Bootmenu die Big Sur Installation auswählen und er lädt auch das BaseSystem.dmg aber leider endet dies in einer Textschleife, welche von abgebrochenen Prozessen und Code Signing-Fehlern spricht. Ich habe mal ein Bild davon angehangen. Zudem habe ich meinen EFI-Ordner angefügt. Die config.plist habe ich über den offiziellen Opencore-Guide (https://dortania.github.io/Ope…fig.plist/comet-lake.html) erstellt.


    Als Bootloader verwende ich Opencore in der Version 0.6.4 und meine Hardware ist wie folgt:


    Mainboard: Gigabyte Z490 Gaming X (aktuellste Firmware)

    Prozessor: Intel i5 10400

    RAM: Corsair Vengeance 16GB 3000 MHz

    Grafikkarte: Gigabyte Radeon 5500 XT 4GB

    SSD: Samsung Evo 850 250GB (aktuellste Firmware)


    Kann mir von euch jemand einen Hinweis geben, welche Einstellungen ich ändern sollte?


    Vielen Dank! :)

  • Willkomen im Forum,


    kannst du sagen, wie du den Stick erstellt hast und woher du BigSur geladen hast?

  • Hallo hackmac004,

    vielen Dank, dass du dir mein Problem anschaust! Ich habe den Stick mittels des Opencore-Guides erstellt: https://dortania.github.io/Ope…ctions-vs-prelinkedkernel


    macOS Big Sur habe ich mittels "gibMacOS.command" heruntergeladen, dann über InstallAssistant.pkg die Installationsdatei erstellt und schließlich per Terminalbefehl

    Code
    1. sudo /Applications/Install\ macOS\ Big\ Sur.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume

    einen macOS Big Sur Boot-USB-Stick erstellt. Den EFI-Ordner habe ich dann mittels "MountEFI" auf die EFI-Partition des USB-Sticks kopiert.


    PS: Ich habe über den gleichen Weg übrigens auch versucht Catalina zu installieren und habe die gleichen Code Signing-Fehler erhalten.

  • Das hört sich soweit schon mal gut an.

    Ich würde als erstes die SSDT Rhub in der config deaktivieren, da die nur für ASUS oder MSI boards gedacht ist.

    Ob du die CtlnaAHCIPort.kext brauchst weiss du schon oder ist die nur vorsorglich dabei?

    Hast du an alle Bios Einstellungen gedacht?

  • Ich habe nun SSDT RHUB, CtlnaAHCIPort.kext und auch NVMEFix.kext aus meinem EFI und der config.plist entfernt aber erhalte noch immer die gleichen Code Signing Fehler. Im BIOS habe ich die Einstellungen geprüft und auch mal die interne Grafik deaktiviert sowie das XMP-Profil entfernt, aber das Ergebnis ist das gleiche wie vorher.

    Files

    • EFI.zip

      (2.19 MB, downloaded 2 times, last: )
  • Ob du diese hier mal probierst?

    Files

    • EFI.zip

      (2.9 MB, downloaded 10 times, last: )
  • Als nächste würde ich SIP aktivieren. So hier an dieser Stelle.



    Trägst du csr-active-config noch wie auf dem Bild unter delete ein, dann brauchst du nicht immer einen Nvram reset machen, damit Änderungen an der Stelle wirksam werden.


    Edit:

    Kannst du bitte deine Hardware noch in dein Profil eintragen?

  • Ob du diese hier mal probierst?

    Vielen Dank für deinen EFI-Ordner Erdenwind Inc.! Ich habe diesen getestet und obwohl das Apple-Logo gleich zu sehen war lief der Balken nur bis ca. einem Viertel durch und wollte dann nicht weiter. Ich habe also mal "-v" in die Bootargumente eingefügt, um den Text anstelle des Apple Logos zu sehen und bekomme die gleichen Fehler wie vorher: unzählige Code Signing Errors.

  • dann wissen wir schonmal mehr.check mal einen anderen USB Port bitte und versuch damit zu installieren. Solange bis alle durch sind.reset auch mal machen bitte

  • Ich habe meine config.plist wie von dir gezeigt angepasst aber sehe keine Änderung in der Anzeige -- weiterhin nur Code Signing Fehler.

    Files

    • config.plist

      (23.05 kB, downloaded 2 times, last: )
  • Erdenwind Inc. In deiner EFI ist ein custom USBport.kext drin, heisst der passt nicht zu seinem board.

    Besser wäre es wenn er den löscht und XhciPortLimit auf Yes stellt.

    Ich glaub aber auch nicht, dass es an den USB ports liegt.

    Den Fehler habe ich so noch nie gesehen..... mhmm.


    Bankster als du versucht hast Catalina zu installieren, hast du den Stick auch per terminal erstellt?

  • Erdenwind Inc. Ich habe alle USB-Ports durchgetestet und überall kommt der gleiche Code Signing Fehler.


    hackmac004: Ja, auch Catalina habe ich auf die gleiche Weise erstellt wie den Big Sur Installationsstick. Ich wollte testen, ob es an Big Sur liegt, aber das war wohl nicht der Fall.

  • hackmac004 du wirst lachen...das ist von einem gigabyte Gaming x board daher sollte es grob passen.


    Bankster sag mal bitte was du an Hardware verbaut hast alles.

    NVRAM Reset auch mal bitte. Du weisst wie man den macht? Will dir nicht auf die Füsse treten...

  • Erdenwind Inc. Den NVRAM Reset mache ich immer über den Opencore Bootloader -- ist dort der letzte Menüpunkt. Habe ich auch nach jedem USB-Anschlusstest gemacht, hat aber nichts geändert.


    Meine verbaute Hardware habe ich in meine Signatur geschrieben: Das Mainboard, der Prozessor, die Grafikkarte, der Arbeitsspeicher und die SSD findest du dort. Zudem habe ich noch eine Hitachi HDD mit 3TB (ist noch NTFS formatiert, da es aus meinem Gaming PC stammt) und ein 550W Netzteil von Seasonic. Mehr ist in dem Gehäuse nicht drin. Unter Windows 10 (derzeit noch auf der SSD) funktioniert der Computer tadellos.

  • dann mach mal die hdd ab und im Bios den Sata port AHCI aus test weise.oder einfach im Bios abschalten

  • Ich habe den SATA Port 3 im BIOS deaktiviert (daran hängt die HDD) aber auch das hat keine Änderung an den Fehlermeldungen bewirkt.


    Anbei habe ich mal Fotos meiner BIOS-Einstellungen angefügt, nur um sicherzustellen, dass dort nichts gravierend falsch ist. Vielleicht kannst du das mal prüfen, da du ja auch ein Gigabyte Z490 Motherboard hast. Vielen Dank! :)


  • Das einzige was mir auffällt ist, dass secure boot im 1. Bild auf custom und im letzten auf Auto steht. Kannst du das komplett disablen?

  • Das "Auto" im letzten Bild bezieht sich auf "Preferred Operating Mode". Secure Boot kann ich nur auf "Custom" stellen. Die Alternative wäre "Standard". Enable/Disable gibt es da leider nicht.

    Edited once, last by Bankster ().

  • Stell mal EnableWriteUnprotector unter Booter-Quirks auf Yes.

  • stell mal Datum und Uhrzeit richtig ein...oder is in Frankfurt ne andere Zeitzone?