RTX 2080 Windows, Vega 56 MacOS - ist das möglich?

  • Hallo,


    Vielleicht kann mir hier jemand helfen.


    Ich hab folgendes Problem. Aktuell hab ich eine RTX 2080, welche natürlich mit Mojave nicht funktioniert, soweit so gut. Des weiteren hab ich auch noch eine Vega56 in Reserve, welche für Mojave passen sollte.


    Mein Motherboard: Z390-F

    CPU: 8700k


    Hat jemand Erfahrung damit eine Grafikkarte für den Hackintosh "auszublenden"?


    Konkret soll Windows mit der RTX 2080 laufen und Mojave nur mit der Vega56, die RTX soll am besten für den Hackintosh deaktiviert sein.


    Danke für eure Hilfe

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Hallo Seven und Herzlich Willkommen im Hackintosh Forum. :welcome:

    Hast du hier schon mal rein geguckt -> Graphikkarte lahmlegen ohne Ausbau


    Gruß derHackfan


    Sei höflich und bescheiden, vervollkommnene deinen Charakter, sei geduldig und beherrscht, sei gerecht und hilfsbereit, sei mutig.

  • Funktioniert nur mit einer SSDT oder OpenCopre Bootloader per Clover kann man die Karte nicht richtig deaktivieren, da geht nur der WEG kext aber dann sind alle GPU's tot.

  • Hallo,


    Danke für eure Antworten, bin nur schon paar Schritte vorher stecken geblieben.


    Kurzes Update, ich hatte einige Probleme den beim installieren von MacOS. Dachte schon ich werde verrückt, da der Installer immer wieder stecken geblieben ist, bis ich gesehen habe, dass es Probleme mit den Evo Plus NVME SDDs von Samsung gibt. Jetzt auf eine normale 970er evo gewechselt und alles funktioniert problemlos.


    Die Nvidia Karte taucht jetzt noch folgendermaßen im System Report auf:

    Display:


    Type: GPU

    Bus: PCIe

    Slot: Slot-1

    PCIe Lane Width: x8

    Vendor: NVIDIA (0x10de)

    Device ID: 0x1e87

    Revision ID: 0x00a1

    Kernel Extension Info: No Kext Loaded


    Ich nehme mal an da kommen die SSDT's jetzt ins Spiel?


    Danke

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Was soll dir eine SSDT bringen ? Die Nvidia wird nicht unter MacOS laufen, verwende einfach die VEGA und gut!

    Verstehe nicht wo das Problem ist...


    Da kein Treiber geladen wird und geladen werden kann, muss bei der Nvidia überhaupt gar nichts gemacht werden.

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

  • Das Problem ist, dass die Vega über HDMI und die 2080er über Display Port am selben Monitor hängen und wenn beide angesteckt sind erkennt MacOS etwas so halb.

    Konkrekt heißt das, er erkennt zwei Bildschirme, kann aber nur am HDMI Port was anzeigen, der andre ist schwarz.


    Es wäre eben schön gewesen, sich das Ganze einfacher machen zu können und auf eventuelle herumsteckerei verzichten zu können.

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Seven  

    Vielleicht hilft dir ja ein Switch?

    Monitor1 verbunden mit VEGA
    Monitor2 verbunden mit einem 1-Output-2-Input-Switch. Am Switch hängen dann VEGA und GTX 2080

    Keine Ahnung ob das funktionieren würde. Statt rumzustecken betätigst du nur den Button an dem Switch.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • Kannst du zwischen den Ausgängen schalten?


    Oder bezieht der Monitor diesen selbst?


    Schau mal in das Handbuch von deinem Monitor falls nicht bekannt.

    An meinem kann ich den Input selbst bestimmen, falls das geht schaltest du für Windows entsprechend einfach nur auf DisplayPort um und gut oder besorgst dir wie schon von Kazuya91 erwähnt nen switch.

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

  • @Evo 970 Plus


    Da gibt es jetzt wohl ein Firmware Update, das die Karte unter MacOS nutzbar macht.

  • Ich klinke mich mal hier mit ein. Hab ein ähnliches Thema mit meiner 1080 Ti. Hab die Tage überlegt mir einfach nen zweiten kleinen PC zusammenzuschrauben den ich dann ausschließlich für macOS nutze, aber wenn ein Einbau einer zweiten GPU reicht und sauber läuft würde ich das natürlich bevorzugen und mir eine 580 zusätzlich in den BigHack einbauen.


    Ich hab einen Monitor und würde dann die RX580 per HDMI ansteuern. Die 1080 Ti hängt am DP

     BigHack (iMacPro1,1) - macOS 10.14.5

    Mainboard: Asus Z390-F Gaming

    Prozessor: i7-9700K

    Grafikkarte: ASUS Dual Radeon RX 580 OC

    RAM: 16GB Corsair Vengeance LPX DDR4-3000

    Bootloader: Clover


     Hackbook Pro (MacBookPro15,2) - macOS 10.14.5

    Mainboard: Lenovo Thinkpad E580

    Prozessor: i5-8250U

    RAM: 8GB DDR4-2400

    Grafikkarte: Intel UHD Graphics 620

    Speicher: 250GB Samsung Evo 970

    WLAN: DW-1560 Broadcom BCM94352Z

    Bootloader: Clover

  • Hallo,


    Vllt. nochmal zum genauen Setup

    Rtx 2080 -> Display Port -> Monitor

    Vega 56 -> HDMI -> Monitor


    Vega 56 ist in Windows deaktiviert, Windows hat auch kein Problem wenn beide Grafikarten mit dem Monitor verbunden sind, alles funktioniert einwandfrei.

    RTX 2080 taucht in MacOs so halb erkannt auf, MacOs hat damit aber ein Problem und denkt es müsste auch mit dieser Grafikkarte den Monitor ansteuern und zeigt mir "zwei" Monitore, auch wenns der selbe ist, jedoch macht das nur Probleme, da die RTX 2080 kein Bild liefert. Wird die RTX 2080 getrennt, hat MacOS kein Problem mehr, ist aber lästig dan man ständig herumstecken muss.


    DSM2

    Ich kann am Monitor die Eingänge umschalten, genau das mache ich auch. Genanntes Problem in MacOs ist leider trotzdem da.


    Kazuya91

    DSM2

    Danke für den Tipp mit dem Umschalten, das wäre wirklich einen Versuch wert und ist sicher die simpelste Lösung!

    So ein Teil müsste eigentlich funktionieren: https://www.amazon.de/dp/B07DV…sc=0&ref_=lv_ov_lig_dp_it



    Si Vis Pacem

    Ich hab gestern im SSD Magician kein Firmware update gesehen, da ich auch gehört habe, dass es dann gehen soll. Das Thema hat sich aber jetzt zum Glück ohnehin erledigt.


    Apfelkompott

    Wie gesagt, unter Windows hab ich die zweite GPU einfach im Device Manager deaktiviert, da klappt alles.

    Du hast auch ein Z390-F Board? Darf ich dich fragen welche UEFI64Driver du aktuell in Clover verwendest? Ich musste unbedingt emuvariableuefi-64 verwenden da ich sonst nicht runterfahren/in sleep modus gehen konnte.

    Dzt. hab ich noch Schwierigkeiten, dass ich den nvram von Zeit zu Zeit löschen muss.

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Lad mal ein ioreg von deinem System hoch.

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

  • DSM2

    Hier bitteschön, wenn du etwas spezielles brauchst lässt sich das auch machen.

    ioreg.txt

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Ich brauche kein Text file sondern das richtige ioreg file

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

  • So bitteschön, hoffe es passt.

    Files

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

  • Das File in deinen EFI folder unter EFI/CLOVER/ACPI/Patched legen und rebooten.


    Besser wäre das ganze aber per USB Stick zu testen, SSDT ist nicht gerade mein Gebiet aber versuch es mal damit.


    Muss heute zur Nachtschicht raus, bin gar auf dem Weg ins Bett, schaue später wenn ich Zeit hab nochmal rein.

    Files

    • SSDT-OFF.aml

      (178 Byte, downloaded 10 times, last: )

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

  • Apfelkompott

    Du hast auch ein Z390-F Board? Darf ich dich fragen welche UEFI64Driver du aktuell in Clover verwendest? Ich musste unbedingt emuvariableuefi-64 verwenden da ich sonst nicht runterfahren/in sleep modus gehen konnte.

    ist bei mir das gleiche

     BigHack (iMacPro1,1) - macOS 10.14.5

    Mainboard: Asus Z390-F Gaming

    Prozessor: i7-9700K

    Grafikkarte: ASUS Dual Radeon RX 580 OC

    RAM: 16GB Corsair Vengeance LPX DDR4-3000

    Bootloader: Clover


     Hackbook Pro (MacBookPro15,2) - macOS 10.14.5

    Mainboard: Lenovo Thinkpad E580

    Prozessor: i5-8250U

    RAM: 8GB DDR4-2400

    Grafikkarte: Intel UHD Graphics 620

    Speicher: 250GB Samsung Evo 970

    WLAN: DW-1560 Broadcom BCM94352Z

    Bootloader: Clover

  • DSM2

    Danke, Ich probier es heute Abend noch aus


    Apfelkompott

    Hast du die AptioMemoryFix oder eine von den Osx* Memory Fixes?


    DSM2

    Hab die SSDT ausprobiert, die nvidia taucht nach wie vor im system report auf.


    Ich scheine auch noch Probleme mit den USB Ports zu haben, wenn ich die externe Soundkarte anstecke bekomme ich sehr oft einen Komplettfreeze 2-3 Minuten nach dem Start.

    Hier scheint auch noch was zu erledigen zu sein.

    Mainboard: Z390-F, CPU: Intel 8700k, RAM: 64 GB G.Skill SniperX 3600 Mhz, SSD: 970 Evo, Grafikkarte: MSI Airboost Vega 56 OC (Watercooled), Asus GeForce RTX 2080 ROG Strix OC 8 GB

    Edited once, last by Seven ().

  • Na dann muss man das ganze anders angehen und die bridge nullen bei der Nvidia.


    Vielleicht hat unser apfelnico ja ein wenig Zeit dafür.


    Bin ab jetzt 4 Wochen verhindert und nur vom Handy hier und da mal zwischendurch im Forum unterwegs.

    Dell 7773 - i7 8550U - 16 GB 2400MHz RAM - 512 GB SSD - DELL DW 1830 4.1 Bluetooth/Wifi Card - 10.15 Beta (19A471t)


    X299 - i9 7960X - ASUS WS X299 Sage 10/G - 128 GB RAM - 1TB 970 Evo - 512 GB 950 Pro - MSI Radeon VII - 10.14.6 (18G29g)


    Keine Unterstützung per PN... Eure Fragen gehören ins Forum, nicht in mein Postfach!


    Case Modding/Custom Computerbau samt Wasserkühlung/Delidding/GPU Umbau - Bei Interesse PN

    Edited once, last by DSM2 ().

  • DSM2

    Danke trotzdem für den Versuch


    Aber wie gesagt, momentan kämpfe ich mit regelmäßigen Freezes ca. 2 Minuten nach dem Start, passiert bis dahin kein Freeze läuft alles stabil, sehr seltsam. Die Soundkarte wars dann doch nicht, ich hab momentan keine Idee, vllt. doch wieder die Evo Plus.

    Edit: Nach dem FIrmware Update sind die Freezes weg, es war die Evo Plus.


    Ein seltsames Phänomen hab ich immer wieder nach einem Reboot oder dergleichen, da bekomme ich nur ein Rauschbild, habs mal angehängt. Kennt jemand sowas?


    Si Vis Pacem

    Ich habe heute das Firmware-Update durchgeführt, meine Freezes sind weg.


    DSM2

    Kazuya91

    Ich hab mir jetzt einen DisplayPort Switch besorgt, jetzt klappt alles wunderbar, danke nochmal für den Tip!