[Sammelthread] macOS Mojave 10.14 Developer Beta - Erfahrungen

  • Einer muss ja damit anfangen, dieses bin es mal ich...


    Lasst uns hier die neusten Erkenntnisse und Erfahrungen zum neuen macOS Mojave 10.14. auf dem Hackintosh sammeln.


    Mein Download ist gerade fertig und der Installer wird jetzt erstmal erstellt :D


    // Edit @Thogg Niatiz //
    für die Public Beta bitte hier klicken

    Viele Grüße

    Coaster

    Co-Administrator & Community Manager

  • Bei den Verrückten gibt es von PMHeart schon eine angepasste Clover.efi welche im Anhang ist.
    Leider läuft mein Download noch ein bisschen, kann es also leider noch nicht ausprobieren.


    Edit:
    Nutzungshinweise von PMHeart: /EFI/CLOVER/CLOVERX64.efi und /EFI/BOOT/BOOTX64.efi mit der clover.efi aus der Zip ersetzen, natürlich dabei die Namen anpassen.
    Es soll 2x die gleiche Datei verwendet werden.


    Edit2: neue Clover.efi und apfs.efi hinzugefügt


    Edit3: neue Clover 4516 mit Mojave Unterstützung hinzugefügt, damit muss die Clover.efi nicht mehr benutzt werden.

    Files

    CFL-Hack mini: i5 10400 - Asrock B460M Steel Legend - 4x8GB Corsair Vengeance LPX 2666MHz - Gigabyte RX 460 @ RX560 BIOS + BCM943602CDP PCIe Wifi + GC-Titan Ridge - iMacPro SMBIOS - macOS Monterey + Windows 11
    Original Apple: Macbook Pro Retina 13" Early 2015 (MF840D/A) - macOS Monterey

    Original Apple: MacBook Air 2020 M1 (MGN63D/A) - macOS Monterey

    Edited 3 times, last by ductator ().

  • Ich teste das erstmal in einer Parallels-VM...
    bin mal gespannt ob das gleich schnurrt.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Leider läuft mein Download noch ein bisschen, kann es also leider noch nicht ausprobieren.


    Dann sieht man bestimmt auch den Anhang

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX560 |16GB |250GB SSD |macOS 12.6.1 & macOS 13.0.1 |*
    MacBook9,1XiaoMi Air 12,5"(erster XiaoMi im Forum)|M3 6Y30 HD515 |4GB |128 & 250GB SSD |macOS 11.6 |Clover
    MacBookPro15,4XiaoMi-Pro-15,6" |i5-8250U UHD620 |8GB |250 & 250GB SSD |macOS 12.6.1 & 13.0.1 |*
    MacBookPro16,1XiaoMi RedMi 14" |i7-10510U | 8GB | 512GB SSD | macOS 13.0.1 & 13.1 b4|*
    MacMini8,1 NVISEN Y-MU01(erster NVISEN im Forum)|i7-10510U |24GB |256GB SSD |macOS 13.0.1 & 13.1 b4 |*
    MacMini8,1HYSTOU S210H (Adventskalender vs. DSM2)|i9-9880H UHD630|32GB |250GB SSD |macOS 13.0.1 & 13.1 b4 |*
    MacMini8,1HYSTOU P05B (erster Hack mit OpenCore im Forum)|I7-8550U UHD620|16GB |500GB SSD |macOS 13.0.1 & 13.1 b4 |*

    * BootLoader OpenCore REL-088-2022-12-07


    XiaoMi Mi Notebook Ultra (2023) |macOS 13


    Quote from CMMChris
    Ach komm, klar willst du klugscheißen. Das will doch jeder.
  • ich erstelle grad den installStick,und dann lege ich los.

    1.GA Z390 AORUS ULTRA i9 9900K 64GBDDR4 2XRadeon RX 580samsung 970 evo

    2.Z170X-SOC FORCE i7 7700K 16GBDDR4 m2 samsung 960 msi nv 1050 ti win10 sierra + High Sierra- Mojave BL clover
    3. GA-Z97X UD3H/i7 4790K 32GBDDR3, Ssd Samsung 500Gb 2X2TB HDD Gigab GTX 670 OC, 4GB win 10 Sierra - Mojave BL ozmosis
    4.GA-Z77X-UD3H i7 3770K16GBDDR3 Speicher Toschiba ssd256GB 2X2TB HDD ati 5770 1GB Mojave BL ozmosis
    5.Asus N73sv Dual Boot8GB Ram DDR 3,Ssd Samsung 256Gb +500GB Hdd High Sierra Mojave Win 10 BL Clover

  • Habe gerade einen Stick mit createinstallmedia erstellt. Der neueste Clover, den ich auf den Stick installiert habe, findet den Installer nicht, der Clover (ein älterer) auf meiner System-SSD jedoch schon. Damit kann ich den Installer booten und komme auch fast bis zur GUI, aber eben nur fast, kurz vorher (Sound assertion, IOGraphics Flags) bleibt er stecken...

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 12.0.1, Manjaro Linux


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 12.0.1, Manjaro Linux


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 12.0.1), iPhone X 64GB (iOS 15.1)

  • Doofe Frage, aber du testest das nicht auf dem Rxzen oder? ^^

  • Nein, der bleibt auf 10.13.3 bis es neue Kernel-Source gibt. Testsystem ist der 'alte iHack'. Probiere jetzt mal den oben gerosteten Clover, aber auch damit erkennt der Stick nicht sich selbst...

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 12.0.1, Manjaro Linux


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 12.0.1, Manjaro Linux


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 12.0.1), iPhone X 64GB (iOS 15.1)

  • Wollte mal fragen ob mann die Beta laden kann ohne D-Zugang!

    Asus ZenBook 15 UX534F, Comet-Lake, Intel Core i7-10510U, Intel HD 620 16GB, Nvidia GeForce GTX 1650, 16GB RAM, Intel Optane+477 GB SSD PCI Express NVM

  • Nein geht nur mit Developer Access...

  • Ok danke für die info! euch dann noch viel spaß!

    Asus ZenBook 15 UX534F, Comet-Lake, Intel Core i7-10510U, Intel HD 620 16GB, Nvidia GeForce GTX 1650, 16GB RAM, Intel Optane+477 GB SSD PCI Express NVM

  • Ab in die Wüste...

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 12.0.1, Manjaro Linux


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 12.0.1, Manjaro Linux


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 12.0.1), iPhone X 64GB (iOS 15.1)

  • @TakisGR


    was schreibst du als Terminal Befehl createinstallmedia ...... application/install/install macOS 10.14????


    (

    iMacPro 1.1   Monterey (OC 0.8.5 ) Gigabyte Z390 Aorus Master 1.0 Bios F11f - Intel i9-9900K - Sapphire Radeon Pulse RX 5500 XT (8GB) - NVMe WD Black SN850 (1000 GB, M.2 2280) - Corsair Vengeance LPX DDR4 16GB Kit (2 x 8GB)- WI-FI /Bluetooth 4.0 BCM943602CS

    real iMac 13.1    Ventura 13.01 (late 2012)

    MacBook Pro 14.2 Ventura 13.0.1   13" 2018



  • was schreibst du als Terminal Befehl createinstallmedia ...... application/install/install macOS 10.14????
    (


    Vorausgesetzt du benennst Deinen BootStick mit "USB", dann lautet der komplette Befehl:


    sudo /Applications/Install\ macOS\ 10.14\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ 10.14\ Beta.app --nointeraction


    Heisst dein Bootstick anders, musst Du die Befehlszeile im Bereich USB auf deinen Namen anpassen. Einfacher wäre den Stick auf USB umzubenennen

    ASUS WS X299 SAGE/10G • Intel Core i9-7920X 12-Core 2.9GHz • 128GB RAM • ASRock Radeon VII Phantom Gaming • 2x Samsung 980 NVMe M.2 SSD 1 TB
    Custom Wasserkühlung • Thermaltake TheTower 900 • 1x SAMSUNG 49" @ 5120 x 1440 (100Hz) via DP • LG OLED 55" TV @ 3840 x 2160 (100Hz) via HDMI
    WINDOWS 11 ENTERPRISE INSIDER (PRO950 NVMe) • macOS BIG SUR und MONTEREY latest Build (jeweils auf Samsung 980 NVMe) • OpenCore always latest

  • @Mork vom Ork


    Danke funktioniert, hatte ne Leerzeile drin,......nervööös ;)

    iMacPro 1.1   Monterey (OC 0.8.5 ) Gigabyte Z390 Aorus Master 1.0 Bios F11f - Intel i9-9900K - Sapphire Radeon Pulse RX 5500 XT (8GB) - NVMe WD Black SN850 (1000 GB, M.2 2280) - Corsair Vengeance LPX DDR4 16GB Kit (2 x 8GB)- WI-FI /Bluetooth 4.0 BCM943602CS

    real iMac 13.1    Ventura 13.01 (late 2012)

    MacBook Pro 14.2 Ventura 13.0.1   13" 2018


  • IT WORKS!!! :thumbsup:

    Dark Mode schaut auf den ersten Blick gut aus, scheint aber noch nicht ganz ausgereift zu sein, einige Icons und die Schrift wirken, zumindest auf non-Retina-Bildschirmen, nicht sonderlich gut aufgelöst.
    Viel ausprobiert habe ich nicht, ich starte aber mit dem selben EFI-Ordner wie aus 10.13.5. Aufgefallen ist mir bisher das der Ton nicht funktioniert (AppleALC). Wird's wahrscheinlich bald ein Update geben.
    Ich habe mal durch die Kexte geschaut, auf der Suche nach neuer Hardware, aber auf den ersten Blick nichts gefunden. Aber: Es wurde radikal mit der Grafik aufgeräumt. Bei AMD ist alles unter 7000 weg, bei Intel alles unter HD4000 und von Nvidia ist nur noch Fermi und Kepler da, Tesla ist weg. Also wirklich nur noch Metal-fähige Karten.
    Noch ein paar Screenshots:

    Man kann jetzt jede Farbe als Auswahlfarbe festlegen. Was jedoch nicht mehr geht, ist der 'Dark Mode Light', also dunkle Menüleiste / Dock, aber helles Design wie früher. Entweder alles dunkel, oder alles hell.

    Die Grafik hat anscheinend einen neuen Featureset-Identifier.


    Bugs bisher:

    • In Vorschau, Quick Look und der neuen Screenshot-UI werden ab und an Teile des Bildes nicht angezeigt.

    EDIT: Gefühlt läuft es auf einer HDD flüssiger als High Sierra auf HDD. Vielleicht liegts an APFS - es werden jetzt anscheinend auch HDDs automatisch konvertiert, zumindest habe ich sie als HFS+ formatiert und jetzt ists APFS.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 12.0.1, Manjaro Linux


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 12.0.1, Manjaro Linux


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 12.0.1), iPhone X 64GB (iOS 15.1)

    Edited once, last by DerJKM ().

  • bei mir hängt er im boot „kextd stall0 appleACPICPU“ ganze weile

    iMacPro 1.1   Monterey (OC 0.8.5 ) Gigabyte Z390 Aorus Master 1.0 Bios F11f - Intel i9-9900K - Sapphire Radeon Pulse RX 5500 XT (8GB) - NVMe WD Black SN850 (1000 GB, M.2 2280) - Corsair Vengeance LPX DDR4 16GB Kit (2 x 8GB)- WI-FI /Bluetooth 4.0 BCM943602CS

    real iMac 13.1    Ventura 13.01 (late 2012)

    MacBook Pro 14.2 Ventura 13.0.1   13" 2018


  • @schmalen hast du die Clover.efi von oben umbenannt und eingesetzt? Du musst sowohl EFI/CLOVER/CLOVERX64.efi, als auch EFI/BOOT/BOOTX64.efi ersetzen.

    iHack: Ryzen 5 1600, GA-AB350M-D3H, Sapphire RX570 4GB, 32GB DDR4-3200, 250GB NVMe SSD + 512GB SSD + 1TB HDD, OC, macOS 12.0.1, Manjaro Linux


    alter iHack: i3-4330, GA-H81M-HD3, Sapphire RX460 4GB -> RX560 BIOS, 8GB DDR3-1600, 128GB SSD, 250GB HDD, OC, macOS 12.0.1, Manjaro Linux


    ThinkPad T410: i5-520M, Nvidia NVS3100M, 4GB DDR3-1066, 120GB SSD, 250GB HDD, Clover, macOS 10.14.6


    Bastlerware: Acer Aspire 7741G: i5-430M, ATI HD 5650 1GB; 4GB DDR3-1066; 250GB HDD, Clover, macOS 10.13.6, 1.5 von 2 SATA-Ports defekt...


    Originals: MacBook Pro 15 Late 2013 (macOS 12.0.1), iPhone X 64GB (iOS 15.1)

  • So nachdem ich Mojave erstmal auf dem MacBook Pro installiert hatte, kam auch der Hack2 dran.
    Dazu habe ich den bisherigen Clover Ordner auf den USB Stick gepackt und die Bootx64.efi und Cloverx64.efi mit der oben geposteten ersetzt.
    Installation lief, bis auf das manuelle auswählen der richtigen Bootpartition, wie geschmiert.
    AppleALC scheint nicht mehr zu funktionieren. Die RX560 hat jedoch auch hier wieder HDMI Sound, somit kein Problem.


    Werd mir dann später am Tag auch mal die Xcode Beta laden und schauen wie der Dark Mode sich da macht.

    Images

    CFL-Hack mini: i5 10400 - Asrock B460M Steel Legend - 4x8GB Corsair Vengeance LPX 2666MHz - Gigabyte RX 460 @ RX560 BIOS + BCM943602CDP PCIe Wifi + GC-Titan Ridge - iMacPro SMBIOS - macOS Monterey + Windows 11
    Original Apple: Macbook Pro Retina 13" Early 2015 (MF840D/A) - macOS Monterey

    Original Apple: MacBook Air 2020 M1 (MGN63D/A) - macOS Monterey