Sleep, Hibernate und Co

  • Vorgeschichte: Ich fahre seit langem einen Hackintosh (i5-6600, Radeon R9 270, Samsung 950 Pro NVMe, Shuttle SH270), zuerst mit 10.10 und weiter upgedatet bis 10.11.6, dann wollte die Maschine nach einem Update nicht mehr hochfahren. Da ich keine Zeit hatte, hab ich ein Backup zurückgespielt und seitdem kein Systemupdate mehr gefahren. Die Maschine wollte zwar keinen Sleep, aber Hibernate, über "Ruhezustand" aus dem Systemmenü heraus, funktionierte.


    Nun hab ich mir endlich mal die Zeit genommen, Clover aktualisiert, und bin bei erfolgreich bei Mojave 10.14.3 gelandet. Von VoodooHDA auf AppleHDA umgestellt, alte KEXTs rausgeworfen. Leider funktionieren weder Sleep noch Hibernate, mit allen hibernatemode rumgespielt. Beim Boot mit hibernate macht die Maschine sofort bei "Check hibernate state" ein Reboot.

    In ein zweites Volume des APFS Containers hab ich ein frisches Mojave installiert. Diese Doppel-bootet dadurch jetzt mit den gleichen Clover. Auch dieses will nicht aus dem Hibernate zurückkommen, aber der Sleep funktioniert. Die Hardware+Clover kann also Sleep, nur die alte/upgegradete Version nicht.


    Woran kann es noch liegen?

  • Hallo und herzlich willkommen im Forum,

    es kann viele unterschiedliche Ursachen haben warum der wake nicht will. Am besten trägst du einmal deine Hardware in dein Profil ein und dann sei so lieb und lade noch deinen aktuellen EFI-Ordner hoch, damit wir einmal drüber scheuen können. Dann kann dir bestimmt auch geholfen werden.


    MFG Patrick

    Lange Weile? Dann besucht doch meine Website: patricksworld.de


    Meine Systeme:


  • Anhängend mein EFI.


    Gruss

    Andreas

    Dateien

    • EFI.zip

      (19,19 MB, 7 Mal heruntergeladen, zuletzt: )
  • mit allen hibernatemode rumgespielt.

    Hast du mal die darkwake modi durchgetestet?

    Lange Weile? Dann besucht doch meine Website: patricksworld.de


    Meine Systeme:


  • Nutz folgenden Command im Terminal und dann versetz deinen Hackintosh in den Sleep, guck nach dem aufwachen was im Log steht. :)


    log show --style syslog | fgrep "Wake reason"

  • Hast du mal die darkwake modi durchgetestet?

    Diverse bevor ich das 2. macOS aufsetzte. Da das ja normal aus dem Sleep aufwacht, sollte die Clovereinstellung korrekt sein.


    Dnl :

    log show zeigt Wake reason: Host (0x01) an. Da der Rechner nicht aus dem Sleep hochkommt, sondern nach dem Re-Hibernieren rebootet stehen im Log nur die Bootmeldungen.

  • Da das ja normal aus dem Sleep aufwacht, sollte die Clovereinstellung korrekt sein.

    Ja. Wahrscheinlich schon... Ich nutze hibernate leider nie. Was hast du denn für ein Hibernate mode gewählt? Die 0?

    Auch mal in BIOS-Settings gestöbert, ob da eventuell noch was zu verändern ist?

    Lange Weile? Dann besucht doch meine Website: patricksworld.de


    Meine Systeme:


  • Ja. Wahrscheinlich schon... Ich nutze hibernate leider nie. Was hast du denn für ein Hibernate mode gewählt? Die 0?

    Auch mal in BIOS-Settings gestöbert, ob da eventuell noch was zu verändern ist?

    S.o.: Alle Hibernatemodes ausprobiert. Eingestellt ist 0, die Maschine verhält sich aber wie 3: Bildschirm wird dunkel bei sleep, lange Diskaktivität, dann Maschine aus. Nach Powerbutton kommt Biosmeldung und Versuch aus dem Hibernate zu restaurieren mit sofortigem Fehler/Reboot. AUCH BEI hibernatemode=0!


    Im BIOS ist nichts aufregendes, nicht verändert seit 10.11 welches ja noch problemlos Hibernate konnte. Irgendwas außerhalb von Clover sagt dem macOS offenbar daß Sleep nicht geht, die andere Installation kanns ja mit dem gleichen Clover.