Mojave installation

  • Welche Clover Version verwendest du?


    übrigens brauchst du Bilder nicht zu zippen, die kannst du direkt hochladen

    Meine Systeme



  • verwende den Clover_v2.4k_r4520


    hier mein EFI Ordner

    Dateien

    • EFI.zip

      (4,62 MB, 12 Mal heruntergeladen, zuletzt: )

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • wo sind deine Kexte? einen fakemsc solltest du schon mindestens haben um zu booten

    Meine Systeme




  • Im zweiten Beispiel wird das Device PEGP in GFX0 umbenannt sprich alles was vorher PEGP geheißen hat ist jetzt GFX0 das PEGP Device ist verschwunden anschließend wird GFX0 in IGPU umbenannt das Ergebnis dieser Operation ist ein einziges Device mit dem Namen IGPU in dem Die Informationen zu GFX0 und PEGP enthalten sind. Das zweite Beispiel führt mit einer Wahrscheinlichkeit dazu das macOS nicht starten wird weil es mit dem auf diesem Weg gebauten IGPU Device nicht umgehen kann.


    Nee. Im zweiten Fall wird das vorhandene PEGP in GFX0 umgewandelt, nun gibt es zwei solche Devices. Im nächsten Schritt werden beide nach IGPU umgewandelt. Das ist, was konkret in der DSDT passiert – und nicht nur da, falls diese Devices auch noch in weiteren internen SSDTs auftauchen – denn Clover Werkzeug dazu ist mächtig und durchforstet die gesamte ACPI. Nebenbei bemerkt verstehe ich deshalb auch nicht, warum das dann DSDT-Patches heißt, es sind ganz klar ACPI-Patches.
    Nur zur Richtigstellung, in der DSDT stehen nun zwei Device-Einträge "GFX0". Das an sich ist schon unschön, könnte aber durchaus noch macOS zum booten bewegen. WENN da nicht jetzt noch ein weiteres Elend hinzukommen würde. Befinden sich die beiden "GFX0" im selben Scope, so ist die DSDT nun fehlerhaft, weil es keine zwei gleichnamige Devices innerhalb des gleichen Scopes geben darf. Was sehr wohl geht, ist ein weiterer Scope-Eintrag mit gleichen Namen zur Erweiterung (das nutzt man gern bei SSDTs). Liegen die Scopes auseinander, so ist aus Sicht der DSDT erst mal kein Fehler drin, es sind dann tatsächlich zwei voneinander völlig unabhängige Devices, die lediglich den gleichen Namen haben. Eine Zusammenführung zu einem einzigen Device passiert also hier auf keinem Fall. Was macOS dann daraus macht, ist eine andere Sache.


    Trotzdem ist klar, dass die Reihenfolge bei der Umbenennung via Clover entscheidend ist. Denn Clover benennt SÄMTLICHES in der gesamten ACPI um, was man dort eingibt. Ein wunderbares Beispiel ist die Umbenennung sämtlicher _DSM-Routinen, also etwa "_DSM zu XXXX". Man kann mit Clover ja nicht wirklich etwas aus der DSDT löschen. Hiermit aber werden alle _DSM-Routinen in XXXX-Routinen umbenannt, die weiterhin dann in der DSDT so existieren. Nur werden diese dann nicht mehr erkannt, ausgelesen, berücksichtigt. Also kann man nun getrost in einer SSDT bestimmte eigene _DSM-Routinen einbauen, ohne Angst zu haben, das diese in Konflikt mit bestehenden geraten. Denn dann sind wir wieder beim obigen Punkt, dass es keine zwei gleichen Einträge innerhalb des gleichen Scopes geben darf.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt EX3 • 2x AMD Radeon RX Vega 64

  • hat jemand vielleicht ein passenden efi ordner für mich mit meinen bootet er nicht

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • der kann ja nicht booten ohne Kexte im Kext-Ordner. Ausserdem ist dein SMBios nicht erstellt. Die ganzen Fixe die im ACPI Bereich angehakt sind, scheinen auch suspect,
    Bei mir ist ausser FixHDA nichts angehakt

    Meine Systeme



    Einmal editiert, zuletzt von Nightflyer ()

  • Denke wr hat einfach ne sample_config genommen

    Gruss, Andy



    Keine Unterstützung per PN! Eure Anfragen gehören zu den Profis, nicht zu den Anfängern! :whistling:

  • so hab jetzt Mojave installiert läuft auch nur wird meine Grafikkarte nicht erkannt

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • Wie erkenns du das

    Gruss, Andy



    Keine Unterstützung per PN! Eure Anfragen gehören zu den Profis, nicht zu den Anfängern! :whistling:

  • unter Apfel über diesen mac steht nur 7mb

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • Wenn du keine Kexte drin hast wird sich daran auch nix ändern

    Gruss, Andy



    Keine Unterstützung per PN! Eure Anfragen gehören zu den Profis, nicht zu den Anfängern! :whistling:

  • geht es um die gtx 1050?
    Die braucht den Nvidia Webdriver und im Cloverconfigurator muss bei Systemparameters NvidiaWeb angehakt sein

    Meine Systeme



  • hab den webdriver für higsierra genommen Bildschirm bleibt nun schwarz bin jetzt wieder am neu installieren


    kext hab ich auch drine sonst hätte ich es ja nicht installieren können ;)

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • Wieso wieder neuninstallieren? Kannst du nicht mit der internen GPu installieren slles einstellen das alles topi läuft und zum schluss die graka ausprobieren?

    Gruss, Andy



    Keine Unterstützung per PN! Eure Anfragen gehören zu den Profis, nicht zu den Anfängern! :whistling:

  • Bildschirm bleibt nach den booten schwarz kann nix mehr einstellen

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • bildschirm bleibt schwarz, auch wenn du mit der iGPU bootest und den Monitor da anschliesst?

    Meine Systeme



  • hab jetzt schon neu installiert Bildschirm wieder da

    IMAC 5K - Gigabyte GA-Z17M0X - Intel Core i7-6700K - Asus ROG Strix GeForce GTX1050TI - 16GB RAM 1TB HDD WD Blue

  • und Grafikkarte richtig erkannt?
    Dock und Symbolleiste transparent?

    Meine Systeme



  • leider nicht Grafikkarte wird nicht erkannt

  • Wenn es um die GTX1050TI geht bekommst die auch nur bedingt zum laufen mit diesem Tool:
    https://www.hackintosh-forum.d…?postID=360807#post360807


    Ohne Metal bis der erste Treiber für Mojave raus ist.


    :hackintosh: