Anleitung: USB 3.0 Mojave / (High-) Sierra / El Capitan für jedermann (zukunftssicher für Updates & komplett gepatcht)

  • Ja, hatte ich versucht. Dann gingen aber kaum wieder welche, einschließlich BT

  • Ich sehe gerade, es gab einen Commit mit uia_include. Früher hat die Kext alle verfügbaren USBPorts injected, deswegen auch der Name. Jetzt tut die Kext das wohl nur noch, wenn man sie explizit dazu anweist...

    Nein die muss raus, die brauchst du nur um alle Ports zu erkennen.

    USBInjectAll muss drinnen bleiben, das Bootarg -uia wird von UsbInjectAll eingelesen und verarbeitet, Apple kennt uia nicht. Wenn du die Kext nicht willst (auch wenn sie keinen Schaden anrichtet), kannst du auch deine eigene Kext schreiben. Mit dem Wissen was du durch diese Anleitung erlangt hast, ist das jetzt kein Problem mehr, Anleitungen gibts einige.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Wollte sie schon gern loswerden, da damit der Sleep-Modus nicht funktioniert hat. Das mit der eigenen Kext habe ich dann nach Anleitung von al6042 mit dem Hackintool gemacht. Hat problemlos geklappt :)

  • Guten Abend, ich sitze jetzt seit 2 tagen daran meine USB Ports zum laufen zu bringen und ich komme einfach nicht weiter. Ich hoffe ihr könnt mir helfen. Unten im Anhang findet ihr meine EFI sowie ein Bildschirmfoto auf dem ihr links sehen könnt welche Ports bei mir erkannt wurden und rechts welche Ports es bei mir gibt.

    Vielen dank für eure Hilfe LG

  • Wo kommst du denn nicht weiter?

    LG Chris


    Meine Hardware:

  • Ja, deiner Nachricht kann man jetzt nicht so direkt entnehmen, was das Problem ist. Dem Screenshot nach zu urteilen vermute ich mal, dass du die einen Großteil deinen Ports über das Tool nicht zuordnen konntest? Falls ja, versuch es mal mit dieser Ansicht


    Hatte damit wesentlich mehr Erfolg, da man nicht erst schauen muss, wo genau im Baum sich was geändert hat. Die grüne Markierung verschwindet nämlich recht schnell wieder.

  • In erster Linie würde ich das ganze mal mit Hackintool erledigen statt alles händisch zu machen. Deutlich komfortabler und Einfacher gerade für Einsteiger. Port Limit Patch rein und dann meinen Standard Textbaustein befolgen:

    LG Chris


    Meine Hardware:

  • Sorry wegen meiner schlechten Erklärung war leider schon sehr spät gestern. Ich konnte einen Teil meiner Ports über das Tool wirklich schlecht zuordnen. Jedoch habe ich die die ich zugeordnet habe anschließend in das Boot arg Feld von Clover eingefügt und leider haben danach nur die gleiche Anzahl an Ports wie zuvor funktioniert. Habe anschließend versucht das Boot arg anzupassen jedoch hat dies auch nicht geholfen. Habe jetzt das Hackintool benutzt und festgestellt das 1 Port mehr erkannt wurde als ich es zuvor bemerkt habe. Ich habe eben der Anleitung von CMMChris gefolgt und mir wurden die Dateien erstellt. Anschließend habe ich USB inject all aus dem kext folder entfernt und die USBPorts.kext eingefügt. Es funktioniert ein Port mehr jedoch fehlen 2 weitere. Liegt es vielleicht daran, dass ich in Clover noch Boot args für die USB ports drinnen habe ? kann ich diese einfach entfernen ?

    Vielen dank für eure schnelle Hilfe :danke:

    LG

    Emir

  • Raus können sie in jedem Fall. Ich fürchte aber, dass das am Problem nichts ändert. Meine, dass die ohnehin nur von USBInjectAll genutzt wurden.

  • stimmt, das hat leider nicht geholfen. Was mich jedoch wundert ist das vor dem letzten OS update alle meine USB ports funktioniert haben und einfach nach dem Update aufgehört haben zu funktionieren. Hatte zuvor nur die USBInject all Kext drinnen sowie den USB fix an.

  • Mach mal einen Screenshot von den Port Limit Patches die du genutzt hast um die USB Ports mit Hackintool einzurichten. Außerdem darfst du keine USBInjectAll Args nutzen fürs Einrichten wenn du per Port Limit Patch alle USB Anschlüsse ins System bringst.

    LG Chris


    Meine Hardware:

  • CMMChris hier ist ein Screenshot von den Patches die ich genutzt habe.Habe es auch eben ohne Boot args versucht klappt leider genau so wenig.

  • Falschen Screenshot erwischt? Zu sehen ist hier der Grafik Patching Bereich vom Hackintool.

    LG Chris


    Meine Hardware:

  • Hallo,


    wollte gerad nach einer clover Neu-Installation per "generic install" boot-stick v.

    mein System optimieren (siehe Signatur) und in dem Zusammenhang eben auch die

    ungenutzen ports "excluden". Nun bin ich an der Stelle, wo USB 2.0

    zwar läuft (da habe ich gerad alle ports abgeklappert und aufgescchrieben),

    3.0 aber nicht, und ich weiss nicht mehr, wie man das Problem angehen

    konnte.. Bei meiner früheren Installation hatte ich es am Laufen...


    Kann mir da jmd kurz nen Erinnerung geben?

    Danke

  • USBInjectall.kext (wenn vorhanden eigene USB.kext oder SSDT raus.

    Dann das Hackintool nutzen.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • USBInjectall ist am start.. Das mit dem hackintool hatte ich seinerzeit nicht gemacht...

    hmmm...

  • Da gibt es auch noch direkt im Programm eine Anleitung.


    Auch im CloverConfigurator solltest du nochmal nachsehen ob da alte Portlimit Patches drin sind.

    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte.


    Hardware:

  • locojens schlägt hier eine ganz andere Methode, also eine Alternative zu USBInjectAll vor.

    Wenn du aktuell jemanden fragst wie man seine USB Ports patcht, wird dir die Dummy-/Hackintool- Kext Methode vorgeschlagen. Würde ich als Trend bezeichnen, USBInjectAll funktioniert wie eh und jeh (unter Ozmosis besser als Dummy-Kext), andererseits muss ich auch zugeben, dass ich selbst ebenfalls eine abgeänderte Version eines Dummy-Kexts benutze und das Hackintool für Anfänger evtl.

    einfacher zu bedienen ist.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Aaalso, step by step... habe den " Remove 15 port limit completely 10.14" patch in clover drin, plus USBInjectAll

    Soll ich nun erstmal den patch entfernen?


    (wie gesagt, mein Problem ist, dass USB 3.0 Geräte nicht laufen, die ports hingegen sind alle funktional)


    ...Wenn du aktuell jemanden fragst wie man seine USB Ports patcht...

    Was heisst das genau? BIsher bin ich auf zweierloei Probleme gestossen:

    1. nur USB 2 Geräte laufen

    2. es funktionieren nicht alle ports


    Bei meiner alten Installation war es so, dass erst nicht alle ports funktionierten. Da hatte ich, WIMRE, erst die USB 3 Funktionalität hergestellt

    (weiss halt leide nicht mehr, wie), und dann mit der in diesem thread beschr. Methode alle ports ans Laufen gebracht.

  • Welche macOS Version läuft denn aktuell bei dir? Der Port Limit Patch ändert sich meist mit jedem Update.

    LG Chris


    Meine Hardware: