EFI FÜR SONOMA

  • Hallo Freunde, kann mir jemand einen Hinweis geben was in der Ventura EFI geändert / hinzugefügt werden muss damit Sonoma läuft ? wird meine RX 580 Grafik noch Unterstützt ?

  • Die markierten Texte und Bootargs und die SIP, dann müsste alles Laufen, außer ggf. WLAN/BT, je nach Setup. Die RX580 macht keine Probleme.

    amfi=0x80 nach der Installation durch -amfipassbeta ersetzen.


    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Ich kriege da immer Pickel, bei diesen ein-Satz-Anfragen "könnt Ihr mir mal die Brötchen backen?"

    Erster Post Tread "MACOS 14 SONOMA BETA" war bereits Juni 2023, inzwischen 83 Folge-Seiten, wo alle Probleme gezeigt und genannt werden, aber selbst mal was Lesen ist inzwischen ja überbewertet, oder?


    Arkturus

    natürlich, wenn man es versteht, dann reicht auch ein Satz für die Frage, sofern Dein Post verstanden wird, was ich nicht wirklich glaube.

    Medion P9614: C2D 2,8GHz 8GB DDR3 GT330M 512GB FullHD intern BCM WLAN/BT SSD 512GB + 512GB + 1TB macOS Catalina / Win10pro 8)

    Real: MacMini M1: 8GB 32" LG 4k SSD 250GB + 1TB nvme USB-C + 1TB thunderbolt nvme macOS 14.5 / macOS 15

    MacBook Air M2 15": 8GB SSD 512GB macOS 14.5

    MacMini2014: i5 2,8GHz 16GB DDR3 Intel Iris 5100 23" Apple-Cinema 1TB NVMe / 1TB HDD macOS 13.6.6

    iPhoneSE 3.Gen 128GB: iOS 17.4.1 iPad Pro 9,7" WiFi 32GB: iPadOS 16.7.7 MacPro3,1 macOS 13.6.4 / 14.4

  • Arkturus ,vielen lieben Dank für die kurze präzise Antwort. Das reicht mir schon und nun backe ich meine Brötchen selber weiter wie MacPeet das so abwertend bemerkt hat. MacPeet ich bin 70 Jahre und das ist alles nicht mehr so schnell im Kasten.Ich hatte schon hier im Forum Beiträge dazu gelesen, aber nicht richtig verstanden. Ich dachte das dieses Forum ''AUCH'' für Amateure da ist um Fragen zu stellen und keine Spezialisten Ecke. Ich werde mich in Zukunft zurückhalten und keine Fragen mehr stellen.Ich bin nun mal kein Voll Profi wie Ihr.Ich habe 2 Freunde in meinem Alter die auch gerne einen Hacki bauen würden, aber an Hand solcher Bemerkungen sich einfach nicht trauen.@Arktus deswegen noch einmal vielen lieben Dank für Deine kameradschaftliche Antwort.

  • ich bin 70 Jahre

    Das ist keine Ausrede. Ich bin 72 und kriege meine Brötchen dank der Zutaten hier im Forum auch gebacken

    Too Old To Rock 'n' Roll; Too Young To Die!

    Mein System


  • Nightflyer , dann sagt doch konkret das man in diesem Forum keine Fragen stellen soll und sich Bitteschön nur durch Belesen der Beiträge helfen muss. Ich entschuldige mich viellmals Eure Gottheiten mit simplen Fragen belästigt zu haben.Vielleicht kommt Ihr auch mal in die Situation das Ihr Hilfe braucht von einem Thema was Euch schwer fällt.Ich hoffe das Ihr dann auch solche Antworten bekommt.Ihr solltet den Forum Namen ändern. HACKINTOSH FÜR PROFIS..Amateure unerwünscht.Manche hier sind ganz schön abgehoben... Gott sei Dank gibt es ein paar Ausnahmen.ich werde in Zukunft nur noch lesen und gar keine Fragen mehr stellen. Hat alles keinen Sinn mehr hier...

  • WITON Ich bin voll auf deiner Seite und stehe voll und hinter deinen Kommentaren.Hier gibt es viel zu viele hochnäsige Gernemöchter, bin 79 und mach seit Jahren nicht mehr in diesen Forum mit denn einige Leute kotzen mich hier einfach an. Es gibt viele andere Quellen wo man sich informieren kann und wo mann auch freundlich untergebracht wird.


    Güße Henties

  • Ähm ich finde das weder Alter noch Wissenstand ein Kriterium sein sollte...


    Natürlich kann und soll man hier Fragen stellen auch und gerade als Amateur und natürlich bekommt man dann, abhängig davon wie die Frage formuliert ist, in der Regel auch recht schnell und zielgerichtet Hilfe geboten. Die Wahrheit ist aber hier wie anderswo das es eben auch hier nur Menschen unterwegs sind die zum Beispiel auch mal einen schlechten Tag haben und daher vielleicht auch mal "patzig" oder sarkastisch antworten. Es kommt eben immer und bei allem auch darauf an wie man etwas formuliert denn es ist schon ein Unterschied ob man Hilfe bei etwas möchte ansonsten aber erkennbar Eigeninitiative zeigt oder ob man die Erwartungshaltung hat das man Dinge gemacht bekommt. Helfen wollen hier eigentlich alle nur den Leuten buchstäblich den Hintern nach tragen das möchten verständlicherweise die wenigsten machen.


    Wie schon gesagt es hängt sehr viel an der Formulierung der Frage hätte man nämlich bereits in der initialen Frage die Information untergebracht das man sich durchaus selbst belesen hat aber den Ausführungen nicht so recht folgen konnte weil man eben nicht so den großen technischen Sachverstand hat, wie ja dann ein paar Posts weiter auch ausgeführt wurde, wäre das kein Problem gewesen und das Thema so gar nicht erst aufgekommen. Es ist eben leider so das die deutsche Sprache, gerade die geschriebene, relativ viel Raum für Interpretation lässt. Je Weinger Information transportiert wird umso mehr Raum bleibt für Interpretation und das kann dann, abhängig von der Tagesform des Lesers, durchaus auch schonmal in die falsche Richtung gehen...

  • griven Danke für deine Sachliche Antwort wie immer :top: Es ist nicht so das ich mir nicht selber helfe.Ich habe eine neue EFI für Sonoma selber gebastelt und alle Kext und OC aktualisiert.AMFIPass,RestrictEvents,CryptexFixup hinzugefügt. Check zeigt keine Probleme. Anscheinend habe ich noch einen Fehler in den Bootargs.Die Installation läuft ohne einen Fehler im Verbose Mode durch. Nur zum Schluss lande ich in einer Schleife. Ständiger Neustart ohne Ende. Vielleicht hätte ich das so konkret schreiben sollen, da ich hier am Ende bin.Also Brötchen backe ich schon selber und es dauert sehr lange bevor ich eine Frage stelle, da ich schon mehrfach hier unqualifizierte Antworten erhalten habe. Vielleicht erinnerst Du Dich noch wo ich stolz wie Bolle einen Screenshot meines Hacki gepostet hatte und irgend ein Dünster mir unterstellt hat ich würde geklaute Software verwenden weil das ICON anders war wie das Original.Icvh frag mal ganz schüchtern nach... [hust] hast Du einen kleinen Tipp warum der Bootvorgang in einer Schleife endet ? Meine Grafik RX 580 dürfte keine Probleme machen. Aber bei den Bootargs scheint was zu klemmen... ich habe es so eingestellt wie Arkturus es weiter oben empfohlen hat

  • Die 'kann mir einer ne EFI machen'-Anfragen kommen hier doch meist von jüngeren, von denen, die sich eigentlich auskennen und dazu in der Lage sein sollten sich Informationen im Internet zu beschaffen aber schlicht zu faul zum lesen sind und sich maximal ein Youtube Howto sehen wollen... da kann ich solche Reaktionen auch verstehen. Kam hier bei mir aber nicht so rüber. Den Frust kann ich auch gut nachvollziehen. Die User die auch einen Anfänger an die Hand nehmen, nicht um im alles vorzukauen aber den Weg aufzeigen, sind lange weg oder verstummt. Genauso wie die, die hier tolle Beiträge geschrieben haben nur um ihr Wissen zu teilen. Sehr schade aber ist nun mal so. Auch die 'Anfänger'-Threads habe ich vor ein paar Jahren immer gerne verfolgt und viel dabei gelernt. Jetzt schaue ich nur noch selten vorbei, lese 10 immer gleiche 'Hier geht's zum Wiki'-Post... und bin dann auch wieder weg...

    Mac Pro - Gigabyte GA-H87-D3H - i7-4790K 4.40 GHz - HD Graphics 4600 - 4 x 8 Gb DDR3-RAM - OS X 10.9.5 - MacOS 10.15
    Power Mac - Foxconn G31MG-S - Core 2 Duo E8500 3.17 GHz - 2 x 2 Gb DDR2-RAM - ATI HD6450 1GB - OS X 10.9.5 - OS X 10.11.6

    ThinkPad T450

    ThinkPad X240
    iMac 27" (Late 2015) - Mac mini Server (Late 2012)

  • WITON es ist schwierig Dir etwas zu raten wenn man nicht zumindest die config.plist mal vor Augen hat vielleicht magst Du die ja noch ergänzen?


    Generell die RX580 ist kein Problem und wenn es bei Dir um das System in Deinem Profil geht ist zum Beispiel der CryptexFixup.kext gar nicht notwendig denn der wird nur bei Systemen ohne AVX-2 benötigt (also bis inkl. IvyBridge CoreI 3 Generation) auch AMFIpass brauchst Du nur dann wenn Du irgendwas auf Rootlevel ins System einbringst (-> OpenCoreLegacyPatcher) gleiches gilt für RestrictEvents auch der wird eigentlich nur benötigt wenn Du mit einer nicht mehr offiziell unterstützten Systemdefinition unterwegs bist oder aber etwas am RootVolume verändert wurde. Du siehst es gibt bei Deinem Setup einige Stolpersteine die aus dem Weg geräumt gehören...

  • Hallo griven , Danke für die nützliche Info. Vielleicht könntest Du mal einen Blick auf die Plist werfen.Du musst mir die List auch nicht die bearbeiten.Das kann ich selber dann versuchen.Aber den Fehler vielleicht eingrenzen und eine Info geben. Das währe nett. LG Udo

  • Kann ich machen allerdings erst heute Abend denn aktuell bin ich bei der Arbeit und habe nicht die Möglichkeiten in die EFI zu gucken....

  • Hey zusammen,


    WITON

    Bei vielen kommt eine Frage „macht mir einer ne EFI feddig?“ gar nicht gut an, ich denke das ist auch klar warum. Hilfe zu Selbsthilfe ist das Motto am Ende des Tages, dass ist der Unterschied zu anderen Foren. Der Gedanke hier ist am Ende von Nachhaltigkeit geprägt und die Nachwelt sich selber beliest. Das habe ich bei meinem Job auch immer so gehandhabt und meine Standartantwort ist: „guck im Ordner nach“. Das nehmen viele sehr negativ auf, aber wenn ich mal erkläre warum, ich das so trocken erwidere, dann verstehen es die Meisten.

    Die Infos wo wie und was die liefere ich, die Lösung sollte dann aber auch selbstständig erarbeitet werden.

    Das sehen nicht alle so, die wollen die Lösung haben und fertig… selbstdenken? Niemals.
    Das habe ich von meinem Ausbilder damals gelernt, seine Standartantwort war immer: Guck im Ordner nach. Hat mich immer übelst abgefuckt, aber ich habe es dann iwann verstanden, was er am Ende damit bezwecken wollte.

    Aber man muss auch die Kirche im Dorf lassen bei manchen Sachen, genauso wie in deinem Fall.

    Du bist ja einer der selbst Hand anlegt und versucht es zu lösen und da brauchst du manchmal nur die Info wo es steht etc. das ist auch vollkommen legitim. Finde das es Leute gibt die vllt zu vorschnell urteilen, dazu neige ich auch, aber dein Name ist mir bekannt und du bist eher nicht der Kandidat, der alles auf einem silber Tablet serviert bekommen möchte.


    Und generell habe ich immer gelernt, dass man ältere Kollegen unterstützen sollte, egal wie… man lernt auch was dazu, auch wenn es am Ende „nur“ zwischenmenschlich ist. Aber da kommen wir doch alle hin und ich denke, man sollte daher nicht voreilig Schlüsse ziehen… über Hilfe ist doch jeder Dankbar. Manchmal kommt es nur auf die Frage an und im Netz kommen manche Fragen/ Aussagen falsch rüber und werden falsch verstanden… ist wie Streit mit der Freundin über Whatsapp, das sollte man immer im Hinterkopf haben, egal auf welcher Seite man steht.


    Sorry für den Aufsatz, wollte ich aber loswerden.

    Ich küsse eure Augen Habibis, habt euch lieb ❤️

  • ich hab mal schnelle eine Blick in dem Config.plist geworfen, WITON


    schiebe mal AMFIPass.kext in der Reihenfolge unter Kernel/Add gleich unter VirtualSMC.kext

    Bei den Bootargs fehlen Leerzeichen zwischen den einigen bootargs und da hat sich ein b reingeschummelt.


    SMBIOS würde ich iMacPro1,1 empfehlen, was für die RX580 zuträglich ist.


    Viel Spaß damit und vielleicht hat griven weiter Tipps.


    EDIT: halt mal den Ball hier etwas flacher, anstelle immer wieder Öl ins Feuer zu gießen, henties

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Arkturus … hat nichts gebracht.. habe Leerzeichen gesetzt und einen Schreibfehler in den Bootargs korrigiert. Kein Erfolg. Bootet weiterhin in ständiger Schleife nach Installation. Vor dem erneutem Bootvorgang kommt diese Meldung

  • WITON


    Sorry, vermutlich hatte ich einen dieser schlechten Tage. Natürlich sollte es kein persönlicher Angriff werden, liegt mir auch fern.

    Weitere Infos in Post#1, wie "Dies habe ich bislang selbst versucht... und/oder hier bleibe ich hängen..." hätte auch jede Diskussion überflüssig gemacht, denn dann hätte man die Eigeninitiative auch bereits vorab gesehen.

    Deine Thread-Überschrift hat es hierbei nicht wirklich besser gemacht.

    An meiner Grundaussage halte ich aber fest, auch wenn es Dich jetzt zu unrecht getroffen haben sollte.


    So, alle wieder runter kommen, die Schuld liegt bei mir, hätte auch anders Fragen können "z.B. Was hast Du für den Wechsel auf Sonoma bislang selbst getan, bzw. wo genau klemmt es?", aber die erste Reaktion ist vielleicht nicht immer richtig, hab Ihr sicher auch alle schon selbst erlebt.

    Da sich die Sache, wie es KungfuMarek es in seinem ersten Satz beschrieb, leider sehr häuft, zieht man dann alle über einen Kamm, was vielleicht auch nicht immer richtig ist. Ich bin halt kein Freund von 0 Infos geben und die Lösung erwarten. Tut mir leid, ist halt so.

    Alter ist für mich allerdings gar keine Entschuldigung, egal ob jetzt 70 oder 79. Ich bin noch keine 70, aber gehe gefühlt in mega schnellen Schritten darauf zu. Allerdings, Hirn altert nicht, wenn man was für's Hirn tut, es immer wieder trainiert, auch im Alter und Lesen verlernt man doch nicht, oder?

    Anfang August bin ich zum 90. Geburtstag eingeladen, ja der Körper schwächelt schon hier und da, aber was der Mann noch heute im Hirn hat, hätte ich gern.


    Edit:

    Wenn ich mir Deinen Post#9 so ansehe: "Ich habe mir für Sonoma eine neue EFI gebaut", warum? Wenn Deine EFI mit Ventura sehr gut lief, dann bitte nicht alles neu machen, lediglich die Neuerungen bei config.plist, Kext's, etc. aufnehmen. Ihr macht Euch die Sache aber auch oft selbst zu schwer.

    Mit gewissen Anpassungen kann man eine EFI bereits sicher von mindest Mojave mitnehmen. Es ist auch ein grundlegendes Fehldenken, dass man unbedingt auf neustes OC muss, selbst OC0.9.3 geht noch mit Sonoma, wenn alle anderen Anpassungen stimmen.

    Betreffs OCLP, wenn man auf z.B. die WLAN-Patches angewiesen ist, empfehle ich allerdings auch mindestens das aktuelle Release, wenn nicht sogar die aktuelle Beta, weil die Änderungen hierbei so schnelllebig sind, welche Apple immer wieder bringt.


    Laut Deinem Letzten Bild scheitert der Boot ja schon in einer ganz frühen Phase, bevor der Boot überhaupt richtig los geht.

    Medion P9614: C2D 2,8GHz 8GB DDR3 GT330M 512GB FullHD intern BCM WLAN/BT SSD 512GB + 512GB + 1TB macOS Catalina / Win10pro 8)

    Real: MacMini M1: 8GB 32" LG 4k SSD 250GB + 1TB nvme USB-C + 1TB thunderbolt nvme macOS 14.5 / macOS 15

    MacBook Air M2 15": 8GB SSD 512GB macOS 14.5

    MacMini2014: i5 2,8GHz 16GB DDR3 Intel Iris 5100 23" Apple-Cinema 1TB NVMe / 1TB HDD macOS 13.6.6

    iPhoneSE 3.Gen 128GB: iOS 17.4.1 iPad Pro 9,7" WiFi 32GB: iPadOS 16.7.7 MacPro3,1 macOS 13.6.4 / 14.4

    Edited 2 times, last by MacPeet ().

  • ich hab hier lediglich mal ein Bootarg gekürzt und OC aktualisiert auf 1.0.1 Da ich deine Version nicht kannte.SMBIOS iMacPro1,1 ohne SN zu genieren. Solltest Du dabei bleiben, bitte machen.

    Der RestrictEvents.kext wurde auch aktualisiert.


    Versuchs mal. Wenn das immer noch nicht geht, dann musst Du die Dortania Guide komplette durchgehen und alle Qirks abgleichen.


    EDIT: und ja, dass hättest Du alles selbst herausfinden können, aber erstmal muss es ja klappen. Vielleicht bin ich auf dem Holzweg und das Problem liegt ganz woanders. Nur die EFI rüberschicken ohne zu schreiben was gemacht wurde, dass hat nicht früher immer geärgert denn dadurch lernt man ja gar nix. Ich bin noch nicht Siebzig, gehe aber drauf zu leider viel zu schnell. Das Alter ist überhaupt nicht das Thema. Aber wer hier noch nicht lange dabei ist hat es sicherlich erstmal nicht leicht, ich finde des sehr OK, dass Du da dran bleibst. Aufgeben gibst nicht und geht nicht gibt auch nicht ;)  WITON


    EDIT: Der Screenshot sagt mir nichts. Habe ich so noch nicht gesehen.

    Files

    • witon_EFI.zip

      (6.72 MB, downloaded 13 times, last: )

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • So nun hatte ich auch die Gelegenheit mal ein Auge drauf zu werfen und wie schon vermutet ist da einiges drin was raus kann. Ich vermute mal Du hast einiges einfach eingebaut weil Du in den diversen Sonoma Threads darüber gelesen hast ohne dabei allerdings zu verstehen wofür das eigentlich gut ist (was nicht schlimm ist)...


    Also raus können Amfipass.kext nebst dessen BootArg sowie AMFI=0x80 diese Dinge braucht es nur wenn Du in Deinem System eine Broadcom WLAN Karte verbaut hast und daher auf den OpenCore Patcher angewiesen bist um den Support für diese Karten wiederherzustellen. Weiterhin raus kann auch der CryptexFixup denn auch den brauchst Du bei Deiner Maschine nicht da Deine CPU AVX-2 beherrscht. Bei den Bootargs kann alles raus was mit Beta zu tun hat denn die Extensions aus dem Acidanthera Umfeld betrachten Sonoma schon eine ganze Weile nicht mehr als Beta OS und wo wir gerade bei den Bootargs sind kann auch -btlfxallowanyaddr raus denn das gehört zu brcmpatchram was Du auch nicht im Einsatz hast.


    Alles andere sieht bis auf eine Sache soweit aber gut aus. Ich habe mal das SecureBootModel auf disabled gestellt denn die Einstellung sorgt unter Sonoma in Verbindung mit einem SMBIOS von einem T2 Mac gerne auch mal für Probleme. Sollte das so nicht fruchten dann kann man gefahrlos das SMBIOS auch auf den Imac19.1 oder 19.2 stellen. Das iMac19.X Smbios hat den Vorteil das es von Sonoma nativ unterstützt ist aber keinen T2 Chip besitzt man hat damit also deutlich weniger Probleme als mit den T2 SMBIOSen (auch der iMacPro macht mitunter Probleme daher eher die Tendenz zum iMac19.2). Ich habe Dir meine geänderte Version mal beigefügt zum angucken, vergleichen und ggf. testen. Guck Dir aber vorher auch den Vorschlag von Arkturus an denn bekanntlich führen ja immer mehrere Wege nach Rom bzw. zum Ziel ;)

    Files

    • EFI.zip

      (5.39 MB, downloaded 27 times, last: )
  • Arkturus griven , nach mehrmaligen versuchen und Vergleiche mit Euren Vorschlägen ist es mir gelungen Sonoma bis zum Ende zu installieren. Bei den ersten 2 Startversuchen ist es abgestürzt, Die Tastatur hatte nicht mehr funktioniert und bei der Maus die Tasten. Komischerweise konnte der Maus Cursor bewegt werden. Nur die Tasten nicht. WLAN kann nicht aktiviert werden, obwohl der Router angezeigt wird. Bluethoot funktioniert. Nach den Abstürzen habe ich im Rechner Bios wieder umgestellt und meine Ventura Platte als Startvolumen aktiviert. Und nun wird's lustig Sonoma startet mit meiner Ventura EFI und stürzt nicht mehr ab.Obs so bleibt werde ich morgen mal testen. So richtig rund läuft die Kiste mit Sonoma noch nicht. Mein FENFI WLAN wird verschmäht und USB werde ich auch mal prüfen. Mit der angepassten EFI und Eurer Tipps startet Sonoma sehr schnell. Stürzt aber auch ab. Mit der Ventura EFI startet Sonoma langsamer aber stürzt nicht ab. Werde morgen mal ein Bootprotokoll erstellen und gucken was da so aufgelistet ist. Auf jeden Fall Dank ich Euch Jungs für Eure Hilfe. Nun kann ich in Ruhe testen ob Sonoma (wenn alle Blockaden beseitigt sind) besser mit meiner Musiksoftware klar kommt als Ventura. Ich hoffe ich darf Euch noch mal ansprechen wenn ich überhaupt nicht weiterkomme. Schönen Abend noch an Euch Beide


    Hmm gerade eben etwas später habe ich doch noch eine unklare Angelegenheit für mich. Es sind jetzt zwei OS Systeme auf verschiedenen Platten installiert. Jede Platte hat Ihre eigene EFI. Der Bootpicker kann aber ja nur eine EFI laden.Es gilt also das die EFI der gerade gewählten Platte dann für alle OS Systeme im PC gilt ? Sehe ich das richtig

    Edited once, last by WITON ().