HP800 G5 openCore

  • Moin,

    welche Hardware ist in dem Rechner verbaut? Bitte eintragen. Wie hast du das Installationsmedium erstellt? Welche MacOS-Version willst du installieren?

    Fragen über Fragen.

    Ohne mehr darüber mitzuteilen, wird dir niemand helfen können.

    Viel Glück

  • Moin,

    bitte die Fragen vollständig beantworten, und deine Hardware eintragen in "Über mich - mein System".

    Mit OC kenne ich mich nicht aus, da kann ich dir leider nicht weiterhelfen. Vielleicht kannst du mal deine aktuelle EFI hochladen, sodaß sich die Fachleute hier mal anschauen können.


    Viel Glück

  • Hi,


    hab alles hin bekommen, mein G5 läuft Perfekt mit Sleep/Sound/Lan etc.


    ich fasse wenn ich Zeit hab mal alles zusammen und lade es hoch

  • Hi mistry7,


    ich bin gerade dabei einen sehr ähnlichen Hackintosh aufzusetzen und haben das gleiche oder ähnliches Problem. Wie hast du das gelöst?


    Mein PC:

    HP Elitedesk 800 G4 mini

    i5-8600

    Q370

    Open Core 0.62 (aktuellste Version)

    Catalina 10.15.7 (aktuelleste Version)


    Ich bin der Open Core Anleitung von Dortania für Desktop Coffee Lake gefolgt und habe meine eigenen SSDT mit SSDTTime erstellt.

    Ich komme in den OC Selektor und wenn ich dann Installation von Catalina auswähle bleibt der Rechner hängen. Wenn ich dann den Rechner wieder starte meldet er, dass es Probleme mit der Realtime Clock gibt (Real Time Clock Power Loss). Also wurde zumindest dort etwas vom Installer geändert.


    Hier der Bildschirm beim Crash.


    Hier der Dump von OC vom EFI Laufwerk

    opencore-2020-10-31-195600.txt


    Hier meine plist. Der Sanity Checker hat keinerlei Fehler angezeigt.

    config.plist


    Vielen Dank,


    Ansgar

  • ansgar Fehler: [EB|#LOG:EXITBS:START] > Schau mal hier:https://dortania.github.io/Ope…ck-on-eb-log-exitbs-start


    >> Anscheinend passen Deine Booter > Quirks noch nicht, insbesondere "SetupVirtualMap", "EnableWriteUnprotector" und ggf "DevirtualiseMmio". DIese würde ich mal testen:


    Booter > Quirks:


    DevirtualiseMmio = No

    RebuildAppleMemoryMap = No

    SyncRuntimePermissions = No


    Eventuell noch: ACPI > Quirks > RebaseRegions = Yes


    Viel Erfolg

  • Hi,


    hab alles hin bekommen, mein G5 läuft Perfekt mit Sleep/Sound/Lan etc.


    ich fasse wenn ich Zeit hab mal alles zusammen und lade es hoch

    Hallo allerseits,


    ich habe auch ein ähnliches Setup:

    HP Elitedesk 800 G5 mini

    Coffee i5-8500

    HD630

    2x Displayport, 1x DP auf HDMI

    ALCID=20

    Ram 32 GB

    2x NVme 500/250 GB

    Mac mini 8,1

    Open Core 0.63

    Catalina 10.15.7


    Bei mir läuft eigentlich auch alles soweit, nur leider habe ich ein Problem mit dem Multiboot und sleep wenn ich von OC boote.


    Wenn ich von Clover aus boote, dann funktioniert der sleep.

    Beim boot von OC funktioniert er nicht.

    Ich habe dann jeweils unterschiedliche Energieoptionen. (siehe Anhang)


    Multiboot mit Clover funktioniert auch aber leider nicht mit OC.


    Wäre Super, wenn ich in deine OC configplist mal reinschauen dürfte.


    Ist das normal das diese 3 PCI devices nicht geladen werden?


    Dank im Voraus!


    PS: einige Config Einstellungen mögen falsch sein Aufgrund der Multiboot Spielerei.







    config.plist.zip

    HP Mac mini.ioreg.zip

  • Hallo Carstimann,


    ich bin mit meinem HP 800 G4 mini mittlerweile etwas weiter. Er bootet in OSX, sleep und dual-boot mit Windows sind kein Problem. Ich habe meine Konfiguration zur Info angehängt. Hast du dir mal deine BIOS Einstellungen angesehen?


    Setup:

    HP Elitedesk 800 G4 mini

    i5-8600

    2x DP und 1x USB-C DP Option Board

    Opencore 0.6.3

    Catalina 10.15.7


    Ich habe noch 3 Probleme:

    a) Mein Dell 4k Bildschirm wird nur als 2k Bildschirm erkannt und ich kann nicht mehr als 2560x1440 als Auflösung angeben.


    b) Ein zweiter Bildschirm wird nicht erkannt.


    c) Ich habe immer mal wieder RTC Error 005 beim Booten. Ist nicht bei jedem Reboot aber immer mal wieder.


    Hat jemand eine Idee, was zu tun ist?


    Danke,


    Ansgar



    config.plist

  • Hallo zusammen,


    ich sitze am gleichen System wie @mistry7… glaubst Du Du findest noch die Zeit dein Vorgehen mal niederzuschreiben? Da wäre ich Dir sehr dankbar :)


    LG

    Edited once, last by kapiza ().

  • Hallo,


    habe jetzt meinen PC für mich - dank des Dortania Guides - komplett zum laufen gebracht. Die SSDT habe ich nach dem Guide per Hand erstellt.


    Der 4k Monitor funktioniert und das RTC Problem scheint auch gelöst zu sein. Was nicht funktioniert, ist mehr als 1 Bildschirm zu betreiben. Ich kann meinen Bildschirm an jedem Port anschließen und er geht. Ein 2. wird aber nicht erkannt.


    Im BIOS habe ich das für den Bildschirm 512MB reserviert.


    Hier nochmal mein Setup:

    HP Elitedesk 800 G4 mini

    i5-8600

    2x DP und 1x USB-C DP Option Board

    Opencore 0.6.3

    Catalina 10.15.7


    Falls jemand noch Hinweise zur Verbesserung hat (z.B. 2. Bildschirm), wäre ich natürlich dankbar. Anbei mein kompletter EFI Ordner, falls jemand sich das Setup ansehen möchte.


    EFI HP 800 G4 mini.zip