Jumper EZBook X4 Pro Hackbook

  • Nein alles gut. Ist deine config.plist aus Post #21 noch aktuell?


    Edit:


    Falls ja, hier mal eine geänderte config.plist und die DSDT inkl. SSDTs in den patched Ordner packen und die SSDT-EC löschen.

    Files

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Und wieder einen Schritt weiter! Das Netzteil wird jetzt im Hotplug erkannt. Wenn ich es abstecke bleibt aber das Ladesymbol stehen und es wird angezeigt "Batterie wird nicht geladen" und "Stromversorgung: Netzteil".


    Eine weitere Neuerung: In den Trackpad Einstellungen wird nun nicht mehr nach einem Bluetooth Trackpad gesucht, stattdessen werden die Einstellungen fuer ein internes Trackpad angezeigt. Das Trackpad reagiert aber nach wie vor nicht auf Eingaben.

  • Schau mal ob mit dieser DSDT in Verbindung mit dem ACPIDebug.kext Output im Log bezüglich der Batterie angezeigt wird.

    Laut IOReg ist der _STA für BAT0 0x0, der müsste aber 0x1f sein wenn eine Batterie installiert ist, wovon ich mal stark ausgehe.


    Bei dem Trackpad habe ich noch nicht richtig nachgeschaut, da muss ich mich mal einarbeiten weil es bei meinen Acer Laptops glücklicherweise nicht kompliziert war.

    Files

    • DSDT-Debug.aml

      (94.46 kB, downloaded 2 times, last: )

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Das mit dem Trackpad liegt wohl daran, dass es ein unbekanntes ist. Man findet zu dem Hersteller (HTIX) quasi nichts. Wurde abseits von ein paar China Laptops mal in nem Medion Laptop verbaut, sonst keine Infos dazu. Vermutlich springt irgendein Treiber nicht auf den Namen an? Leider fehlt es mir da noch an Erfahrung. Aber jetzt hat eh erstmal der Akku Priorität. Die DSDT teste ich gleich.


    Edit: Etwas mehr wird jetzt schon angezeigt.

    Files

    • log.zip

      (6.34 kB, downloaded 3 times, last: )

    LG Chris


    Meine Hardware:

  • Dann mal den nächsten Versuch.


    Ich habe mal die _STA Methoden vom EC und BAT0 hardcoded zu 0x1f weil laut log auch 0x1f als Status angezeigt wird aber in der ioreg wiederum 0x00 angezeigt wird.

    Files

    • DSDT-Debug.aml

      (94.42 kB, downloaded 2 times, last: )

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Netzteil wird nicht mehr mit Hotplug erkannt. Keine Prozentanzeige.

    LG Chris


    Meine Hardware:

  • Okay, war nur eine Theorie. Welche Specs hat der Akku, mAH und Volt? Die sind nämlich nicht in der _BIF Methode hinterlegt. Das kann dass Problem sein, warum der Akkustand immer bei 0% liegt

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Laut Aufdruck 38Wh bei 7,6V, also 5Ah bzw. 5000mAh.

    LG Chris


    Meine Hardware:

  • Danke. 7,6 Volt habe ich mir schon gedacht, konnte man in deinem Systembericht erkennen. Habe ich übersehen. Dann schauen wir mal...


    EDIT:


    Dann teste doch mal diese DSDT. Den Debugcode habe ich bei dieser DSDT vorerst rausgelassen. Und am besten mal einen EC reset machen.

    Files

    • DSDT.aml

      (93.96 kB, downloaded 2 times, last: )

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

    Edited once, last by Quipper ().

  • Also die Prozentanzeige funktioniert jetzt. Das Netzteil wird aber immer noch nicht erkannt. In Coconut Battery springt der Status zwar auf "wird geladen" aber das Akkusymbol aendert sich nicht und auch das Netzteil wird als nicht angeschlossen deklariert. Dabei ist es egal ob ich per Hohlklinke oder den Typ-C mit Power Delivery lade.

  • Wunderbar. Jetzt wäre jeweils eine IOReg mit und ohne angeschlossenem Ladegerät interessant.

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Wie willst du den haben? Mit Reboot, dass das Netzteil erkannt wird oder ohne Reboot?

    LG Chris


    Meine Hardware:

  • Am besten erstmal ohne reboot.

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • So hier bitteschoen.

    Files

    • ioregs.zip

      (881.87 kB, downloaded 1 times, last: )

    LG Chris


    Meine Hardware:

  • Teste mal bitte die DSDT. Sollte das nicht klappen muss ich mich mal in der ACPI Spezifikation nachlesen und man müsste einzelne Methoden debuggen. Das musste ich bis jetzt noch nicht, aber es gibt immer ein erstes mal =)

    Files

    • DSDT.aml

      (93.96 kB, downloaded 2 times, last: )

    MacBook Pro 13,2: Acer Aspire V3 372-57CW / Intel Core i5-6267U / Intel Iris Graphics 550 / 8GB DDR3 / BCM94352Z / macOS 10.14.5 / Clover


    MacBook Pro 15,2: Acer Aspire 7 A717-72G / Intel Core i7-8750H / Intel UHD Graphics 630 / GTX 1060 6GB / 16GB DDR4 / BCM94352Z / WIN10 Pro / macOS 10.14.5 / Clover

  • Leider keine Veraenderung

    LG Chris


    Meine Hardware: