[SUCCESS] Gigabyte Z390 M Gaming + RX 580 Nitro+ [EFI im Anhang]



  • Ich weiß nicht wohin mit dem Thread, also habe ich einfach mal das Showroom-Unterforum genommen.

    Hier möchte ich meine Konfigurationsdateien samt Screenshots vom BIOS zur Verfügung stellen. Das ist für diejenigen in der Community, die sich überlegen ein Z390 System zusammenzubauen und für mein zukünftiges ich.

    Hardware:
    CPU: egal (i3/i5/i7/i9)

    Board: Gigabyte Z390 M Gaming
    Grafikkarte: Sapphire RX 580 Nitro+
    SSD: Samsung Evo 970 NVMe

    Software:
    - macOS Mojave 10.14.x
    - Clover

    Was funktioniert:
    - Audio über ALC892
    - Grafikbeschleunigung
    - Sleep
    - Hibernate
    - LAN
    - Audio über Displayport
    - Shutdown/Reboot

    Was nicht funktioniert:
    - Nichts aufgefallen, mit Verdacht auf nicht funktionierende iGPU.

    Ungetestet:
    - HDMI Audio
    - iGPU (Intel HD 630)


    Z390 M Gaming.zip (für macOS 10.14.0 - 10.14.3)


    Z390 M Gaming 10_14_5.zip (für macOS 10.14.5)


    Inhalt der Zip-Dateien

    - komplette EFI
    - Clover Installer
    - BIOS Screenshots

    Ich stelle euch hier alles als zip Datei zur Verfügung. In dem EFI Ordner der Z390 M Gaming.zip befindet sich eine DSDT. Wenn ihr ein anderes Board benutzt, bitte diese vorher entfernen. Bitte generiert euch eine neue Seriennummer beim Clover Configurator unter SMBIOS.

    Ich werde diesen Thread regelmäßig updaten.

    UPDATE 21/05/2019: Neue Zip Version für 10.14.5 (Z390 M Gaming 10_14_5.zip)
    Changelog:
    - SMBIOS von iMac 18,3 zu iMac Pro 1,1 geändert -> behebt Fehler mit JPG-Dateien in der Vorschau-App / Preview. Dadurch wird der NoVPAJPEG.kext überflüssig
    - aktualisierte KEXTs
    - Clover auf Version 4920 aktualisiert
    - angepasste USB-Patches für 10.14.3 und höher (übernommen von theOuzel )
    - DSDT wird nicht mehr benötigt! Diese wurde entfernt!
    - Sensoren hinzugefügt

    Files

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

    Edited 5 times, last by Kazuya91 ().

  • Kazuya91

    Changed the title of the thread from “[SUCCESS] Gigabyte Z390M Gaming + RX 580 Nitro+ [EFI im Anhang]” to “[SUCCESS] Gigabyte Z390 M Gaming + RX 580 Nitro+ [EFI im Anhang]”.
  • MacOS Mojave 10.14.1:
    Das System hat ein Update ohne jegliche Änderungen überstanden.

    VT-D kann im BIOS aktiviert werden. Dies hat keinerlei Auswirkungen auf die Funktionalität des Systems.

    Update:
    Um die Intel HD 630 zum Laufen zu bringen ist scheinbar der neue Whatevergreen.kext und ein Inject in Clover von Nöten:
    Quelle: Intel Grafikchip wird nicht richtig erkannt

    Update2:
    Der neue Clover configurator hat den SMBIOS vom Macmini 8,1 spendiert bekommen der ebenfalls auf die 8. Generation der Intel CPUs setzt. Somit kann die iGPU höchstwahrscheinlich auch ohne Probleme zum Laufen gebracht werden.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

    Edited 2 times, last by Kazuya91 ().

  • Kazuya91


    Hast du schon versucht 10.14.2 zu installieren?

    Das rote 1 Symbol der Einstellungen im Dock nervt mich ;(

  • Matze9605  
    Da mir 10.14.2 überhaupt keine Vorteile bringt, lasse ich es getrost weg. Ich mach mir das Leben gerne sehr einfach :).

    Soweit ich aber erfahren habe, sollte das Update kein Problem sein. Solltest du es wagen, würde ich mich gerne über eine Rückmeldung freuen.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • Kazuya91


    Nein ich habe es nicht ausprobiert.

    Bleibe ebenfalls auf 10.14.1 :)

    Solange es keine wirklich relevanten Neuerungen gibt, lohnt sich das Update ja eh nicht.

  • Update: Auf 10.14.3 funktioniert alles weiterhin problemlos!.

    Einzig die USB 3.0 Ports haben gestreikt, aber auch die funktionieren jetzt ohne Probleme.

  • Hey,


    Do you have HWMonitor and fans speed showing up there? Have you tried running Prime95 torture test to see if they spin up to max? Does the speed change at all?


    sorry, german only via google translate :)


    Haben Sie HWMonitor und die Geschwindigkeit der Fans, die dort oben angezeigt werden? Haben Sie versucht, den Prime95-Folterungstest auszuführen, um zu sehen, ob sie sich bis zum Maximum drehen? Ändert sich die Geschwindigkeit überhaupt?

  • nobody111  
    Hi :)

    I dont have any HWMonitor or fan speed data. I didnt run any torture tests either. But what I can tell you is that the RX 580 is working just like in Windows. On Idle the fans are turned off completely. Of course if I run any applications which use the graphics card, the fans start to spin. The speed is bound to the temperature.

    Everything runs fine. Completely satisfied with the system :) .

    Matze9605  
    Gut zu wissen. Was hast du gemacht damit die USB Ports wieder funktionieren? Das Update auf 10.14.4 mache ich definitiv sobald es draußen ist. Die X.X.4 Versionen bringen immer große Neuerungen mit was Hardwareunterstützung angeht.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • Kazuya91


    Also die USB Ports habe ich mit IORegistryExplorer neu eingestellt.

    Siehe auch hier : Anleitung: USB 3.0 El Capitan / (High-) Sierra / Mojave für jedermann (zukunftssicher für Updates & komplett gepatcht)


    Alles klar danke für die Information, werde dann auch mal updaten.

  • @Kazuya91

    Vielen Dank für Deine zip-Datei,


    hat mir sehr geholfen beim aufsetzten meines neuen Systems. (mit dem aktuellen Hardwareangebot von Apple kann ich mich irgendwie nicht mehr anfreunden ...)


    Danke!

  • TimGerdts  
    Gern geschehen. Eine Frage: Hat es direkt einwandfrei geklappt oder musstest du noch was ändern?

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • @Kazuya91


    am Anfang hat mein USB Stick nicht funktioniert, erst nach dem ich einen Älteren benutzt habe hat es geklappt. Ist jetzt schon wieder etwas her und ich habe viel probiert, bis ich die Ursache rausgefunden hatte.. aber ich denke am Ende habe ich nichts an Deiner zip verändert. Ich warte jetzt noch auf eine Flughafenkarte, dann werde ich vielleicht noch mal etwas basteln.. über LAN macht der Neue aber schon viel spass..

  • Hi Kazuya91 - deine Dateien waren eine großartige Hilfe!


    Was mich wundert - du verwendest einige Dateien, die nicht mehr ganz aktuell sind wie zB die "HFSPlus-64.efi" und die alte "OsxAptioFixDrv-64.efi". Mit bestimmten Grund?


    Bevor ich deinen Thread gefunden habe, eine eigene EFI Config erstellt. Allerdings immer die aktuellsten Clover Builds, da immer wieder Fixes für die Z390 dabei waren. Meine eigene EFI Konfiguration klappte auch ausgezeichnet (sogar inkl. iGPU des i5 8600K), Audio, USB, Sleep, restart, etc. Bis auf einmal (nach 3 Tagen) nichts mehr ging. Egal welche EFI Einstellungen ich in Clover veränderte ... das System hing beim Start (verbose Output) "WindowServer triggered unset of range ... " (schien irgend ein Buffer/Memory Problem). Lösung: bestehendes EFI komplett mit deinem ersetzt, macOS 10.14.3 auf der internen HD die Ordner /System und "/Library" durch umbenennen (System-OLD, Library-OLD) außer Kraft gesetzt, macOS mittels Stick (mit deinem EFI) neu installiert => es geht!


    Mein System:

    Mainboard : Gigabyte Z390 M (Bios Version aktuell, F7)

    CPU : Intel Core i5 8600K

    Grafik: Radeon RX560

    Betriebsystem : Mac OS Mojave 10.14.3


    Frage: ein Update auf 10.14.4 ist kein Problem, oder?

  • osxonpc  
    Freut mich dass es funktioniert. Ich bin leider aktuell auf das System angewiesen und ich lese hier still über 10.14.4 mit. Bei vielen gibt es anscheinend noch extreme Probleme mit 10.14.4 weshalb ich jetzt erstmal abwarte bis mindestens die neuen SMBIOS für den neuen iMac erscheinen. Die haben schließlich aktuelle Prozessoren wie den 9900K etc.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • Hallo,

    Es tut mir leid für mein Deutsch. Aber google, spreche kein deutsch.

    @ Kazuya91, was ist deine BIOS-Version?

    Wenn ich Gaming M, i9 9900K und "Ati 590" oder "Vega" -Grafik verwende, kann ich Ihre DSDT verwenden? Hat jemand nur Intel 630 verwendet?


    Grüße an alle;)


    English version:

    Welcome,

    @ Kazuya91, what's your bios version?

    If I am using Gaming M, i9 9900K and "Ati 590" or "Vega" graphics, can I use your DSDT?

    Has anyone used only Intel 630?


    Regards to everyone;)

  • contakt.box  

    The BIOS-Version doesnt matter. I updated my BIOS after installation twice, so its not a problem. It depends on which Radeon 590 you use because i heard some might cause some troubles. If you want to be sure its working, take one from Sapphire.

    You can use my DSDT. The DSDT is just for fixing a crash. I dont know about version 10.14.4 of macOS though, it seems to cause many troubles. Many people have problems with that version.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • @ Kazuya91

    Ich habe noch keine Grafikkarte gekauft. Was ist Ihrer Meinung nach die beste Wahl? Bei niedrigem Stromverbrauch, guter Leistung und leisem Betrieb. Ich wundere mich über:

    Saphir Radeon RX 570 Pulse 8G

    Saphir RX 580 Puls 8 GB

    Saphir RX 580 Nitro + 8 GB

    Saphir Radeon NITRO + RX 590 8 GB

    XFX Radeon RX Vega 64 8 GB

    Sapphire Nitro + RX Vega 64 8GB - Hier sind einige Probleme?

    Haben Sie es geschafft, Intel 630 mit "HDMI" oder "DVI" auszuführen?


    Danke.


    @ Kazuya91

    I have not bought a graphics card yet, what do you think the best choice will be? Considering low power consumption, good performance and quiet operation. I wonder if:

    Sapphire Radeon RX 570 Pulse 8G

    Sapphire RX 580 Pulse 8GB

    Sapphire RX 580 Nitro + 8GB

    Sapphire Radeon NITRO + RX 590 8GB

    XFX Radeon RX Vega 64 8GB

    Sapphire Nitro + RX Vega 64 8GB - Here are some problems?

    Did you manage to run Intel 630 with "HDMI" or "DVI"?


    Thank you.

  • contakt.box

    I deactived the Intel HD 630. Other users could activate it. I would recommend the Nitro+ Version of Sapphire. I would take the RX 580 or 590. VEGA Graphic cards have the issue with the fan (no speed control) which you need to take care of additionally.

    iMac Pro 1,1
    Intel Core i9 9900K
    Gigabyte Z390 M Gaming
    Sapphire RX 580 Nitro+
    Samsung 970 Evo 500GB
    macOS 10.14.5

    Clover 4920

  • @Kazuya91 Da fehlen jetzt nur noch ein paar Fotos von dem ganzen. :)

    Ist ja schließlich ein Showroom.

  • I have the same setup (Z390 M Gaming, RX 580) and I cannot boot with 10.14.4. I was running 10.14.3 with no problems and now I get a black screen after the apple logo. No errors, just black screen. The system is running at the login screen (beeps) but no video. I'm going to have to re-intall 10.14.3 and time-machine restore. Stay away from 10.14.4 for the time being.