Versuch El Capitan zu installieren Verursacht Kernel Panic

  • Hallo ihr vom Hackintosh Forum.
    Ich habe folgendes Problem. Ich habe mir das aktuellste Clover von eurer Website hier geladen. Ich habe mit diesem Clover einen Bootstick erstellt. Dann habe ich einen seperaten Install Stick via Tinu El Capitan erstellt.
    So nun aufgemacht den Laptop zu booten. Clover Bootet, Installationsstick El Capitan ausgewählt, fängt auch an Aber stoppt dann mit einer Kernel Panic (Siehe Screenshot) KernelExtension in Backtrace com.apple.driver.usb.AppleUSBUHCIPCI. Ich habe schon einige Tage damit verbracht dem Problem auf die Schliche zu kommen. Leider ist mein Wissen mit KEXTs kopieren in die richtigen Ordner etwas begrenzt. Ich habe nun beide Sticks einmal neu erstellt um noch einmal richtig anfangen zu können. Ich habe die FakeSMC sowie NullCpupowermanagement in den Clover/Kexts/Others kopiert. Der Clover Bootstick wurde im Legacy erstellt da UEFI bei mir nicht bootet. Ich habe einen Screenshot sowie meinen aktuellen Clover Ordner.zip im Anhang eingefügt. Ich hoffe es könnte mir einer behilflich sein diesen doch etwas betagten Laptop in einen Hacki zu verwandeln. Mfg Nina

  • Hallo @Nina1986,
    herzlich Willkommen im Hackintosh-Forum! :welcome:


    Versuche es mal mit der angehängten config.plist. Benenne bitte die vorhandene im Cloverordner um und kopiere die angehängte dorthin.

    Files

    • config.plist

      (22.37 kB, downloaded 286 times, last: )

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Hallo @McRudolfo
    Danke für die nette Begrüßung. Und Danke für die schnelle Hilfe.
    Ich habe die config.plist in den Efi Folder kopiert. Clover bootet, und ich wähle das Install El Capitan Stick aus. Es wird einige Zeit etwas geladen, dann startet der PC neu. Die Meldung mit dem Kernel Panic war bis jetzt nicht zu sehen. Ich habe vor dem Restart einen Screenshot erstellt. Ich hoffe vielleicht hast du ja noch eine Idee. MFG Danke Nina

  • Kopiere mal bitte die neueste USBInjectAll.kext in den Ordner /Clover/Kexts/Other/


    https://bitbucket.org/RehabMan…usb-inject-all/downloads/

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • HAllo @ McRudolfo, ich habe den USBINJECTALL.KEXT(Release)in den Others Ordner kopiert. Es erscheint leider wieder die KernelPanic mit dem USB. Screenshot habe icph eingefügt. Dann habe ich anstatt den Release mal den Debugger USbInjectAll.kext in den others kopiert, da Stoppt der Bootvorgang mit dem im zweiten Screenshot.Danke für deine Hilfe

  • Versuche es mal bitte an einem anderen USB-Port.
    Teste mal eine ältere Version vom USBInjectAll.

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Hallo @McRudolfo ich habe eine anderen USB Probiert, und eine Version von USB Inject Probiert, vom 30.12.2015, leider bekomme ich da immer noch die Meldung mit dem USB Panic. Hast du noch eine Idee dazu? Mit freundlichen Grüßen Nina

  • Versuche es mal bitte mit dieser config.plist.

    Files

    • config.plist

      (23.42 kB, downloaded 203 times, last: )

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Hallo @McRudolfo, ich habe wieder den aktuellsten USBInjectAll.Kext (Release) in den Others kopiert. Leider kommt die Kernel Panic immernoch. verwende ich den DEBUG vom USbInjectAll.kext, dann erscheine lauter rote Zahlen. Mfg Nina

  • Und ohne USBInjectAll.kext?

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Ohne USBInjectall.kext ist es genauso.

  • Versuche es mal bitte mit diesem Cloverordner.

    Files

    • CLOVER.zip

      (1.99 MB, downloaded 197 times, last: )

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Hallo McRudolfo, habe den Clover Ordner ersetzt. Es kommt immernoch die Meldung mit der Kernel Panic. Ich habe aus Spaß mal nen Yosemity Stick erstellt, und dies Installiert. Es ließ sich einwandfrei installieren. Ich habe mal ein Screenshot mit Device List gemacht. Vielleicht kannst du ja anhand dieser Liste sehen ob die USB Chips für Capitan geeignet sind? Mit freundlichen Grüßen Nina

  • Wenn es mit Yosemite funktioniert, sollte es grundsätzlich auch mit El Capitan funktionieren. Zwar hat es einige Änderungen mit El Capitan gegeben wie die entgültige Einführung der SIP, die haben wir aber ,it entsprechenden Clovereinträgen im Griff. Auch gab es Änderungen im USB-Bereich, was - soweit ich mich erinnere - aber vor allem mit USB 3.0 betraf. Da du kein USB 3.0 am deinem Notebook hast sollte es eigentlich keine Schwierigkeiten geben.
    Wenn du im Clovermenü bist drücke doch bitte mehmals hintereinander die Taste F4. Es werden verschiedene Dateien in der Ordner /Clover/ACPI/org/ geschrieben. Bitte lade mal die datei DSDT.aml hier hoch, vielleicht hilft das Patchen der Datei hier weiter.

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Ich hab mehrmals F4 gedrückt, aber im ACPI/ Origins ist keine DSDT.
    Ich habe eine mit dem Tool DPCI Manager extrahiert, hilft dir das auch weiter?

    Files

    • DSDT.aml

      (26.58 kB, downloaded 181 times, last: )
  • Leider nein, da im laufenden System die Tabellen duch Clover schon verändert worden sind.
    Komisch, dass das Extrahieren im Clovermenü nicht funktioniert. ?(

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD7850 2GB, 8GB RAM, Clover, macOS 10.14.6, Windows 10

    iMac19,2: Asus B85M-E, Xeon E3-1230 v3, XFX Radeon RX570 4GB, 8GB RAM, Clover 5138, macOS 11.6

    MacBookPro11,4: Lenovo Thinkpad W541, i5-4340M, intel HD4600 (+nVidia deaktiviert), 16 GB Ram, Whitelist-BIOS-Mod, Clover, macOS 10.14.6, Windows 10

  • Ich habe mal F1 Help gedrückt. Da steht hotkey F4 Dsdt (Fat32) dummerweise habe ich Ja im Legacy installiert. Weil mein Board kein Efi bios hat.

  • Man kann doch aber auch Clover auf einem Legacy BIOS in die EFI-Partition der Festplatte installieren.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo @al6042 und @McRudolfo, ich habe meinen Clover Bootstick mit einer EFI Partition erstellt und siehe da, im Anhang Die DSDT.aml. MFG Nina

    Files

    • DSDT.aml

      (26.3 kB, downloaded 181 times, last: )
  • Ein ICH9 Chipset ohne XHCI-Controller und hartnäckige USB Ports...


    Ich schieß jetzt mal ins Dunkle und sage ein IRQ Problem... Kann man in deinem BIOS irgendwie IRQs zuordnen oder so?


    Probiers bitte mal mit angehängter config.plist. Alternativ mit angehängter DSDT ;)

    Files

    • config.plist

      (22.55 kB, downloaded 207 times, last: )
    • DSDT.aml

      (26.77 kB, downloaded 181 times, last: )

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.