Finder hängt sich auf

  • Hallo Zusammen,


    seit letzter Woche habe ich das Problem, dass sich mein Finder aufhängt bzw. sehr sehr langsam funktioniert. Beispielsweise lassen sich keine Apps mehr öffnen oder bedienen (In der Kopfleiste habe ich das "loading" Rad wenn ich mit der Maus darüber gehe.


    Ich habe auch schon alle Updates (OC, Kexte, usw.) gemacht und auch das System schon mal neu aufgesetzt. Leider besteht das Problem weiterhin.


    Hat jemand eine Idee woran es liegen könnte bzw. hatte schon mal jemand das Problem und schon eine Lösung für mich?

  • Vllt. kränkelt der Datenträger auf dem das OS drauf ist? So hat sich mal eine Sandisk auf meinem T530 verabschiedet.

  • Das wäre natürlich möglich, lässt sich das irgendwie überprüfen?

  • Du könntest mal die Smartwerte auslesen. Bei einer SSD ist das aber nicht unbed. aussagekräftig. Wenn der Controller dabei ist sich zu verabschieden bringen die Smart Werte gleich null. Der geht meist (wenn) von hier auf jetzt hops. Das ist ja das eigtl. "gefährliche" an SSDs. Bei den drehenden Teilen hat man meist noch eine Chance die Daten zu retten wenn man früh genug prüft.


    Oder hast Du zufällig eine NVME von Samsung drin?

  • Nein leider nicht, das sind die Specs mittels OCSysInfo


    Storage

    ├── SPCC M.2 PCIe SSD

      ├── Type: Non-Volatile Memory Express (NVMe)

      ├── Connector: PCI-Express

      └── Location: Internal

  • Naja "leider" würde ich da nicht sagen. ;) Gut so wenn du keine Samsung drin hast. Welche hast Du denn?

  • Kann ich dir auf die Schnelle leider garnicht sagen.

    Kann es deswegen sein, das alle Programme sehr verzögert reagieren, egal ob Safari, Pages, Chrome, usw.. Nach einem Neustart ist das Problem eine zeitlang gut, dann geht es wieder los.

  • Ja, dass kann sehr wohl mit dem Datenträger zusammenhängen.


    Du kannst bei "Über diesen Mac" dir den Namen der SSD rausholen.

  • Es ist eine Silicon Power PCIe M.2 NVMe SSD 1TB


    sry, die Kiste ist schon wieder abgeschmiert.


    DriveDX sagt auch -> 0 issues found.

  • Die Marke sagt mir nix. Ist das eher preiswerter Sektor?


    Hast Du eine andere SSD am Start auf der Du das System mal clonen könntest und versuchen von der anderen SSD zu starten?


    Naja und wenn das Sys vorher lief und selbst Neuinstall nichts bringt ... evtl. kann es aber auch der Arbeitsspeicher sein. Wäre jetzt noch eine 2. Option.


    ICh würde aber wie gesagt das System mal auf einer anderen Platte erstmal ausprobieren.

  • Ok, vielen Dank schon mal. Falls ich noch fragen hab dann melde ich mich hier nochmal.


    Hast du eine Empfehlung bzg. SSD?

  • Ähnliches verhalten habe ich auch. Mir hilft der Terminal-Befehl "killall Dock". Dann löppt der Finder, Dock und Apps wieder. Warum? KA...

  • Ok, vielen Dank schon mal. Falls ich noch fragen hab dann melde ich mich hier nochmal.


    Hast du eine Empfehlung bzg. SSD?

    Die WD Black läuft 1a. Die Blaue sollte aber auch ok sein.

  • Ähnliches verhalten habe ich auch. Mir hilft der Terminal-Befehl "killall Dock". Dann löppt der Finder, Dock und Apps wieder. Warum? KA...

    interessant wäre trotzdem warum das so ist. Wenn das Teil hängt, dann dauert es 2-3 Minuten bis alles was man versucht hat nachgeholt wird. Ich hab jetzt auch schon neue config.plist versucht (leider auch keine Besserung).


    Der Fehler tritt bei mir besonders nach dem Sleep auf, allerdings hatte ich damit noch nie Probleme.


    PS: Kann ich die config.plist, Kexte und Treiber 1:1 von OC v. 0.7.x nach 0.8.3 übernehmen oder kann hierbei der Fehler entstanden sein?


    PPS: killall Dock bringt auch nichts.

  • Thema Sleep ... hast du das Sleepimage deaktiviert? Nimm am besten meinen Kextupdater. Da kannst du unter "Werkzeuge" den Sleepfix etablieren.

    Meine Vermutung ist das er bei dir beim Aufwachen das SLeepimage lädt und wenn die SSD Lese/Schreibeinbrüche hat dauert das Aufwachen eben länger.

  • Genau so äusserten sich damals meine Kompatibilitätsprobleme mit einer mSATA SSD von Samsung in meinem MacBook Pro von 2012. Der Einbau der originalen Apple SSD löste das Problem wieder.

    Power Mac G5
    (Late 2004)



    CPU: Intel Core i9-9900K (Coffee Lake)
    Mainboard: GIGABYTE Z390 M GAMING
    Grafik: SAPPHIRE Pulse Radeon RX 580
    Bootloader: OpenCore (0.7.9)
    Operation Systems: macOS "Ventura" 13.0, macOS "Monterey" 12.6.1,
    macOS "Big Sur" 11.6.3, macOS "Catalina" 10.15.7
    Power Mac G4
    (Quicksilver)



    CPU: Intel Core i3-10103F (Comet Lake)
    Mainboard: ASROCK H470M-HDV/M.2
    Grafik: MSI Radeon RX 560 AERO ITX 4G OC
    Bootloader: OpenCore (0.7.8)
    Operation Systems: macOS "Monterey" 12.6, Windows 10 Professional


  • Thema Sleep ... hast du das Sleepimage deaktiviert? Nimm am besten meinen Kextupdater. Da kannst du unter "Werkzeuge" den Sleepfix etablieren.

    welchen Kextupdater? Eigentlich sind alle meine Kexts auf dem aktuellsten Stand

  • Ok, hab den Fix mal installiert.

    Ich hab jetzt allerdings eine MacHDD-rw Datei am Schreibtisch, brauch ich die oder kann ich die löschen?