ASUS ThunderboltEX 3 + Apollo Twin DUO

  • Hallo zusammen,


    ich schließe mich mal hier an denn ich habe aktuell das selbe Problem was OP auch davor hatte.


    Meine ASUS ThunderboltEX3 Karte wird leider nicht erkannt, weder im IORegistryExplorer, noch in Hackintool unter PCIe.

    Unter Windows funktioniert die Karte.


    In den Systeminformationen steht bei mir unter Thunderbolt "keine Treiber geladen" und in PCIe auch nichts dazu.


    Somit kann ich die SSDT nicht erstellen, denn ich kenne den Pfad meiner Karte nicht.


    apfelnico könnten Sie mir da bitte behilflich sein?


    Ich bin neu dazugekommen hier in dem Forum, bin nach etwas Recherche im Internet zufällig hier zu diesem Thread gestoßen, meine Hardware habe ich bereits in meinem Profil eingetragen, sollte zu sehen sein - hoffe ich.

    Ich habe schon mehrere Hackintoshes erstellt, mit OpenCore und habe viel Erfahrung damit.

    Jedoch komme ich bei diesem Schritt nicht weiter mit der TB-Karte :D


    Meine EFI & BIOS-Settings und eine Kopie vom IORegistry habe ich anbei angefügt.


    Vielen Dank im Voraus!


    Viele Grüße,

    Leo

  • Moin und willkommen!


    Ich frage zur Sicherheit:

    Header Kabel steckt am Board?


    Slot-4 ist die Karte verbaut?


    Alpine Ridge und besonders die Asus sind keine freundlichen Gesellen, die sind manchmal echt nervig.


    Boote mal mit vorher eingeschalteter Apollo angeschlossen das System aus dem ausgeschalteten Zustand und schau dann in die Systeminfos und IOReg…


    Ist die dann auch leer, also kein Thunderbolt device erkannt?

  • kaneske

    Hey, erstmal vielen Dank für die rasche Antwort!


    Ja das Header-Kabel ist dran, wie gesagt die Karte ist voll funktionsfähig mit der Apollo unter Windows.


    Was genau meinen Sie mit dem 4. Slot?

    Die Karte ist bei mir im PCIe X4 Slot eingebaut.


    Das habe ich soeben versucht, bringt leider auch nichts, keine Thunderbolt Treiber geladen und auch keine Einträge im IORegistry oder Hackintool.


    Ich muss dazu aber auch sagen, dass die Karte - soweit ich es in Erinnerung habe mal in Hackintool unter PCIe aufgelistet war als TB-device. Jetzt steht da aber komischerweise nichts drin.


    Andere PCIe-Steckplätze habe ich bereits alle versucht - kein Erfolg. Ich denke es liegt an den BIOS-settings von Thunderbolt, jedoch weiß ich nicht genau was ich da alles einstellen soll (Bilder im Anhang oben).

    Edited once, last by leo1021: mehr Infos ().

  • Könnte mir hier jemand bitte weiterhelfen? Oder muss ich einen neuen Thread eröffnen? :D


    VG,

    Leo


    Update:

    Die Thunderbolt Karte wird nun endlich erkannt im Hackintool.


    Da steht auch der IORegistry Pfad drin.

    In IORegistry wird jedoch kein Thunderbolt device aufgelistet.


    Der Pfad von der ThunderboltEX3 Karte ist anscheinend /PC00@0/RP19@1B,2/PXSX@0/ laut Hackintool (siehe Screenshot, rot markiert).


    Wie kann ich nun fortfahren bzw. wie soll ich die SSDT mit HackinDROM erstellen?

    Das verstehe ich leider nicht...


    apfelnico könnten Sie mir bitte auch da behilflich sein? :D


    Und sollte ich nach meinem System vielleicht das iMacPro1,1er SMBIOS verwenden oder passt das MacPro7,1er schon?


    Ich habe auch eine neue Kopie von meinem IOReg mal im Anhang hochgeladen. Die EFI ist auch dabei falls es weiterhilft.


    VG,

    Leo

  • Ich denke du musst in HackinDROM deine Karte auswählen und dann den Pfad ändern.


    Bei der Standard SSDT von der ASUS tbEX3 Karte in HackinDROM ist der Pfad PCI0.RP21 und dein Pfad ist PC00.RP19.


    Diese Einträge musst du halt ersetzen und danach die SSDT kompilieren & downloaden.
    Das ganze kann man auch auf HackinDROM bearbeiten auf der Seite, ohne MaciASL.


    Die SSDT sollte dann fertig sein und dann kannst du die ausprobieren, für OC vergiss nicht bei der plist die SSDT auch einzutragen oder einen Snapshot mit ProperTree durchzuführen.

    https://github.com/ad422

  • Vielen Dank ad4222


    Ich verstehe aber leider immer noch nicht wie man das erstellt und meinen Pfad hinfügt in die SSDT...

    ---


    Ich habe es nun hinbekommen, dass Thunderbolt erkannt wird in der IORegistry, dank der empfohlenen BIOS settings & PCIe Slot von apfelnico :)

    Ich glaube, dass ich schon weit gekommen bin.


    Wie kann ich nun die SSDT erstellen?


    SMBIOS habe ich auf iMacPro1,1 geändert aufgrund USB Mapping.


    Eine neue Kopie vom IORegistry ist im Anhang.


    Den Hackintosh habe ich mit eingeschalteter Apollo betrieben.


    Kann mir jemand helfen :D


    Vielen Dank im Voraus!


    Viele Grüße,

    Leo

  • Moin leo1021

    die beigefügte SSDT sollte passen, einfach in EFI\OC\ACPI kopieren und in der "config.plist" unter ACPI\Add nach gleichem Muster wie die bereits vorhandenen eintragen.

    Files

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)