Externe (USB) Festplatte wird nicht erkannt

  • Hallo,


    Ich habe das System endlichem laufen bekommen. Jedoch habe ich folgendes Problem: Einzelne Festplatten (USB) werden nicht erkannt. Auch unter Festplattendienstprogramm werden diese nicht angezeigt.

    Andere starten wieder.


    Die Festplatten die auf meinem Rechner nicht starten sind nicht defekt, da diese zum Teil Neu sind und sowie auf einem Macbook zB ohne Probleme angehen. Ich habe bereits verschiedene Anschlüsse ausprobiert. Also liegt es auch nicht am Anschluss.

    Was kann es noch sein? Dass einige funktionieren und andere nicht.


    Zudem merke ich, dass ich seit heute Störungen am Bluetooth habe. Ich habe eine Maus (MX Master) der sein eigenes Dongle über USB hat.

  • USB ist noch nicht korrekt definiert. Möglich sind fehlende USB3-Unterstützung, sowie zu geringe Leistungsabgabe. Eine individuelle Kext wie auch Definition der XHCI-, EC- und/oder USBX-Controller helfen.

    ASUS PRIME X299-DELUXE • i9-7900X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64

  • Welchen USB-Kext hast du in deiner EFI drin und wie sieht deine config.plist aus. Ohne die Infos kann dir keiner helfen.

  • Hallo,

    An Power liegt es glaube ich nicht. Da auch Festplatten dabei sind, die mit externem Netzteil funktionieren.

    Ich habe USBInjectAll.kext (von 25.5.17)

    Plist ist hier in der Anlage.

    Files

    • config.plist

      (11.36 kB, downloaded 20 times, last: )
  • USBInjectall alleine wird dir nicht reichen.

    Port Limit Patch ist auf den ersten Blick in deiner cfg.plist enthalten (nutze ich persönlich jedoch nicht, daher kann ich dazu nichts sagen).

    Erstelle dir bitte über das Hackintool eine USB Kext und eventuell musst du eine ssdt nutzen um die Stromstärke der USB Ports anzupassen.

  • Hallo,

    Kannst du das genaue erklären was ich machen soll?

  • Danke.

    <was heißt denn "

    Wir schliessen aufeinander einen USB 2.0 Stick in alle Ports ein. Intel FB-Patcher markiert die verwendeten Ports auf grün.

    "


    Brauche ich also 12 Stick wenn ich 12 Eingänge habe?

  • Nacheinander.


    Und dann immer schön auf die Ports achten, ob ein USB 2 oder USB 3 angesteuert werden soll und Hackintool das auch richtig responset.

    Macht euren Scheiß selbst!


    "Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten." Albert Einstein


  • ruc wo zu brauchst du das für dein Mainboard, schau auf der Herstellerseite du hast nur 15 USB Anschlüsse.



    Brauchst aller höchstens USBInjectAll.kext mehr nicht, selbst ohne müssten dein USB Anschlüsse funktionieren.

    Edited once, last by rubenszy ().

  • Ich habe eine ähnliches Problem. Meine externe USB-3 Festplatte, welche ein verschlüsseltes Volume enthält, wird nicht erkannt. Ich verwende den USBInjectAll.kext in der neusten Version. Die Festplatte wird von meinem Macbook natürlich ohne Probleme erkannt. Hier im Forum habe ich gelesen, dass weitere Anpassungen notwendig sind. Entsprechend der Empfehlungen, sich einen individuellen USB kext zu erstellen, habe ich mit dem HackinTool geprüft, ob die Festplatte erkannt wird. Selbst dort wird der Port nicht grün also aktiv markiert, wenn ich die Festplatte anschließe. Mit meiner meiner USB-2 Festplatte funktioniert es. Ich vermute deshalb eine fehlende USB-3 Unterstützung. Allerdings bin ich mir sicher, dass ich die Festplatte schon mit Mojave verwendet habe.


    Files

    • config.plist

      (7.29 kB, downloaded 9 times, last: )
  • Das Problem habe ich inzwischen bei mir gelöst, indem ich mit dem Hackintool unter dem Tab Bootloader alle USB port limit patches aktiviert habe. Vielleicht hilft dir das auch weiter ruc.

  • Ich habe es gerade ausprobiert.
    Mein Problem ist: Hackintool zeigt die Anschlüsse nicht an die gehen: Also Beispielsweise schließe ich an einen Port einen Stick an, der wird auch vom System erkannt, startet also, aber der Anschluss wird nicht grün. Genauso ist es bei USB 3.1 oder USB C. Die Festplatte geht an aber der Anschluss wird nicht grün.


    Heißt das dann nicht, dass wenn ich die nicht grünen Anschlüsse deaktiviere, die dann nicht funktionieren werden?


    Ich werde daraus nicht schlau.

    Edited once, last by ruc ().

  • Ich habe es gerade ausprobiert.

    Mein Problem ist: Hackintool zeigt die Anschlüsse nicht an die gehen: Also Beispielsweise schließe ich an einen Port einen Stick an, der wird auch vom System erkannt, startet also, aber der Anschluss wird nicht grün. Genauso ist es bei USB 3.1 oder USB C. Die Festplatte geht an aber der Anschluss wird nicht grün.


    Heißt das dann nicht, dass wenn ich die nicht grünen Anschlüsse deaktiviere, die dann nicht funktionieren werden?


    Ich werde daraus nicht schlau.

  • Hat niemand eine Idee?
    Es klappt immer noch nicht.


    Ich habe mal den Standart USBinject gelöscht und nochmal reingenommen. Es hat funktioniert.

    Als ich den Rechner neustartete war das Problem aber erneut da.

  • Update:
    Gestern hat es geklappt ohne das irgendetwas anders war.

    Heute schalte ich den Rechner an und es funktioniert wieder nicht.