upgrade von 10.12.6 auf 10.13.6 - mit meiner konfiguration mgl?

  • liebe kollegen,


    ich überlege mit meinem (sierra) system auf high sierra upzugraden.

    weil ich noch nicht so fest im hacktosh-sattel sitze hier kurz die frage, ob das mit meiner hardware erstmal grundsätzlich möglich ist

    und und auch stabil läuft?


    und wenn ja, wie setze ich das upgrade auf meiner kiste auf?

    erstelle ich nen boot stick mit osx hs etc. pp. oder kann ich auf meinem aktuellen system aufbauen?


    danke für eure hilfe und nen schönen sonntag

  • Update ist natürlich möglich.


    Falls du dir nicht sicher bist, machst du ein Klon denier SSD/HDD, auch kopierst du deine EFI auf EFI der anderen SSD/HDD,

    machst Clover und kexts update, startest von der neuen und kannst ohne Stress update testen.

  • backup meines aktuellen system (inkl efi inhalt) hab ich gemacht.

    hab mir @MacGrummel´s anleitung zum upgrade auf high sierra und einige userpost zum thema durchgelesen.


    was mir noch nicht ganz klar ist. wenn ich kexte mit der app update, werden dann nur die in der efi aktualisiert oder auch die unter s/l/e ? (und muss ich diese separat backupn?)


    edit:

    und was ich auch nicht ganz verstehe "machst Clover und kexts update, startest von der neuen" platte? verstehe nicht ganz was du mir vorschlägst nach dem update des glover und der kexte zu tun…


    und muss das bios vor dem update auf den neusten stand gebracht werden?

    Edited 4 times, last by hannez ().

  • Nein, das Programm Kext Updater modifiziert nur kexts, die sich auf EFI befinden. Du solltest dein System auf fremde kexts durchsuchen und die hackintosh-kexts auf EFI in den Ordner Others kopieren, und aus s/l/e löschen. Aber zuerst klonen!

    BIOS, nein.


    Was ich vorgeschlagen habe, dass deine 2 Festplatte mit dem Klon auch startfähig ist, also EFI besitzt, mit Kopie deiner EFI.

    Und die EFI-Kopie kannst du updaten. Also nicht nur kexte, sondern auch Clover.

    Danach startest du von der zweiten Festplatte und machst update der 2 Festplatte, einfach als Test.

    Wenn das funktioniert und du gelernt hast wie das geht, kannst du die Hauptfestplatte modernisieren.


    Oder du hast ein Rettungsring, falls dir das update der Hauptfestplatte nicht gelingt. Falls du sofort die 1 HDD updaten willst.

  • und muss das bios vor dem update auf den neusten stand gebracht werden?

    Eigentlich nicht, solltest du doch ein BIOS Update machen muss eine vorhandene DSDT ggf. neu gepatcht werden, wobei ich es (einfacher) angehen würde.
    Kopiere deine ESP/EFI auf einen FAT 32 USB Stick, Bügel Clover in der neuen/aktuellen Version drüber, aktualisiere deine Kexte von Hand, starte einen ersten Anlauf im Verbose Mode mit einem macOS High Sierra Installer.

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • …im gloverconfig geguckt und meine biosversion ist vom 09/03/2013.


    hab eben mal folgendes durchgespielt:

    system platte stammt efi auf eine 2te interne platte geklont. dann von der 2ten gebootet, dort dann clover geupdatet und versucht die kexte zu erneuern.

    der kextupdater guckt aber immer in die efi meiner 1sten (system)platte und sagt ständig das ich updaten muss ob wohl ich schon längst geupdatet habe.

    in den pref nix gefunden womit man das anpassen kann. ums mal zu probieren hab ich dann wieder von der ersten platte gebootet, dort dann clover geupdatet. beim neustart wurden mir dann nicht wie gewöhnlich von clover die bootdrives angezeigt sondern nur optionen und die möglichkeit einzusehen welche glover version gerade läuft()es war die aktuelle) und dieses zu beenden. dann hab ich die fei der 1sten platte auf Original zurückgesetzt und es geht wieder.


    @der hackfan werde mal dein weg durchspielen. bin aber wie du merkst hackintosh anfänger.

  • iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • hallo hackfan,


    danke für deine Hilfe.

    irgendwie hab ich es jetzt geschafft mein system nicht mehr von meiner system und nicht mehr von meiner 2t platte starten zu können.

    bei ersteren bleibt der ladebalken kurz vor ende hängen und zeigt dann nur noch schwarz. die 2t platte zeigt beim wesentl langsameren ladebalken dann nur noch ein verbotsschild. Feierabend.


    ich habe zum glück heuet vormittag noch mit dem ccc ein klon auf einer externen platte gemacht. mit der ich jetzt noch arbeiten könnte und zugriff auf die systemplatte habe. nach dem ich jetzt die systemplatten efi durch die des externen backups ersetzt habe und das nichts gebracht hat, gehen mir langsam die Ideen aus. könnte ich zur not ein recovery von der externen platte auf die system platte machen? mache jetzt ein recovery von dem klon und schau mal ob es dann wieder läuft. befürchte aber das ich da was zerwürgt habe.


    plan b wäre der sprung ins kalte wasser und direkt high Sierra aufsetzen…


    freue mich über feedback

    Edited once, last by hannez ().

  • Was fummelst du denn auch in deinen laufenden Systemen herum, ich habe ausdrücklich auf einen USB Stick verwiesen, sehe mal zu dass du das gebacken bekommst und damit wirklich auf der sicheren Seite bist. :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • ist klar. das hatte ich versucht. aber von dem stick ließ sich nicht booten. das gehe ich morgen nochmal an...

    auf welche platte soll denn dann das os installiert werden?weil du fragtest: im kext/others ordner liegt bei mir nur IntelMausiEthernet.kext und FakeSMC.kext.




    bzgl meiner systemplatte:

    ich verstehe nicht warum meine systemplatte nicht mehr richtig bootet wenn meine externe platte mit der gleichen efi 1a gebootet wird. werden denn von clover installer noch irgendwo anders dateien hingeschrieben?

  • Das ASRock Z170 Extreme4 habe ich selber zu Hause im Regal liegen und ehrlich gesagt verstehe ich gerade deine Problematik nicht, müsste ich mir mal in Ruhe anschauen und auch den passenden EFI Ordner dazu hervorkramen, aber glaube mir das Board rennt 1A wie geschnitten Brot.

    Vielleicht schaffe ich es morgen Abend... :)

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • wäre top. kann sein das ich was falsch gemacht habe. ist mein erster hackintosh-geh-versuch. das sierra hatte mir jemand aufgesetzt… danke dir

  • Ach weisst du was?


    Lass uns das gleich mal heute Abend testen, nimm (mal) das hier als Grundlage -> Skylake Sammelthread (lauffähige Konfigurationen) Desktop


    Laut Verzeichnis sollte macOS High Sierra 10.13.3 laufen. :)


    Gruß

    iMac16,2 (Late 2015): GA Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.4 - OpenCore v0.1
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • so nach recovery von dem externen klon läuft nun das system sowohl auf meiner standard systemplatte und auf meiner datenplatte (gerade eben mal sicherheitshalber dort noch n klon drauf geballert).

    die system platte fasse ich jetzt nicht mehr an und auf letzteren würde ich dann das hs drauf installieren - zumindest vorläufig.


    jetzt beschäftige ich mich mit dem bootstick…


    @hackfan


    das von dir empfohlende skylake efi soll sozusagen als basis für das hs herhalten. versuche jetzt denoch erstmal mein efi auf den fat32 formnatierten stick zu legen und dann clover zu aktualisieren. der aktuelle clover installer bietet mir OsxAptioFix3Drv-64.efi an in meiner efi existiert aber nur die 1er und 2er version davon. was wähle ich?


    heute abend bin ich leider nicht an meinem rechner.

    freue mich trotzdem über hilfe. könnte das morgen dann nachholen oder so… danke.

  • hannez warum nicht eine Radeon Graka kaufen und direkt auf 10.14 gehen? Dein Setup gleicht meinem doch recht genau.

    Einziger unterschied ist das Board.

    Ich würde mir keine fummelei auf 10.13 mehr antun.

    OsxAptioFix3Drv-64.efi wurde ich nicht bevorzugen, vielmehr AptioInputFix-64.efi (ist m.E. stabiler und macht weniger Probleme).

  • danke für dein feedback. das hat den einfachen grund das meine arbeitssoftware (protools) mometan nur auf 10.12.6 und 10.13.6 stabil laufen soll. die grafikkarte spielt für mich eigtl keine besonders große rolle weil sich bei mir alles um audio dreht und protools eh nur hd augeben kann.


    noch mal ganz kurz zu dem bootstick den ich gerade erstelle. wenn ich es richtig verstehe kopiere ich meine aktuelle efi in den efi ordner des fat formatieretn usb sticks?

    und das clover update ebenfalls?


    edit: wenn ich das richtig sehe wird die efi in das reguläre verzeichnis (also nicht in die efi) des sticks kopiert…

    (zumindest macht MacGrummel in seinem clover workshop tutorial so)

  • Also eigentlich ganz easy:

    Laufendes efi aus der esp deines laufenden Systems kopieren (den kompletten Ordner),

    Esp deines install sticks mit clover vorbereiten, clover auf deinen install Stick installieren.

    Öffnen der esp des sticks.

    Löschen des Ordners efi vom Stick und deine lauffähige efi hineinkopieren.

    Das wars auch schon.

  • ich kann dir nicht ganz folgen.

    was meinst du mit "Esp deines install sticks mit clover vorbereiten"?

  • ok, danke für die klärung.


    ich hab glaube ich auch noch nicht ganz verstanden wie ich den stick dann verwende. ich spiel den neusten clover mit allen aktuellen kexten drauf um dann bei neustart im bios eben diese stick partion als bootdisk zu wählen, dann im clover menü(falls alles geladen wird) auf die reguläre systemplatte zu wechslen und zu schauen ob alles korrekt läuft, richtig?


    leider funktioniert das bei mir nicht. bestimmt mach ich irgend einen blödsinn:


    - stick fat32 in diskutility formatiert.

    - dann clover auf den stick installiert, die efi wird dann automatisch gemountet.

    - den efi-ordner in der esp des sticks lösche ich und setze dafür den meines laufenden systems ein. unmounten fertig.


    überschreibe ich damit nicht wieder die clover version?


    im bios wähle ich die partion1 aus. dann läd clover. dort schaue ich in die clover infos und er sagt mir, dass ein altes clover von 2016 geladen wurde (das ist die clover version meines laufenden systems).

    Edited once, last by hannez ().