Wie bekomme ich El Capitan auf meinem Rechner zum laufen?


  • OS X 10.11 El Capitan ist die nächste Version des Betriebssystems für die Rechner von Apple und unsere Hackintosh-Eigenbauten. Apple verspricht einen deutlichen Schub bei der Geschwindigkeit, nach den vorliegenden Beta-Versionen ist es aber vor allem ein deutlicher Schub bei den Sicherheits-Einstellungen, der nicht nur uns Hackintoshern etwas Kopfzerbrechen bereitet..


    Der offizielle Veröffentlichungs-Termin für El Capitan OS X 10.11 ist der 30.September, die weitgehend identische öffentliche Beta-Version „OS X El Capitan GM Candidate“ gibt es seit dem 10. September für alle, die sich bei Apple als Beta-Tester für das Betriebssystem angemeldet haben. Diese Anmeldung ist immer noch möglich, alle anderen dürfen sich noch knapp drei Wochen gedulden.


    Was sind nun die Vorraussetzungen für das nächste Apple-Betriebssystem?
    Alle Apple-Rechner, die mit OS X 10.10 Yosemite gelaufen sind, sollen auch mit OS X 10.11 laufen können, das Gleiche gilt dann auch für alle „modernen“ Hackintosh-Rechner, die schon mit Yosemite gelaufen sind.
    Wir haben dabei nur ein großes Problem: das Betriebssystem verhindert, dass Kexte, Treiber und System-Erweiterungen geladen werden, die nicht direkt zur Apple-Installation gehört haben. Und ohne einige dieser Extra-Kexte starten unsere Selbstbauten nicht. Der FakeSMC-Kext ist zum Beispiel immer nötig, um dem Betriebssystem zu erzählen, er würde mit einem echten Mac arbeiten..
    Diese Sperre gilt es also zu umgehen oder zumindest für die Installation abzustellen.
    Nun also von der Theorie zur Praxis!


    Welche Hack’s laufen, welche nicht?
    Laufen kann das neue Betriebssystem unter allen drei bekannten Boot-Systemen Ozmosis, Clover und Chameleon. Eine Installation unter OZMOSIS 1479 ist zur Zeit nur über Umwege möglich! Aber nach einem Update auf OZMOSIS 1669 ist das ein Kinderspiel..


    Sonst gilt: nur die neusten Versionen von Clover (Clover v3262 ff.) und Chameleon ( Enoch-rev.2758 ) können den dicken Fels aus dem Yosemite-Nationalpark starten!
    Heruntergeladen wird das Betriebssystem wie alle anderen Versionen seit Mac OS X Lion über den App Store, etwas mehr als 6GB insgesamt. Sobald das Installations-Programm komplett geladen ist, öffnet es ein Fenster und will mit der Installation beginnen. Von diesem Download sollte man eine extern gelagerte Kopie machen.
    Aber vor dem richtigen Start sind einige Vorbereitungen zu treffen: Wie auch die Beta-Anleitung von Apple schreibt: UNBEDINGT ein Backup der bestehenden Installation machen!


    Bei den vergangenen OS X-Versionen seit Lion war es problemlos möglich, aus dem AppStore-Download einen Installer-Stick zu erstellen, entweder über ein einfaches Terminal-Protokoll oder über das darauf basierende DiskMaker X. Mit der PublicBeta war das mit dem GoldenMaster nicht mehr so möglich, aber mit der neuen Version vom DiskMaker X 5.0.1 geht es wieder ohne Probleme.


    Während die Beta-Version nur mit Tricks zu überreden war, mit dem USB-Stick als El-Capitan-Installer zu laufen

    ist es inzwischen recht einfach: den Stick als "Untitled" umbenennen, und dann die folgende Zeile in Terminal eingegeben:

    Code
    1. sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction

    Dann auf Anfrage das Passwort bei Terminal eingeben, 20 Minuten warten, fertig! Damit ist dann mit dem Stick wieder alles möglich, ich kann sogar Clover in seine EFI-Partition installieren und von da aus jeden Hackintosh starten!


    Die aktuelle Version der WebDriver (WebDriver-346.03.01b07.pkg), wenn man sie bisher gebraucht hat, also für alle NVIDIA-Karten mit Maxwell-Chip (wie GTX750 und GTX9xx)
    Und natürlich die neuste Boot-Loader-Version installieren!


    für Chameleon:
    Seit "Enoch-rev.2758" läst sich El Capitan booten.
    In der org.chameleon.Boot.plist sollte folgendes stehen


    Das Update erfolgt dann einfach über das El-Capitan-Installations-Programm.


    Für Ozmosis, mit Update auf Version 1669:
    Was braucht man zusätzlich für einen Rechner, der mit der Booter/BIOS-Kombination Ozmosis arbeitet?
    Das neue OZMOSIS 1669 aus unserer Datenbank (Griven war da sehr fleißig..), passend zu Rechner-Board und -BIOS
    und einen Download von OS X El Capitan aus dem Mac App Store
    einen 8GB-USB-Stick
    einen kleinen USB-Stick, FAT-Formatiert.
    Was muss man vorbereiten?


    Das OZMOSIS wird auf dem kleinen FAT-formatierten USB-Stick entpackt, der Rechner neu gestartet und das BIOS auf Default zurück gesetzt. Dann wird das Oz wie ein normales BIOS-Update eingespielt (bei Gigabyte mit Q-Flash), der Rechner startet automatisch neu, das Hermit Crabs-Logo blinkt ganz kurz auf - und man darf das BIOS wieder komplett neu einstellen, wie es vorher war (da helfen eben manchmal Fotos vom Schirm..).
    Jetzt startet der Rechner erstmal mit dem neuen OZMOSIS in das alte Betriebssystem. Wenn das problemlos geht, kann gleich weiter installiert werden.


    Wenn der Rechner jetzt wieder richtig läuft, geht es zur Installation von El Capitan:


    Wie wird El Capitan nun Installiert?
    Eigentlich ganz genau so wie bei einem echten Mac: Installationsprogramm öffnen, Festplatte auswählen - und los!
    Oder mit dem Installer-Stick: Auf den Installer-Stick neu starten, da das Installations-Programm durchlaufen lassen, fertig!
    Jetzt müssen nur die Spezial-Kexte wieder an ihren angestammten Platz zurück, am leichtesten geht das mit Kext Utility. Und für NVIDIA-Maxwell-Karten brauchen wir natürlich wieder die neusten WebDriver. Kaum zu glauben, so einfach kann ein Hackintosh funktionieren! Das BIOS/Booter-Update ist deutlich aufwändiger als das neue Betriebssystem…

    Für Ozmosis 1479:
    Griven hat hierzu eine gute Kurzanleitung geschrieben.


    Natürlich macht es Sinn, so viele Daten wie möglich von den Ozmosis- in die Clover-Einstellungen zu übernehmen. Also mal kurz iMessageDebug anwerfen und die Zahlen so gut es geht auf die Seiten Rt Variables und SMBIOS übertragen:


    Und für Clover:
    Bei bestehender Clover-Yosemite-Installation:


    Bei bestehender Clover-ElCapitan-Beta-Installation:
    Hier ist es wirklich einfach: wenn es Public Beta 6 war braucht man nur das Installations-Programm aus dem AppStore, sichert das noch einmal irgendwo und startet den Installer.

    Bei älteren Beta-Installationen empfehle ich ein Vorgehen wie unter Yosemite.
    ç MacGrummel

    Files


    :hackintosh:

    Edited 9 times, last by MacGrummel ().

  • Quote

    Sonst gilt: nur die allerneusten Versionen von Clover (Clover v3262)


    und wo finde ich die? Ich finde nur die Clover_v2.3k_r3259

    Too Old To Rock 'n' Roll; Too Young To Die!

    Mein System


  • Sorry, hängt hinten dran! Still in progress..


    :hackintosh:

  • Danke :)


    Noch eins ist mir nicht klar. nv_disable=1,
    ich habe eine Radeon R9 270X eingebaut, gilt das dann auch?

    Too Old To Rock 'n' Roll; Too Young To Die!

    Mein System


  • Ich hab jetzt einen Trick gefunden, mit dem mein USB-Stick jetzt doch als El-Capitan-Installer läuft: Ich hab die gesperrten Zugriffsrechte für das das Installations-Programm um mich erweitert, es umbenannt in "Install OS X El Capitan Public Beta", wie schon die erste Version hieß, den Stick als "Untitled", und dann die folgende Zeile in Terminal eingegeben:

    Code
    1. sudo /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan\ Public\ Beta.app --nointeraction

    Auf Anfrage Passwort in Terminal eingeben, 20 Minuten warten, fertig!
    Damit ist dann mit dem Stick wieder alles möglich, ich kann sogar Clover in seine EFI-Partition installieren und von da aus jeden Hackintosh starten!
    :coolschild:


    :hackintosh:

    Edited once, last by MacGrummel ().

  • Ich hab jetzt einen Trick gefunden, mit dem mein USB-Stick jetzt doch als El-Capitan-Installer läuft


    Can we use Clover Special Edition to make USB more easily?

    Gigabyte Z77-DS3H [Ozmosis 167X] - i5 3570k - HD3000 - 8GB Corsair Vengeance 1600Mhz - Samsung 840 Pro 256GB SSD [OS X 10.11.2] / 1TB Seagate HDD [symlinked user folders] / 1TB Seagate HDD [Windows 8.1] / 1TB WD Green HDD [Time Machine]

  • Nightflyer: Ich denke schon, dass das auch bei Dir helfen müsste. Meine Nvidia-Grafik läuft nach dem Installieren ja auch ohne Grafik-Unterstützung und wird nicht erkannt.


    :hackintosh:

  • I have followed the guide step by step, have all the latest Clover and FakeSMC, however when I start the installation with Clover, the Screen goes black and nothing happens, I have to press reset. Any thoughts?
    Okay, I managed to run the installer, using FakeSMC from the latest HWSensors, and installing Clover in USB EFI system partition (ESP) (previously I just used standard install). Put FakeSMC 6.18.1394 in 10.11 folder and configured SIP 0x67 in config.plist (actually it was like this by default).
    However, I launch the USB installer from BIOS, and when the progress bar is at around 3/4, the install screen goes like this:



    I also reflashed Ozmosis, and tried Clover OS X El Capitan USB tool as well, same happens.
    What do you think the problem could be? ?(

    Gigabyte Z77-DS3H [Ozmosis 167X] - i5 3570k - HD3000 - 8GB Corsair Vengeance 1600Mhz - Samsung 840 Pro 256GB SSD [OS X 10.11.2] / 1TB Seagate HDD [symlinked user folders] / 1TB Seagate HDD [Windows 8.1] / 1TB WD Green HDD [Time Machine]

    Edited once, last by neoyoli ().

  • You should start with -v Verbose mode ant take a photo from the end of the booting-prozess..


    :hackintosh:

  • Here you go, I hope they are readable:



    Gigabyte Z77-DS3H [Ozmosis 167X] - i5 3570k - HD3000 - 8GB Corsair Vengeance 1600Mhz - Samsung 840 Pro 256GB SSD [OS X 10.11.2] / 1TB Seagate HDD [symlinked user folders] / 1TB Seagate HDD [Windows 8.1] / 1TB WD Green HDD [Time Machine]

  • Hm: Bluetooth .. etc. It looks like a graphics problem. The graphic kexts should be the next..
    Do you have switched the internal ON at the BIOS part?


    :hackintosh:

  • Yes, it is enabled. Although "Internal Display First" was on auto, now I've set it to IGFX (although I don't think that one matters, or does it?)
    Which graphic kexts do you mean exactly? Should I just inject them with kext utility? I thought graphics kexts are already part of Ozmosis...


    Although, the truth is, since I removed my nVidia GTX card, I got some random freezing, but I didn't bother since I wanted to upgrade to El Capitan. That is why I reflashed Ozmosis now.

    Gigabyte Z77-DS3H [Ozmosis 167X] - i5 3570k - HD3000 - 8GB Corsair Vengeance 1600Mhz - Samsung 840 Pro 256GB SSD [OS X 10.11.2] / 1TB Seagate HDD [symlinked user folders] / 1TB Seagate HDD [Windows 8.1] / 1TB WD Green HDD [Time Machine]

  • A NVIDIA-Card? What kind of it? It's not on your signature..


    :hackintosh:

  • When I first Installed Mavericks with Chimera, I had an NVIDIA card (don't remember which, but the last one was GTX 760), then I flashed Ozmosis and I was still using it (under the same Mavericks), and some moths ago I've sold it and switched to IGXF, this is why I deleted form my signature. Since then had I those rare random freezings.

    Gigabyte Z77-DS3H [Ozmosis 167X] - i5 3570k - HD3000 - 8GB Corsair Vengeance 1600Mhz - Samsung 840 Pro 256GB SSD [OS X 10.11.2] / 1TB Seagate HDD [symlinked user folders] / 1TB Seagate HDD [Windows 8.1] / 1TB WD Green HDD [Time Machine]

    Edited once, last by neoyoli ().

  • So it is all right so! My Quo is running with El Capitan in a good speed and a good NVIDIA-Card. But I really prefer the old lowpower Apple 120GT to the iGPU from Intel i5/4670...


    :hackintosh:

  • Ich hab nach deiner Anleitung auch alles ausprobiert, aber ich wieder die alten Probleme wie früher, mit Clover shclaten sich meine Monitor aus, wenn er durchgebootet hat, mit nvdisable=1 bekomm ich das gespiegelte Parkverbotszeichen. Derzeit nutz ich Ozmosis für El Capitan, was in der OB 6 gut läuft, aber ein normales Update läuft nicht an. Wnn ich die GM Release Version starte kommt entweder das Rad des Todes, oder nur weiße Bildschirme, daher hab ich nun versucht nach deiner Grivens Anleitung per Clover zu installieren.
    Zu Ozmosis bin ich damals gewechselt, weil nach einen großen Clover Update bei mir nur noch die Bildschirme schwarz blieben und dies bei einer GTX 660TI, seither benutz ich eben die beiden Ozmosis Varianten für mein Z87mx D3H.

    Als MacPro: Gigabyte Z87MX D3H Board mit Intel Xeon E3 1231, GeForce GTX 660 Ti 2048 MB, 16 GB Arbeitsspeicher, Ozmosis 1479, OS X 10.11 OB6
    ansonsten Mac Keyboad + Magicmouse, 3 Monitore 2x per DP 1x per DVI,

  • Es könnte ein Wenig helfen, wenn Du Deine Hardware in die Signatur schreibst! Ich weiss ja nicht, was Du mit Deiner Clover-Einstellung gemacht hast, aber die meisten Sachen sind da doch sehr ähnlich! Wenn Du schon ein OZMOSIS-BIOS hast, brauchst Du Clover auch wirklich nur, so lange die Installation läuft! Leider ist es unter El Capitan da meist notwendig, den aufwändigen Weg mit DSDT-Datei zu gehen und sich nicht auf die Clover Automatok zu verlassen! Also ganz so einstellen, als ob Du Clover dauerhaft benutzen wolltest. Aber das sollte weder mit dem Z87MX-Board, noch mit der GTX 660i ein Problem sein. Wie gesagt: Mit DSDT! Die mit MaciASL zu erstellen ist kein großes Problem, sonst :google: ist Dein Freund!


    :hackintosh:

  • So nun hab ich auf der 2ten Platte mit einigen Versuchen El Capitan drauf bekommen. Kexts in S/L/E drinn, aber weiterhin nur Probleme, El Capi scheint wohl ne richtige Zicke zu sein, Die OB6 läuft ohne Probleme, aber mit dem selben UEFI/ Ozmosis und den selben Kexts / Einstellungen, will die GM einfach nicht laufen.
    In etwa das selbe Verhalten bei dem Update von OB6 zu GM, wie auch der Neuinstallation auf der 2ten Platte, beide dauern extrem lang beim Booten, dann endet es entweder in weiße Bildschirme, oder in dem Rad des Todes.
    So bin wieder zurück auf Clover, es funkioniert so wie früher sauber und Sleep und die meisten Sachen funkionieren auch, ausser meine hinteren USB 3 Steckplätze, komisch die 2 externen am Gehäuse funkionieren ohne Probleme. Erstmal läuft alles über diese beiden und dem Dell Monitor Hub, aber langfristig ist dies keine Lösung daher hoffe ich auf eine einfache Lösung für das USB 3 Problem wo man nicht so viel frickeln muss, dass eher über runtergeladene Kext´s lösen kann.

    Als MacPro: Gigabyte Z87MX D3H Board mit Intel Xeon E3 1231, GeForce GTX 660 Ti 2048 MB, 16 GB Arbeitsspeicher, Ozmosis 1479, OS X 10.11 OB6
    ansonsten Mac Keyboad + Magicmouse, 3 Monitore 2x per DP 1x per DVI,

    Edited once, last by Egomane ().

  • Ich nehme an, die USB Ports werden auch in den "Systeminformationen" falsch deklariert?
    Dann muss ein DSDT patch her ;)

    Gruß CrusadeGT


  • Ahhhhh sag doch z87mx braucht nicht wirklich eine dsdt, früher hab ich auch ohne Clover benutzt, die Dsdt ausgewurfen und die hinteren USB Steckplätze gehen wieder.

    Als MacPro: Gigabyte Z87MX D3H Board mit Intel Xeon E3 1231, GeForce GTX 660 Ti 2048 MB, 16 GB Arbeitsspeicher, Ozmosis 1479, OS X 10.11 OB6
    ansonsten Mac Keyboad + Magicmouse, 3 Monitore 2x per DP 1x per DVI,