X220 als Hackintosh - Unterstützung bei Installation von High Sierra

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    X220 als Hackintosh - Unterstützung bei Installation von High Sierra

    Ahoi,

    ich bin durch Zufall vor einigen Wochen im Internet darauf gestoßen das ein treues Thinkpad auch als Hackintosh auf Zweitfestplatte funktionieren könnte.

    Nun habe ich dieses Wochenende versucht das Projekt anzugehen bin aber gnadenlos gescheitert..

    Ich habe schon versucht über die Anleitungen hier im Forum voran zu kommen, aber ich krieg das irgendwie nicht auf die Reihe..

    Meine momentanen Probleme:

    - Ich habe ein T61 mit Windows7 auf dem ich VM Ware nicht mit High Sierra zum laufen kriege
    - Ein X220 mit Linux Mint bei dem ich High Sierra nicht unter VirtualBox zum laufen kriege
    - Alle versuche irgendwie nen Installationsstick über TransMac(unter Windows) und der Anleitung zum erstellen eines Installationsstick unter Linux( Anleitung hier aus dem Forum) haben leider auch nicht funktioniert

    Meine Hoffnung besteht nun darin dass sich hier finden lässt der die Zeit und die Geduld hat, einem absoluten Neuling auf dem Gebiet zu sagen was er Falsch macht, beziehungsweise wie ich vorgehen sollte.

    Ich habe zur Verügung:
    - Thinkpad T61p mit Windows 7
    - X220 mit Linux Mint
    - Clover Iso
    - TransMac (Trial Version)
    - Internetzugang um neue Programme etc zu laden

    Ich hoffe das meine Anfrage hier angebracht ist und ich würde sie auch wirklich nicht stellen wenn ich nicht schon 6 Stunden ohne Ergebnis damit verbracht hätte es alleine zu versuchen...

    Beste Grüße
    Bruce

    Edit: Hab die Anfrage dann nochmal entsprechend der Forenregeln überabreitet.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Bruce_Forte“ ()

    ne High Sierra als.dmg bekommt man sicher nicht legal bzw. Forenregeln-Konform.
    AMD Athlon II X4 605 e - ASRock N68-S3 UCC - 8GB - 8400 GS - 10.10.5_SSEPlus_V3 + Shaneee10.11.x-RC4 Enoch r2839
    AMD Phenom II X6 1035T - ASRock N68-S - 4GB - XFX HD 6450 - BSA_10.9.5_FX_rc1 + Shaneee10.11.x-RC4 Enoch r2839
    AMD Ryzen 3 1200 - ASRock A320M-DGS - 8GB - 8400GS – 10.11.6, 10.13.4 Clover
    Intel i5-6600T Gigabyte GA-Z170-HD3P - 8GB - Palit GTX1050Ti 10.13.1 Clover
    Intel i3-4330 Asus H81M-C - 16GB RAM - Intel HD 4600 - 10.11.6 - 10.13.4 Clover
    Intel E7200 - Asus P5G41T­M LX2 - 4 GB DDR3 – GT710 – 10.13.0 Clover - Die PCs sind fast nur passiv/lautlos





    Wenn eine VM mit macOS zur Verfügung steht wäre die einfachste Methode dort den Installer aus dem AppStore zu laden und dann mittels Terminal Befehl sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ High\ Sierra.app einen USB Stick zum Installieren auf dem X220 zu erstellen. Nachdem der Stick fertig erstellt ist kommt noch Clover auf den Stick Einfach Haken setzen bei "Install for UEFI Motherboards". Da das T420 und das X220 technisch identisch sind kannst Du ohne weiteres einen EFI Ordner von einem T420 benutzen zum Beispiel den hier: EFI.zip
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    alles speziell zum X220 ist auch hier gut zu lesen ... neben diesem ***** Forum eine weitere gute Quelle... für X220 ... -->

    x220.mcdonnelltech.com/


    LG gerox


    :nowin:
    @Bruce_Forte wie hast du den stick denn formatiert? mbr oder gpt?
    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T420: i5-2540m, HD3000, 6gb, systemvorkoster

    ersthilfe vor ort für altes zeugs (-> laptops)
    8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 25.7.2018, 19.00 Uhr
    Habe den Fehler nachher bei der Formatierung des Sticks finden können und hab nun erfolgreich High Sierra installiert, einziges Problem ist dass das Wlan nicht funktioniert, obeohl ich meines Erachtens eine kompatible Karte drin hab...

    Die Karte ist eine Dell DW1702

    Muss ich da noch irgendwie nen treiber oder irgendwas installieren ?
    Unter folgendem Link findest du eine Kompatibilitäts-Liste -> osxlatitude.com/forums/topic/2…supported-wireless-cards/
    Die DW1702 ist zwar nicht drinnen, aber der weitere Link sagt, dass es sich um einen Atheros-Chip mit der Vendor-/Device-ID 0x168c, 0x002b handelt.

    Das sollte mit einem DSDT patch oder einem AtheorsWifiInjector.kext zu lösen sein.
    Atheros WiFi Injector Kext!
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.5 | Clover 4586
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4586
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Der Patch dient dem Eintrag eines Kompatibilitäts-Wertes, indem darauf verwiesen wird, dass die Karte an auch als 0x168c,0030 durchgehen kann und damit der Original AirportAtheros40.kext dafür geladen wird.

    Quellcode

    1. "compatible", // Declares compatibility with a device
    2. Buffer (0x0B)
    3. {
    4. "pci168c,30" // PCI id of device supported OOB
    5. }
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.5 | Clover 4586
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4586
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Ich komm bei dem Thema leider echt nicht weiter, bei dem Thema DSDT Patch steig ich irgendwie nicht durch und das mit der Kext-Datei hat bei mir auch nicht wirklich funktioniert...
    Richtig gut wäre ne schritt für schritt anleitung wie ich jetzt die dw1702 auf meinem x220 zu laufen kriege, bzw welche Karte ich mir besorgen muss um unproblematisch Wlan und Bluetooth zu haben