Update bzw. Neubau OzmosisBios

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Update bzw. Neubau OzmosisBios

    Neu

    Lange Zeit war ich was die Hackintosherei angeht ziemlich ruhig, doch habe ich jetzt beschlossen mein aktuelles Ozmosis Bios endlich mal auf Vordermann zu bringen.

    Ihr könnt euch also vorstellen auf was das hier abzielt :)

    Aktuell habe ich keine Werte in einer defaults.plist in der EFI ist alles per Terminal in den NVRAM geschrieben.
    Auch sämtliche benötigten kexte sind in der ROM, der Platz ist halt vorhanden :)
    Bis zum heutigen Tag habe ich noch keine ordentliche DSDT erstellt, geschweige denn eine passende SSDT.

    Ich würde diese ganzen kleinen Baustellen nun gerne mal abschließen, so das ich wieder Up to date bin.
    Mir ist vollkommen klar das Ozmosis ein im sterben liegendes Tier ist, aber totgesagte leben länger. Vielleicht kommt ja doch
    nochmal ein Phönix aus der Asche.
    Ich möchte also solange wie möglich noch bei Ozmosis bleiben, obwohl ich weiss das der Weg mit Clover auch möglich, vielleicht sogar leichter zu gehen ist.

    So jetzt aber genug der Worte ;)

    Was habe ich schon erledigt:
    Aktuelles Ozmosis-BIOS gesichert
    Mit der Ozmosis-Toolbox eine defaults.plist exportiert
    Aus dem Downloadbereich das letzte HighSierra fähige Ozmosis-Bios geladen.

    Was gibt es zu beachten:
    Sound:
    Läuft bei mir seit jeher per LED Cinema Display ... Also USB und DisplayPort. Der Voodoo steckt glaube ich aber noch im BIOS, meldet sich aber nicht.
    Ist aber eh nicht mehr von Interesse, denn das soll ja beseitigt werden. Ich denke das wird mit eurer Hilfe das kleinste Problem.
    Grafik:
    Meine ATI Radeon HD 5770 1024 MB macht ab macOS Sierra Version: 10.12.3 (16D32) nur noch Disco!
    Habe die 10.12.6 auf einer Testplatte laufen und dort die Disco mit SwitchResX beseitigt.
    Falls es einen anderen Weg geben sollte wäre ich sehr begeistert :)
    LAN:
    Netzwerkkext: RealtekRTL8111 Version: 1.2.0
    WLAN:
    Original AirPort Extreme Broadcom BCM43xxCD ... läuft beides, Bluetooth + WLAN ohne Probleme

    iMessage läuft auch und sollte es auch weiterhin tun. Es ist also wichtig die Werte zu übernehmen. Das ist so meine größte Panik.
    Denn ich habe vor Jahren mal, mit einem User von insanely an der DSDT rumgebastelt und hatte dann ständig veränderte MAC-Adressen
    oder so und hatte dann riesige Probleme wieder in iMessage reinzukommen. Das sollte also vermieden werden. Ich stocher da nur im Nebel,
    aber vielleicht wäre es das beste wenn man mein vorhandenes BIOS nur bereinigt/auffrischt/ändert ... So das ansonsten alles beim alten bleibt.

    Wie sollte ich jetzt weiter vorgehen ... Nehmt mich mal an die Hand und helft einem altem Mann über die Straße.
    Also dann: Let's Go und schonmal :danke2:

    Neu

    Moin!

    Unterstütze dich gern, wenn du magst.
    Kleine Frage:
    Ziel = lernen oder
    Ziel = geht besser?
    Liebe Grüße
    Freddie :)

    Hackintosh Systeme

    iMac late 2015:
    i5 6600, Gigabyte GA-Z170 HD3P, Sapphire RX580 Nitro 4Gb, 16Gb DDR4 Corsair Vengeance LPX Dual Kit, 256Gb Plextor M6V, 500Gb Samsung HDD, TP-Link TL-WDN4800, Zalman Z9 Neo White - 10.13.1
    MacBook Pro mid 2015: i3 3110, 4Gb DDR3, Intel HD 4000, 275Gb Crucial MX300 (Acer Aspire E1-571), AR9285 - 10.12.1
    iMac mid 2010: Intel Pentium G2020, 4Gb DDR3, Nvidia Geforce GT9300, provisorisches Holz-Gehäuse, 1TB HDD - 10.10.5


    andere Systeme

    Nextcloud Server: Raspberry Pi 2 ModelB 1Gb - Raspbian Jessie
    Sonstiges altes Zeugs: Core 2 Duo E4500, AsRock ConRoe 1333-667 rev.1.01 2Gb DDR2, 1Tb HDD - Leer


    Sind eure Probleme geheim? Falls nicht, nutzt bitte das Forum, statt meines Postfaches. Und falls doch, sind eure Geheimnisse bei mir eher weniger gut aufgehoben.

    Your problems are secrets? If not, please use the forum instead of my mailbox. But if they are, your secrets will not be safe anymore after having told me.

    Vos
    probèmes sont secret? Si non, vous pouvez utiliser le forum à place de mon boîte mail. Si oui, vos secrets ne seront plus assurés après que vous m'avez informés.

    Neu

    Das hier schon gelesen: Ozmosis Bios für macOS High Sierra erstellen ?
    Damit hättest du die Basics schonmal drauf ;) Fragen: Immer her damit, du sollst es ja verstehen!
    Auf der Basis können wir uns an das einfügen der ganzen Dateien ins Bios machen.

    Dann müssten wir uns um die DSDT kümmern, wofür du das hier definitiv gelesen haben solltest: hackintosh-forum.de/wffaq/inde…gepatchten-DSDT-Desktops/

    Und den @al6042 sollten wir definitiv auch dazu ins Boot holen! :D

    Defaults.plist bearbeiten ist Nebensache, das kriegen wir auch so ohne Anleitung hin.
    Wenn du soweit bist können wir anfangen :P
    Liebe Grüße
    Freddie :)

    Hackintosh Systeme

    iMac late 2015:
    i5 6600, Gigabyte GA-Z170 HD3P, Sapphire RX580 Nitro 4Gb, 16Gb DDR4 Corsair Vengeance LPX Dual Kit, 256Gb Plextor M6V, 500Gb Samsung HDD, TP-Link TL-WDN4800, Zalman Z9 Neo White - 10.13.1
    MacBook Pro mid 2015: i3 3110, 4Gb DDR3, Intel HD 4000, 275Gb Crucial MX300 (Acer Aspire E1-571), AR9285 - 10.12.1
    iMac mid 2010: Intel Pentium G2020, 4Gb DDR3, Nvidia Geforce GT9300, provisorisches Holz-Gehäuse, 1TB HDD - 10.10.5


    andere Systeme

    Nextcloud Server: Raspberry Pi 2 ModelB 1Gb - Raspbian Jessie
    Sonstiges altes Zeugs: Core 2 Duo E4500, AsRock ConRoe 1333-667 rev.1.01 2Gb DDR2, 1Tb HDD - Leer


    Sind eure Probleme geheim? Falls nicht, nutzt bitte das Forum, statt meines Postfaches. Und falls doch, sind eure Geheimnisse bei mir eher weniger gut aufgehoben.

    Your problems are secrets? If not, please use the forum instead of my mailbox. But if they are, your secrets will not be safe anymore after having told me.

    Vos
    probèmes sont secret? Si non, vous pouvez utiliser le forum à place de mon boîte mail. Si oui, vos secrets ne seront plus assurés après que vous m'avez informés.

    Neu

    Also ganz jungfräulich bin ich ja nicht. Mit UEFITool, UEFIPatch und Kext2FFS habe ich jeweils schon gearbeitet.
    Bin mir nur nach so langer Zeit nur total unsicher, alles korrekt und richtig zu machen.

    Wie sollte wir also anfangen? Das "alte" aktuell verwendete BIOS umbauen, mit einem nackten frisch von Gigabyte gesaugtem oder mit dem hier bereitgestelltem?
    Mir wäre irgendwie wohler ums iMessage-Herz wenn wir auf dem alten aufsetzen könnten. Wenn das die Sache nicht zu kompliziert macht.

    DSDT kann ich ja aus einem original BIOS von Gigabyte extrahieren?
    /EDIT: Ich seh gerade, das sind ja exe Dateien bei GA auf den Servern :(

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „CrazyCreator“ ()

    Neu

    @CrazyCreator
    Die EXE-Datei kann der Unarchiver aber entpacken.
    Darin findest du dann auch die Datei Z77NWIFI.F3, mit der du weiter arbeiten kannst.
    Gruß
    Al6042

    GA Z270-HD3P F8 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.2 | Clover 4334
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.2 | Clover 4334
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.2

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Neu

    Dann nimm die hier...
    Dateien
    Gruß
    Al6042

    GA Z270-HD3P F8 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.2 | Clover 4334
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.2 | Clover 4334
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.2

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Neu

    Ich würde mir die Mühe nicht machen denn es gibt ja schon ein laufendes und funktionierendes Bios mit OZ warum also neu anfangen?

    Die Idee einen Dump der aktuellen Einstellungen mit der Toolbox zu ziehen war schon mal goldrichtig denn für HighSierra muss das SMBIOS zwingend angepasst werden zumindest die BiosVersion, BiosReleaseDate, FirmwareFeatures sowie die FeaturesMask müssen erneuert werden (CloverConfigurator liefert hier aktuelle Werte. Bei den FirmwareFeautres und der FeaturesMask bitte die Hex Werte die der Configurator liefert auf Dezimal umrechnen und so einfügen). Wenn die defaults auf diese Weise erstellt sind hast Du schon die halbe Miete. Als nächstes bitte einen Dump von Deinem aktuell genutzten Bios erstellen (Im Bios F8 -> Save Bios to disk) der Vorteil in dem Vorgehen liegt auf der Hand denn der Dump dumped auch den NVRAM und die Einstellungen sprich im Falle eines Falles kannst Du auf den StatusQuo zurück gehen.

    Wenn Du den Dump hast wird es Zeit die so eben erstellte Defaults.plist zu testen lege sie dazu auf der EFI Partition ins Verzeichnis /Efi/Oz ab und mach dann einen 4 Finger P-RAM Reset um die neuen defaults zu laden und zu verwenden. Teste jetzt Dein System auf Herz und Nieren funktioniert alles noch so wie es soll? Geht irgendwas nicht und wenn ja was nicht? Hier ist Vorsicht die Mutter der Porzellankiste. Wenn alles funktioniert wie es soll kannst Du anfangen die erzeugten Defaults zu trimmen denn die Toolbox zieht nicht nur die Werte aus dem NVRAM sondern baut alle möglichen Keys mit ein hier ist also zunächst mal Aufräumen angesagt da so einiges eigentlich nicht nötig ist. Wenn Du bis hier gekommen bist und alles tut wie es soll kannst Du die erzeugten Defaults gerne um den SMBIOS Bereich gekürzt kurz hochladen und wir räumen gemeinsam auf :D

    Wenn das mit den defaults soweit läuft kannst Du dran gehen und den ROM bearbeiten hierzu einfach eine Kopie Deines eben gesicherten ROMS erzeugen und diese dann im UEFI Tool öffnen und dann die folgenden Dinge ersetzen

    - Ozmosis -> Ozmosis gepached für HighSierra
    - SMCEmulator -> FakeSMC.Rev-6.25
    - SMCPlugins -> analog zu FakeSMC

    Einfügen für HighSierra musst Du dann noch die APFS.ffs diese am besten direkt unterhalb der HFS+ und zusätzlich kannst Du eine ggf. noch enthaltene VoodooHDA löschen da Du ja, wie Du selbst sagst, den onBoard Sound nicht nutzt und so die VoodooHDA nur unnötig Platz frisst (überlege Dir ob Du anstelle dessen lieber den KernExtPatcher oder der ACPIPatcher von cecekpawon einbaust). Alle nötigen Files die zu ersetzen bzw. anzufügen sind habe ich Dir mal angehangen: HighSierra.zip

    Wenn Du damit durch bist den ROM speichern und flashen und dann gib Schub Rakete :D
    DSDT Bastelei und onBoard Sound mit AppleALC und Lilu gerne im Nachgang...
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit

    Neu

    Na dann gehen wir mal Schritt für Schritt der Zielflagge entgegen.

    Erste Frage ... Welches MacModel wähle ich. Aktuell habe ich eine Mischung aus MacPro3,1 und iMac14,1
    Dieser Mischmasch wurde mir mal empfohlen, als es um die Installation von Sierra ging, dieses aber den MacPro3,1 ausgesperrt hat
    und ich aber logischerweise die Serialnummer weiter verwenden wollte mit der iMessage etc. funktioniert.
    Wenn man das ganze, ohne Gefahr, ändern könnte wäre es schön ... Muss aber nicht.

    Hier mal der Dump von OzmosisToolbox:
    Spoiler anzeigen

    XML-Quellcode

    1. <?xml version="1.0" encoding="UTF-8"?>
    2. <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    3. <plist version="1.0">
    4. <dict>
    5. <key>Defaults:1F8E0C02-58A9-4E34-AE22-2B63745FA101</key>
    6. <dict>
    7. <key>AAPL,ig-platform-id</key>
    8. <integer>0</integer>
    9. <key>AAPL,snb_platform_id</key>
    10. <integer>0</integer>
    11. <key>AcpiLoaderMode</key>
    12. <string>0x0</string>
    13. <key>AndroidDiskOptionTemplate</key>
    14. <string>initrd=$initfs root=UUID=$uuid androidboot.hardware=android_x86 ro SRC=$path</string>
    15. <key>AndroidDiskTemplate</key>
    16. <string>$label</string>
    17. <key>AtiFramebuffer</key>
    18. <string>Hoolock</string>
    19. <key>BootEntryTemplate</key>
    20. <string>$label</string>
    21. <key>DarwinCoreStorageTemplate</key>
    22. <string>$label</string>
    23. <key>DarwinDiskTemplate</key>
    24. <string>$label</string>
    25. <key>DarwinRecoveryDiskTemplate</key>
    26. <string>$label ($platform.$major.$minor)</string>
    27. <key>DisableAtiInjection</key>
    28. <false/>
    29. <key>DisableBootEntriesFilter</key>
    30. <false/>
    31. <key>DisableIntelInjection</key>
    32. <true/>
    33. <key>DisableNvidiaInjection</key>
    34. <true/>
    35. <key>DisableVoodooHda</key>
    36. <false/>
    37. <key>EnableVoodooHdaInternalSpdif</key>
    38. <false/>
    39. <key>LinuxDiskOptionTemplate</key>
    40. <string>initrd=$initramfs root=$root ro quiet</string>
    41. <key>LinuxDiskTemplate</key>
    42. <string>Linux $build</string>
    43. <key>LinuxRescueDiskTemplate</key>
    44. <string>Linux Rescue</string>
    45. <key>LinuxRescueOptionTemplate</key>
    46. <string>initrd=$initramfs root=$root ro quiet</string>
    47. <key>SkipSmbusSpdScan</key>
    48. <true/>
    49. <key>TimeOut</key>
    50. <integer>0</integer>
    51. <key>UserInterface</key>
    52. <false/>
    53. </dict>
    54. <key>Defaults:4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102</key>
    55. <dict>
    56. <key>BaseBoardAssetTag</key>
    57. <string>Base Board Asset Tag#</string>
    58. <key>BaseBoardSerial</key>
    59. <string>C02437702SPG3M91L</string>
    60. <key>BiosDate</key>
    61. <string>09/03/2013</string>
    62. <key>BiosVersion</key>
    63. <string>IM141.88Z.0118.B00.1309031248</string>
    64. <key>ChassisAssetTag</key>
    65. <string>Asset Tag#</string>
    66. <key>EnclosureType</key>
    67. <integer>7</integer>
    68. <key>FirmwareFeatures</key>
    69. <integer>2147488791</integer>
    70. <key>FirmwareFeaturesMask</key>
    71. <integer>201342967</integer>
    72. <key>FirmwareRevision</key>
    73. <integer>65546</integer>
    74. <key>FirmwareVendor</key>
    75. <string>Apple</string>
    76. <key>HardwareAddress</key>
    77. <string>7c:6d:f8:46:3b:64</string>
    78. <key>HardwareSignature</key>
    79. <string>46052CFE-C57B-4350-9780-41556451DA17</string>
    80. <key>Manufacturer</key>
    81. <string>Apple Inc.</string>
    82. <key>ProcessorSerial</key>
    83. <string>CK0020DZE1D</string>
    84. <key>ProductFamily</key>
    85. <string>iMac</string>
    86. <key>ProductId</key>
    87. <string>Mac-031B6874CF7F642A</string>
    88. <key>ProductName</key>
    89. <string>iMac14,1</string>
    90. <key>SystemSKU</key>
    91. <string>System SKU#</string>
    92. <key>SystemSerial</key>
    93. <string>CK123456XYL</string>
    94. <key>SystemVersion</key>
    95. <string>1.0</string>
    96. </dict>
    97. <key>Defaults:7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
    98. <dict>
    99. <key>boot-args</key>
    100. <string></string>
    101. <key>csr-active-config</key>
    102. <integer>103</integer>
    103. </dict>
    104. <key>Timestamp</key>
    105. <integer>0</integer>
    106. <key>Version</key>
    107. <string>1.0.1</string>
    108. </dict>
    109. </plist>



    Weitere Fragen:
    Welche Werte MÜSSEN in der OzmosisDefaults in der ROM stehen, wenn ich in Zukunft die eigentliche defaults.plist ins EFI legen will?

    Die OzmosisDefaults.bin mit UEFITool 0.21.4 aus dem BIOS holen habe ich gemacht -> in *.plist umbenannt natürlich auch. Jetzt könnte ich die hervorragend editieren. Aber wie bekomme ich sie wieder zurück?
    Benenne ich sie einfach als OzmosisDefaults.bin markiere "PE32 image section" und füge sie per "Replace Body" wieder ein?
    Habe darüber leider nichts mehr gefunden.

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „CrazyCreator“ ()

    Neu

    Brauchst sie nichtmal umbenennen einfach auf die PE Section -> Replace body und die plist wählen und fertig ist der Lack.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit

    Neu

    ok ... Dann wäre das ja geklärt :D
    Aber bleibe ich bei meiner Mischkombination aus MacPro3,1 und iMac14,1 oder sollte/muss ich das umstellen?
    Probleme habe ich dadurch bisher noch keine festgestellt.
    Nächste Frage, die noch offen ist: Welche Werte müssen in die OzmosisDefaults.plist in der ROM und welche dann
    dementsprechend in die defaults.plist in der EFI?

    Und was mir noch aufgefallen ist:
    Bei mir sieht das so aus:

    Und in einer Anleitung hier aus dem Forum so:

    Ist das normal und ich habe auch Fehlermeldungen wenn ich das ROM öffne

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „CrazyCreator“ ()

    Neu

    Nein kannst Du so lassen das passt wie es ist :D
    Die können beide identisch sein also ROM und EFI wobei man die im ROM vernachlässigen kann wenn man mit den den defaults auf der EFI arbeitet eben so wie ich es oben geschrieben habe. Hänge dir die Defaults auf die EFI, teste ob alles geht und wenn das der Fall ist pflanz sie in den ROM (Replace Body) that's it.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit

    Neu

    Was sagen die Fehlermeldungen in meinem Screen, im vorigen Post? Muss ich da was drauf geben?

    /EDIT
    Habe jetzt die defaults.plist ins EFI geworfen ... Mir den bunten NVRAM-Monitor angeschaut und scheinbar läuft noch alles so wie vorher.
    iMessage geht, AppStore auch und komme auch in die Accountdetails unter iCloud ... Also alles schick. Kann man sicherheitshalber irgendwo prüfen welche
    defaults geladen worden. Obwohl ich denke das das schon hinhaut, denn der NVRAM-Reset war ja ersichtlich.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „CrazyCreator“ ()

    Neu

    Erscheinen diese Meldungen wenn Du Deinen extrahierten ROM öffnest? Die Parse Fehler tauchen zu weilen auf besondere Beachtung muss man ihnen aber in der Regel nicht schenken...
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit

    Neu

    Jupp ... wenn ich die gesicherte ROM öffne, dann kommen diese Fehler. Aber ich glaube das ist schon immer so.

    /EDIT
    Habe jetzt die defaults.plist ins EFI geworfen ... Mir den bunten NVRAM-Monitor angeschaut und scheinbar läuft noch alles so wie vorher.
    iMessage geht, AppStore auch und komme auch in die Accountdetails unter iCloud ... Also alles schick.
    Kann man sicherheitshalber irgendwo prüfen welche defaults geladen worden.
    Obwohl ich denke das das schon hinhaut, denn der NVRAM-Reset war ja ersichtlich.

    /EDIT01

    griven schrieb:


    ... zwingend angepasst werden zumindest die BiosVersion, BiosReleaseDate, FirmwareFeatures sowie die FeaturesMask müssen erneuert werden (CloverConfigurator liefert hier aktuelle Werte. Bei den FirmwareFeautres und der FeaturesMask bitte die Hex Werte die der Configurator liefert auf Dezimal umrechnen und so einfügen).

    griven schrieb:


    Wenn Du den Dump hast wird es Zeit die so eben erstellte Defaults.plist zu testen lege sie dazu auf der EFI Partition ins Verzeichnis /Efi/Oz ab und mach dann einen 4 Finger P-RAM Reset um die neuen defaults zu laden und zu verwenden. Teste jetzt Dein System auf Herz und Nieren funktioniert alles noch so wie es soll? Geht irgendwas nicht und wenn ja was nicht? Hier ist Vorsicht die Mutter der Porzellankiste. Wenn alles funktioniert wie es soll kannst Du anfangen die erzeugten Defaults zu trimmen denn die Toolbox zieht nicht nur die Werte aus dem NVRAM sondern baut alle möglichen Keys mit ein hier ist also zunächst mal Aufräumen angesagt da so einiges eigentlich nicht nötig ist. Wenn Du bis hier gekommen bist und alles tut wie es soll kannst Du die erzeugten Defaults gerne um den SMBIOS Bereich gekürzt kurz hochladen und wir räumen gemeinsam auf

    Meine defaults.plist habe ich ja ein bisschen weiter oben schon gepostet ... Passt die dann so?


    /EDIT02
    Nächster Schritt wäre jetzt also die apfs.ffs und das HighSierra gepatchte Ozmosis ins vorhandene BIOS zu werfen und dann zu schauen was passiert? :)
    Alles was mit iMessage zu tun hat sollte ja in der defaults.plist stehen die ich mit OzmosisToolbox gezogen, gespeichert und nun in der EFI habe?

    @griven
    Übrigens ist die aktuell "verbaute" FakeSMC schon Version: FakeSMC.Rev-6.25-333-g05e0f4be.1759.ffs , also die die auch in deinem hier hochgeladenem Or
    Laut Kext-Updates gibt es zwar auch schon eine Version: 6.26-322 ... Aber sollte ich lieber die nehmen, oder lieber erstmal so wenig wie möglich und in kleinen Schritten ändern, damit eventuell auftauchende Fehler nachvollziehbar bleiben?

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von „CrazyCreator“ ()

    Neu

    Vorsicht die Variante die ich drin habe hat einige Keys zusätzlich die HighSierra gerne hätte also besser austauschen...
    Deine gezogenen Defaults habe ich angepasst in den relevanten Werten und unnötige Keys entfernt hier ist sie: defaults.plist

    Den Rest kannst Du aber so machen wie gedacht sprich APFS hinzufügen, OZ updaten und FakeSMC und zur Vorsicht auch die Plugins austauschen sicher ist sicher.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit

    Neu

    griven schrieb:


    Vorsicht die Variante die ich drin habe hat einige Keys zusätzlich die HighSierra gerne hätte also besser austauschen...


    Das bezieht sich jetzt auf die neue von dir bearbeitete defaults.plist, oder habe ich was übersehen?

    Neu

    Nein das bezieht sich auf die FakeSMC :D
    Die Version mag die gleiche sein aber genau wie OZ ist auch die FakeSMC Version an HighSierra angepasst worden daher besser tauschen schadet ja nix und kostet auch nicht viel Zeit aber besser so als anschließend wieder von vorne zu beginnen oder nicht?
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.1, Windows10 Pro 64Bit