Sleep->Wake = Crash bzw. Reboot

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Ich bin ein Stückchen weitergekommen.
    Also ich habe es geschafft, meinen Rechner jeweils direkt in den Hibernatemode zu versetzen. Bei Aufwecken aus diesem Modus gibt es keine Probleme.
    Testweise habe ich gerade noch einmal auf Hibernatemode 0 umgestellt. Direkt beim ersten Test gab es wieder einen Absturz.
    Das Problem scheint also ausschließlich den Sleepmodus zu betreffen.
    Das heißt mit 25 funktioniert alles?

    Wäre ja schön, der 25er ist komplettes Hibernate, 0er ist pseudo-sleep, beim 25er wird auch der komplette Strom vom RAM entfernt. Einziges Problem ist, das der Inhalt vom RAM auf die Festplatte geschrieben wird. Benutzt du eine SSD, solltest du deshalb überlegen das Sleepimage auf eine HDD umzuleiten. Anleitungen dazu findest du sicherlich über Google.

    Vielleicht hast du ja auch ein Problem mit dem RAM... ?(
    @Kuckuck
    Ja, es funktioniert perfekt. Habe zum Test auch mal das Netzteil stromlos geschaltet. Der Rechner ist
    danach ganz 'entspannt' wieder aus dem Hibernatemode aufgewacht.

    Wieso meinst du, dass ich das Sleepimage umleiten sollte?
    Frisst das auf Dauer so viel Speicherplatz? Ich könnte es doch auch regelmäßig löschen?

    Ich meine, dass ich in der Vergangenheit bzgl. des Problems schon einmal am RAM versucht zu haben, d. h. ich habe mit nur einem RAM gearbeitet.

    Ich kann es natürlich nochmal versuchen, wobei es eigentlich ja keinen Nachteil mit Hibernatemode 25 gibt?

    Grüße
    Linus
    Vor jedem Sleep wird der Inhalt des RAMs auf die Platte geschrieben. Sind das mal 12gb o.ä, werden 12gb auf die SSD gelegt, vor jedem Sleep. Auf Dauer führt das zur Abnutzung der SSD...
    @Kuckuck
    Alles klar, vielen Dank für die Info!
    Auslagern wäre grundsätzlich kein Problem, aber ich gehe nochmal den RAM durch.
    Ich denke aber eher nicht, dass der defekt ist, weil ich ja sonst auch keinerlei Probleme habe.
    Könnte es vielleicht doch eine Einstellung sein?
    Ich meine, jetzt wo Hibernatemode 25 einwandfrei funktioniert, können ja gewisse Dinge ja ausgeschlossen werden.
    Hibernatemode 25 ist doch so ziemlich das Wunsch-Setting, wenn man keine Probleme mit SSD-Abnutzung hat (zB durch Auslagerung)!

    Nochmal zum Mitschreiben:
    • pmset hibernatemode 0 SleepImage nur im RAM --> einfacher Sleep (wenn das Festplatten-Sleepimage unveränderlich ist, ist es sicher nur im RAM)
    • pmset hibernatemode 1 SleepImage nur auf der Festplatte, aber RAM hat noch Power --> einfacher Sleep, aber SleepImage wiederherstellbar bei Stromverlust
    • pmset hibernatemode 3 SleepImage im RAM und auf der Festplatte --> sicherer Sleep, erst Sleep und dann Hibernate
    • pmset hibernatemode 25 SleepImage nur auf der Festplatte, RAM und ein paar weiteren Geräten wird der Strom entzogen --> echtes Hibernate
    Danke für die ausführlichen Erläuterungen!

    Ja, ich bin in jedem Fall erstmal froh, dass die Kiste nun überhaupt in irgendeiner Form schläft und sich wieder aufwecken lässt.

    Hibernatemode 25 dauert halt beim Einschlafen und insbesondere Aufwecken deutlich länger.

    Hibernatemode 0 noch stabil auf die Reihe zu bekommen, wäre jetzt der goldene Abschluss ;)

    enjoylinus schrieb:

    Hibernatemode 25 dauert halt beim Einschlafen und insbesondere Aufwecken deutlich länger.

    Der RAM und die anderen Geräte brauchen wieder ihre Power und das Sleepimage muss von der Festplatte wieder eingelesen werden... So ist das.

    enjoylinus schrieb:

    Hibernatemode 0 noch stabil auf die Reihe zu bekommen, wäre jetzt der goldene Abschluss

    Dann schau jetzt erstmal ob der RAM ok ist, denn wie beschrieben ist der normale Sleep sehr RAM betont ;)
    @Kuckuck
    Nach einigen Tagen des Testens lässt sich feststellen, dass der RAM okay ist.
    Allerdings habe ich festgestellt, dass das Problem nicht auftritt, wenn nur 2 RAM-'Riegel', d. h. 16 GB
    installiert sind. Wenn alle 4 'Riegel', d. h. 32 GB installiert sind, gibt es die Abstürze beim Aufwecken.
    Gib mal im Terminal folgendes ein:

    Quellcode

    1. ​sudo nvram 1F8E0C02-58A9-4E34-AE22-2B63745FA101:SkipSmbusSpdScan=%01

    Danach einen Neustart machen und schauen wie sich der RAM verhält. Rückgängig machen kannst du das dann wieder mit einer 0 oder mit einem NVRam reset...
    Ja, der komplette RAM.

    Eventuell hat es einen Einfluss darauf, wie der RAM erkannt wird... Hier steht auch noch bisschen was: hackintosh-forum.de/wffaq/inde…aktuell-11-2016-Englisch/ (bei 167X)
    Okay, dann probiere ich es gleich mal aus.
    Melde mich, sobald ich mehr weiß!
    DANKE!

    @Kuckuck

    Alles vier Riegel rein, den Befehl im Terminal eingegeben.
    1. Versuch = Absturz!!!

    Leider kein Erfolg :cursing:

    Es liegt aber def. an den vier Speicherriegeln.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „enjoylinus“ ()

    Crash beim Aufwecken aus Sleep (nur mit 32Gb RAM)

    Hallo,

    nachdem ich seit Wochen versuche herauszubekommen, was der Grund für die Abstürze beim Aufwecken meines Hackis aus dem Sleep ist,
    habe ich nun festgestellt, dass es ausschließlich bei der Verwendung von 4 RAM Riegeln passiert.
    Ein Defekt einzelner RAM Units sowie der Slots auf dem Mainboard konnte ich bereits ausschließen.
    Auch wird der RAM korrekt vom System erkannt.

    Sicher bin ich mir, dass die Abstürze nur vorkommen, wenn alles vier RAM Riegel installiert sind.

    Für Ideen und Anregungen bin ich wie immer SEHR dankbar!
    Es gibt keinen wirklichen Grund deswegen einen neuen Thread zu eröffnen, weswegen ich den Beitrag mal hier hinzugefügt habe.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.5 | Clover 4586
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4586
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Ist das Sleep Image ganz sicher unveränderlich und 0-1kb groß?
    Ja, ganz sicher! Bzgl. der Größe des Images fragst du um auszuschließen, dass es nicht doch veränderlich ist?
    Beim Hibernatemode 0 + gesperrtes Sleepimage bleibt ja sicher komplett alles im RAM. Damit hat dein PC Probleme, wenn 32 GB installiert sind...

    Mit Hibernatemode 25 ist alles auf der Festplatte, RAM wird deaktiviert. Dabei funktioniert alles, egal ob 32 oder 16 GB... (PS: Wieso belässt du es nicht einfach dabei, funktionierender 25 ist doch beneidenswert? ?( )

    Ich kann mir echt nicht ausmalen das hier das Problem sein soll, außer dein RAM. Mir fällt nur noch folgendes ein:
    Mach mal das Sleepimage wieder veränderlich und probiert Hibernate 0 Sleep aus. Schau dann mal ob etwas ins Sleepimage gelegt wurde. Vielleicht geht ja bei dir sogar Sleep mit aktiviertem Sleepimage besser als mit deaktivierten...
    Schau auch mal was du für BIOS Settings zum RAM und zu Sleep findest. Auf wieviel mhz läuft der eigentlich?