Sierra auf Windows 10 RAID 0 möglich?

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Sierra auf Windows 10 RAID 0 möglich?

    Hallo ihr lieben,
    ich habe hier eine sehr außergewöhnliche Frage.
    Und zwar: ich habe ein mehr oder weniger lauffähiges El Capitan Hackintosh am laufen (muss nur die webtreiber für die Pascal Karten installieren).
    Wie ihr wisst, ist erst vor kurzem ein Treiber für die o.g. Grafikkarten gekommen... nach 8 Monaten des wartens..

    Da es ungewiss war, ob überhaupt irgendwelche Treiber kommen sollten hatte ich vor 2 Monaten die ganze Hackintosh Geschichte abgeschrieben und dachte, ich fahr mit Windows bis ans Ende meiner Tage durch und hab mir aus dem Grund ein RAID 0 verbund (1 TB...höhöhö) Softwareseitig installiert.. nun kommen wir zum eigentlichen Problem:

    Der Hackintosh muss im BIOS/UEFI im ACHI Modus Betrieben werden.. kurz, ich müsste im BIOS jedes mal von ACHI auf RAID umstellen... Gäbe es denn eine Möglichkeit, ohne zusätzlich einen Hardware Raid zu installiren einen Weg zu einem Funktionierenden Sierrea mit der 1070 und einem RAID 0 Windows Verbund?!

    Tante Edith: Versteht mit nicht falsch, Windows ist auf 2 separaten Platten und El Capitan auf einer anderen SSD!
    Liebe Grüße
    in.Vitro ehemals "Fahradfahrer"
    Kurz: Keine Chance, der Hardware RAID Controller auf dem Mainboard ist nicht mit OS X und macOS kompatibel. Ohne zusätzliches Hardware RAID gibt es nur noch die Möglichkeit per PCIe eine AHCI Karte nachzurüsten und daran die OS X Platte zu betreiben. Das dürfte nach dem "Umschalten im BIOS" auch die günstigste Lösung sein. Weitere Alternativen wären Hardware RAID Karte fürs Windows (RAID 0) und onboard AHCI, oder besser noch, eventuell nichtmal teurer, eine NVMe SSD statt RAID 0 SSDs, und ebenfalls onboard AHCI für die OS X Platte.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)
    Nun bangt sich ein neues Problem an... wenn ich im BIOS/UEFI die Einstellung von ACHI wieder auf RAID stelle kann ich nicht in Windows laden... ich wusste doch das irgendwo der Wurm drin ist! :(

    ich versuche es weiter und werde es dann hier rein posten!

    Trotzdem vielen Dank an @Thogg Niatiz für deine Hilfe!
    Eventuell musst du das RAID erst wieder konfigurieren, damit der Controller weiß, welche Platten dazu gehören. Schau am besten ins Handbuch des Mainboards.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)
    Erledigt!

    Ich depp hatte eine der Platten des RAID 0 Windows-Verbundes nicht angeschlossen.

    um es kurz zu fassen. Es ist kostengünstiger die Einstellungen im BIOS/UEFI zu ändern als unsummen für einen Hardware-Raid auszugeben... also das Thema ist erledigt! :)
    Wie gesagt, es gibt als Alternative zum Hardware RAID auch die Möglichkeit, eine AHCI Erweiterung zu nutzen.

    Beispiel PCIe - 2x SATA:
    amazon.de/PCI-Express-Controll…sr=8-2&keywords=pcie+sata

    Beispiel PCIe - SSD-Carrier:
    amazon.de/Sedna-SATA-III-Port-…sr=8-3&keywords=pcie+sata
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)
    Also wie hast du das jetzt gemacht?

    Ich überlege meinen weiteren Schritt den Rechner etwas zu beschleunigen, und Raid 0 wäre eine Möglichkeit für die Zukunft.
    Hab mir gedacht ich kaufe mir zweite und genau die gleiche SSD, und bei der Installation mit Hilfe von Festplattendienstprogramm verbinde beide zu einem RAID 0, und installiere OS drauf. Die Geschwindigkeit soll sich beinahe verdoppeln.

    Hat jemand sowas ausprobiert? Nachteil wäre die erhöhte Wahrscheinlichkeit eines Ausfalls. Und ob das noch geht? Hab schon lange keine Option für Raid in FDP gesehen.
    Er setzt für Windows auf eine RAID Konfiguration, für macOS auf AHCI.

    Disk Utility bietet noch immer ein SoftRAID an (Ablage > RAID-Assistent...), dieses ist aber nicht für die Systemplatte geeignet. Wenn du mehr Speed willst kaufe dir eine NVMe SSD, eine bessere Lösung gibt es nicht.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)
    Also 3 Platten, so hab ich jetzt verstanden.
    Und nein, unter Ablage und El Capitan sehe ich keinen Raid Assistenten. Weder auf dem hack, noch auf meinem MBP.
    Im 10.9.5 hab ich sowas zuletzt gesehen.

    Für M.2 SSD hab ich leider keinen Platz mehr auf dem Board (Grafikkarte und WIFI belegen die 2 PCI-E slots).
    Die sind noch teuer und nicht OOB installierbar.
    Bilder
    • Bildschirmfoto 2017-04-18 um 15.58.56.png

      312,53 kB, 782×668, 10 mal angesehen
    Du musst die Festplatte in der Auswahl haben, nicht die Partition:
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX770 2GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.4
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.4 | Clover 4061
    Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD 840 EVO 1 TB | BCM943602BAED | macOS 10.12.4 | Clover 4061
    Aja, El Capitan... also mit Disk Utility wird das nichts, dort kannst du es aber mit diskutil oder Drittanbieter Tools machen oder auf Sierra upgraden.

    Quellcode

    1. diskutil appleRAID create stripe VolumeName JHFS+ disk1 disk2


    Aber das geht halt nur mit Datenplatten, nicht mit dem Systemdatenträger, da es nicht bootfähig ist.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)
    Ja tatsächlich. in Sierra ist die Raid Option da.

    @al6042 - Ist egal was man auswählt. Es lag an El Capitan.
    @Thogg Niatiz - Hab einen gefunden, dass behauptet, dass Raid 0 doch boot-fähig ist:

    "Dec 26, 2016

    I've been exploring the idea of implementing RAID0 on my desktop. I started with various ways of doing it with windows, and it wasn't at all successfull or worth the money. I'm talking about taking 2 equal sized SATA III SSDs in order to achieve somewhere near 600MB/sec read AND write. I'm super happy with this, my desktop speed started feeling more like my Macbook Pro 2015 with insane SSD speeds. So the following procedure took me a lot of trial and error but it was definetly worth it.

    1) Make a bootable Hackintosh with a single SATA SSD. See that everything is perfect, then copy the EFI partition to a USB stick or one of your non booting hard drives (used Hard disk Manager by Paragon to do this - kind of complicated... easier to stick the USB stick..

    2) See that you boot from the USB stick just as well, nothing is missing.

    3) Make a disk image with Disk Utility of that single SSD into a dmg file and save it to an external hard drive.

    4) Attach a second SATA SSD (equal size is very recommended, not equal size makes disk Utility to do weird things that end up formatting in a way that loses disk space). Use recovery mode, or the original USB stick, or a real mac you have, just to get Disk Utility taking over your computer outside of MacOS - and open file> RAID Assistant> RAID0 (Striped), choose your working SSD and the second one, and continue with the RAID set. This will make the Virtual disk as if it were just a continuous single SSD (meaning you don't lose any storage space - this is awesome!)

    5)Now you have inside your desktop, 2 SSDs, formatted for RAID0 , HFS+, but there's nothing in it, so you plug in the external hard drive you saved the image on, and restore it to the RAID set. Once this is done, you are going to boot from your USB stick. Surprisingly enough, Clover will recognize this RAID0 disk set as 1 single bootable MacOS disk. All this without changing anything in BIOS.

    6) Enjoy! Now you made your existing hardware working twice as fast, without any cost (I had 2x 240GB SSDs,
    and got a virtual disk with 480GB)."




    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „Altemirabelle“ ()

    Neu

    Eigentlich ist das gar nicht so merkwürdig denn hier wird ein Software Raid erzeugt sprich der Verbund wird nicht vom Controller (Hardware) verwaltet sondern vom Betriebssystem (Software). Software Raids sind relativ weit verbreitet in der Linux/Unix/OpenBSD Welt und stellen ein probates Mittel dar mit relativ geringem (finanziellen) Aufwand ein Raid zu realisieren. Bei einer Software basierten Raid Lösung wird vom Betriebssystem/Filesystemtreiber aus allen Teilnehmern des Raid Verbunds ein virtuelles Laufwerk erzeugt (Logical Volume Group) und je nachdem wie das Raid definiert ist (Raid0, Raid1 oder bei Apple auch FusionDrive) steuert die Software wie die Daten auf den jeweiligen Teilnehmern des Raid Verbunds aufgeteilt werden. Bei einem Raid0 werden die Lese und Schreibanforderungen gleichmäßig auf alle Teilnehmer verteilt (theoretisch ist ein Raid0 Verbund also in der Schreib und Leseleistung doppelt so schnell wie sein langsamster Member und doppelt so groß wie sein kleinster Member) bei einem Raid1 werden die Daten auf allen Teilnehmern des Verbunds synchron gehalten und bei einem FusionDrive werden die Daten je nach Größe und Häufigkeit der Verwendung entweder auf der SSD oder HDD des Verbunds abgelegt.

    Während Raid0 und FusionDrive meist aus performance Gründen verwendet werden nutzt man ein Raid1 aus Gründen der Datensicherheit. Fällt bei einem Raid1 Verbund einer der Member aus gehen keine Daten verloren da sie auf den anderen Membern in Kopie vorhanden sind fällt in einem Raid0 oder FusionDrive einer der Member defekt aus sind alle Daten verloren da sie verteilt über alle Member des Verbunds gespeichert werden.

    Die modernen Bootloader können alle samt mit Software Raids umgehen wobei die Voraussetzung zum gelingen natürlich ist das der Bootloader selbst nicht auf dem logischen Volume installiert ist sondern auf einem physikalischen im Falle von Clover muss die Installation auf den ESP Partitionen der Member erfolgen (üblicherweise auf allen Membern) denn nur diese Partitionen kann das UEFI/Bios des Rechners erkennen und von dort starten im Falle von OZ ist nichts weiter zu tun als den Verbund einzurichten.
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
    Downloads: DSDT für T61,ModBios für T61,ModBios für T420s

    Neu

    Rein technisch gesehen stellt sich die Frage, ob die ESP Partition, aus der Clover starten soll bei der Einrichtung von RAID bestehen bleibt, oder gelöscht wird. Die beiden SSD werden ja gelöscht.
    Falls die EFI nicht mehr vorhanden ist stellt sich die Frage Numero 2. Ob EFI Partition bei der Einrichtung von RAID0 erzeugt wird. Auf diese soll Clover installiert werden. Oder wird noch eine SSD/Volume benötigt, eben für Clover.

    Die Technik ist sehr interessant, weil man die Verdoppelung der Geschwindigkeit bekommt, und wie der Engländer schreibt keinen Platz von den beiden SSDs verliert.

    Neu

    Die EFI Partitionen bleiben auf beiden Membern erhalten bzw. werden auf beiden Membern erzeugt.
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
    Downloads: DSDT für T61,ModBios für T61,ModBios für T420s

    Neu

    Na wenn das keine guten Nachrichten sind!
    Danke!
    Das einzige wären jetzt Berichte aus der Praxis. Ich meine die Theorie ist wirklich viel versprechend. Jedoch fehlt etwas an Berichten, wie stabil diese Lösung funktioniert.
    Trotzdem bei der Gelegenheit werde ich das testen, ich meine für wenig Geld erreiche ich womöglich die magische Barriere 1GB/s.

    Neu

    Praxisberichte für Softraids findest du im Netz ausreichend. Dass sich das über die Recovery Partition auch für Systemdatenträger einrichten lässt ist echt spannend. Also wenn du mit den Risiken von RAID 0 vertraut bist solltest du das probieren. Denk aber immer dran, die ESPs synchron zu halten. Das übersieht man schnell mal und bootet dann nach einer Änderung des Bootloaders mit der alten Konfiguration und wundert sich.

    Übrigens gehört es zum guten Ton Artikel wie in deinem Beitrag oben zu übersetzen, statt nur zu kopieren, und vor allem aber die Quelle zu nennen. Wenn du Erfolg hattest wäre es außerdem super, wenn du eine eigene Anleitung mit deinen Erfahrungen verfassen könntest. Das Vorgehen ist nämlich sicher noch für mehr Nutzer hier interessant.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)

    Neu

    @Thogg Niatiz,
    mir scheint es, dass du das etwas zu persönlich genommen hast. Deswegen die Bemerkung über Übersetzung. Ich denke für 99% der Leser ist englischer Text eigentlich kein Problem. Und die Quelle ist nicht wichtig. Eigentlich besser, wenn man sie nicht nennt. Wie du selber schreibst gibt es im Netz ausreichend Beschreibungen.
    Natürlich melde ich mich wieder, wenn ich das gemacht habe, das kann aber dauern. Bis SIerra 05 erscheint. OK?

    Neu

    Nein gar nicht, sorry wenn das falsch herübergekommen ist. Es ist nur problematisch, wenn du Inhalt, den du nicht selbst erzeugt hast hier einfach nur in deinem Beitrag einfügst. Mich persönlich stört das gar nicht, aber korrektes Zitieren schaut anders aus, und wozu man zitiert muss ich dir sicher auch nicht erklären. Ich kann mir denken, wo du das gefunden hast, ich kann auch Google verwenden, aber jemand anders könnte es tatsächlich stören, und außerdem wärst du nicht besser als die Betreiberfirma hinter der Quelle. Don't feed the trolls ;)
    Außerdem muss ich aus eigener Erfahrung die 99% korrigieren - mir kommt es eher so vor, also ob 80-85% hier der Sprache mächtig sind, aber davon sind sicher viele dankbar, wenn sie hier in der deutschen Community die Verwendung von Fremdsprachen minimieren können. Beim nächsten Mal schreibst du einfach kurz in eigenen Worten, was du aus der Anleitung verstanden hast. Das ist persönlicher, spricht andere Leser mehr an und vermeidet auch die Frage nach der Quelle, weil du dich damit auseinander gesetzt und dein Wissen eingebracht hast.
    gez. Thogg Niatiz


    Tower
    iMac14,1
    Fractal Design Define R5, ASUS ROG Maximus VII Ranger, Intel Core i7 4790K, Intel HD 4600, Gainward GeForce GTX 570, 2x HyperX Savage 8GB 1600MHz, 3x Samsung SSD 850 EVO 250GB, WD Caviar Red 2TB, BeQuiet Pure Power 630W, Custom Wasserkühlung, Windows 10 (UEFI), macOS Sierra (UEFI), Clover (UEFI)
    Notebook
    HP Elitebook 8460P, Intel Core i5 2410M, Intel HD 3000, 1x4GB 1333MHz RAM, Samsung SSD 850 EVO 250GB, macOS Sierra (UEFI), Clover (UEFI)

    Neu

    Dazu braucht es im Übrigen nicht mal die Recovery man kann ein Softraid auch direkt im Festplattendienstprogramm des Installers einrichten bzw. schlägt OS-X das bei erfüllten Vorraussetzungen zumindest für Fusiondrive auch selbstständig vor. Spannender wird es da schon bei der Installation von Clover denn ein einfaches "Install for UEFI Mainboards" aus dem Installer funktioniert da nicht. Es macht Sinn Clover vor dem erzeugen des RAIDS auf die jeweiligen EFI Partitionen beider Member zu installieren und erst dann das Raid zu erzeugen und OS-X darauf zu installieren. Ich habe mal ein Raid 0 Setup mit 2 drehenden Platten betrieben in der Form funktioniert hat das Prima ist halt nur nervig immer im Hinterkopf zu behalten das beide EFI Partitionen jeweils bearbeitet werden müssen wenn was geändert werden soll. Alternativ kann man Clover aber auch auf einer evtl. noch vorhandenen dritten Platte installieren damit entfällt dann das Thema mit den Synchron gehaltenen EFI Partitionen auf dem Raid.
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
    Downloads: DSDT für T61,ModBios für T61,ModBios für T420s