Monterey Standby/Wake Problem

  • Habe Monterey auf einem Optiplex 3020. Alles läuft gut, außer dass er jede paar Minuten gebootet. Weiß da jemand Rat?

    Hier das Fehlerprotokoll, damit kann ich nichts anfangen. Das ist komplettes chinesisch für mich. Kann mir da jemand, der sich da ein wenig auskennt, mal reinschauen und mir erklären, warum er immer wieder rebootet.

    Files

    Optiplex 3020 \ Intel i5 4570 \ HD 4600 \ 16GB \ Catalina \ OpenCore

  • kru102

    Habe auch einen 3020 der ohne Probleme auf Monterey läuft. Lad mal deinen EFI Ordner hoch. Dann vergleiche ich den mal mit meinem

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ OpenCore 0.76 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2 / MONTEREY 12.0.1 (21A559)


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / BigSur 11.6.1 (20G224) via Opencore 0.76


  • hier mal die EFI...


    Ich habe im Hackintool und kextupdater gesehen, dass er mir das Opencore 0.5.7 anzeigt und ich auf 0.7.5 aktualisieren soll. Ich habe aber zur Installation meine Catalina-efi mit ocauxiliarytool geupdatet und mir von der aktuellen Master auf GitHub die 0.7.6 gezogen. Da bin ich mir nun nicht sicher, ob er deshalb das falsch anzeigt, weil es offiziell die 0.7.6 noch nicht als Release gibt.

    Bei meinem T440s habe ich es genau so gemacht. Da zeigt er mir aber jetzt im Hackintool auch die 0.7.6 an als verwendete Version.

    Aber da könnte ich nochmal schauen, ob da vielleicht ein Fehler steckt. Oder könntest Du auch mal sehen, was Du da siehst? Vergleichst die efis mit einem Programm oder per Hand?


    edit: Ach... den USBInjektall habe ich vom USBMappen noch drin... aber der ist in der efi als "no" gestellt...

    Files

    • EFI hack.zip

      (8.21 MB, downloaded 6 times, last: )

    Optiplex 3020 \ Intel i5 4570 \ HD 4600 \ 16GB \ Catalina \ OpenCore

  • kru102

    also in deiner EFI ist schon einiges anders als bei mir. Verstehe da auch manche Sachen überhaupt nicht. Ziemlich viel durcheinander. Diverse Kext bei dir drin die ich überhaupt nicht brauche, Diverse Patches die ich überhaupt nicht brauche. Diverse Einstellungen bei den Device Properties die meiner Meinung nach anders sein sollten etc.


    Teste mal meine im Anhang. Bitte dementsprechend wieder deine SMBios Daten Einpflegen.


    Und wegen der falsch angezeigten OC Version, da musst du mal einen NVRAM Reset machen. Meine EFI ist auch 076

    Files

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ OpenCore 0.76 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2 / MONTEREY 12.0.1 (21A559)


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / BigSur 11.6.1 (20G224) via Opencore 0.76


  • ja.... das sieht gut aus!

    Seit ca. 20min. kein Reboot!!!:):):)


    Ich muss mir die efi von dir ansehen. bin gespannt was da anders ist. aber er läuft auf den ersten Blick erstmal astrein. DANKE!!!

    Optiplex 3020 \ Intel i5 4570 \ HD 4600 \ 16GB \ Catalina \ OpenCore

  • Gern geschehen 🙂

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ OpenCore 0.76 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2 / MONTEREY 12.0.1 (21A559)


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / BigSur 11.6.1 (20G224) via Opencore 0.76


  • schabulske Nach vielen Versuchen muss ich jetzt doch feststellen, dass der sleep oder Standby nicht klappt. Ich kann ihn in den Ruhezustand schicken, doch bei deiner pmset Einstellung macht er dann einen Reboot im Ruhezustand wenn er in den disksleep geht (so würde ich das zumindest interpretieren). Hab vieles rumprobiert. Alle verschiedenen hibernategeschichten, 0,1,3 und verschiedene Standby und sleep Einstellungen mit pmset.


    Aber ich komme gerade zu dem Ergebnis, dass er

    • nicht alleine in den sleep geht (Minutenwert bei sleep geht nicht), sondern ich muss mit appleMenü in den Ruhezustand schicken.
    • er dann bei den meisten Einstellungen sich rebootet
    • wenn ich "disksleep" auf 0 setze geht er in den Ruhezustand. Er lässt sich dann auch wieder wecken (beim drücken von space-Taste macht er Hochfahr-Geräusche), doch dann bleibt der Bildschirm schwarz und bei meiner Tastatur leuchtet kein Lämpchen. (bekommt also kein Strom nach dem Wake...
    • USB-port.kext habe ich eine eigene erstellt. die läuft. bin aber nicht 100%ig sicher, ob die so wirklich passt.


    Das sind mal die Werte mit denen er zumindest in den Standby geht. aber dann bleibt Tastatur tot:



    standby 1

    Sleep On Power Button 1

    womp 0

    hibernatefile /var/vm/sleepimage

    proximitywake 1

    powernap 0

    gpuswitch 2

    networkoversleep 0

    disksleep 0

    standbydelayhigh 0

    sleep 0 (sleep prevented by nsurlsessiond, screensharingd)

    autopoweroffdelay 259200

    hibernatemode 0

    autopoweroff 0

    ttyskeepawake 0

    displaysleep 86400

    highstandbythreshold 0

    standbydelaylow 0



    Warum stehen da eigentlich für einen iMac solche Einträge? Ich habe vom MacBookPro die Platte eingebaut... das kommt daher oder? Die ganzen "standbydelayhigh, standbydelaylow,..." das sind doch Einstellungen für Akku. Ich bin aber am Optiplex3020 Desktop-Rechner. Kann man die irgendwie anpassen? Wäre mir ja eigentlich egal, wenn sie funktionieren würden.


    Welche Werte stehen da bei dir?

    Optiplex 3020 \ Intel i5 4570 \ HD 4600 \ 16GB \ Catalina \ OpenCore

  • kru102

    Der sleep ist meiner Meinung nach seit Monterey nicht mehr ganz funktionsfähig. Wenn ich Bildschirm sperren im Apple Menü Wähle und er dann nach einer gewissen Zeit von alleine in den sleep geht Bilde ich mir ein das er das ganz normal macht. Ansonsten aber nicht. Unter Big Sur hat das glaube ich noch alles funktioniert.


    Aber wenn ich ehrlich bin hat mich das auch noch nie gestört oder interessiert da für mich die Sleep Funktion eher irrelevant ist.

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ OpenCore 0.76 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2 / MONTEREY 12.0.1 (21A559)


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / BigSur 11.6.1 (20G224) via Opencore 0.76


  • kru102

    Changed the title of the thread from “Monterey Reboot jede paar Minuten” to “Monterey Standby/Wake Problem”.
  • Für mich wäre sie echt eine tolle Sache. Ich bediene den Rechner immer wieder vom Laptop aus. Der Rechner hat kein WakeOnLan. D.h., wenn ich ihn in den Ruhestand lassen könnte, könnte ich ihn laufen lassen und dann wacht er per networkoversleep wieder auf... so sollte das eigentlich bei realmac klappen.


    Vielleicht noch jemand anderer eine Idee zum Ruhestand - Reboot - kein Wake durch Tastatur Problem?

    Optiplex 3020 \ Intel i5 4570 \ HD 4600 \ 16GB \ Catalina \ OpenCore

    Edited once, last by kru102 ().