(Brauche Hilfe) HP "Hackbook" Folio1040 G3 kein Touchpad, keine Tastatur und keine Batterie Anzeige

  • Hallo liebe Hackis,


    ja ich schon wieder, bin im Moment an einem HP Folio 1040 G3 Ultrabook.


    Prozessor:

    Intel i5-6300U

    Grafikkarte:

    Intel HD 520

    Arbeitsspeicher:

    8 GB

    Festplatte:

    500 GB NVMe


    Die Installation mit OC und BigSur verlief ohne Probleme ist auch soweit abgeschlossen, sogar Wlan und Bluetooth mit der intel Wlankarte funktioniert und ich sehe sogar die LTE Karte konnte aber noch nicht testen ob die Wirklich funktioniert, nur fehlt mir mal wieder der passende Hinweis was ich falsch gemacht habe, da keine Tastatur und kein Touchpad funktionieren.


    Update: TON und Batterie bekomme ich auch nicht zum laufen, ich bin kurz vorm aufgeben...




    Im Moment behelfe ich mir mit einer externen USB Tastatur und einer USB Maus, aber ist für ein Notebook schlecht wenn ich das immer mitnehmen muss.;)


    Ich hänge mal den aktuellen EFI an, vielleicht hat ja jemand mal Lust und Zeit sich das anzuschauen?


    Vielen dank schonmal,

    KantarOSX

    Files

    • EFI1040G3.zip

      (22.5 MB, downloaded 33 times, last: )

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

    Edited once, last by KantarOSX ().

  • Ohne einen kext für Tastatur und Maus können die Komponenten auch nicht gehen.


    Für den Ton musst du schauen was verbaut ist und die entsprechende Nummer eintragen


    Für die Batterie brauchst du auch einen kext


    Lass mich raten... Du hast diese efi nicht selbst erstellt?

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • Servus Hecatomb, ja ich hab jetzt schon verschiedene VoodooPS2.kext probiert nur leider hat bis jetzt nichts funktioniert. Ich hab grade rausgefunden das hier wohl ein ALPS Touchpad verbaut ist.


    Kannst du damit was anfagen? Ich bin ja noch nicht solange in der Materie, ich bin froh das überhaubt was läuft.


    Gruß,

    KantarOSX:danke:

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Ich bin grad nur mit meinem Handy online... Ein Wunder das ich mir da überhaupt deine efi mal angeschaut hab.


    Du hast die kexte auch in deine config richtig eingepflegt?


    Wegen Touchpad müsste ich selbst erstmal googeln. Heute Abend hätte ich mehr Zeit nach deinen Problemen zu schauen und dir zu helfen


    Lese da mal bisschen Treiber für Alps Electronic Trackpad

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • Was steht im Hackintool unter Sound ?

  • Hallo Hecatomb666, vielen dank dafür ich fange schon mal an zu lesen.


    :danke::danke::danke::danke::danke:


    und hier aus dem Hacktool OSX-Einsteiger


    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Kannst du mal auf PCIe klicken und ganz unten rechts auf Exportieren klicken und die Sachen hier hochladen .

  • Einmal der Export und echt vielen dank für die Hilfe.


    Gruß,


    Kantar

    Files

    • Archiv.zip

      (5.97 kB, downloaded 17 times, last: )

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Hier ist die Lösung damit sollte es Funktionieren .

  • So hab ich es jetzt mal eingestellt und boote mal durch.



    Danke schonmal für die Mühe



    Update: leider keinen Erfolg, muss ich noch irgendwas beachten?


    Update02: Ich hab es hinbekommen und zwar mit den bootargs alcid=3


    Jetzt fehlt nur noch maus und Tastatur.


    Danke Nochmal:danke2::danke2::danke2:

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

    Edited once, last by KantarOSX ().

  • Geht deine Tastatur und Trackpad inzwischen?

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • Nein leider nicht, aber der Sound den hab ich mit hilfe von OSX-Einsteiger hinbekommen.

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

    Edited once, last by KantarOSX ().

  • Ich schau eventuell später wenn's zeitlich passt mal nach. Lade mal in der nächsten Stunde ne aktuelle efi von dir hoch... Eilt auch nicht.


    Schau mal ob die Batterie Anzeige jetzt funktioniert, Tastatur u.s.w.

    Files

    • EFI1040G§.zip

      (22.68 MB, downloaded 31 times, last: )

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

    Edited 2 times, last by Hecatomb ().

  • Hallo zusammen, ich hab jetzt die EFI genommen die mir Hecatomb hochgeladen hat und was soll ich sagen, Trackpad und Tastatur gehen jetzt. JUHU !!!!!!!!


    Jetzt hab ich noch die Batterieanzeige die nicht funktioniert, vielleicht bekommen wir das ja auch noch irgendwie hin.?


    Also ich muss es mal loswerden, echt ihr seid hier der Hammer!!!! So schnelle Hilfe und auch noch so kompetent und nett, ihr seid hier echt ein Super Forum und einfach sehr nette Leute.

    Ich hab was gelesen das man was Spenden kann, ich glaube ich werde mir das mal überlegen.


    Also bis später,


    KantarOSX

    Files

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Sicher dass die Anzeige nicht geht? Linke Maustaste mal drauf und Prozente anzeigen lassen geht nicht?

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • Sorry es ist leider gar keine Anzeige da. hier ein Bild.


    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Oh es steht auch auf null Prozent. Jetzt verstehe ich die Thematik. Danke fürs Bild.


    Ich kann höchstes noch ein anderen kext versuchen... Kann auch sein das es gepatcht werden muss, aber so genau weiß ich das auch nicht.... Mit patchen kenne ich mich auch leider nicht so gut aus.


    Schau mal ob es jetzt geht

    Files

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • hi leider immer noch nichts, muss ich sonst noch irgendwo was einstellen? Config.plist? oder irgendwelche Treiber einspielen?


    Gruß,


    KantarOSX

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s:

  • Also wenn ich ne efi bearbeite, dann konfiguriere ich auch die config. Du kannst aber selbst mal nachlesen, weil mir etwas die Zeit fehlt.


    https://github.com/RehabMan/OS-X-ACPI-Battery-Driver


    Hab wie gesagt nur den ahci Batterie kext noch eingetragen.


    Falls er nicht geht dann lösche den kext wieder raus !!!

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - BCM94360NG - OC 0.8.8 - Windows 11 / macOS Ventura 13.2 (a) Beta

    Dell XPS 13 7390  Intel® Core™ i7-10510u - OpenCore 0.8.6 - Windows 11 / Ubuntu / macOS Ventura 13.1

    MacBook Air 2022  M2 - 10 Core GPU - 16GB RAM - 512 GB - macOS Ventura 13.2 (a) Beta

    MacMini 6,1  Late 2012 - macOS Ventura Beta 13.1 - OC Legacy Patcher 0.5.1

  • Alles Klar, danke nochmal für deine Hilfe heute war echt super. Ich werde mal schauen ob ich was finde und falls du nochmal Lust bzw. Zeit hast kannst du mir es ja schreiben.


    Jetzt erstmal einen guten Rutsch ins neue Jahr und ich hoffe ihr bleibt alle Gesund.


    Gruß,


    KantarOSX

    Hackingtosh Projekte:

    Abgeschlossen:


    Echte Mac`s: