ASUS Rampage VI Extreme (original) with Radeon VII

  • ASUS Rampage VI Extreme (original) with Radeon VII


    I am currently using OpenCore 6.2 and have a "decently" working EFI setup for my Rampage VI Extreme (original), but there are things that still don't work.


    Things that don't work

    • Sleep, I couldn't get the machine to sleep, the screen will go dark, but the computer won't go to sleep
    • USBMap has been a bit of a pain to say the least

    I am including my config.plist, with a side note. I have a DSDT.aml that was created for me that seems to cover a ton of stuff, the other SSDT's that I was using seemed to do a good job, I think the big DSDT.aml is a bit more detailed.

    If anyone has any pointers or suggestions based on my config.plist let me know. If someone has an amazing fully working EFI they want to share, I would be happy to check it out.
    It is rare to find X299 Hackintosh setups using the ASUS Rampage VI Extreme, so I am glad I found this forum.

    My apologies that my post is in English, I read through the forum rules and didn't see any rules against posting in English. I have pasted a google translation below:

    German version


    ASUS Rampage VI Extreme (Original) mit Radeon VII


    Ich verwende derzeit OpenCore 6.2 und habe ein "anständig" funktionierendes EFI-Setup für mein Rampage VI Extreme (Original), aber es gibt Dinge, die immer noch nicht funktionieren.


    Dinge, die nicht funktionieren

    • Schlaf, ich konnte die Maschine nicht in den Ruhezustand versetzen, der Bildschirm wird dunkel, aber der Computer wird nicht in den Ruhezustand versetzt
    • USBMap war, gelinde gesagt, ein bisschen schmerzhaft

    Ich füge meine config.plist mit einer Randnotiz hinzu. Ich habe eine DSDT.aml, die für mich erstellt wurde und eine Menge Dinge abzudecken scheint. Die anderen SSDTs, die ich verwendet habe, schienen gute Arbeit zu leisten. Ich denke, die große DSDT.aml ist etwas detaillierter.


    Wenn jemand Hinweise oder Vorschläge hat, die auf meiner config.plist basieren, lass es mich wissen. Wenn jemand einen erstaunlichen voll funktionsfähigen EFI hat, den er teilen möchte, würde ich ihn gerne ausprobieren.

    Es ist selten, dass X299-Hackintosh-Setups mit ASUS Rampage VI Extreme gefunden werden. Daher bin ich froh, dass ich dieses Forum gefunden habe.

    .

    Ich entschuldige mich dafür, dass mein Beitrag auf Englisch ist. Ich habe die Forenregeln durchgelesen und keine Regeln gegen das Posten auf Englisch gesehen.

    Files

    • config.plist

      (35.83 kB, downloaded 7 times, last: )
  • Welcome to the forum! :welcome:

    Writing in english is okay for most of our users, the translation is okay, too.

    There`s a user DSM2 here in the forum who is a specialist for X299-Boards. Maybe he`ll take a look at your config.

  • wellcome @Warbands

    I´m using your same motherboard & GPU. I will update my config to 062 and compare.

    7960X / Rampage VI Extreme / Radeon VII / OC 0.6.1

  • I didn't check your config.plist but I don't need too to answer your questions.


    Sleep will work without issues as soon as all usb ports will be mapped.


    You have to set up some of the ports as USB 2 ports since the motherboard have more then 15 USB ports available in total.


    EFI wise it would be better if you could upload your whole EFI Folder and not only your config.plist

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • Thank you for the warm welcome! DSM2 I was about to handle my USB port mapping. I have seen 2 main methods for this.

    Method # 1 InjectAll and Hackintool
    https://www.youtube.com/watch?…channel=OlarilaHackintosh


    Method # 2 Using USBMap


    After watching the video for Method # 1, it seemed straight forward. I found USBMap in the past to be a bit hit and miss. Which method do most people use?
    I have included my EFI, though this is ahead of me finishing the USB port mapping.


    juantrix ,what is not currently working for you for your setup?


    Edit, I ended up using USBMap as Method #1 ended up acting odd.

    Damn there are alot of USB ports on this board ;)

    ZhiayoB.png


    I was able to bring my ports down to 15 according to USBMap

    3rnMtOO.png

  • If you use OpenCore as your Bootloader there is no need in any port limit patches.

    You just have to enable the XhciPortLimit Quirk.


    Most of the people use the Hackintool method for the creation process of a custom USB Kext.

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • For me, using just the XhciPortLimit Quirk wasn't enough, I still had some USB oddities. I ended up using USBMap and I was able to reduce my port count and not have my Bluetooth disappear. On this motherboard, HS11 seems to be tied my Bluetooth.

    Even though I have my ports down to 15 (checked via USBMap and Hackintool) trying to put my computer to sleep only puts the screen to sleep, my fans and motherboard lights are still all going.


    I ordered the ASUS ThunderEX 3 Thunderbolt add in card, I saw a thread here on the forums about someone who got it work (unsure if they got hot swapping to work) so hopefully that will be not too hard.

    Edit* I installed the ASUS ThunderEX 3 card, and set up my bios settings based on KGP's older x299 page ( his .aml locked up my machine so need to figure that one out ). I booted into Windows 10 and got it "working", I am getting a Thunderbolt 3 Samsung X5 tomorrow to test with, but my Type C key worked just fine in the Thunderbolt port. I booted into Mojave and again the Type C worked without issue, and supported plug and play. I am unsure what this will mean with the Thunderbolt 3 drive tomorrow. If there is anything else I need to know about getting the ThunderboltEX 3 card working under OS X, I would love to hear it.


    Do you know if it is possible to capture or store the boot info that goes by. I know I can record errors to a log via opencore, and am doing that currently, I just would like to see everything, and recording it on a phone as it scrolls by is not great.


    I also wanted to see if I could install Catalina on a second SSD, and start going down that path ( I am currently on Mojave ). When I use my current EFI and boot into the Catalina installer and go to install Catalina to my second SSD ( or any drive at all ) the install window disappears, checking the log I get the log that I have included below.

  • So I did a completely fresh EFI, and hand constructed all my own SSDT's. I also added initial setup for my ASUS ThunderboltEX 3 card. I followed KGP's info on his big post for x299 and Mojave.

    I also learned something today, the 15 port USB limit is per USB controller, not for the entire system, according to CorpNewt. That was awesome to find out, meaning I only had to remove one USB port ( my ASUS RGB haha which was already useless ).


    Edit* I was able to get my ThunderboltEX 3 fully working! I followed KGP's guide to the letter, and took his SSDT-X299-TB3HP.aml and modified it to point to my 4th PCI slot. I was able to get my Thunderbolt drive working, but only if it was connected on boot. I read his post over and over again. Then it dawned on me, I remember seeing his post in 2 places, insanelymac and (illegal word on this forum). I was using the one at an insanelymac, so I went over to the (illegal word on this forum). It turns out he had completely different BIOS settings for Thunderbolt in that one. It was also dated 2 weeks later. So I updated my BIOS settings, and now it is working with full hot swap support!


    Still having issues with trying to boot up Catalina sadly.

    Edited once, last by Warbands ().

  • juantrix Please don`t use external filehosters. Share your files within the forum by using "Dateianhänge" und "Hochladen" (Attachments & Upload).

  • juantrix Sorry I haven't responded till now. I had to evacuate due to the Silverado Fire in Orange County California. Just got back, so taking a look at your data. I was surprised to see you are using a way newer bios for the R6E, did it improve anything for you? I am also guessing why you have a Cascade Lake Fix aml possibly? This will take a bit of time to dig through, and I may have some more questions. Thank you for sending me this, very appreciated.

  • Awac Fix ivia ssdt is not the only way to fix this situation with the newer Bios versions.


    It was the initial one but there is already a better one out there.

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

    Edited once, last by DSM2 ().

  • juantrix you can not link a private message... No one besides from you can access it.

    Keine Unterstützung per PN...

    Eure Fragen gehören ins Forum, nicht in mein Postfach!

  • juantrix


    Hi,

    I write in english as my german is rusty ...

    I succeeded to install BS (20B29). All work fine but sometimes I have a reboot reported as a problem with GFX0 kext (com.apple.driver.AppleGFXHDA(100.1.431)). That happened with Catalina too and a Google search allowed me to discover that this seems to be an issue related to Radeon VII audio (see on this forum too: here and here).

    I saw your EFI posted above and I noticed that in your ACPI folder there are specific SSDTs, including two for Radeon VII.

    At this time, my build is so composed:

    1. ASUS SAGE/10G

    2. 128 GB RAM (16x8)

    3. Radeon VII (slot 1)

    4. Titan Ridge TTB3 (slot 2)

    5. HighPoint RocketRAID 2840A (slot 3)

    6. MQUPIN FENVI T919 Scheda Wireless BCM94360CD (slot 4)
    7. HighPoint SSD7101A-1 NVMe RAID controller

    Do you think I could use "SSDT-X299-Radeon7-Slot-1" in my build?

    Thank you in advance

  • Hi Ghostmac1969 , as you posted, I also had kernel panics / problems with AppleGFXHDA - if the SSDT is not going to help, you could try using the tool in Kext Updater´s (dl: https://www.sl-soft.de/kext-updater/) tool ("Werkzeuge" in German) section to block AppleGFXHDA:



    I did not have kernel panics in the last month using it ...


    all the best,

    timmtomm

    Lg TimmTomm

    ____________________________________________________

    Catalina 10.15.7 & Big Sur Beta - iMacPro1,1/ Asrock z370m Pro4 / i7 8700k / Asus Radeon VII /64 GB DDR4-3000 G.SKILL Aegis/ Broadcom Bcm943602cs 802.11ac WiFi Bluetooth / Zalman S2 / OpenCore 0.6

  • @Ghostmac1969,


    I´m moving to a Sage/10G Mobo. Try my OC modified for it.
    (OC063 Sage10G 7960x 2xVII TH wifi 3203Bios)

    I´m working in a correct implement of USB yet.

    Files

    7960X / Rampage VI Extreme / Radeon VII / OC 0.6.1